Welcome to Cinemachine

Cinemachine is a suite of ‘smart’ procedural camera modules which allow you to define the shot and they’ll dynamically follow your direction.

Set up shots which track and compose motion in realtime, like AI camera operators. The procedural nature makes them bug-resistant as they always work to make the shot based on your direction. That’s great for gameplay, but they’re also amazingly fast for cutscenes. Change an animation, a vehicle speed, ground terrain - whatever - and Cinemachine will dynamically make the shot. You can use really telephoto lenses and not have to update the cutscene if things change.

The Brain

The idea is to tell the Unity camera where to go and what to do in response to gameplay and scene evolution. To do this, the first step is to give the Unity Camera a CinemachineBrain behaviour. Think of that as the movie director, who chooses among the available camera shots for the one that tells the best story at any given moment.

The next step is to populate your scene with intelligent CinemachineVirtualCamera objects. These can be thought of as skilled cameramen who are given instructions about what game objects to target, and how to follow them. It is the brain's job to monitor these and choose the most appropriate one to track at any given frame.

Virtual Cameras

A virtual camera is not a camera. Instead, it can be thought of as a camera controller, not unlike a cameraman. It can drive the Unity Camera and control its position, orientation, lens settings, and PostProcessing effects. Each Virtual Camera owns its own Cinemachine Component Pipeline, through which you provide the instructions for dynamically tracking specific game objects.

A virtual camera is very lightweight, and does no rendering of its own. It merely tracks interesting GameObjects, and positions itself accordingly. A typical game can have dozens of virtual cameras, each set up to follow a particular character or capture a particular event.

A Virtual Camera can be in any of three states:

  • Live: The virtual camera is actively controlling the Unity Camera. The virtual camera is tracking its targets and being updated every frame.
  • Standby: The virtual camera is tracking its targets and being updated every frame, but no Unity Camera is actively being controlled by it. This is the state of a virtual camera that is enabled in the scene but perhaps at a lower priority than the Live virtual camera.
  • Disabled: The virtual camera is present but disabled in the scene. It is not actively tracking its targets and so consumes no processing power. However, the virtual camera can be made live from the Timeline.

The Unity Camera can be driven by any virtual camera in the scene. The game logic can choose the virtual camera to make live by manipulating the virtual cameras' enabled flags and their priorities, based on game logic.

In order to be driven by a virtual camera, the Unity Camera must have a CinemachineBrain behaviour, which will select the most eligible virtual camera based on its priority or on other criteria, and will manage blending.

Blending

Camera Blending is a concept that brings the Virtual Cameras beyond the analogy of a cameraman. It is essentially an interpolation over time of one virtual camera position and state to another. If you think of virtual cameras as cameramen, then blending is a little like one cameraman smoothly passing the camera to another cameraman. You can specify the time over which to blend, as well as the blend curve shape. Note that a camera cut is just a zero-time blend.

The CinemachineBrain behaviour holds the instructions for blending. There you can specify the default blend (how virtual cameras transtion from one being live to another), and also specific overrides to the default blend in the form of an instruction list: "when this vcam goes live, blend like this", or "when bending from this vcam to that one, do it like that", and so on.

Getting Started

The first thing to look at is the CinemachineVirtualCamera behaviour. That should lead you to the pipeline of ICinemachineComponents which serve as instructions for controlling the Position, Orientation, and Lens of the camera. Create some Virtual Cameras in your scene, set their targets, and play with their settings to see what they do. Also have a look at some of the example scenes included with the package.

The API generally reflects what you see in the inspector for the behaviours of the different sorts of Virtual Cameras and their components. Have a look at the corresponding classes, beginning with:

  • CinemachineVirtualCamera
  • CinemachineBrain
  • CinemachineClearShot
  • CinemachineFreeLook
  • CinemachineCollider
  • CinemachineTransposer
  • CinemachineComposer

See Also

Other Resources

Version History
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


Version History

The topics in this section describe the various changes made to the [TODO: Project Title] over the life of the project.

Version History

Select a version below to see a description of its changes.

  • Version 2.0

  • Version 2.1

See Also

Other Resources

Welcome to Cinemachine


Version 2.0

Version 2.0 was released on July 23, 2017.

Changes in This Release

  • This is a complete overhaul of Cinemachine 1.0, and contains many new features and implementations.

  • Unfortunately it was not possible to maintain back-compatibility with Cinemachine 1, and so any Cinemachine content created with earlier versions will have to be re-created using this version.

  • Please see the Cinemachine Forum for a complete list of changes in this release.

See Also

Other Resources

Version History


Version 2.1

Version 2.1 was released on Nov 11, 2017.

Changes in This Release

  • PostProcessing V2 is now supported.

  • New Collider implementation. Curb feelers are gone, replaced by a clever camera-repositioning algorithm that will try to preserve camera height or distance from target (strategy is user-selectable).

  • New CinemachineConfiner: confine a virtual camera to a simple bounding volume or PolygonCollider2D.

  • New Framing Transposer. This is a special transposer that will respect composition and framing rules by moving the camera without rotating it. Takes only a Follow Target (no LookAt - this is important). Designed for Orthographic cameras, but will also work for Perspective cameras. If Follow target is a CinemachineTargetGroup, then will also provide Group Framing options.

  • New CinemachinePOV Aim component. Camera aim is entirely controlled by user, using 2 input axes.

  • New CinemachineMixingCamera. Drive a continuous blend of up to 8 virtual cameras from timeline or game logic. Create complex rigs with custom blends and expose them as ordinary vcams.

  • New CinemachineBlendListCamera. A mini vcam sequencer that provides a quick and easy way to do AB camera moves on the fly.

  • New CinemachineDollyCart behaviour, for moving anything along a path. No need to create dummy vcams just for that.

  • New CinemachineSmoothPath component. You can use it instead of the old CinemachinePath. The difference is that the SmoothPath guarantees second-order continuity, which means that there will never be any sudden camera rotation changes baked into the path tangents. Easier to use, too: no tangents to mess around with (they get automatically set for smoothness).

  • Path now supports Distance Units in addition to Path units, making it easy to create steady motion.

  • TrackedDolly: added ability to use Distance or Path units for path position.

  • Transposer and TrackedDolly: added target angular damping on 3 axes.

  • OrbitalTransposer and FreeLook: added angular damping and binding mode, same as Transposer.

  • OrbitalTransopser and freelook: added checkbox to invert input axis.

  • Transposer, OrbitalTransposer, and FreeLook: added new Simple Follow binding mode, which will follow the target using rotation as much as possible, changing position as little as possible. Like a lazy cameraman.

  • Added IgnoreTimeScale option to Brain. Useful for snappy cameras even in slo-mo.

  • Added Lookahead Time to composer. Composer will look at the point where it estimates the target will be at some time in the near future. This gives much more natural framing of a moving target.

  • SmartUpdate is smarter: added support for Interpolation when target is animated by physics system.

  • Added off-button for SaveDuringPlay.

  • No SaveDuringPlay for vcam priority, LookAt and Follow targets, GroupTarget members.

  • Added IsBlending API method to StateDrivenCamera and ClearShot.

  • TargetGroup now has a user-selectable update method.

  • TargetGroup now respects the weight when computing bounding box, so it's possible to gradually add or remove members by manipulating the weight.

  • Clearshot: if randomize, then re-randomize whenever it becomes active.

  • ClearShot: default blend is cut.

  • ClearShot create menu: add a Collider by default.

  • FollowZoom: min/max FOV defaults changed to 3/60.

  • Composer damping range is now 0-20 instead of 0-100.

  • Orbital and FreeLook: Heading Bias can now be animated on the timeline.

  • Orbital and FreeLook: damping no longer interferes with camera response to user input. Axis movement bypasses all damping.

  • TrackedDolly: added path position offset to Auto-Dolly. Stays on the path (unlike path offset, which is based on the path tangent and so can go off the path)

  • Noise component inspector now has a dropdown for Profile presets, instead of directly allowing editing of the Profile asset.

  • Added concept of Cinemachine Extension. Collider, confiner, PostProcessing, etc are now Extensions. They are available via a dropdown at the bottom of the inspection for virtual cameras. They will no longer appear in the standard Components menu.

  • Time.timeScale = 0 is now supported. Pausing the game will also pause the virtual cameras.

  • HardConstraint has been split into two settings: Do Nothing and Hard LookAt/Follow. Do Nothing will leave the camera's transform alone, ignoring any target that may have been set.

  • CinemachineBrain no longer requires a Camera component. Can be used with any GameObject, making it possible to use Cinemachine to control the transforms of arbitrary objects.

  • Improved logic for AxisState accel/decel. More realistic behaviour.

  • SaveDuringPlay obsolete API fix for 2017.2.

  • Fixed build errors when building for UWP.

  • Clearshot and SDC: don't reset state if deactivated.

  • FreeLook destroy - no more orphan rigs.

  • Fixed strange build error that only showed up in MonoDevelop.

  • FreeLook was not respecting X-axis accel and decel. Heading speed had to be crazy high. Now same as Orbital (warning: may have to re-tune settings on existing FreeLooks).

  • Recenter to target heading was not moving smoothly in some circumstances.

  • Collider raycasts no longer hit triggers.

  • Noise: handle variable deltaTime gracefully.

  • State-Driven-Camera: don't generate errors when animated target is inactive.

  • Several jitter and judder issues resolved.

See Also

Other Resources

Version History


Namespaces

Namespaces
Namespace | Description
Cinemachine | This namespace holds the Core Cinemachine code.
Cinemachine.Utility | Cinemachine non-domain utilities and Unity extensions and helpers


Cinemachine Namespace

This namespace holds the Core Cinemachine code.
Classes
Class Description
Public class CinemachineBasicMultiChannelPerlin
As a part of the Cinemachine Pipeline implementing the Noise stage, this component adds Perlin Noise to the Camera state, in the Correction channel of the CameraState. The noise is created by using a predefined noise profile asset. This defines the shape of the noise over time. You can scale this in amplitude or in time, to produce a large family of different noises using the same profile.
Public class CinemachineBlend
Describes a blend between 2 Cinemachine Virtual Cameras, and holds the current state of the blend.
Public class CinemachineBlendDefinitionPropertyAttribute
Property applied to CinemachineBlendDefinition. Used for custom drawing in the inspector.
Public class CinemachineBlenderSettings
Asset that defines the rules for blending between Virtual Cameras.
Public class CinemachineBlendListCamera
This is a virtual camera "manager" that owns and manages a collection of child Virtual Cameras. When the camera goes live, these child vcams are enabled, one after another, holding each camera for a designated time. Blends between cameras are specified. The last camera is held indefinitely.
Public class CinemachineBrain
CinemachineBrain is the link between the Unity Camera and the Cinemachine Virtual Cameras in the scene. It monitors the priority stack to choose the current Virtual Camera, and blend with another if necessary. Finally and most importantly, it applies the Virtual Camera state to the attached Unity Camera. The CinemachineBrain is also the place where rules for blending between virtual cameras are defined. Camera blending is an interpolation over time of one virtual camera position and state to another. If you think of virtual cameras as cameramen, then blending is a little like one cameraman smoothly passing the camera to another cameraman. You can specify the time over which to blend, as well as the blend curve shape. Note that a camera cut is just a zero-time blend.
Public class CinemachineBrainBrainEvent
Event with a CinemachineBrain parameter
Public class CinemachineBrainVcamEvent
Event with a ICinemachineCamera parameter
Public class CinemachineClearShot
Cinemachine ClearShot is a "manager camera" that owns and manages a set of Virtual Camera gameObject children. When Live, the ClearShot will check the children, and choose the one with the best quality shot and make it Live. This can be a very powerful tool. If the child cameras have CinemachineCollider extensions, they will analyze the scene for target obstructions, optimal target distance, and other items, and report their assessment of shot quality back to the ClearShot parent, who will then choose the best one. You can use this to set up complex multi-camera coverage of a scene, and be assured that a clear shot of the target will always be available. If multiple child cameras have the same shot quality, the one with the highest priority will be chosen. You can also define custom blends between the ClearShot children.
Public class CinemachineCollider
An add-on module for Cinemachine Virtual Camera that post-processes the final position of the virtual camera. Based on the supplied settings, the Collider will attempt to preserve the line of sight with the LookAt target of the virtual camera by moving away from objects that will obstruct the view. Additionally, the Collider can be used to assess the shot quality and report this as a field in the camera State.
Public class CinemachineComponentBase
An abstract representation of a mutator acting on a Cinemachine Virtual Camera
Public class CinemachineComposer
This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to aim the camera at the vcam's LookAt target object, with configurable offsets, damping, and composition rules. The composer does not change the camera's position. It will only pan and tilt the camera where it is, in order to get the desired framing. To move the camera, you have to use the virtual camera's Body section.
Public class CinemachineConfiner
An add-on module for Cinemachine Virtual Camera that post-processes the final position of the virtual camera. It will confine the virtual camera's position to the volume specified in the Bounding Volume field.
Public class CinemachineCore
A singleton that manages complete lists of CinemachineBrain and, Cinemachine Virtual Cameras, and the priority queue. Provides services to keeping track of whether Cinemachine Virtual Cameras have been updated each frame.
Public class CinemachineDollyCart
This is a very simple behaviour that constrains its transform to a CinemachinePath. It can be used to animate any objects along a path, or as a Follow target for Cinemachine Virtual Cameras.
Public class CinemachineExtension
Base class for a Cinemachine Virtual Camera extension module. Hooks into the Cinemachine Pipeline.
Public class CinemachineExternalCamera
This component will expose a non-cinemachine camera to the cinemachine system, allowing it to participate in blends. Just add it as a component alongside an existing Unity Camera component.
Public class CinemachineFollowZoom
An add-on module for Cinemachine Virtual Camera that adjusts the FOV of the lens to keep the target object at a constant size on the screen, regardless of camera and target position.
Public class CinemachineFramingTransposer
This is a Cinemachine Component in the Body section of the component pipeline. Its job is to position the camera in a fixed screen-space relationship to the vcam's Follow target object, with offsets and damping. The camera will be first moved along the camera Z axis until the Follow target is at the desired distance from the camera's X-Y plane. The camera will then be moved in its XY plane until the Follow target is at the desired point on the camera's screen. The FramingTansposer will only change the camera's position in space. It will not re-orient or otherwise aim the camera. For this component to work properly, the vcam's LookAt target must be null. The Follow target will define what the camera is looking at. If the Follow target is a CinemachineTargetGroup, then additional controls will be available to dynamically adjust the camera’s view in order to frame the entire group. Although this component was designed for orthographic cameras, it works equally well with persective cameras and can be used in 3D environments.
Public class CinemachineFreeLook
A Cinemachine Camera geared towards a 3rd person camera experience. The camera orbits around its subject with three separate camera rigs defining rings around the target. Each rig has its own radius, height offset, composer, and lens settings. Depending on the camera's position along the spline connecting these three rigs, these settings are interpolated to give the final camera position and state.
Public class CinemachineGroupComposer
This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to aim the camera at a target object, with configurable offsets, damping, and composition rules. In addition, if the target is a CinemachineTargetGroup, the behaviour will adjust the FOV and the camera distance to ensure that the entire group of targets is framed properly.
Public class CinemachineHardLockToTarget
This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to place the camera on the Follow Target.
Public class CinemachineHardLookAt
This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to aim the camera hard at the LookAt target.
Public class CinemachineMixingCamera
CinemachineMixingCamera is a "manager camera" that takes on the state of the weighted average of the states of its child virtual cameras. A fixed number of slots are made available for cameras, rather than a dynamic array. We do it this way in order to support weight animation from the Timeline. Timeline cannot animate array elements.
Public class CinemachineOrbitalTransposer
This is a CinemachineComponent in the the Body section of the component pipeline. Its job is to position the camera in a variable relationship to a the vcam's Follow target object, with offsets and damping. This component is typically used to implement a camera that follows its target. It can accept player input from an input device, which allows the player to dynamically control the relationship between the camera and the target, for example with a joystick. The OrbitalTransposer introduces the concept of __Heading__, which is the direction in which the target is moving, and the OrbitalTransposer will attempt to position the camera in relationship to the heading, which is by default directly behind the target. You can control the default relationship by adjusting the Heading Bias setting. If you attach an input controller to the OrbitalTransposer, then the player can also control the way the camera positions itself in relation to the target heading. This allows the camera to move to any spot on an orbit around the target.
Public class CinemachinePath
Defines a world-space path, consisting of an array of waypoints, each of which has position, tangent, and roll settings. Bezier interpolation is performed between the waypoints, to get a smooth and continuous path.
Public class CinemachinePathBase
Abstract base class for a world-space path, suitable for a camera dolly track.
Public class CinemachinePathBaseAppearance
This class holds the settings that control how the path will appear in the editor scene view. The path is not visible in the game view
Public class CinemachinePipeline
Internal container for CinemachineComponentBase. Does nothing but contain.
Public class CinemachinePOV
This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to aim the camera in response to the user's mouse or joystick input. The composer does not change the camera's position. It will only pan and tilt the camera where it is, in order to get the desired framing. To move the camera, you have to use the virtual camera's Body section.
Public class CinemachineSmoothPath
Defines a world-space path, consisting of an array of waypoints, each of which has position and roll settings. Bezier interpolation is performed between the waypoints, to get a smooth and continuous path. The path will pass through all waypoints, and (unlike CinemachinePath) first and second order continuity is guaranteed
Public class CinemachineStateDrivenCamera
This is a virtual camera "manager" that owns and manages a collection of child Virtual Cameras. These child vcams are mapped to individual states in an animation state machine, allowing you to associate specific vcams to specific animation states. When that state is active in the state machine, then the associated camera will be activated. You can define custom blends and transitions between child cameras. In order to use this behaviour, you must have an animated target (i.e. an object animated with a state machine) to drive the behaviour.
Public class CinemachineTargetGroup
Defines a group of target objects, each with a radius and a weight. The weight is used when calculating the average position of the target group. Higher-weighted members of the group will count more. The bounding box is calculated by taking the member positions, weight, and radii into account.
Public class CinemachineTrackedDolly
A Cinemachine Virtual Camera Body component that constrains camera motion to a CinemachinePath. The camera can move along the path. This behaviour can operate in two modes: manual positioning, and Auto-Dolly positioning. In Manual mode, the camera's position is specified by animating the Path Position field. In Auto-Dolly mode, the Path Position field is animated automatically every frame by finding the position on the path that's closest to the virtual camera's Follow target.
Public class CinemachineTransposer
This is a CinemachineComponent in the Body section of the component pipeline. Its job is to position the camera in a fixed relationship to the vcam's Follow target object, with offsets and damping. The Tansposer will only change the camera's position in space. It will not re-orient or otherwise aim the camera. To to that, you need to instruct the vcam in the Aim section of its pipeline.
Public class CinemachineVirtualCamera
This behaviour is intended to be attached to an empty Transform GameObject, and it represents a Virtual Camera within the Unity scene. The Virtual Camera will animate its Transform according to the rules contained in its CinemachineComponent pipeline (Aim, Body, and Noise). When the virtual camera is Live, the Unity camera will assume the position and orientation of the virtual camera. A virtual camera is not a camera. Instead, it can be thought of as a camera controller, not unlike a cameraman. It can drive the Unity Camera and control its position, orientation, lens settings, and PostProcessing effects. Each Virtual Camera owns its own Cinemachine Component Pipeline, through which you provide the instructions for dynamically tracking specific game objects. A virtual camera is very lightweight, and does no rendering of its own. It merely tracks interesting GameObjects, and positions itself accordingly. A typical game can have dozens of virtual cameras, each set up to follow a particular character or capture a particular event. A Virtual Camera can be in any of three states: * **Live**: The virtual camera is actively controlling the Unity Camera. The virtual camera is tracking its targets and being updated every frame. * **Standby**: The virtual camera is tracking its targets and being updated every frame, but no Unity Camera is actively being controlled by it. This is the state of a virtual camera that is enabled in the scene but perhaps at a lower priority than the Live virtual camera. * **Disabled**: The virtual camera is present but disabled in the scene. It is not actively tracking its targets and so consumes no processing power. However, the virtual camera can be made live from the Timeline. The Unity Camera can be driven by any virtual camera in the scene. The game logic can choose the virtual camera to make live by manipulating the virtual cameras' enabled flags and their priorities, based on game logic. In order to be driven by a virtual camera, the Unity Camera must have a CinemachineBrain behaviour, which will select the most eligible virtual camera based on its priority or on other criteria, and will manage blending.
Public class CinemachineVirtualCameraBase
Base class for a Monobehaviour that represents a Virtual Camera within the Unity scene. This is intended to be attached to an empty Transform GameObject. Inherited classes can be either standalone virtual cameras such as CinemachineVirtualCamera, or meta-cameras such as CinemachineClearShot or CinemachineFreeLook. A CinemachineVirtualCameraBase exposes a Priority property. When the behaviour is enabled in the game, the Virtual Camera is automatically placed in a queue maintained by the static CinemachineCore singleton. The queue is sorted by priority. When a Unity camera is equipped with a CinemachineBrain behaviour, the brain will choose the camera at the head of the queue. If you have multiple Unity cameras with CinemachineBrain behaviours (say in a split-screen context), then you can filter the queue by setting the culling flags on the virtual cameras. The culling mask of the Unity Camera will then act as a filter for the brain. Apart from this, there is nothing that prevents a virtual camera from controlling multiple Unity cameras simultaneously.
Public class DocumentationSortingAttribute
Atrtribute to control the automatic generation of documentation.
Public class LensSettingsPropertyAttribute
Property applied to LensSettings. Used for custom drawing in the inspector.
Public class NoiseSettings
This is an asset that defines a noise profile. A noise profile is the shape of the noise as a function of time. You can build arbitrarily complex shapes by combining different base perlin noise frequencies at different amplitudes. The frequencies and amplitudes should be chosen with care, to ensure an interesting noise quality that is not obviously repetitive. As a mathematical side-note, any arbitrary periodic curve can be broken down into a series of fixed-amplitude sine-waves added together. This is called fourier decomposition, and is the basis of much signal processing. It doesn't really have much to do with this asset, but it's super interesting!
Public class NoSaveDuringPlayAttribute
Suppresses play-mode-save for a field. Use it if the calsee has [SaveDuringPlay] attribute but there are fields in the class that shouldn't be saved.
Public class SaveDuringPlayAttribute
Invoke play-mode-save for a class. This class's fields will be scanned upon exiting play mode, and its property values will be applied to the scene object. This is a stopgap measure that will become obsolete once Unity implements play-mode-save in a more general way.
Structures
 | Structure | Description
Public structure | AxisState | Axis state for defining to react to player input. The settings here control the responsiveness of the axis to player input.
Public structure | CameraState | The output of the Cinemachine engine for a specific virtual camera. The information in this struct can be blended, and provides what is needed to calculate an appropriate camera position, orientation, and lens setting. Raw values are what the Cinemachine behaviours generate. The correction channel holds perturbations to the raw values - e.g. noise or smoothing, or obstacle avoidance corrections. Coirrections are not considered when making time-based calculations such as damping. The Final position and orientation is the comination of the raw values and their corrections.
Public structure | CameraStateCustomBlendable | Opaque structure represent extra blendable stuff and its weight. The base system ignores this data - it is intended for extension modules
Public structure | CinemachineBlendDefinition | Definition of a Camera blend. This struct holds the information necessary to generate a suitable AnimationCurve for a Cinemachine Blend.
Public structure | CinemachineBlenderSettingsCustomBlend | Container specifying how two specific Cinemachine Virtual Cameras blend together.
Public structure | CinemachineBlendListCameraInstruction | This represents a single entry in the instrunction list of the BlendListCamera.
Public structure | CinemachineFreeLookOrbit | Defines the height and radius of the Rig orbit
Public structure | CinemachineOrbitalTransposerHeading | How the "forward" direction is defined. Orbital offset is in relation to the forward direction.
Public structure | CinemachineOrbitalTransposerRecentering | Controls how automatic orbit recentering occurs
Public structure | CinemachinePathWaypoint | A waypoint along the path
Public structure | CinemachineSmoothPathWaypoint | A waypoint along the path
Public structure | CinemachineStateDrivenCameraInstruction | This represents a single instrunction to the StateDrivenCamera. It associates an state from the state machine with a child Virtual Camera, and also holds activation tuning parameters.
Public structure | CinemachineTargetGroupTarget | Holds the information that represents a member of the group
Public structure | CinemachineTrackedDollyAutoDolly | Controls how automatic dollying occurs
Public structure | LensSettings | Describes the FOV and clip planes for a camera. This generally mirrors the Unity Camera's lens settings, and will be used to drive the Unity camera when the vcam is active.
Public structure | NoiseSettingsNoiseParams | Describes the behaviour for a channel of noise
Public structure | NoiseSettingsTransformNoiseParams | Contains the behaviour of noise for the noise module for all 3 cardinal axes of the camera
Interfaces
 | Interface | Description
Public interface | ICinemachineCamera | An abstract representation of a virtual camera which lives within the Unity scene
Delegates
 | Delegate | Description
Public delegate | CinemachineCoreAxisInputDelegate | Delegate for overriding Unity's default input system. Returns the value of the named axis.
Public delegate | CinemachineFreeLookCreateRigDelegate | Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in this class.
Public delegate | CinemachineFreeLookDestroyRigDelegate | Override component pipeline destruction. This needs to be done by the editor to support Undo.
Public delegate | CinemachineVirtualCameraCreatePipelineDelegate | Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in the CinemachineVirtualCamera class.
Public delegate | CinemachineVirtualCameraDestroyPipelineDelegate | Override component pipeline destruction. This needs to be done by the editor to support Undo.
Public delegate | CinemachineVirtualCameraBaseOnPostPipelineStageDelegate | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. Parameters: * CinemachineVirtualCameraBase vcam: the virtual camera being updated * CinemachineCore.Stage stage: what stage in the pipeline has just been updated * ref CameraState newState: the current state of the vcam * float deltaTime: the frame timestep. Less than 0 means "don't consider the previous frame"
Enumerations
 | Enumeration | Description
Public enumeration | CinemachineBlendDefinitionStyle | Supported predefined shapes for the blend curve.
Public enumeration | CinemachineBrainUpdateMethod | This enum defines the options available for the update method.
Public enumeration | CinemachineColliderResolutionStrategy | The way in which the Collider will attempt to preserve sight of the target.
Public enumeration | CinemachineConfinerMode | The confiner can operate using a 2D bounding shape or a 3D bounding volume
Public enumeration | CinemachineCoreStage | Stages in the Cinemachine Component pipeline, used for UI organization>. This enum defines the pipeline order.
Public enumeration | CinemachineCoreUpdateFilter | Internal use only
Public enumeration | CinemachineDollyCartUpdateMethod | This enum defines the options available for the update method.
Public enumeration | CinemachineFramingTransposerAdjustmentMode | How to adjust the camera to get the desired framing
Public enumeration | CinemachineFramingTransposerFramingMode | What screen dimensions to consider when framing
Public enumeration | CinemachineGroupComposerAdjustmentMode | How to adjust the camera to get the desired framing
Public enumeration | CinemachineGroupComposerFramingMode | What screen dimensions to consider when framing
Public enumeration | CinemachineOrbitalTransposerHeadingHeadingDefinition | Sets the algorithm for determining the target's heading for purposes of re-centering the camera
Public enumeration | CinemachinePathBasePositionUnits | How to interpret the Path Position
Public enumeration | CinemachineTargetGroupPositionMode | How the group's position is calculated
Public enumeration | CinemachineTargetGroupRotationMode | How the group's orientation is calculated
Public enumeration | CinemachineTargetGroupUpdateMethod | This enum defines the options available for the update method.
Public enumeration | CinemachineTrackedDollyCameraUpMode | Different ways to set the camera's up vector
Public enumeration | CinemachineTransposerBindingMode | The coordinate space to use when interpreting the offset from the target
Public enumeration | DocumentationSortingAttributeLevel | Refinement level of the documentation


AxisState Structure

Axis state for defining to react to player input. The settings here control the responsiveness of the axis to player input.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(6.4f, DocumentationSortingAttributeLevel.UserRef)]
public struct AxisState
JavaScript supports the use of structures, but not the declaration of new ones.

The AxisState type exposes the following members.

Constructors
 | Name | Description
Public method | AxisState | Constructor with specific values
Top
Methods
 | Name | Description
Public method | SetThresholds | Sets the constraints by which this axis will operate on
Public method | Update | Updates the state of this axis based on the axis defined by AxisState.m_AxisName
Public method | Validate | Call from OnValidate: Make sure the fields are sensible
Top
Fields
 | Name | Description
Public field | m_AccelTime | The amount of time in seconds it takes to accelerate to MaxSpeed with the supplied Axis at its maximum value
Public field | m_DecelTime | The amount of time in seconds it takes to decelerate the axis to zero if the supplied axis is in a neutral position
Public field | m_InputAxisName | The name of this axis as specified in Unity Input manager. Setting to an empty string will disable the automatic updating of this axis
Public field | m_InputAxisValue | The value of the input axis. A value of 0 means no input You can drive this directly from a custom input system, or you can set the Axis Name and have the value driven by the internal Input Manager
Public field | m_InvertAxis | If checked, then the raw value of the input axis will be inverted before it is used.
Public field | m_MaxSpeed | How fast the axis value can travel. Increasing this number makes the behaviour more responsive to joystick input
Public field | Value | The current value of the axis
Top
See Also

Reference

Cinemachine Namespace


AxisState Constructor

Constructor with specific values

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public AxisState(
    float maxSpeed,
    float accelTime,
    float decelTime,
    float val,
    string name,
    bool invert
)
Cinemachine.AxisState = function(maxSpeed, accelTime, decelTime, val, name, invert);

Parameters

maxSpeed
Type: SystemSingle

[Missing <param name="maxSpeed"/> documentation for "M:Cinemachine.AxisState.#ctor(System.Single,System.Single,System.Single,System.Single,System.String,System.Boolean)"]

accelTime
Type: SystemSingle

[Missing <param name="accelTime"/> documentation for "M:Cinemachine.AxisState.#ctor(System.Single,System.Single,System.Single,System.Single,System.String,System.Boolean)"]

decelTime
Type: SystemSingle

[Missing <param name="decelTime"/> documentation for "M:Cinemachine.AxisState.#ctor(System.Single,System.Single,System.Single,System.Single,System.String,System.Boolean)"]

val
Type: SystemSingle

[Missing <param name="val"/> documentation for "M:Cinemachine.AxisState.#ctor(System.Single,System.Single,System.Single,System.Single,System.String,System.Boolean)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Cinemachine.AxisState.#ctor(System.Single,System.Single,System.Single,System.Single,System.String,System.Boolean)"]

invert
Type: SystemBoolean

[Missing <param name="invert"/> documentation for "M:Cinemachine.AxisState.#ctor(System.Single,System.Single,System.Single,System.Single,System.String,System.Boolean)"]

See Also

Reference

AxisState Structure


AxisState Methods

The AxisState type exposes the following members.

Methods
 | Name | Description
Public method | SetThresholds | Sets the constraints by which this axis will operate on
Public method | Update | Updates the state of this axis based on the axis defined by AxisState.m_AxisName
Public method | Validate | Call from OnValidate: Make sure the fields are sensible
Top
See Also

Reference

AxisState Structure


AxisState.SetThresholds Method

Cinemachine

AxisStateSetThresholds Method

Sets the constraints by which this axis will operate on

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void SetThresholds(
    float minValue,
    float maxValue,
    bool wrapAround
)
function SetThresholds(minValue, maxValue, wrapAround);

Parameters

minValue
Type: SystemSingle
The lowest value this axis can achieve
maxValue
Type: SystemSingle
The highest value this axis can achieve
wrapAround
Type: SystemBoolean
If true, values commanded greater than mMaxValue or less than mMinValue will wrap around. If false, the value will be clamped within the range.
See Also

Reference

AxisState Structure


AxisState.Update Method

AxisStateUpdate Method

Updates the state of this axis based on the axis defined by AxisState.m_AxisName

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool Update(
    float deltaTime
)
function Update(deltaTime);

Parameters

deltaTime
Type: SystemSingle
Delta time in seconds

Return Value

Type: Boolean
Returns true if this axis' input was non-zero this Update, flase otherwise
See Also

Reference

AxisState Structure


AxisState.Validate Method

AxisStateValidate Method

Call from OnValidate: Make sure the fields are sensible

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void Validate()
function Validate();
See Also

Reference

AxisState Structure


AxisState Fields

The AxisState type exposes the following members.

Fields
 | Name | Description
Public field | m_AccelTime | The amount of time in seconds it takes to accelerate to MaxSpeed with the supplied Axis at its maximum value
Public field | m_DecelTime | The amount of time in seconds it takes to decelerate the axis to zero if the supplied axis is in a neutral position
Public field | m_InputAxisName | The name of this axis as specified in Unity Input manager. Setting to an empty string will disable the automatic updating of this axis
Public field | m_InputAxisValue | The value of the input axis. A value of 0 means no input You can drive this directly from a custom input system, or you can set the Axis Name and have the value driven by the internal Input Manager
Public field | m_InvertAxis | If checked, then the raw value of the input axis will be inverted before it is used.
Public field | m_MaxSpeed | How fast the axis value can travel. Increasing this number makes the behaviour more responsive to joystick input
Public field | Value | The current value of the axis
Top
See Also

Reference

AxisState Structure


AxisState.m_AccelTime Field

AxisStatem_AccelTime Field

The amount of time in seconds it takes to accelerate to MaxSpeed with the supplied Axis at its maximum value

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The amount of time in seconds it takes to accelerate to MaxSpeed with the supplied Axis at its maximum value")]
public float m_AccelTime
var m_AccelTime

Field Value

Type: Single
See Also

Reference

AxisState Structure


AxisState.m_DecelTime Field

AxisStatem_DecelTime Field

The amount of time in seconds it takes to decelerate the axis to zero if the supplied axis is in a neutral position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The amount of time in seconds it takes to decelerate the axis to zero if the supplied axis is in a neutral position")]
public float m_DecelTime
var m_DecelTime

Field Value

Type: Single
See Also

Reference

AxisState Structure


AxisState.m_InputAxisName Field

AxisStatem_InputAxisName Field

The name of this axis as specified in Unity Input manager. Setting to an empty string will disable the automatic updating of this axis

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[FormerlySerializedAsAttribute("m_AxisName")]
[TooltipAttribute("The name of this axis as specified in Unity Input manager. Setting to an empty string will disable the automatic updating of this axis")]
public string m_InputAxisName
var m_InputAxisName

Field Value

Type: String
See Also

Reference

AxisState Structure


AxisState.m_InputAxisValue Field

AxisStatem_InputAxisValue Field

The value of the input axis. A value of 0 means no input You can drive this directly from a custom input system, or you can set the Axis Name and have the value driven by the internal Input Manager

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[NoSaveDuringPlayAttribute]
[TooltipAttribute("The value of the input axis.  A value of 0 means no input.  You can drive this directly from a custom input system, or you can set the Axis Name and have the value driven by the internal Input Manager")]
public float m_InputAxisValue
var m_InputAxisValue

Field Value

Type: Single
See Also

Reference

AxisState Structure


AxisState.m_InvertAxis Field

AxisStatem_InvertAxis Field

If checked, then the raw value of the input axis will be inverted before it is used.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[NoSaveDuringPlayAttribute]
[TooltipAttribute("If checked, then the raw value of the input axis will be inverted before it is used")]
public bool m_InvertAxis
var m_InvertAxis

Field Value

Type: Boolean
See Also

Reference

AxisState Structure


AxisState.m_MaxSpeed Field

AxisStatem_MaxSpeed Field

How fast the axis value can travel. Increasing this number makes the behaviour more responsive to joystick input

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The maximum speed of this axis in units/second")]
public float m_MaxSpeed
var m_MaxSpeed

Field Value

Type: Single
See Also

Reference

AxisState Structure


AxisState.Value Field

AxisStateValue Field

The current value of the axis

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[NoSaveDuringPlayAttribute]
[TooltipAttribute("The current value of the axis.")]
public float Value
var Value

Field Value

Type: Single
See Also

Reference

AxisState Structure


CameraState Structure

The output of the Cinemachine engine for a specific virtual camera. The information in this struct can be blended, and provides what is needed to calculate an appropriate camera position, orientation, and lens setting. Raw values are what the Cinemachine behaviours generate. The correction channel holds perturbations to the raw values - e.g. noise or smoothing, or obstacle avoidance corrections. Coirrections are not considered when making time-based calculations such as damping. The Final position and orientation is the comination of the raw values and their corrections.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public struct CameraState
JavaScript supports the use of structures, but not the declaration of new ones.

The CameraState type exposes the following members.

Properties
 | Name | Description
Public property | CorrectedOrientation | Orientation with correction applied.
Public property | CorrectedPosition | Position with correction applied.
 | Default | State with default values
Public property | FinalOrientation | Orientation with correction and dutch applied. This is what the final camera gets.
Public property | FinalPosition | Position with correction applied. This is what the final camera gets.
Public property | HasLookAt | Returns true if this state has a valid ReferenceLookAt value.
Public property | Lens | Camera Lens Settings.
Public property | NumCustomBlendables | The number of custom blendables that will be applied to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules
Public property | OrientationCorrection | Orientation correction. This will be added to the raw orientation. This value doesn't get fed back into the system when calculating the next frame. Can be noise, or smoothing, or both, or something else.
Public property | PositionCorrection | Position correction. This will be added to the raw position. This value doesn't get fed back into the system when calculating the next frame. Can be noise, or smoothing, or both, or something else.
Public property | RawOrientation | Raw (un-corrected) world space orientation of this camera
Public property | RawPosition | Raw (un-corrected) world space position of this camera
Public property | ReferenceLookAt | The world space focus point of the camera. What the camera wants to look at. There is a special constant define to represent "nothing". Be careful to check for that (or check the HasLookAt property).
Public property | ReferenceUp | Which way is up. World space unit vector.
Public property | ShotQuality | Subjective estimation of how "good" the shot is. Larger values mean better quality. Default is 1.
Top
Methods
 | Name | Description
Public method | AddCustomBlendable | Add a custom blendable to the pot for eventual application to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules
Public method | GetCustomBlendable | Get a custom blendable that will be applied to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules
 | Lerp | Intelligently blend the contents of two states.
Top
Fields
Name | Description
kNoPoint | This constant represents "no point in space" or "no direction".
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CameraState Properties

The CameraState type exposes the following members.

Properties
 | Name | Description
Public property | CorrectedOrientation | Orientation with correction applied.
Public property | CorrectedPosition | Position with correction applied.
 | Default | State with default values
Public property | FinalOrientation | Orientation with correction and dutch applied. This is what the final camera gets.
Public property | FinalPosition | Position with correction applied. This is what the final camera gets.
Public property | HasLookAt | Returns true if this state has a valid ReferenceLookAt value.
Public property | Lens | Camera Lens Settings.
Public property | NumCustomBlendables | The number of custom blendables that will be applied to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules
Public property | OrientationCorrection | Orientation correction. This will be added to the raw orientation. This value doesn't get fed back into the system when calculating the next frame. Can be noise, or smoothing, or both, or something else.
Public property | PositionCorrection | Position correction. This will be added to the raw position. This value doesn't get fed back into the system when calculating the next frame. Can be noise, or smoothing, or both, or something else.
Public property | RawOrientation | Raw (un-corrected) world space orientation of this camera
Public property | RawPosition | Raw (un-corrected) world space position of this camera
Public property | ReferenceLookAt | The world space focus point of the camera. What the camera wants to look at. There is a special constant define to represent "nothing". Be careful to check for that (or check the HasLookAt property).
Public property | ReferenceUp | Which way is up. World space unit vector.
Public property | ShotQuality | Subjective estimation of how "good" the shot is. Larger values mean better quality. Default is 1.
Top
See Also

Reference

CameraState Structure


CameraState.CorrectedOrientation Property

CameraStateCorrectedOrientation Property

Orientation with correction applied.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Quaternion CorrectedOrientation { get; }
function get_CorrectedOrientation();

Property Value

Type: Quaternion
See Also

Reference

CameraState Structure


CameraState.CorrectedPosition Property

CameraStateCorrectedPosition Property

Position with correction applied.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 CorrectedPosition { get; }
function get_CorrectedPosition();

Property Value

Type: Vector3
See Also

Reference

CameraState Structure


CameraState.Default Property

CameraStateDefault Property

State with default values

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static CameraState Default { get; }
Cinemachine.CameraState.get_Default = function();

Property Value

Type: CameraState
See Also

Reference

CameraState Structure


CameraState.FinalOrientation Property

CameraStateFinalOrientation Property

Orientation with correction and dutch applied. This is what the final camera gets.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Quaternion FinalOrientation { get; }
function get_FinalOrientation();

Property Value

Type: Quaternion
See Also

Reference

CameraState Structure


CameraState.FinalPosition Property

CameraStateFinalPosition Property

Position with correction applied. This is what the final camera gets.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 FinalPosition { get; }
function get_FinalPosition();

Property Value

Type: Vector3
See Also

Reference

CameraState Structure


CameraState.HasLookAt Property

CameraStateHasLookAt Property

Returns true if this state has a valid ReferenceLookAt value.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool HasLookAt { get; }
function get_HasLookAt();

Property Value

Type: Boolean
See Also

Reference

CameraState Structure


CameraState.Lens Property

CameraStateLens Property

Camera Lens Settings.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public LensSettings Lens { get; set; }
function get_Lens();
function set_Lens(value);

Property Value

Type: LensSettings
See Also

Reference

CameraState Structure


CameraState.NumCustomBlendables Property

CameraStateNumCustomBlendables Property

The number of custom blendables that will be applied to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public int NumCustomBlendables { get; }
function get_NumCustomBlendables();

Property Value

Type: Int32
See Also

Reference

CameraState Structure


CameraState.OrientationCorrection Property

CameraStateOrientationCorrection Property

Orientation correction. This will be added to the raw orientation. This value doesn't get fed back into the system when calculating the next frame. Can be noise, or smoothing, or both, or something else.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Quaternion OrientationCorrection { get; set; }
function get_OrientationCorrection();
function set_OrientationCorrection(value);

Property Value

Type: Quaternion
See Also

Reference

CameraState Structure


CameraState.PositionCorrection Property

CameraStatePositionCorrection Property

Position correction. This will be added to the raw position. This value doesn't get fed back into the system when calculating the next frame. Can be noise, or smoothing, or both, or something else.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 PositionCorrection { get; set; }
function get_PositionCorrection();
function set_PositionCorrection(value);

Property Value

Type: Vector3
See Also

Reference

CameraState Structure


CameraState.RawOrientation Property

CameraStateRawOrientation Property

Raw (un-corrected) world space orientation of this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Quaternion RawOrientation { get; set; }
function get_RawOrientation();
function set_RawOrientation(value);

Property Value

Type: Quaternion
See Also

Reference

CameraState Structure


CameraState.RawPosition Property

CameraStateRawPosition Property

Raw (un-corrected) world space position of this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 RawPosition { get; set; }
function get_RawPosition();
function set_RawPosition(value);

Property Value

Type: Vector3
See Also

Reference

CameraState Structure


CameraState.ReferenceLookAt Property

CameraStateReferenceLookAt Property

The world space focus point of the camera. What the camera wants to look at. There is a special constant define to represent "nothing". Be careful to check for that (or check the HasLookAt property).

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 ReferenceLookAt { get; set; }
function get_ReferenceLookAt();
function set_ReferenceLookAt(value);

Property Value

Type: Vector3
See Also

Reference

CameraState Structure


CameraState.ReferenceUp Property

CameraStateReferenceUp Property

Which way is up. World space unit vector.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 ReferenceUp { get; set; }
function get_ReferenceUp();
function set_ReferenceUp(value);

Property Value

Type: Vector3
See Also

Reference

CameraState Structure


CameraState.ShotQuality Property

CameraStateShotQuality Property

Subjective estimation of how "good" the shot is. Larger values mean better quality. Default is 1.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float ShotQuality { get; set; }
function get_ShotQuality();
function set_ShotQuality(value);

Property Value

Type: Single
See Also

Reference

CameraState Structure


CameraState Methods

The CameraState type exposes the following members.

Methods
 | Name | Description
Public method | AddCustomBlendable | Add a custom blendable to the pot for eventual application to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules
Public method | GetCustomBlendable | Get a custom blendable that will be applied to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules
 | Lerp | Intelligently blend the contents of two states.
Top
See Also

Reference

CameraState Structure


CameraState.AddCustomBlendable Method

CameraStateAddCustomBlendable Method

Add a custom blendable to the pot for eventual application to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void AddCustomBlendable(
    CameraStateCustomBlendable b
)
function AddCustomBlendable(b);

Parameters

b
Type: CinemachineCameraStateCustomBlendable
The custom blendable to add. If b.m_Custom is the same as an already-added custom blendable, then they will be merged and the weights combined.
See Also

Reference

CameraState Structure


CameraState.GetCustomBlendable Method

CameraStateGetCustomBlendable Method

Get a custom blendable that will be applied to the camera. The base system manages but otherwise ignores this data - it is intended for extension modules

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CameraStateCustomBlendable GetCustomBlendable(
    int index
)
function GetCustomBlendable(index);

Parameters

index
Type: SystemInt32
Which one to get. Must be in range [0...NumCustomBlendables)

Return Value

Type: CameraStateCustomBlendable
The custom blendable at the specified index.
See Also

Reference

CameraState Structure


CameraState.Lerp Method

CameraStateLerp Method

Intelligently blend the contents of two states.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static CameraState Lerp(
    CameraState stateA,
    CameraState stateB,
    float t
)
Cinemachine.CameraState.Lerp = function(stateA, stateB, t);

Parameters

stateA
Type: CinemachineCameraState
The first state, corresponding to t=0
stateB
Type: CinemachineCameraState
The second state, corresponding to t=1
t
Type: SystemSingle
How much to interpolate. Internally clamped to 0..1

Return Value

Type: CameraState
Linearly interpolated CameraState
See Also

Reference

CameraState Structure


CameraState Fields

The CameraState type exposes the following members.

Fields
Name | Description
kNoPoint | This constant represents "no point in space" or "no direction".
Top
See Also

Reference

CameraState Structure


CameraState.kNoPoint Field

CameraStatekNoPoint Field

This constant represents "no point in space" or "no direction".

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Vector3 kNoPoint
var Cinemachine.CameraState.kNoPoint

Field Value

Type: Vector3
See Also

Reference

CameraState Structure


CameraState.CustomBlendable Structure

CameraStateCustomBlendable Structure

Opaque structure represent extra blendable stuff and its weight. The base system ignores this data - it is intended for extension modules

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public struct CustomBlendable
JavaScript supports the use of structures, but not the declaration of new ones.

The CameraStateCustomBlendable type exposes the following members.

Constructors
 | Name | Description
Public method | CameraStateCustomBlendable | Constructor with specific values
Top
Fields
 | Name | Description
Public field | m_Custom | The custom stuff that the extention module will consider
Public field | m_Weight | The weight of the custom stuff. Must be 0...1
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CameraState.CustomBlendable Constructor

CameraStateCustomBlendable Constructor

Constructor with specific values

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CustomBlendable(
    Object custom,
    float weight
)
Cinemachine.CustomBlendable = function(custom, weight);

Parameters

custom
Type: Object
The custom stuff that the extention module will consider
weight
Type: SystemSingle
The weight of the custom stuff. Must be 0...1
See Also

Reference

CameraStateCustomBlendable Structure


CustomBlendable Fields

The CameraStateCustomBlendable type exposes the following members.

Fields
 | Name | Description
Public field | m_Custom | The custom stuff that the extention module will consider
Public field | m_Weight | The weight of the custom stuff. Must be 0...1
Top
See Also

Reference

CameraStateCustomBlendable Structure


CameraState.CustomBlendable.m_Custom Field

CameraStateCustomBlendablem_Custom Field

The custom stuff that the extention module will consider

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Object m_Custom
var m_Custom

Field Value

Type: Object
See Also

Reference

CameraStateCustomBlendable Structure


CameraState.CustomBlendable.m_Weight Field

CameraStateCustomBlendablem_Weight Field

The weight of the custom stuff. Must be 0...1

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float m_Weight
var m_Weight

Field Value

Type: Single
See Also

Reference

CameraStateCustomBlendable Structure


CinemachineBasicMultiChannelPerlin Class

As a part of the Cinemachine Pipeline implementing the Noise stage, this component adds Perlin Noise to the Camera state, in the Correction channel of the CameraState. The noise is created by using a predefined noise profile asset. This defines the shape of the noise over time. You can scale this in amplitude or in time, to produce a large family of different noises using the same profile.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineBasicMultiChannelPerlin

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(8f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineBasicMultiChannelPerlin : CinemachineComponentBase
Cinemachine.CinemachineBasicMultiChannelPerlin = function();

Type.createClass(
    'Cinemachine.CinemachineBasicMultiChannelPerlin',
    Cinemachine.CinemachineComponentBase);

The CinemachineBasicMultiChannelPerlin type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if the component is valid, i.e. it has a noise definition and is enabled. (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Noise stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Public method | MutateCameraState | Applies noise to the Correction channel of the CameraState if the delta time is greater than 0. Otherwise, does nothing. (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
Fields
 | Name | Description
Public field | m_AmplitudeGain | Gain to apply to the amplitudes defined in the settings asset.
Public field | m_FrequencyGain | Scale factor to apply to the frequencies defined in the settings asset.
Public field | m_NoiseProfile | Serialized property for referencing a NoiseSettings asset
Top
See Also

Reference

Cinemachine Namespace
CinemachineNoiseSettings


CinemachineBasicMultiChannelPerlin Properties

The CinemachineBasicMultiChannelPerlin type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if the component is valid, i.e. it has a noise definition and is enabled. (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Noise stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBasicMultiChannelPerlin.IsValid Property

CinemachineBasicMultiChannelPerlinIsValid Property

True if the component is valid, i.e. it has a noise definition and is enabled.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBasicMultiChannelPerlin.Stage Property

CinemachineBasicMultiChannelPerlinStage Property

Get the Cinemachine Pipeline stage that this component implements. Always returns the Noise stage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBasicMultiChannelPerlin Methods

The CinemachineBasicMultiChannelPerlin type exposes the following members.

Methods
 | Name | Description
Public method | MutateCameraState | Applies noise to the Correction channel of the CameraState if the delta time is greater than 0. Otherwise, does nothing. (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBasicMultiChannelPerlin.MutateCameraState Method

CinemachineBasicMultiChannelPerlinMutateCameraState Method

Applies noise to the Correction channel of the CameraState if the delta time is greater than 0. Otherwise, does nothing.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
How much to advance the perlin noise generator. Noise is only applied if this value is greater than or equal to 0
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBasicMultiChannelPerlin Fields

The CinemachineBasicMultiChannelPerlin type exposes the following members.

Fields
 | Name | Description
Public field | m_AmplitudeGain | Gain to apply to the amplitudes defined in the settings asset.
Public field | m_FrequencyGain | Scale factor to apply to the frequencies defined in the settings asset.
Public field | m_NoiseProfile | Serialized property for referencing a NoiseSettings asset
Top
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBasicMultiChannelPerlin.m_AmplitudeGain Field

CinemachineBasicMultiChannelPerlinm_AmplitudeGain Field

Gain to apply to the amplitudes defined in the settings asset.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Gain to apply to the amplitudes defined in the NoiseSettings asset.  1 is normal.  Setting this to 0 completely mutes the noise.")]
public float m_AmplitudeGain
var m_AmplitudeGain

Field Value

Type: Single
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBasicMultiChannelPerlin.m_FrequencyGain Field

CinemachineBasicMultiChannelPerlinm_FrequencyGain Field

Scale factor to apply to the frequencies defined in the settings asset.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Scale factor to apply to the frequencies defined in the NoiseSettings asset.  1 is normal.  Larger magnitudes will make the noise shake more rapidly.")]
public float m_FrequencyGain
var m_FrequencyGain

Field Value

Type: Single
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBasicMultiChannelPerlin.m_NoiseProfile Field

CinemachineBasicMultiChannelPerlinm_NoiseProfile Field

Serialized property for referencing a NoiseSettings asset

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HideInInspector]
[TooltipAttribute("The asset containing the Noise Profile.  Define the frequencies and amplitudes there to make a characteristic noise profile.  Make your own or just use one of the many presets.")]
[FormerlySerializedAsAttribute("m_Definition")]
public NoiseSettings m_NoiseProfile
var m_NoiseProfile

Field Value

Type: NoiseSettings
See Also

Reference

CinemachineBasicMultiChannelPerlin Class


CinemachineBlend Class

Describes a blend between 2 Cinemachine Virtual Cameras, and holds the current state of the blend.
Inheritance Hierarchy
SystemObject
CinemachineCinemachineBlend

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public class CinemachineBlend
Cinemachine.CinemachineBlend = function();

Type.createClass(
    'Cinemachine.CinemachineBlend');

The CinemachineBlend type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineBlend | Construct a blend
Top
Properties
 | Name | Description
Public property | BlendCurve | The curve that describes the way the blend transitions over time from the first camera to the second. X-axis is time in seconds over which the blend takes place and Y axis is blend weight (0..1)
Public property | BlendWeight | The current weight of the blend. This is an evaluation of the BlendCurve at the current time relative to the start of the blend. 0 means camA, 1 means camB.
Public property | CamA | First camera in the blend
Public property | CamB | Second camera in the blend
Public property | Description | Text description of the blend, for debugging
Public property | Duration | Duration in seconds of the blend. This is given read from the BlendCurve.
Public property | IsComplete | True if the time relative to the start of the blend is greater than or equal to the blend duration
Public property | IsValid | Validity test for the blend. True if both cameras are defined.
Public property | State | Compute the blended CameraState for the current time in the blend.
Public property | TimeInBlend | The current time relative to the start of the blend
Top
Methods
 | Name | Description
Public method | UpdateCameraState | Make sure the source cameras get updated.
Public method | Uses | Does the blend use a specific Cinemachine Virtual Camera?
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBlend Constructor

Construct a blend

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBlend(
    ICinemachineCamera a,
    ICinemachineCamera b,
    AnimationCurve curve,
    float duration,
    float t
)
Cinemachine.CinemachineBlend = function(a, b, curve, duration, t);

Parameters

a
Type: CinemachineICinemachineCamera
First camera
b
Type: CinemachineICinemachineCamera
Second camera
curve
Type: AnimationCurve
Blend curve
duration
Type: SystemSingle

[Missing <param name="duration"/> documentation for "M:Cinemachine.CinemachineBlend.#ctor(Cinemachine.ICinemachineCamera,Cinemachine.ICinemachineCamera,UnityEngine.AnimationCurve,System.Single,System.Single)"]

t
Type: SystemSingle
Current time in blend, relative to the start of the blend
See Also

Reference

CinemachineBlend Class


CinemachineBlend Properties

The CinemachineBlend type exposes the following members.

Properties
 | Name | Description
Public property | BlendCurve | The curve that describes the way the blend transitions over time from the first camera to the second. X-axis is time in seconds over which the blend takes place and Y axis is blend weight (0..1)
Public property | BlendWeight | The current weight of the blend. This is an evaluation of the BlendCurve at the current time relative to the start of the blend. 0 means camA, 1 means camB.
Public property | CamA | First camera in the blend
Public property | CamB | Second camera in the blend
Public property | Description | Text description of the blend, for debugging
Public property | Duration | Duration in seconds of the blend. This is given read from the BlendCurve.
Public property | IsComplete | True if the time relative to the start of the blend is greater than or equal to the blend duration
Public property | IsValid | Validity test for the blend. True if both cameras are defined.
Public property | State | Compute the blended CameraState for the current time in the blend.
Public property | TimeInBlend | The current time relative to the start of the blend
Top
See Also

Reference

CinemachineBlend Class


CinemachineBlend.BlendCurve Property

CinemachineBlendBlendCurve Property

The curve that describes the way the blend transitions over time from the first camera to the second. X-axis is time in seconds over which the blend takes place and Y axis is blend weight (0..1)

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public AnimationCurve BlendCurve { get; set; }
function get_BlendCurve();
function set_BlendCurve(value);

Property Value

Type: AnimationCurve
See Also

Reference

CinemachineBlend Class


CinemachineBlend.BlendWeight Property

CinemachineBlendBlendWeight Property

The current weight of the blend. This is an evaluation of the BlendCurve at the current time relative to the start of the blend. 0 means camA, 1 means camB.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float BlendWeight { get; }
function get_BlendWeight();

Property Value

Type: Single
See Also

Reference

CinemachineBlend Class


CinemachineBlend.CamA Property

CinemachineBlendCamA Property

First camera in the blend

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public ICinemachineCamera CamA { get; set; }
function get_CamA();
function set_CamA(value);

Property Value

Type: ICinemachineCamera
See Also

Reference

CinemachineBlend Class


CinemachineBlend.CamB Property

CinemachineBlendCamB Property

Second camera in the blend

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public ICinemachineCamera CamB { get; set; }
function get_CamB();
function set_CamB(value);

Property Value

Type: ICinemachineCamera
See Also

Reference

CinemachineBlend Class


CinemachineBlend.Description Property

CinemachineBlendDescription Property

Text description of the blend, for debugging

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public string Description { get; }
function get_Description();

Property Value

Type: String
See Also

Reference

CinemachineBlend Class


CinemachineBlend.Duration Property

CinemachineBlendDuration Property

Duration in seconds of the blend. This is given read from the BlendCurve.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float Duration { get; set; }
function get_Duration();
function set_Duration(value);

Property Value

Type: Single
See Also

Reference

CinemachineBlend Class


CinemachineBlend.IsComplete Property

CinemachineBlendIsComplete Property

True if the time relative to the start of the blend is greater than or equal to the blend duration

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsComplete { get; }
function get_IsComplete();

Property Value

Type: Boolean
See Also

Reference

CinemachineBlend Class


CinemachineBlend.IsValid Property

CinemachineBlendIsValid Property

Validity test for the blend. True if both cameras are defined.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineBlend Class


CinemachineBlend.State Property

CinemachineBlendState Property

Compute the blended CameraState for the current time in the blend.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CameraState State { get; }
function get_State();

Property Value

Type: CameraState
See Also

Reference

CinemachineBlend Class


CinemachineBlend.TimeInBlend Property

CinemachineBlendTimeInBlend Property

The current time relative to the start of the blend

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float TimeInBlend { get; set; }
function get_TimeInBlend();
function set_TimeInBlend(value);

Property Value

Type: Single
See Also

Reference

CinemachineBlend Class


CinemachineBlend Methods

The CinemachineBlend type exposes the following members.

Methods
 | Name | Description
Public method | UpdateCameraState | Make sure the source cameras get updated.
Public method | Uses | Does the blend use a specific Cinemachine Virtual Camera?
Top
See Also

Reference

CinemachineBlend Class


CinemachineBlend.UpdateCameraState Method

CinemachineBlendUpdateCameraState Method

Make sure the source cameras get updated.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world up. Individual vcams may modify this
deltaTime
Type: SystemSingle
Time increment used for calculating time-based behaviours (e.g. damping)
See Also

Reference

CinemachineBlend Class


CinemachineBlend.Uses Method

CinemachineBlendUses Method

Does the blend use a specific Cinemachine Virtual Camera?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool Uses(
    ICinemachineCamera cam
)
function Uses(cam);

Parameters

cam
Type: CinemachineICinemachineCamera
The camera to test

Return Value

Type: Boolean
True if the camera is involved in the blend
See Also

Reference

CinemachineBlend Class


CinemachineBlendDefinition Structure

Definition of a Camera blend. This struct holds the information necessary to generate a suitable AnimationCurve for a Cinemachine Blend.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(10.2f, DocumentationSortingAttributeLevel.UserRef)]
public struct CinemachineBlendDefinition
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineBlendDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineBlendDefinition | Constructor
Top
Properties
 | Name | Description
Public property | BlendCurve | An AnimationCurve specifying the interpolation duration and value for this camera blend. The time of the last key frame is assumed to the be the duration of the blend. Y-axis values must be in range [0,1] (internally clamped within Blender) and time must be in range of [0, +infinity)
Top
Fields
 | Name | Description
Public field | m_Style | The shape of the blend curve.
Public field | m_Time | The duration (in seconds) of the blend
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBlendDefinition Constructor

Constructor

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBlendDefinition(
    CinemachineBlendDefinitionStyle style,
    float time
)
Cinemachine.CinemachineBlendDefinition = function(style, time);

Parameters

style
Type: CinemachineCinemachineBlendDefinitionStyle
The shape of the blend curve.
time
Type: SystemSingle
The duration (in seconds) of the blend
See Also

Reference

CinemachineBlendDefinition Structure


CinemachineBlendDefinition Properties

The CinemachineBlendDefinition type exposes the following members.

Properties
 | Name | Description
Public property | BlendCurve | An AnimationCurve specifying the interpolation duration and value for this camera blend. The time of the last key frame is assumed to the be the duration of the blend. Y-axis values must be in range [0,1] (internally clamped within Blender) and time must be in range of [0, +infinity)
Top
See Also

Reference

CinemachineBlendDefinition Structure


CinemachineBlendDefinition.BlendCurve Property

CinemachineBlendDefinitionBlendCurve Property

An AnimationCurve specifying the interpolation duration and value for this camera blend. The time of the last key frame is assumed to the be the duration of the blend. Y-axis values must be in range [0,1] (internally clamped within Blender) and time must be in range of [0, +infinity)

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public AnimationCurve BlendCurve { get; }
function get_BlendCurve();

Property Value

Type: AnimationCurve
See Also

Reference

CinemachineBlendDefinition Structure


CinemachineBlendDefinition Fields

The CinemachineBlendDefinition type exposes the following members.

Fields
 | Name | Description
Public field | m_Style | The shape of the blend curve.
Public field | m_Time | The duration (in seconds) of the blend
Top
See Also

Reference

CinemachineBlendDefinition Structure


CinemachineBlendDefinition.m_Style Field

CinemachineBlendDefinitionm_Style Field

The shape of the blend curve.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Shape of the blend curve")]
public CinemachineBlendDefinitionStyle m_Style
var m_Style

Field Value

Type: CinemachineBlendDefinitionStyle
See Also

Reference

CinemachineBlendDefinition Structure


CinemachineBlendDefinition.m_Time Field

CinemachineBlendDefinitionm_Time Field

The duration (in seconds) of the blend

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Duration of the blend, in seconds")]
public float m_Time
var m_Time

Field Value

Type: Single
See Also

Reference

CinemachineBlendDefinition Structure


CinemachineBlendDefinition.Style Enumeration

CinemachineBlendDefinitionStyle Enumeration

Supported predefined shapes for the blend curve.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(10.21f, DocumentationSortingAttributeLevel.UserRef)]
public enum Style
Cinemachine.Style = function();
Cinemachine.Style.createEnum('Cinemachine.Style', false);
Members
Member name | Value | Description
Cut | 0 | Zero-length blend
EaseInOut | 1 | S-shaped curve, giving a gentle and smooth transition
EaseIn | 2 | Linear out of the outgoing shot, and easy into the incoming
EaseOut | 3 | Easy out of the outgoing shot, and linear into the incoming
HardIn | 4 | Easy out of the outgoing, and hard into the incoming
HardOut | 5 | Hard out of the outgoing, and easy into the incoming
Linear | 6 | Linear blend. Mechanical-looking.
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBlendDefinitionPropertyAttribute Class

Property applied to CinemachineBlendDefinition. Used for custom drawing in the inspector.
Inheritance Hierarchy
SystemObject
SystemAttribute
PropertyAttribute
CinemachineCinemachineBlendDefinitionPropertyAttribute

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public sealed class CinemachineBlendDefinitionPropertyAttribute : PropertyAttribute
Cinemachine.CinemachineBlendDefinitionPropertyAttribute = function();

Type.createClass(
    'Cinemachine.CinemachineBlendDefinitionPropertyAttribute',
    UnityEngine.PropertyAttribute);

The CinemachineBlendDefinitionPropertyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineBlendDefinitionPropertyAttribute |
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBlendDefinitionPropertyAttribute Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineBlendDefinitionPropertyAttribute.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBlendDefinitionPropertyAttribute()
Cinemachine.CinemachineBlendDefinitionPropertyAttribute = function();
See Also

Reference

CinemachineBlendDefinitionPropertyAttribute Class


CinemachineBlenderSettings Class

Asset that defines the rules for blending between Virtual Cameras.
Inheritance Hierarchy
SystemObject
Object
ScriptableObject
CinemachineCinemachineBlenderSettings

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(10f, DocumentationSortingAttributeLevel.UserRef)]
public sealed class CinemachineBlenderSettings : ScriptableObject
Cinemachine.CinemachineBlenderSettings = function();

Type.createClass(
    'Cinemachine.CinemachineBlenderSettings',
    UnityEngine.ScriptableObject);

The CinemachineBlenderSettings type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineBlenderSettings |
Top
Methods
 | Name | Description
Public method | GetBlendCurveForVirtualCameras | Attempts to find a blend curve which matches the to and from cameras as specified. If no match is found, the function returns either the default blend for this Blender or NULL depending on the state of returnDefaultOnNoMatch.
Top
Fields
 | Name | Description
 | kBlendFromAnyCameraLabel | Internal API for the inspector editopr: a label to represent any camera
Public field | m_CustomBlends | The array containing explicitly defined blends between two Virtual Cameras
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBlenderSettings Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineBlenderSettings.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBlenderSettings()
Cinemachine.CinemachineBlenderSettings = function();
See Also

Reference

CinemachineBlenderSettings Class


CinemachineBlenderSettings Methods

The CinemachineBlenderSettings type exposes the following members.

Methods
 | Name | Description
Public method | GetBlendCurveForVirtualCameras | Attempts to find a blend curve which matches the to and from cameras as specified. If no match is found, the function returns either the default blend for this Blender or NULL depending on the state of returnDefaultOnNoMatch.
Top
See Also

Reference

CinemachineBlenderSettings Class


CinemachineBlenderSettings.GetBlendCurveForVirtualCameras Method

CinemachineBlenderSettingsGetBlendCurveForVirtualCameras Method

Attempts to find a blend curve which matches the to and from cameras as specified. If no match is found, the function returns either the default blend for this Blender or NULL depending on the state of returnDefaultOnNoMatch.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public AnimationCurve GetBlendCurveForVirtualCameras(
    string fromCameraName,
    string toCameraName,
    AnimationCurve defaultCurve
)
function GetBlendCurveForVirtualCameras(fromCameraName, toCameraName, defaultCurve);

Parameters

fromCameraName
Type: SystemString
The game object name of the from camera
toCameraName
Type: SystemString
The game object name of the to camera
defaultCurve
Type: AnimationCurve
Curve to return if no curve found. Can be NULL.

Return Value

Type: AnimationCurve

[Missing <returns> documentation for "M:Cinemachine.CinemachineBlenderSettings.GetBlendCurveForVirtualCameras(System.String,System.String,UnityEngine.AnimationCurve)"]

See Also

Reference

CinemachineBlenderSettings Class


CinemachineBlenderSettings Fields

The CinemachineBlenderSettings type exposes the following members.

Fields
 | Name | Description
 | kBlendFromAnyCameraLabel | Internal API for the inspector editopr: a label to represent any camera
Public field | m_CustomBlends | The array containing explicitly defined blends between two Virtual Cameras
Top
See Also

Reference

CinemachineBlenderSettings Class


CinemachineBlenderSettings.kBlendFromAnyCameraLabel Field

CinemachineBlenderSettingskBlendFromAnyCameraLabel Field

Internal API for the inspector editopr: a label to represent any camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public const string kBlendFromAnyCameraLabel = "**ANY CAMERA**"
var Cinemachine.CinemachineBlenderSettings.kBlendFromAnyCameraLabel

Field Value

Type: String
See Also

Reference

CinemachineBlenderSettings Class


CinemachineBlenderSettings.m_CustomBlends Field

CinemachineBlenderSettingsm_CustomBlends Field

The array containing explicitly defined blends between two Virtual Cameras

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The array containing explicitly defined blends between two Virtual Cameras")]
public CinemachineBlenderSettingsCustomBlend[] m_CustomBlends
var m_CustomBlends

Field Value

Type: CinemachineBlenderSettingsCustomBlend
See Also

Reference

CinemachineBlenderSettings Class


CinemachineBlenderSettings.CustomBlend Structure

CinemachineBlenderSettingsCustomBlend Structure

Container specifying how two specific Cinemachine Virtual Cameras blend together.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(10.1f, DocumentationSortingAttributeLevel.UserRef)]
public struct CustomBlend
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineBlenderSettingsCustomBlend type exposes the following members.

Fields
 | Name | Description
Public field | m_Blend |
Public field | m_From |
Public field | m_To |
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CustomBlend Fields

The CinemachineBlenderSettingsCustomBlend type exposes the following members.

Fields
 | Name | Description
Public field | m_Blend |
Public field | m_From |
Public field | m_To |
Top
See Also

Reference

CinemachineBlenderSettingsCustomBlend Structure


CinemachineBlenderSettings.CustomBlend.m_Blend Field

CinemachineBlenderSettingsCustomBlendm_Blend Field

[Missing <summary> documentation for "F:Cinemachine.CinemachineBlenderSettings.CustomBlend.m_Blend"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Blend curve definition")]
public CinemachineBlendDefinition m_Blend
var m_Blend

Field Value

Type: CinemachineBlendDefinition
See Also

Reference

CinemachineBlenderSettingsCustomBlend Structure


CinemachineBlenderSettings.CustomBlend.m_From Field

CinemachineBlenderSettingsCustomBlendm_From Field

[Missing <summary> documentation for "F:Cinemachine.CinemachineBlenderSettings.CustomBlend.m_From"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When blending from this camera")]
public string m_From
var m_From

Field Value

Type: String
See Also

Reference

CinemachineBlenderSettingsCustomBlend Structure


CinemachineBlenderSettings.CustomBlend.m_To Field

CinemachineBlenderSettingsCustomBlendm_To Field

[Missing <summary> documentation for "F:Cinemachine.CinemachineBlenderSettings.CustomBlend.m_To"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When blending to this camera")]
public string m_To
var m_To

Field Value

Type: String
See Also

Reference

CinemachineBlenderSettingsCustomBlend Structure


CinemachineBlendListCamera Class

This is a virtual camera "manager" that owns and manages a collection of child Virtual Cameras. When the camera goes live, these child vcams are enabled, one after another, holding each camera for a designated time. Blends between cameras are specified. The last camera is held indefinitely.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
CinemachineCinemachineBlendListCamera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(13f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[DisallowMultipleComponent]
[AddComponentMenu("Cinemachine/CinemachineBlendListCamera")]
public class CinemachineBlendListCamera : CinemachineVirtualCameraBase
Cinemachine.CinemachineBlendListCamera = function();

Type.createClass(
    'Cinemachine.CinemachineBlendListCamera',
    Cinemachine.CinemachineVirtualCameraBase);

The CinemachineBlendListCamera type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineBlendListCamera |
Top
Properties
 | Name | Description
Public property | ChildCameras | The list of child cameras. These are just the immediate children in the hierarchy.
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Overrides CinemachineVirtualCameraBaseDescription.)
Public property | Follow | Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | IsBlending | Is there a blend in progress?
Public property | LiveChild | Get the current "best" child virtual camera, that would be chosen if the State Driven Camera were active.
Public property | LiveChildOrSelf | Return the live child. (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The State of the current live child (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Makes sure the internal child cache is up to date (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnTransformChildrenChanged | Makes sure the internal child cache is up to date
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | (Overrides CinemachineVirtualCameraBaseOnTransitionFromCamera(ICinemachineCamera).)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid. (Inherited from CinemachineVirtualCameraBase.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Public method | ValidateInstructions | Internal API for the inspector editor.
Top
Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ChildCameras | Internal API for the editor. Do not use this field
Public field | m_EnableAllChildCameras | Force all child cameras to be enabled. This is useful if animating them in Timeline, but consumes extra resources.
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | Default object for the camera children wants to move with (the body target), if not specified in a child rig. May be empty
Public field | m_Instructions | The set of instructions associating virtual cameras with states. The set of instructions for enabling child cameras
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | Default object for the camera children to look at (the aim target), if not specified in a child rig. May be empty
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ShowDebugText | When enabled, the current camera and blend will be indicated in the game window, for debugging
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBlendListCamera Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineBlendListCamera.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBlendListCamera()
Cinemachine.CinemachineBlendListCamera = function();
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera Properties

The CinemachineBlendListCamera type exposes the following members.

Properties
 | Name | Description
Public property | ChildCameras | The list of child cameras. These are just the immediate children in the hierarchy.
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Overrides CinemachineVirtualCameraBaseDescription.)
Public property | Follow | Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | IsBlending | Is there a blend in progress?
Public property | LiveChild | Get the current "best" child virtual camera, that would be chosen if the State Driven Camera were active.
Public property | LiveChildOrSelf | Return the live child. (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The State of the current live child (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.ChildCameras Property

CinemachineBlendListCameraChildCameras Property

The list of child cameras. These are just the immediate children in the hierarchy.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineVirtualCameraBase[] ChildCameras { get; }
function get_ChildCameras();

Property Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.Description Property

CinemachineBlendListCameraDescription Property

Gets a brief debug description of this virtual camera, for use when displayiong debug info

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override string Description { get; }
function get_Description();

Property Value

Type: String

Implements

ICinemachineCameraDescription
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.Follow Property

CinemachineBlendListCameraFollow Property

Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform

Implements

ICinemachineCameraFollow
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.IsBlending Property

CinemachineBlendListCameraIsBlending Property

Is there a blend in progress?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsBlending { get; }
function get_IsBlending();

Property Value

Type: Boolean
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.LiveChild Property

CinemachineBlendListCameraLiveChild Property

Get the current "best" child virtual camera, that would be chosen if the State Driven Camera were active.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public ICinemachineCamera LiveChild { get; set; }
function get_LiveChild();
function set_LiveChild(value);

Property Value

Type: ICinemachineCamera
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.LiveChildOrSelf Property

CinemachineBlendListCameraLiveChildOrSelf Property

Return the live child.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override ICinemachineCamera LiveChildOrSelf { get; }
function get_LiveChildOrSelf();

Property Value

Type: ICinemachineCamera

Implements

ICinemachineCameraLiveChildOrSelf
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.LookAt Property

CinemachineBlendListCameraLookAt Property

Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform

Implements

ICinemachineCameraLookAt
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.State Property

CinemachineBlendListCameraState Property

The State of the current live child

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CameraState State { get; }
function get_State();

Property Value

Type: CameraState

Implements

ICinemachineCameraState
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera Methods

The CinemachineBlendListCamera type exposes the following members.

Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Makes sure the internal child cache is up to date (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnTransformChildrenChanged | Makes sure the internal child cache is up to date
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | (Overrides CinemachineVirtualCameraBaseOnTransitionFromCamera(ICinemachineCamera).)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid. (Inherited from CinemachineVirtualCameraBase.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Public method | ValidateInstructions | Internal API for the inspector editor.
Top
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.IsLiveChild Method

CinemachineBlendListCameraIsLiveChild Method

Check whether the vcam a live child of this camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsLiveChild(
    ICinemachineCamera vcam
)
function IsLiveChild(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The Virtual Camera to check

Return Value

Type: Boolean
True if the vcam is currently actively influencing the state of this vcam

Implements

ICinemachineCameraIsLiveChild(ICinemachineCamera)
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.OnEnable Method

CinemachineBlendListCameraOnEnable Method

Makes sure the internal child cache is up to date

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnEnable()
function OnEnable();
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.OnTransformChildrenChanged Method

CinemachineBlendListCameraOnTransformChildrenChanged Method

Makes sure the internal child cache is up to date

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void OnTransformChildrenChanged()
function OnTransformChildrenChanged();
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.OnTransitionFromCamera Method

CinemachineBlendListCameraOnTransitionFromCamera Method

[Missing <summary> documentation for "M:Cinemachine.CinemachineBlendListCamera.OnTransitionFromCamera(Cinemachine.ICinemachineCamera)"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void OnTransitionFromCamera(
    ICinemachineCamera fromCam
)
function OnTransitionFromCamera(fromCam);

Parameters

fromCam
Type: CinemachineICinemachineCamera

[Missing <param name="fromCam"/> documentation for "M:Cinemachine.CinemachineBlendListCamera.OnTransitionFromCamera(Cinemachine.ICinemachineCamera)"]

Implements

ICinemachineCameraOnTransitionFromCamera(ICinemachineCamera)
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.RemovePostPipelineStageHook Method

CinemachineBlendListCameraRemovePostPipelineStageHook Method

Remove a Pipeline stage hook callback. Make sure it is removed from all the children.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void RemovePostPipelineStageHook(
    CinemachineVirtualCameraBaseOnPostPipelineStageDelegate d
)
function RemovePostPipelineStageHook(d);

Parameters

d
Type: CinemachineCinemachineVirtualCameraBaseOnPostPipelineStageDelegate
The delegate to remove.
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.UpdateCameraState Method

CinemachineBlendListCameraUpdateCameraState Method

Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than or equal to 0)

Implements

ICinemachineCameraUpdateCameraState(Vector3, Single)
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.ValidateInstructions Method

CinemachineBlendListCameraValidateInstructions Method

Internal API for the inspector editor.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void ValidateInstructions()
function ValidateInstructions();
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera Fields

The CinemachineBlendListCamera type exposes the following members.

Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ChildCameras | Internal API for the editor. Do not use this field
Public field | m_EnableAllChildCameras | Force all child cameras to be enabled. This is useful if animating them in Timeline, but consumes extra resources.
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | Default object for the camera children wants to move with (the body target), if not specified in a child rig. May be empty
Public field | m_Instructions | The set of instructions associating virtual cameras with states. The set of instructions for enabling child cameras
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | Default object for the camera children to look at (the aim target), if not specified in a child rig. May be empty
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ShowDebugText | When enabled, the current camera and blend will be indicated in the game window, for debugging
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.m_ChildCameras Field

CinemachineBlendListCameram_ChildCameras Field

Internal API for the editor. Do not use this field

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializeField]
[HideInInspector]
[NoSaveDuringPlayAttribute]
public CinemachineVirtualCameraBase[] m_ChildCameras
var m_ChildCameras

Field Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.m_EnableAllChildCameras Field

CinemachineBlendListCameram_EnableAllChildCameras Field

Force all child cameras to be enabled. This is useful if animating them in Timeline, but consumes extra resources.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Force all child cameras to be enabled.  This is useful if animating them in Timeline, but consumes extra resources")]
public bool m_EnableAllChildCameras
var m_EnableAllChildCameras

Field Value

Type: Boolean
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.m_Follow Field

CinemachineBlendListCameram_Follow Field

Default object for the camera children wants to move with (the body target), if not specified in a child rig. May be empty

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Default object for the camera children wants to move with (the body target), if not specified in a child camera.  May be empty if all of the children define targets of their own.")]
[NoSaveDuringPlayAttribute]
public Transform m_Follow
var m_Follow

Field Value

Type: Transform
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.m_Instructions Field

CinemachineBlendListCameram_Instructions Field

The set of instructions associating virtual cameras with states. The set of instructions for enabling child cameras

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The set of instructions for enabling child cameras.")]
public CinemachineBlendListCameraInstruction[] m_Instructions
var m_Instructions

Field Value

Type: CinemachineBlendListCameraInstruction
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.m_LookAt Field

CinemachineBlendListCameram_LookAt Field

Default object for the camera children to look at (the aim target), if not specified in a child rig. May be empty

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Default object for the camera children to look at (the aim target), if not specified in a child camera.  May be empty if all of the children define targets of their own.")]
[NoSaveDuringPlayAttribute]
public Transform m_LookAt
var m_LookAt

Field Value

Type: Transform
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.m_ShowDebugText Field

CinemachineBlendListCameram_ShowDebugText Field

When enabled, the current camera and blend will be indicated in the game window, for debugging

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When enabled, the current child camera and blend will be indicated in the game window, for debugging")]
public bool m_ShowDebugText
var m_ShowDebugText

Field Value

Type: Boolean
See Also

Reference

CinemachineBlendListCamera Class


CinemachineBlendListCamera.Instruction Structure

CinemachineBlendListCameraInstruction Structure

This represents a single entry in the instrunction list of the BlendListCamera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
public struct Instruction
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineBlendListCameraInstruction type exposes the following members.

Fields
 | Name | Description
Public field | m_Blend | How to blend to the next virtual camera in the list (if any)
Public field | m_Hold | How long to wait (in seconds) before activating the next virtual camera in the list (if any)
Public field | m_VirtualCamera | The virtual camera to activate when this instruction becomes active
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


Instruction Fields

The CinemachineBlendListCameraInstruction type exposes the following members.

Fields
 | Name | Description
Public field | m_Blend | How to blend to the next virtual camera in the list (if any)
Public field | m_Hold | How long to wait (in seconds) before activating the next virtual camera in the list (if any)
Public field | m_VirtualCamera | The virtual camera to activate when this instruction becomes active
Top
See Also

Reference

CinemachineBlendListCameraInstruction Structure


CinemachineBlendListCamera.Instruction.m_Blend Field

CinemachineBlendListCameraInstructionm_Blend Field

How to blend to the next virtual camera in the list (if any)

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[CinemachineBlendDefinitionPropertyAttribute]
[TooltipAttribute("How to blend to the next virtual camera in the list (if any)")]
public CinemachineBlendDefinition m_Blend
var m_Blend

Field Value

Type: CinemachineBlendDefinition
See Also

Reference

CinemachineBlendListCameraInstruction Structure


CinemachineBlendListCamera.Instruction.m_Hold Field

CinemachineBlendListCameraInstructionm_Hold Field

How long to wait (in seconds) before activating the next virtual camera in the list (if any)

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How long to wait (in seconds) before activating the next virtual camera in the list (if any)")]
public float m_Hold
var m_Hold

Field Value

Type: Single
See Also

Reference

CinemachineBlendListCameraInstruction Structure


CinemachineBlendListCamera.Instruction.m_VirtualCamera Field

CinemachineBlendListCameraInstructionm_VirtualCamera Field

The virtual camera to activate when this instruction becomes active

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The virtual camera to activate when this instruction becomes active")]
public CinemachineVirtualCameraBase m_VirtualCamera
var m_VirtualCamera

Field Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineBlendListCameraInstruction Structure


CinemachineBrain Class

CinemachineBrain is the link between the Unity Camera and the Cinemachine Virtual Cameras in the scene. It monitors the priority stack to choose the current Virtual Camera, and blend with another if necessary. Finally and most importantly, it applies the Virtual Camera state to the attached Unity Camera. The CinemachineBrain is also the place where rules for blending between virtual cameras are defined. Camera blending is an interpolation over time of one virtual camera position and state to another. If you think of virtual cameras as cameramen, then blending is a little like one cameraman smoothly passing the camera to another cameraman. You can specify the time over which to blend, as well as the blend curve shape. Note that a camera cut is just a zero-time blend.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineBrain

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(0f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[DisallowMultipleComponent]
[AddComponentMenu("Cinemachine/CinemachineBrain")]
[SaveDuringPlayAttribute]
public class CinemachineBrain : MonoBehaviour
Cinemachine.CinemachineBrain = function();

Type.createClass(
    'Cinemachine.CinemachineBrain',
    UnityEngine.MonoBehaviour);

The CinemachineBrain type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineBrain |
Top
Properties
 | Name | Description
Public property | ActiveBlend | Get the current blend in progress. Returns null if none.
Public property | ActiveVirtualCamera | Get the current active virtual camera.
Public property | CurrentCameraState | The current state applied to the unity camera (may be the result of a blend)
Public property | DefaultWorldUp | Get the default world up for the virtual cameras.
Public property | IsBlending | Is there a blend in progress?
Public property | OutputCamera | Get the Unity Camera that is attached to this GameObject. This is the camera that will be controlled by the brain.
 | SoloCamera | API for the Unity Editor. Show this camera no matter what. This is static, and so affects all Cinemachine brains.
Top
Methods
 | Name | Description
 | GetSoloGUIColor | API for the Unity Editor.
Public method | IsLive | True if the ICinemachineCamera the current active camera, or part of a current blend, either directly or indirectly because its parents are live.
Top
Fields
 | Name | Description
Public field | m_CameraActivatedEvent | This event will fire whenever a virtual camera goes live. If a blend is involved, then the event will fire on the first frame of the blend
Public field | m_CameraCutEvent | This event will fire whenever a virtual camera goes live and there is no blend
Public field | m_CustomBlends | This is the asset which contains custom settings for specific blends.
Public field | m_DefaultBlend | The blend which is used if you don't explicitly define a blend between two Virtual Cameras.
Public field | m_IgnoreTimeScale | When enabled, the cameras will always respond in real-time to user input and damping, even if the game is running in slow motion
Public field | m_ShowCameraFrustum | When enabled, shows the camera's frustum in the scene view.
Public field | m_ShowDebugText | When enabled, the current camera and blend will be indicated in the game window, for debugging.
Public field | m_UpdateMethod | Depending on how the target objects are animated, adjust the update method to minimize the potential jitter. Use FixedUpdate if all your targets are animated with for RigidBody animation. SmartUpdate will choose the best method for each virtual camera, depending on how the target is animated.
Public field | m_WorldUpOverride | If set, this object's Y axis will define the worldspace Up vector for all the virtual cameras. This is useful in top-down game environments. If not set, Up is worldspace Y.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBrain Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineBrain.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBrain()
Cinemachine.CinemachineBrain = function();
See Also

Reference

CinemachineBrain Class


CinemachineBrain Properties

The CinemachineBrain type exposes the following members.

Properties
 | Name | Description
Public property | ActiveBlend | Get the current blend in progress. Returns null if none.
Public property | ActiveVirtualCamera | Get the current active virtual camera.
Public property | CurrentCameraState | The current state applied to the unity camera (may be the result of a blend)
Public property | DefaultWorldUp | Get the default world up for the virtual cameras.
Public property | IsBlending | Is there a blend in progress?
Public property | OutputCamera | Get the Unity Camera that is attached to this GameObject. This is the camera that will be controlled by the brain.
 | SoloCamera | API for the Unity Editor. Show this camera no matter what. This is static, and so affects all Cinemachine brains.
Top
See Also

Reference

CinemachineBrain Class


CinemachineBrain.ActiveBlend Property

CinemachineBrainActiveBlend Property

Get the current blend in progress. Returns null if none.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBlend ActiveBlend { get; }
function get_ActiveBlend();

Property Value

Type: CinemachineBlend
See Also

Reference

CinemachineBrain Class


CinemachineBrain.ActiveVirtualCamera Property

CinemachineBrainActiveVirtualCamera Property

Get the current active virtual camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public ICinemachineCamera ActiveVirtualCamera { get; }
function get_ActiveVirtualCamera();

Property Value

Type: ICinemachineCamera
See Also

Reference

CinemachineBrain Class


CinemachineBrain.CurrentCameraState Property

CinemachineBrainCurrentCameraState Property

The current state applied to the unity camera (may be the result of a blend)

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CameraState CurrentCameraState { get; }
function get_CurrentCameraState();

Property Value

Type: CameraState
See Also

Reference

CinemachineBrain Class


CinemachineBrain.DefaultWorldUp Property

CinemachineBrainDefaultWorldUp Property

Get the default world up for the virtual cameras.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 DefaultWorldUp { get; }
function get_DefaultWorldUp();

Property Value

Type: Vector3
See Also

Reference

CinemachineBrain Class


CinemachineBrain.IsBlending Property

CinemachineBrainIsBlending Property

Is there a blend in progress?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsBlending { get; }
function get_IsBlending();

Property Value

Type: Boolean
See Also

Reference

CinemachineBrain Class


CinemachineBrain.OutputCamera Property

CinemachineBrainOutputCamera Property

Get the Unity Camera that is attached to this GameObject. This is the camera that will be controlled by the brain.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Camera OutputCamera { get; }
function get_OutputCamera();

Property Value

Type: Camera
See Also

Reference

CinemachineBrain Class


CinemachineBrain.SoloCamera Property

CinemachineBrainSoloCamera Property

API for the Unity Editor. Show this camera no matter what. This is static, and so affects all Cinemachine brains.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static ICinemachineCamera SoloCamera { get; set; }
Cinemachine.CinemachineBrain.get_SoloCamera = function();
Cinemachine.CinemachineBrain.set_SoloCamera = function(value);

Property Value

Type: ICinemachineCamera
See Also

Reference

CinemachineBrain Class


CinemachineBrain Methods

The CinemachineBrain type exposes the following members.

Methods
 | Name | Description
 | GetSoloGUIColor | API for the Unity Editor.
Public method | IsLive | True if the ICinemachineCamera the current active camera, or part of a current blend, either directly or indirectly because its parents are live.
Top
See Also

Reference

CinemachineBrain Class


CinemachineBrain.GetSoloGUIColor Method

CinemachineBrainGetSoloGUIColor Method

API for the Unity Editor.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Color GetSoloGUIColor()
Cinemachine.CinemachineBrain.GetSoloGUIColor = function();

Return Value

Type: Color
Color used to indicate that a camera is in Solo mode.
See Also

Reference

CinemachineBrain Class


CinemachineBrain.IsLive Method

CinemachineBrainIsLive Method

True if the ICinemachineCamera the current active camera, or part of a current blend, either directly or indirectly because its parents are live.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsLive(
    ICinemachineCamera vcam
)
function IsLive(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The camera to test whether it is live

Return Value

Type: Boolean
True if the camera is live (directly or indirectly) or part of a blend in progress.
See Also

Reference

CinemachineBrain Class


CinemachineBrain Fields

The CinemachineBrain type exposes the following members.

Fields
 | Name | Description
Public field | m_CameraActivatedEvent | This event will fire whenever a virtual camera goes live. If a blend is involved, then the event will fire on the first frame of the blend
Public field | m_CameraCutEvent | This event will fire whenever a virtual camera goes live and there is no blend
Public field | m_CustomBlends | This is the asset which contains custom settings for specific blends.
Public field | m_DefaultBlend | The blend which is used if you don't explicitly define a blend between two Virtual Cameras.
Public field | m_IgnoreTimeScale | When enabled, the cameras will always respond in real-time to user input and damping, even if the game is running in slow motion
Public field | m_ShowCameraFrustum | When enabled, shows the camera's frustum in the scene view.
Public field | m_ShowDebugText | When enabled, the current camera and blend will be indicated in the game window, for debugging.
Public field | m_UpdateMethod | Depending on how the target objects are animated, adjust the update method to minimize the potential jitter. Use FixedUpdate if all your targets are animated with for RigidBody animation. SmartUpdate will choose the best method for each virtual camera, depending on how the target is animated.
Public field | m_WorldUpOverride | If set, this object's Y axis will define the worldspace Up vector for all the virtual cameras. This is useful in top-down game environments. If not set, Up is worldspace Y.
Top
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_CameraActivatedEvent Field

CinemachineBrainm_CameraActivatedEvent Field

This event will fire whenever a virtual camera goes live. If a blend is involved, then the event will fire on the first frame of the blend

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("This event will fire whenever a virtual camera goes live.  If a blend is involved, then the event will fire on the first frame of the blend.")]
public CinemachineBrainVcamEvent m_CameraActivatedEvent
var m_CameraActivatedEvent

Field Value

Type: CinemachineBrainVcamEvent
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_CameraCutEvent Field

CinemachineBrainm_CameraCutEvent Field

This event will fire whenever a virtual camera goes live and there is no blend

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("This event will fire whenever a virtual camera goes live and there is no blend")]
public CinemachineBrainBrainEvent m_CameraCutEvent
var m_CameraCutEvent

Field Value

Type: CinemachineBrainBrainEvent
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_CustomBlends Field

CinemachineBrainm_CustomBlends Field

This is the asset which contains custom settings for specific blends.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("This is the asset that contains custom settings for blends between specific virtual cameras in your scene")]
public CinemachineBlenderSettings m_CustomBlends
var m_CustomBlends

Field Value

Type: CinemachineBlenderSettings
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_DefaultBlend Field

CinemachineBrainm_DefaultBlend Field

The blend which is used if you don't explicitly define a blend between two Virtual Cameras.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[CinemachineBlendDefinitionPropertyAttribute]
[TooltipAttribute("The blend that is used in cases where you haven't explicitly defined a blend between two Virtual Cameras")]
public CinemachineBlendDefinition m_DefaultBlend
var m_DefaultBlend

Field Value

Type: CinemachineBlendDefinition
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_IgnoreTimeScale Field

CinemachineBrainm_IgnoreTimeScale Field

When enabled, the cameras will always respond in real-time to user input and damping, even if the game is running in slow motion

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When enabled, the cameras will always respond in real-time to user input and damping, even if the game is running in slow motion")]
public bool m_IgnoreTimeScale
var m_IgnoreTimeScale

Field Value

Type: Boolean
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_ShowCameraFrustum Field

CinemachineBrainm_ShowCameraFrustum Field

When enabled, shows the camera's frustum in the scene view.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When enabled, the camera's frustum will be shown at all times in the scene view")]
public bool m_ShowCameraFrustum
var m_ShowCameraFrustum

Field Value

Type: Boolean
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_ShowDebugText Field

CinemachineBrainm_ShowDebugText Field

When enabled, the current camera and blend will be indicated in the game window, for debugging.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When enabled, the current camera and blend will be indicated in the game window, for debugging")]
public bool m_ShowDebugText
var m_ShowDebugText

Field Value

Type: Boolean
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_UpdateMethod Field

CinemachineBrainm_UpdateMethod Field

Depending on how the target objects are animated, adjust the update method to minimize the potential jitter. Use FixedUpdate if all your targets are animated with for RigidBody animation. SmartUpdate will choose the best method for each virtual camera, depending on how the target is animated.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Use FixedUpdate if all your targets are animated during FixedUpdate (e.g. RigidBodies), LateUpdate if all your targets are animated during the normal Update loop, and SmartUpdate if you want Cinemachine to do the appropriate thing on a per-target basis.  SmartUpdate is the recommended setting")]
public CinemachineBrainUpdateMethod m_UpdateMethod
var m_UpdateMethod

Field Value

Type: CinemachineBrainUpdateMethod
See Also

Reference

CinemachineBrain Class


CinemachineBrain.m_WorldUpOverride Field

CinemachineBrainm_WorldUpOverride Field

If set, this object's Y axis will define the worldspace Up vector for all the virtual cameras. This is useful in top-down game environments. If not set, Up is worldspace Y.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If set, this object's Y axis will define the worldspace Up vector for all the virtual cameras.  This is useful for instance in top-down game environments.  If not set, Up is worldspace Y.  Setting this appropriately is important, because Virtual Cameras don't like looking straight up or straight down.")]
public Transform m_WorldUpOverride
var m_WorldUpOverride

Field Value

Type: Transform
See Also

Reference

CinemachineBrain Class


CinemachineBrain.BrainEvent Class

CinemachineBrainBrainEvent Class

Event with a CinemachineBrain parameter
Inheritance Hierarchy
SystemObject
UnityEventBase
UnityEventCinemachineBrain
CinemachineCinemachineBrainBrainEvent

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
public class BrainEvent : UnityEvent<CinemachineBrain>
Cinemachine.BrainEvent = function();

Type.createClass(
    'Cinemachine.BrainEvent',
    UnityEngine.Events.UnityEvent`1);

The CinemachineBrainBrainEvent type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineBrainBrainEvent |
Top
Methods
 | Name | Description
Public method | AddListener(UnityActionUTP) | (Inherited from UnityEventCinemachineBrain .)
Protected method | AddListener(Object, MethodInfo) | (Inherited from UnityEventBase.)
Protected method | FindMethod_Impl | (Inherited from UnityEventCinemachineBrain .)
Public method | GetPersistentEventCount | (Inherited from UnityEventBase.)
Public method | GetPersistentMethodName | (Inherited from UnityEventBase.)
Public method | GetPersistentTarget | (Inherited from UnityEventBase.)
Protected method | Invoke(Object) | (Inherited from UnityEventBase.)
Public method | Invoke(UTP) | (Inherited from UnityEventCinemachineBrain .)
Protected method | RegisterPersistentListener | (Inherited from UnityEventBase.)
Public method | RemoveAllListeners | (Inherited from UnityEventBase.)
Public method | RemoveListener(UnityActionUTP) | (Inherited from UnityEventCinemachineBrain .)
Protected method | RemoveListener(Object, MethodInfo) | (Inherited from UnityEventBase.)
Public method | SetPersistentListenerState | (Inherited from UnityEventBase.)
Public method | ToString | (Inherited from UnityEventBase.)
Protected method | ValidateRegistration(MethodInfo, Object, PersistentListenerMode) | (Inherited from UnityEventBase.)
Protected method | ValidateRegistration(MethodInfo, Object, PersistentListenerMode, Type) | (Inherited from UnityEventBase.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | UnityEngine#ISerializationCallbackReceiver#OnAfterDeserialize | (Inherited from UnityEventBase.)
Explicit interface implementation | UnityEngine#ISerializationCallbackReceiver#OnBeforeSerialize | (Inherited from UnityEventBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBrain.BrainEvent Constructor

CinemachineBrainBrainEvent Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineBrain.BrainEvent.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public BrainEvent()
Cinemachine.BrainEvent = function();
See Also

Reference

CinemachineBrainBrainEvent Class


BrainEvent Methods

The CinemachineBrainBrainEvent type exposes the following members.

Methods
 | Name | Description
Public method | AddListener(UnityActionUTP) | (Inherited from UnityEventCinemachineBrain .)
Protected method | AddListener(Object, MethodInfo) | (Inherited from UnityEventBase.)
Protected method | FindMethod_Impl | (Inherited from UnityEventCinemachineBrain .)
Public method | GetPersistentEventCount | (Inherited from UnityEventBase.)
Public method | GetPersistentMethodName | (Inherited from UnityEventBase.)
Public method | GetPersistentTarget | (Inherited from UnityEventBase.)
Protected method | Invoke(Object) | (Inherited from UnityEventBase.)
Public method | Invoke(UTP) | (Inherited from UnityEventCinemachineBrain .)
Protected method | RegisterPersistentListener | (Inherited from UnityEventBase.)
Public method | RemoveAllListeners | (Inherited from UnityEventBase.)
Public method | RemoveListener(UnityActionUTP) | (Inherited from UnityEventCinemachineBrain .)
Protected method | RemoveListener(Object, MethodInfo) | (Inherited from UnityEventBase.)
Public method | SetPersistentListenerState | (Inherited from UnityEventBase.)
Public method | ToString | (Inherited from UnityEventBase.)
Protected method | ValidateRegistration(MethodInfo, Object, PersistentListenerMode) | (Inherited from UnityEventBase.)
Protected method | ValidateRegistration(MethodInfo, Object, PersistentListenerMode, Type) | (Inherited from UnityEventBase.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | UnityEngine#ISerializationCallbackReceiver#OnAfterDeserialize | (Inherited from UnityEventBase.)
Explicit interface implementation | UnityEngine#ISerializationCallbackReceiver#OnBeforeSerialize | (Inherited from UnityEventBase.)
Top
See Also

Reference

CinemachineBrainBrainEvent Class


CinemachineBrain.UpdateMethod Enumeration

CinemachineBrainUpdateMethod Enumeration

This enum defines the options available for the update method.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(0.1f, DocumentationSortingAttributeLevel.UserRef)]
public enum UpdateMethod
Cinemachine.UpdateMethod = function();
Cinemachine.UpdateMethod.createEnum('Cinemachine.UpdateMethod', false);
Members
Member name | Value | Description
FixedUpdate | 0 | Virtual cameras are updated in sync with the Physics module, in FixedUpdate
LateUpdate | 1 | Virtual cameras are updated in MonoBehaviour LateUpdate.
SmartUpdate | 2 | Virtual cameras are updated according to how the target is updated.
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBrain.VcamEvent Class

CinemachineBrainVcamEvent Class

Event with a ICinemachineCamera parameter
Inheritance Hierarchy
SystemObject
UnityEventBase
UnityEventICinemachineCamera
CinemachineCinemachineBrainVcamEvent

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
public class VcamEvent : UnityEvent<ICinemachineCamera>
Cinemachine.VcamEvent = function();

Type.createClass(
    'Cinemachine.VcamEvent',
    UnityEngine.Events.UnityEvent`1);

The CinemachineBrainVcamEvent type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineBrainVcamEvent |
Top
Methods
 | Name | Description
Public method | AddListener(UnityActionUTP) | (Inherited from UnityEventICinemachineCamera .)
Protected method | AddListener(Object, MethodInfo) | (Inherited from UnityEventBase.)
Protected method | FindMethod_Impl | (Inherited from UnityEventICinemachineCamera .)
Public method | GetPersistentEventCount | (Inherited from UnityEventBase.)
Public method | GetPersistentMethodName | (Inherited from UnityEventBase.)
Public method | GetPersistentTarget | (Inherited from UnityEventBase.)
Protected method | Invoke(Object) | (Inherited from UnityEventBase.)
Public method | Invoke(UTP) | (Inherited from UnityEventICinemachineCamera .)
Protected method | RegisterPersistentListener | (Inherited from UnityEventBase.)
Public method | RemoveAllListeners | (Inherited from UnityEventBase.)
Public method | RemoveListener(UnityActionUTP) | (Inherited from UnityEventICinemachineCamera .)
Protected method | RemoveListener(Object, MethodInfo) | (Inherited from UnityEventBase.)
Public method | SetPersistentListenerState | (Inherited from UnityEventBase.)
Public method | ToString | (Inherited from UnityEventBase.)
Protected method | ValidateRegistration(MethodInfo, Object, PersistentListenerMode) | (Inherited from UnityEventBase.)
Protected method | ValidateRegistration(MethodInfo, Object, PersistentListenerMode, Type) | (Inherited from UnityEventBase.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | UnityEngine#ISerializationCallbackReceiver#OnAfterDeserialize | (Inherited from UnityEventBase.)
Explicit interface implementation | UnityEngine#ISerializationCallbackReceiver#OnBeforeSerialize | (Inherited from UnityEventBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineBrain.VcamEvent Constructor

CinemachineBrainVcamEvent Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineBrain.VcamEvent.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public VcamEvent()
Cinemachine.VcamEvent = function();
See Also

Reference

CinemachineBrainVcamEvent Class


VcamEvent Methods

The CinemachineBrainVcamEvent type exposes the following members.

Methods
 | Name | Description
Public method | AddListener(UnityActionUTP) | (Inherited from UnityEventICinemachineCamera .)
Protected method | AddListener(Object, MethodInfo) | (Inherited from UnityEventBase.)
Protected method | FindMethod_Impl | (Inherited from UnityEventICinemachineCamera .)
Public method | GetPersistentEventCount | (Inherited from UnityEventBase.)
Public method | GetPersistentMethodName | (Inherited from UnityEventBase.)
Public method | GetPersistentTarget | (Inherited from UnityEventBase.)
Protected method | Invoke(Object) | (Inherited from UnityEventBase.)
Public method | Invoke(UTP) | (Inherited from UnityEventICinemachineCamera .)
Protected method | RegisterPersistentListener | (Inherited from UnityEventBase.)
Public method | RemoveAllListeners | (Inherited from UnityEventBase.)
Public method | RemoveListener(UnityActionUTP) | (Inherited from UnityEventICinemachineCamera .)
Protected method | RemoveListener(Object, MethodInfo) | (Inherited from UnityEventBase.)
Public method | SetPersistentListenerState | (Inherited from UnityEventBase.)
Public method | ToString | (Inherited from UnityEventBase.)
Protected method | ValidateRegistration(MethodInfo, Object, PersistentListenerMode) | (Inherited from UnityEventBase.)
Protected method | ValidateRegistration(MethodInfo, Object, PersistentListenerMode, Type) | (Inherited from UnityEventBase.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | UnityEngine#ISerializationCallbackReceiver#OnAfterDeserialize | (Inherited from UnityEventBase.)
Explicit interface implementation | UnityEngine#ISerializationCallbackReceiver#OnBeforeSerialize | (Inherited from UnityEventBase.)
Top
See Also

Reference

CinemachineBrainVcamEvent Class


CinemachineClearShot Class

Cinemachine ClearShot is a "manager camera" that owns and manages a set of Virtual Camera gameObject children. When Live, the ClearShot will check the children, and choose the one with the best quality shot and make it Live. This can be a very powerful tool. If the child cameras have CinemachineCollider extensions, they will analyze the scene for target obstructions, optimal target distance, and other items, and report their assessment of shot quality back to the ClearShot parent, who will then choose the best one. You can use this to set up complex multi-camera coverage of a scene, and be assured that a clear shot of the target will always be available. If multiple child cameras have the same shot quality, the one with the highest priority will be chosen. You can also define custom blends between the ClearShot children.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
CinemachineCinemachineClearShot

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(12f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[DisallowMultipleComponent]
[AddComponentMenu("Cinemachine/CinemachineClearShot")]
public class CinemachineClearShot : CinemachineVirtualCameraBase
Cinemachine.CinemachineClearShot = function();

Type.createClass(
    'Cinemachine.CinemachineClearShot',
    Cinemachine.CinemachineVirtualCameraBase);

The CinemachineClearShot type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineClearShot |
Top
Properties
 | Name | Description
Public property | ChildCameras | The list of child cameras. These are just the immediate children in the hierarchy.
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Overrides CinemachineVirtualCameraBaseDescription.)
Public property | Follow | Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | IsBlending | Is there a blend in progress?
Public property | LiveChild | Get the current "best" child virtual camera, that would be chosen if the ClearShot camera were active.
Public property | LiveChildOrSelf | Return the live child. (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The CameraState of the currently live child (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Makes sure the internal child cache is up to date (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnTransformChildrenChanged | Makes sure the internal child cache is up to date
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. This implementation resets the child randomization. (Overrides CinemachineVirtualCameraBaseOnTransitionFromCamera(ICinemachineCamera).)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid. (Inherited from CinemachineVirtualCameraBase.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Public method | ResetRandomization | If RandomizeChoice is enabled, call this to re-randomize the children next frame. This is useful if you want to freshen up the shot.
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Top
Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ActivateAfter | Wait this many seconds before activating a new child camera
Public field | m_ChildCameras | Internal API for the editor. Do not use this filed.
Public field | m_CustomBlends | This is the asset which contains custom settings for specific blends
Public field | m_DefaultBlend | The blend which is used if you don't explicitly define a blend between two Virtual Cameras
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | Default object for the camera children wants to move with (the body target), if not specified in a child camera. May be empty.
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | Default object for the camera children to look at (the aim target), if not specified in a child camera. May be empty.
Public field | m_MinDuration | An active camera must be active for at least this many seconds, unless a higher-priority camera wants to activate
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_RandomizeChoice | If checked, camera choice will be randomized if multiple cameras are equally desirable. Otherwise, child list order will be used
Public field | m_ShowDebugText | When enabled, the current camera and blend will be indicated in the game window, for debugging
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineClearShot Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineClearShot.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineClearShot()
Cinemachine.CinemachineClearShot = function();
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot Properties

The CinemachineClearShot type exposes the following members.

Properties
 | Name | Description
Public property | ChildCameras | The list of child cameras. These are just the immediate children in the hierarchy.
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Overrides CinemachineVirtualCameraBaseDescription.)
Public property | Follow | Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | IsBlending | Is there a blend in progress?
Public property | LiveChild | Get the current "best" child virtual camera, that would be chosen if the ClearShot camera were active.
Public property | LiveChildOrSelf | Return the live child. (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The CameraState of the currently live child (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.ChildCameras Property

CinemachineClearShotChildCameras Property

The list of child cameras. These are just the immediate children in the hierarchy.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineVirtualCameraBase[] ChildCameras { get; }
function get_ChildCameras();

Property Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.Description Property

CinemachineClearShotDescription Property

Gets a brief debug description of this virtual camera, for use when displayiong debug info

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override string Description { get; }
function get_Description();

Property Value

Type: String

Implements

ICinemachineCameraDescription
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.Follow Property

CinemachineClearShotFollow Property

Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform

Implements

ICinemachineCameraFollow
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.IsBlending Property

CinemachineClearShotIsBlending Property

Is there a blend in progress?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsBlending { get; }
function get_IsBlending();

Property Value

Type: Boolean
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.LiveChild Property

CinemachineClearShotLiveChild Property

Get the current "best" child virtual camera, that would be chosen if the ClearShot camera were active.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public ICinemachineCamera LiveChild { get; set; }
function get_LiveChild();
function set_LiveChild(value);

Property Value

Type: ICinemachineCamera
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.LiveChildOrSelf Property

CinemachineClearShotLiveChildOrSelf Property

Return the live child.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override ICinemachineCamera LiveChildOrSelf { get; }
function get_LiveChildOrSelf();

Property Value

Type: ICinemachineCamera

Implements

ICinemachineCameraLiveChildOrSelf
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.LookAt Property

CinemachineClearShotLookAt Property

Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform

Implements

ICinemachineCameraLookAt
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.State Property

CinemachineClearShotState Property

The CameraState of the currently live child

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CameraState State { get; }
function get_State();

Property Value

Type: CameraState

Implements

ICinemachineCameraState
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot Methods

The CinemachineClearShot type exposes the following members.

Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Makes sure the internal child cache is up to date (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnTransformChildrenChanged | Makes sure the internal child cache is up to date
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. This implementation resets the child randomization. (Overrides CinemachineVirtualCameraBaseOnTransitionFromCamera(ICinemachineCamera).)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid. (Inherited from CinemachineVirtualCameraBase.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Public method | ResetRandomization | If RandomizeChoice is enabled, call this to re-randomize the children next frame. This is useful if you want to freshen up the shot.
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Top
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.IsLiveChild Method

CinemachineClearShotIsLiveChild Method

Check whether the vcam a live child of this camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsLiveChild(
    ICinemachineCamera vcam
)
function IsLiveChild(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The Virtual Camera to check

Return Value

Type: Boolean
True if the vcam is currently actively influencing the state of this vcam

Implements

ICinemachineCameraIsLiveChild(ICinemachineCamera)
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.OnEnable Method

CinemachineClearShotOnEnable Method

Makes sure the internal child cache is up to date

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnEnable()
function OnEnable();
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.OnTransformChildrenChanged Method

CinemachineClearShotOnTransformChildrenChanged Method

Makes sure the internal child cache is up to date

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void OnTransformChildrenChanged()
function OnTransformChildrenChanged();
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.OnTransitionFromCamera Method

CinemachineClearShotOnTransitionFromCamera Method

Notification that this virtual camera is going live. This implementation resets the child randomization.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void OnTransitionFromCamera(
    ICinemachineCamera fromCam
)
function OnTransitionFromCamera(fromCam);

Parameters

fromCam
Type: CinemachineICinemachineCamera
The camera being deactivated. May be null.

Implements

ICinemachineCameraOnTransitionFromCamera(ICinemachineCamera)
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.RemovePostPipelineStageHook Method

CinemachineClearShotRemovePostPipelineStageHook Method

Remove a Pipeline stage hook callback. Make sure it is removed from all the children.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void RemovePostPipelineStageHook(
    CinemachineVirtualCameraBaseOnPostPipelineStageDelegate d
)
function RemovePostPipelineStageHook(d);

Parameters

d
Type: CinemachineCinemachineVirtualCameraBaseOnPostPipelineStageDelegate
The delegate to remove.
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.ResetRandomization Method

CinemachineClearShotResetRandomization Method

If RandomizeChoice is enabled, call this to re-randomize the children next frame. This is useful if you want to freshen up the shot.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void ResetRandomization()
function ResetRandomization();
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.UpdateCameraState Method

CinemachineClearShotUpdateCameraState Method

Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)

Implements

ICinemachineCameraUpdateCameraState(Vector3, Single)
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot Fields

The CinemachineClearShot type exposes the following members.

Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ActivateAfter | Wait this many seconds before activating a new child camera
Public field | m_ChildCameras | Internal API for the editor. Do not use this filed.
Public field | m_CustomBlends | This is the asset which contains custom settings for specific blends
Public field | m_DefaultBlend | The blend which is used if you don't explicitly define a blend between two Virtual Cameras
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | Default object for the camera children wants to move with (the body target), if not specified in a child camera. May be empty.
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | Default object for the camera children to look at (the aim target), if not specified in a child camera. May be empty.
Public field | m_MinDuration | An active camera must be active for at least this many seconds, unless a higher-priority camera wants to activate
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_RandomizeChoice | If checked, camera choice will be randomized if multiple cameras are equally desirable. Otherwise, child list order will be used
Public field | m_ShowDebugText | When enabled, the current camera and blend will be indicated in the game window, for debugging
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_ActivateAfter Field

CinemachineClearShotm_ActivateAfter Field

Wait this many seconds before activating a new child camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Wait this many seconds before activating a new child camera")]
public float m_ActivateAfter
var m_ActivateAfter

Field Value

Type: Single
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_ChildCameras Field

CinemachineClearShotm_ChildCameras Field

Internal API for the editor. Do not use this filed.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializeField]
[HideInInspector]
[NoSaveDuringPlayAttribute]
public CinemachineVirtualCameraBase[] m_ChildCameras
var m_ChildCameras

Field Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_CustomBlends Field

CinemachineClearShotm_CustomBlends Field

This is the asset which contains custom settings for specific blends

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HideInInspector]
public CinemachineBlenderSettings m_CustomBlends
var m_CustomBlends

Field Value

Type: CinemachineBlenderSettings
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_DefaultBlend Field

CinemachineClearShotm_DefaultBlend Field

The blend which is used if you don't explicitly define a blend between two Virtual Cameras

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[CinemachineBlendDefinitionPropertyAttribute]
[TooltipAttribute("The blend which is used if you don't explicitly define a blend between two Virtual Cameras")]
public CinemachineBlendDefinition m_DefaultBlend
var m_DefaultBlend

Field Value

Type: CinemachineBlendDefinition
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_Follow Field

CinemachineClearShotm_Follow Field

Default object for the camera children wants to move with (the body target), if not specified in a child camera. May be empty.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Default object for the camera children wants to move with (the body target), if not specified in a child camera.  May be empty if all children specify targets of their own.")]
[NoSaveDuringPlayAttribute]
public Transform m_Follow
var m_Follow

Field Value

Type: Transform
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_LookAt Field

CinemachineClearShotm_LookAt Field

Default object for the camera children to look at (the aim target), if not specified in a child camera. May be empty.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Default object for the camera children to look at (the aim target), if not specified in a child camera.  May be empty if all children specify targets of their own.")]
[NoSaveDuringPlayAttribute]
public Transform m_LookAt
var m_LookAt

Field Value

Type: Transform
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_MinDuration Field

CinemachineClearShotm_MinDuration Field

An active camera must be active for at least this many seconds, unless a higher-priority camera wants to activate

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("An active camera must be active for at least this many seconds, unless a higher-priority camera wants to activate")]
public float m_MinDuration
var m_MinDuration

Field Value

Type: Single
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_RandomizeChoice Field

CinemachineClearShotm_RandomizeChoice Field

If checked, camera choice will be randomized if multiple cameras are equally desirable. Otherwise, child list order will be used

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If checked, camera choice will be randomized if multiple cameras are equally desirable.  Otherwise, child list order and child camera priority will be used.")]
public bool m_RandomizeChoice
var m_RandomizeChoice

Field Value

Type: Boolean
See Also

Reference

CinemachineClearShot Class


CinemachineClearShot.m_ShowDebugText Field

CinemachineClearShotm_ShowDebugText Field

When enabled, the current camera and blend will be indicated in the game window, for debugging

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When enabled, the current child camera and blend will be indicated in the game window, for debugging")]
[NoSaveDuringPlayAttribute]
public bool m_ShowDebugText
var m_ShowDebugText

Field Value

Type: Boolean
See Also

Reference

CinemachineClearShot Class


CinemachineCollider Class

An add-on module for Cinemachine Virtual Camera that post-processes the final position of the virtual camera. Based on the supplied settings, the Collider will attempt to preserve the line of sight with the LookAt target of the virtual camera by moving away from objects that will obstruct the view. Additionally, the Collider can be used to assess the shot quality and report this as a field in the camera State.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineExtension
CinemachineCinemachineCollider

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(15f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[AddComponentMenu("")]
[SaveDuringPlayAttribute]
public class CinemachineCollider : CinemachineExtension
Cinemachine.CinemachineCollider = function();

Type.createClass(
    'Cinemachine.CinemachineCollider',
    Cinemachine.CinemachineExtension);

The CinemachineCollider type exposes the following members.

Properties
 | Name | Description
Public property | DebugPaths | Inspector API for debugging collision resolution path
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineExtension.)
Top
Methods
 | Name | Description
Protected method | Awake | Connect to virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Public method | CameraWasDisplaced | See whether the virtual camera has been moved nby the collider
Protected method | GetAllExtraStatesT | Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime! (Inherited from CinemachineExtension.)
Protected method | GetExtraStateT | Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this. (Inherited from CinemachineExtension.)
Public method | IsTargetObscured | See wheter an object is blocking the camera's view of the target
Protected method | OnDestroy | Cleanup (Overrides CinemachineExtensionOnDestroy.)
Protected method | PostPipelineStageCallback | Callcack to to the collision resolution and shot evaluation (Overrides CinemachineExtensionPostPipelineStageCallback(CinemachineVirtualCameraBase, CinemachineCoreStage, CameraState, Single).)
Top
Fields
 | Name | Description
Public field | m_AvoidObstacles | When enabled, will attempt to resolve situations where the line of sight to the target is blocked by an obstacle
Public field | m_CameraRadius | Camera will try to maintain this distance from any obstacle. Increase this value if you are seeing inside obstacles due to a large FOV on the camera.
Public field | m_CollideAgainst | The Unity layer mask against which the collider will raycast.
Public field | m_Damping | The gradualness of collision resolution. Higher numbers will move the camera more gradually away from obstructions.
Public field | m_DistanceLimit | The raycast distance to test for when checking if the line of sight to this camera's target is clear.
Public field | m_MaximumEffort | Upper limit on how many obstacle hits to process. Higher numbers may impact performance. In most environments, 4 is enough.
Public field | m_MinimumDistanceFromTarget | Obstacles closer to the target than this will not be seen
Public field | m_OptimalTargetDistance | If greater than zero, a higher score will be given to shots when the target is closer to this distance. Set this to zero to disable this feature
Public field | m_Strategy | The way in which the Collider will attempt to preserve sight of the target.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineCollider Properties

The CinemachineCollider type exposes the following members.

Properties
 | Name | Description
Public property | DebugPaths | Inspector API for debugging collision resolution path
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineExtension.)
Top
See Also

Reference

CinemachineCollider Class


CinemachineCollider.DebugPaths Property

CinemachineColliderDebugPaths Property

Inspector API for debugging collision resolution path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public List<List<Vector3>> DebugPaths { get; }
function get_DebugPaths();

Property Value

Type: List List Vector3
See Also

Reference

CinemachineCollider Class


CinemachineCollider Methods

The CinemachineCollider type exposes the following members.

Methods
 | Name | Description
Protected method | Awake | Connect to virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Public method | CameraWasDisplaced | See whether the virtual camera has been moved nby the collider
Protected method | GetAllExtraStatesT | Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime! (Inherited from CinemachineExtension.)
Protected method | GetExtraStateT | Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this. (Inherited from CinemachineExtension.)
Public method | IsTargetObscured | See wheter an object is blocking the camera's view of the target
Protected method | OnDestroy | Cleanup (Overrides CinemachineExtensionOnDestroy.)
Protected method | PostPipelineStageCallback | Callcack to to the collision resolution and shot evaluation (Overrides CinemachineExtensionPostPipelineStageCallback(CinemachineVirtualCameraBase, CinemachineCoreStage, CameraState, Single).)
Top
See Also

Reference

CinemachineCollider Class


CinemachineCollider.CameraWasDisplaced Method

CinemachineColliderCameraWasDisplaced Method

See whether the virtual camera has been moved nby the collider

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool CameraWasDisplaced(
    CinemachineVirtualCameraBase vcam
)
function CameraWasDisplaced(vcam);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase
The virtual camera in question. This might be different from the virtual camera that owns the collider, in the event that the camera has children

Return Value

Type: Boolean
True if the virtual camera has been displaced due to collision or target obstruction
See Also

Reference

CinemachineCollider Class


CinemachineCollider.IsTargetObscured Method

CinemachineColliderIsTargetObscured Method

See wheter an object is blocking the camera's view of the target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsTargetObscured(
    ICinemachineCamera vcam
)
function IsTargetObscured(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The virtual camera in question. This might be different from the virtual camera that owns the collider, in the event that the camera has children

Return Value

Type: Boolean
True if something is blocking the view
See Also

Reference

CinemachineCollider Class


CinemachineCollider.OnDestroy Method

CinemachineColliderOnDestroy Method

Cleanup

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnDestroy()
function OnDestroy();
See Also

Reference

CinemachineCollider Class


CinemachineCollider.PostPipelineStageCallback Method

CinemachineColliderPostPipelineStageCallback Method

Callcack to to the collision resolution and shot evaluation

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void PostPipelineStageCallback(
    CinemachineVirtualCameraBase vcam,
    CinemachineCoreStage stage,
    ref CameraState state,
    float deltaTime
)
function PostPipelineStageCallback(vcam, stage, state, deltaTime);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineCollider.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

stage
Type: CinemachineCinemachineCoreStage

[Missing <param name="stage"/> documentation for "M:Cinemachine.CinemachineCollider.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

state
Type: CinemachineCameraState

[Missing <param name="state"/> documentation for "M:Cinemachine.CinemachineCollider.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineCollider.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

See Also

Reference

CinemachineCollider Class


CinemachineCollider Fields

The CinemachineCollider type exposes the following members.

Fields
 | Name | Description
Public field | m_AvoidObstacles | When enabled, will attempt to resolve situations where the line of sight to the target is blocked by an obstacle
Public field | m_CameraRadius | Camera will try to maintain this distance from any obstacle. Increase this value if you are seeing inside obstacles due to a large FOV on the camera.
Public field | m_CollideAgainst | The Unity layer mask against which the collider will raycast.
Public field | m_Damping | The gradualness of collision resolution. Higher numbers will move the camera more gradually away from obstructions.
Public field | m_DistanceLimit | The raycast distance to test for when checking if the line of sight to this camera's target is clear.
Public field | m_MaximumEffort | Upper limit on how many obstacle hits to process. Higher numbers may impact performance. In most environments, 4 is enough.
Public field | m_MinimumDistanceFromTarget | Obstacles closer to the target than this will not be seen
Public field | m_OptimalTargetDistance | If greater than zero, a higher score will be given to shots when the target is closer to this distance. Set this to zero to disable this feature
Public field | m_Strategy | The way in which the Collider will attempt to preserve sight of the target.
Top
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_AvoidObstacles Field

CinemachineColliderm_AvoidObstacles Field

When enabled, will attempt to resolve situations where the line of sight to the target is blocked by an obstacle

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[TooltipAttribute("When enabled, will attempt to resolve situations where the line of sight to the target is blocked by an obstacle")]
[FormerlySerializedAsAttribute("m_PreserveLineOfSight")]
public bool m_AvoidObstacles
var m_AvoidObstacles

Field Value

Type: Boolean
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_CameraRadius Field

CinemachineColliderm_CameraRadius Field

Camera will try to maintain this distance from any obstacle. Increase this value if you are seeing inside obstacles due to a large FOV on the camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Camera will try to maintain this distance from any obstacle.  Try to keep this value small.  Increase it if you are seeing inside obstacles due to a large FOV on the camera.")]
public float m_CameraRadius
var m_CameraRadius

Field Value

Type: Single
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_CollideAgainst Field

CinemachineColliderm_CollideAgainst Field

The Unity layer mask against which the collider will raycast.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HeaderAttribute("Obstacle Detection")]
[TooltipAttribute("The Unity layer mask against which the collider will raycast")]
public LayerMask m_CollideAgainst
var m_CollideAgainst

Field Value

Type: LayerMask
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_Damping Field

CinemachineColliderm_Damping Field

The gradualness of collision resolution. Higher numbers will move the camera more gradually away from obstructions.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 10f)]
[TooltipAttribute("The gradualness of collision resolution.  Higher numbers will move the camera more gradually away from obstructions.")]
[FormerlySerializedAsAttribute("m_Smoothing")]
public float m_Damping
var m_Damping

Field Value

Type: Single
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_DistanceLimit Field

CinemachineColliderm_DistanceLimit Field

The raycast distance to test for when checking if the line of sight to this camera's target is clear.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The maximum raycast distance when checking if the line of sight to this camera's target is clear.  If the setting is 0 or less, the current actual distance to target will be used.")]
[FormerlySerializedAsAttribute("m_LineOfSightFeelerDistance")]
public float m_DistanceLimit
var m_DistanceLimit

Field Value

Type: Single
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_MaximumEffort Field

CinemachineColliderm_MaximumEffort Field

Upper limit on how many obstacle hits to process. Higher numbers may impact performance. In most environments, 4 is enough.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(1f, 10f)]
[TooltipAttribute("Upper limit on how many obstacle hits to process.  Higher numbers may impact performance.  In most environments, 4 is enough.")]
public int m_MaximumEffort
var m_MaximumEffort

Field Value

Type: Int32
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_MinimumDistanceFromTarget Field

CinemachineColliderm_MinimumDistanceFromTarget Field

Obstacles closer to the target than this will not be seen

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Obstacles closer to the target than this will not be seen")]
public float m_MinimumDistanceFromTarget
var m_MinimumDistanceFromTarget

Field Value

Type: Single
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_OptimalTargetDistance Field

CinemachineColliderm_OptimalTargetDistance Field

If greater than zero, a higher score will be given to shots when the target is closer to this distance. Set this to zero to disable this feature

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HeaderAttribute("Shot Evaluation")]
[TooltipAttribute("If greater than zero, a higher score will be given to shots when the target is closer to this distance.  Set this to zero to disable this feature.")]
public float m_OptimalTargetDistance
var m_OptimalTargetDistance

Field Value

Type: Single
See Also

Reference

CinemachineCollider Class


CinemachineCollider.m_Strategy Field

CinemachineColliderm_Strategy Field

The way in which the Collider will attempt to preserve sight of the target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The way in which the Collider will attempt to preserve sight of the target.")]
public CinemachineColliderResolutionStrategy m_Strategy
var m_Strategy

Field Value

Type: CinemachineColliderResolutionStrategy
See Also

Reference

CinemachineCollider Class


CinemachineCollider.ResolutionStrategy Enumeration

CinemachineColliderResolutionStrategy Enumeration

The way in which the Collider will attempt to preserve sight of the target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum ResolutionStrategy
Cinemachine.ResolutionStrategy = function();
Cinemachine.ResolutionStrategy.createEnum('Cinemachine.ResolutionStrategy', false);
Members
Member name | Value | Description
PullCameraForward | 0 | Camera will be pulled forward along its Z axis until it is in front of the nearest obstacle
PreserveCameraHeight | 1 | In addition to pulling the camera forward, an effort will be made to return the camera to its original height
PreserveCameraDistance | 2 | In addition to pulling the camera forward, an effort will be made to return the camera to its original distance from the target
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineComponentBase Class

An abstract representation of a mutator acting on a Cinemachine Virtual Camera
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
More...

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(24f, DocumentationSortingAttributeLevel.API)]
public abstract class CinemachineComponentBase : MonoBehaviour
Cinemachine.CinemachineComponentBase = function();

Type.createClass(
    'Cinemachine.CinemachineComponentBase',
    UnityEngine.MonoBehaviour);

The CinemachineComponentBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CinemachineComponentBase |
Top
Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target.
Public property | IsValid | Returns true if this object is enabled and set up to produce results.
Public property | LookAtTarget | Returns the owner vcam's LookAt target.
Public property | Stage | What part of the pipeline this fits into
Public property | VcamState | Returns the owner vcam's CameraState.
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase
Top
Methods
 | Name | Description
Public method | MutateCameraState | Mutates the camera state. This state will later be applied to the camera.
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing.
Top
Fields
Name | Description
Epsilon | Useful constant for very small floats
Top
See Also

Reference

Cinemachine Namespace
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineBasicMultiChannelPerlin
CinemachineCinemachineComposer
CinemachineCinemachineFramingTransposer
CinemachineCinemachineHardLockToTarget
CinemachineCinemachineHardLookAt
CinemachineCinemachinePOV
CinemachineCinemachineTrackedDolly
CinemachineCinemachineTransposer


CinemachineComponentBase Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineComponentBase.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected CinemachineComponentBase()
Cinemachine.CinemachineComponentBase = function();
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase Properties

The CinemachineComponentBase type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target.
Public property | IsValid | Returns true if this object is enabled and set up to produce results.
Public property | LookAtTarget | Returns the owner vcam's LookAt target.
Public property | Stage | What part of the pipeline this fits into
Public property | VcamState | Returns the owner vcam's CameraState.
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase
Top
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.FollowTarget Property

CinemachineComponentBaseFollowTarget Property

Returns the owner vcam's Follow target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Transform FollowTarget { get; }
function get_FollowTarget();

Property Value

Type: Transform
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.IsValid Property

CinemachineComponentBaseIsValid Property

Returns true if this object is enabled and set up to produce results.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.LookAtTarget Property

CinemachineComponentBaseLookAtTarget Property

Returns the owner vcam's LookAt target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Transform LookAtTarget { get; }
function get_LookAtTarget();

Property Value

Type: Transform
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.Stage Property

CinemachineComponentBaseStage Property

What part of the pipeline this fits into

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.VcamState Property

CinemachineComponentBaseVcamState Property

Returns the owner vcam's CameraState.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CameraState VcamState { get; }
function get_VcamState();

Property Value

Type: CameraState
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.VirtualCamera Property

CinemachineComponentBaseVirtualCamera Property

Get the associated CinemachineVirtualCameraBase

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineVirtualCameraBase VirtualCamera { get; }
function get_VirtualCamera();

Property Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase Methods

The CinemachineComponentBase type exposes the following members.

Methods
 | Name | Description
Public method | MutateCameraState | Mutates the camera state. This state will later be applied to the camera.
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing.
Top
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.MutateCameraState Method

CinemachineComponentBaseMutateCameraState Method

Mutates the camera state. This state will later be applied to the camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
Input state that must be mutated
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.OnPositionDragged Method

CinemachineComponentBaseOnPositionDragged Method

API for the editor, to process a position drag from the user. Base class implementation does nothing.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual void OnPositionDragged(
    Vector3 delta
)
function OnPositionDragged(delta);

Parameters

delta
Type: Vector3
The amount dragged this frame
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase Fields

The CinemachineComponentBase type exposes the following members.

Fields
Name | Description
Epsilon | Useful constant for very small floats
Top
See Also

Reference

CinemachineComponentBase Class


CinemachineComponentBase.Epsilon Field

CinemachineComponentBaseEpsilon Field

Useful constant for very small floats

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected const float Epsilon = 0.0001f
var Cinemachine.CinemachineComponentBase.Epsilon

Field Value

Type: Single
See Also

Reference

CinemachineComponentBase Class


CinemachineComposer Class

This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to aim the camera at the vcam's LookAt target object, with configurable offsets, damping, and composition rules. The composer does not change the camera's position. It will only pan and tilt the camera where it is, in order to get the desired framing. To move the camera, you have to use the virtual camera's Body section.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineComposer
CinemachineCinemachineGroupComposer

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(3f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineComposer : CinemachineComponentBase
Cinemachine.CinemachineComposer = function();

Type.createClass(
    'Cinemachine.CinemachineComposer',
    Cinemachine.CinemachineComponentBase);

The CinemachineComposer type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | HardGuideRect | Internal API for the inspector editor
Public property | IsValid | True if component is enabled and has a LookAt defined (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | SoftGuideRect | Internal API for the inspector editor
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Protected method | GetTrackedPoint | Apply the target offsets to the target location.
Public method | MutateCameraState | Applies the composer rules and orients the camera accordingly (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
Fields
 | Name | Description
Public field | m_BiasX | A non-zero bias will move the targt position away from the center of the soft zone
Public field | m_BiasY | A non-zero bias will move the targt position away from the center of the soft zone
Public field | m_DeadZoneHeight | Camera will not rotate vertically if the target is within this range of the position
Public field | m_DeadZoneWidth | Camera will not rotate horizontally if the target is within this range of the position
Public field | m_HorizontalDamping | How aggressively the camera tries to follow the target in the screen-horizontal direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors.
Public field | m_LookaheadSmoothing | Controls the smoothness of the lookahead algorithm. Larger values smooth out jittery predictions and also increase prediction lag
Public field | m_LookaheadTime | This setting will instruct the composer to adjust its target offset based on the motion of the target. The composer will look at a point where it estimates the target will be this many seconds into the future. Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter. If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly.
Public field | m_ScreenX | Horizontal screen position for target. The camera will rotate to the position the tracked object here
Public field | m_ScreenY | Vertical screen position for target, The camera will rotate to to position the tracked object here
Public field | m_SoftZoneHeight | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed
Public field | m_SoftZoneWidth | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed
Public field | m_TrackedObjectOffset | Target offset from the object's center in LOCAL space which the Composer tracks. Use this to fine-tune the tracking target position when the desired area is not in the tracked object's center
Public field | m_VerticalDamping | How aggressively the camera tries to follow the target in the screen-vertical direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors.
Public field | OnGUICallback | Used by the Inspector Editor to display on-screen guides.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineComposer Properties

The CinemachineComposer type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | HardGuideRect | Internal API for the inspector editor
Public property | IsValid | True if component is enabled and has a LookAt defined (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | SoftGuideRect | Internal API for the inspector editor
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineComposer Class


CinemachineComposer.HardGuideRect Property

CinemachineComposerHardGuideRect Property

Internal API for the inspector editor

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Rect HardGuideRect { get; set; }
function get_HardGuideRect();
function set_HardGuideRect(value);

Property Value

Type: Rect
See Also

Reference

CinemachineComposer Class


CinemachineComposer.IsValid Property

CinemachineComposerIsValid Property

True if component is enabled and has a LookAt defined

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineComposer Class


CinemachineComposer.SoftGuideRect Property

CinemachineComposerSoftGuideRect Property

Internal API for the inspector editor

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Rect SoftGuideRect { get; set; }
function get_SoftGuideRect();
function set_SoftGuideRect(value);

Property Value

Type: Rect
See Also

Reference

CinemachineComposer Class


CinemachineComposer.Stage Property

CinemachineComposerStage Property

Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineComposer Class


CinemachineComposer Methods

The CinemachineComposer type exposes the following members.

Methods
 | Name | Description
Protected method | GetTrackedPoint | Apply the target offsets to the target location.
Public method | MutateCameraState | Applies the composer rules and orients the camera accordingly (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineComposer Class


CinemachineComposer.GetTrackedPoint Method

CinemachineComposerGetTrackedPoint Method

Apply the target offsets to the target location.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual Vector3 GetTrackedPoint(
    Vector3 lookAt
)
function GetTrackedPoint(lookAt);

Parameters

lookAt
Type: Vector3
The unoffset LookAt point

Return Value

Type: Vector3
The LookAt point with the offset applied
See Also

Reference

CinemachineComposer Class


CinemachineComposer.MutateCameraState Method

CinemachineComposerMutateCameraState Method

Applies the composer rules and orients the camera accordingly

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
Used for calculating damping. If less than zero, then target will snap to the center of the dead zone.
See Also

Reference

CinemachineComposer Class


CinemachineComposer Fields

The CinemachineComposer type exposes the following members.

Fields
 | Name | Description
Public field | m_BiasX | A non-zero bias will move the targt position away from the center of the soft zone
Public field | m_BiasY | A non-zero bias will move the targt position away from the center of the soft zone
Public field | m_DeadZoneHeight | Camera will not rotate vertically if the target is within this range of the position
Public field | m_DeadZoneWidth | Camera will not rotate horizontally if the target is within this range of the position
Public field | m_HorizontalDamping | How aggressively the camera tries to follow the target in the screen-horizontal direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors.
Public field | m_LookaheadSmoothing | Controls the smoothness of the lookahead algorithm. Larger values smooth out jittery predictions and also increase prediction lag
Public field | m_LookaheadTime | This setting will instruct the composer to adjust its target offset based on the motion of the target. The composer will look at a point where it estimates the target will be this many seconds into the future. Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter. If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly.
Public field | m_ScreenX | Horizontal screen position for target. The camera will rotate to the position the tracked object here
Public field | m_ScreenY | Vertical screen position for target, The camera will rotate to to position the tracked object here
Public field | m_SoftZoneHeight | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed
Public field | m_SoftZoneWidth | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed
Public field | m_TrackedObjectOffset | Target offset from the object's center in LOCAL space which the Composer tracks. Use this to fine-tune the tracking target position when the desired area is not in the tracked object's center
Public field | m_VerticalDamping | How aggressively the camera tries to follow the target in the screen-vertical direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors.
Public field | OnGUICallback | Used by the Inspector Editor to display on-screen guides.
Top
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_BiasX Field

CinemachineComposerm_BiasX Field

A non-zero bias will move the targt position away from the center of the soft zone

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(-0.5f, 0.5f)]
[TooltipAttribute("A non-zero bias will move the target position horizontally away from the center of the soft zone.")]
public float m_BiasX
var m_BiasX

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_BiasY Field

CinemachineComposerm_BiasY Field

A non-zero bias will move the targt position away from the center of the soft zone

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(-0.5f, 0.5f)]
[TooltipAttribute("A non-zero bias will move the target position vertically away from the center of the soft zone.")]
public float m_BiasY
var m_BiasY

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_DeadZoneHeight Field

CinemachineComposerm_DeadZoneHeight Field

Camera will not rotate vertically if the target is within this range of the position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 1f)]
[TooltipAttribute("Camera will not rotate vertically if the target is within this range of the position.")]
public float m_DeadZoneHeight
var m_DeadZoneHeight

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_DeadZoneWidth Field

CinemachineComposerm_DeadZoneWidth Field

Camera will not rotate horizontally if the target is within this range of the position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 1f)]
[TooltipAttribute("Camera will not rotate horizontally if the target is within this range of the position.")]
public float m_DeadZoneWidth
var m_DeadZoneWidth

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_HorizontalDamping Field

CinemachineComposerm_HorizontalDamping Field

How aggressively the camera tries to follow the target in the screen-horizontal direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to follow the target in the screen-horizontal direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors.")]
public float m_HorizontalDamping
var m_HorizontalDamping

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_LookaheadSmoothing Field

CinemachineComposerm_LookaheadSmoothing Field

Controls the smoothness of the lookahead algorithm. Larger values smooth out jittery predictions and also increase prediction lag

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Controls the smoothness of the lookahead algorithm.  Larger values smooth out jittery predictions and also increase prediction lag")]
[RangeAttribute(3f, 30f)]
public float m_LookaheadSmoothing
var m_LookaheadSmoothing

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_LookaheadTime Field

CinemachineComposerm_LookaheadTime Field

This setting will instruct the composer to adjust its target offset based on the motion of the target. The composer will look at a point where it estimates the target will be this many seconds into the future. Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter. If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("This setting will instruct the composer to adjust its target offset based on the motion of the target.  The composer will look at a point where it estimates the target will be this many seconds into the future.  Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter.  If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly.")]
[RangeAttribute(0f, 1f)]
public float m_LookaheadTime
var m_LookaheadTime

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_ScreenX Field

CinemachineComposerm_ScreenX Field

Horizontal screen position for target. The camera will rotate to the position the tracked object here

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[RangeAttribute(0f, 1f)]
[TooltipAttribute("Horizontal screen position for target. The camera will rotate to position the tracked object here.")]
public float m_ScreenX
var m_ScreenX

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_ScreenY Field

CinemachineComposerm_ScreenY Field

Vertical screen position for target, The camera will rotate to to position the tracked object here

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 1f)]
[TooltipAttribute("Vertical screen position for target, The camera will rotate to position the tracked object here.")]
public float m_ScreenY
var m_ScreenY

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_SoftZoneHeight Field

CinemachineComposerm_SoftZoneHeight Field

When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 2f)]
[TooltipAttribute("When target is within this region, camera will gradually rotate vertically to re-align towards the desired position, depending on the damping speed.")]
public float m_SoftZoneHeight
var m_SoftZoneHeight

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_SoftZoneWidth Field

CinemachineComposerm_SoftZoneWidth Field

When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 2f)]
[TooltipAttribute("When target is within this region, camera will gradually rotate horizontally to re-align towards the desired position, depending on the damping speed.")]
public float m_SoftZoneWidth
var m_SoftZoneWidth

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_TrackedObjectOffset Field

CinemachineComposerm_TrackedObjectOffset Field

Target offset from the object's center in LOCAL space which the Composer tracks. Use this to fine-tune the tracking target position when the desired area is not in the tracked object's center

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Target offset from the target object's center in target-local space. Use this to fine-tune the tracking target position when the desired area is not the tracked object's center.")]
public Vector3 m_TrackedObjectOffset
var m_TrackedObjectOffset

Field Value

Type: Vector3
See Also

Reference

CinemachineComposer Class


CinemachineComposer.m_VerticalDamping Field

CinemachineComposerm_VerticalDamping Field

How aggressively the camera tries to follow the target in the screen-vertical direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to follow the target in the screen-vertical direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors.")]
public float m_VerticalDamping
var m_VerticalDamping

Field Value

Type: Single
See Also

Reference

CinemachineComposer Class


CinemachineComposer.OnGUICallback Field

CinemachineComposerOnGUICallback Field

Used by the Inspector Editor to display on-screen guides.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[NoSaveDuringPlayAttribute]
[HideInInspector]
public Action OnGUICallback
var OnGUICallback

Field Value

Type: Action
See Also

Reference

CinemachineComposer Class


CinemachineConfiner Class

An add-on module for Cinemachine Virtual Camera that post-processes the final position of the virtual camera. It will confine the virtual camera's position to the volume specified in the Bounding Volume field.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineExtension
CinemachineCinemachineConfiner

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(22f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[AddComponentMenu("")]
[SaveDuringPlayAttribute]
public class CinemachineConfiner : CinemachineExtension
Cinemachine.CinemachineConfiner = function();

Type.createClass(
    'Cinemachine.CinemachineConfiner',
    Cinemachine.CinemachineExtension);

The CinemachineConfiner type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineConfiner |
Top
Properties
 | Name | Description
Public property | IsValid | Check if the bounding volume is defined
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineExtension.)
Top
Methods
 | Name | Description
Protected method | Awake | Connect to virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Public method | CameraWasDisplaced | See whether the virtual camera has been moved by the confiner
Protected method | GetAllExtraStatesT | Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime! (Inherited from CinemachineExtension.)
Protected method | GetExtraStateT | Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this. (Inherited from CinemachineExtension.)
Public method | InvalidatePathCache | Call this if the bounding shape's points change at runtime
Protected method | OnDestroy | Disconnect from virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Protected method | PostPipelineStageCallback | Callback to to the camera confining (Overrides CinemachineExtensionPostPipelineStageCallback(CinemachineVirtualCameraBase, CinemachineCoreStage, CameraState, Single).)
Top
Fields
 | Name | Description
Public field | m_BoundingShape2D | The 2D shape within which the camera is to be contained.
Public field | m_BoundingVolume | The volume within which the camera is to be contained.
Public field | m_ConfineMode | The confiner can operate using a 2D bounding shape or a 3D bounding volume
Public field | m_ConfineScreenEdges | If camera is orthographic, screen edges will be confined to the volume.
Public field | m_Damping | How gradually to return the camera to the bounding volume if it goes beyond the borders
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineConfiner Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineConfiner.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineConfiner()
Cinemachine.CinemachineConfiner = function();
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner Properties

The CinemachineConfiner type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Check if the bounding volume is defined
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineExtension.)
Top
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.IsValid Property

CinemachineConfinerIsValid Property

Check if the bounding volume is defined

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner Methods

The CinemachineConfiner type exposes the following members.

Methods
 | Name | Description
Protected method | Awake | Connect to virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Public method | CameraWasDisplaced | See whether the virtual camera has been moved by the confiner
Protected method | GetAllExtraStatesT | Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime! (Inherited from CinemachineExtension.)
Protected method | GetExtraStateT | Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this. (Inherited from CinemachineExtension.)
Public method | InvalidatePathCache | Call this if the bounding shape's points change at runtime
Protected method | OnDestroy | Disconnect from virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Protected method | PostPipelineStageCallback | Callback to to the camera confining (Overrides CinemachineExtensionPostPipelineStageCallback(CinemachineVirtualCameraBase, CinemachineCoreStage, CameraState, Single).)
Top
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.CameraWasDisplaced Method

CinemachineConfinerCameraWasDisplaced Method

See whether the virtual camera has been moved by the confiner

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool CameraWasDisplaced(
    CinemachineVirtualCameraBase vcam
)
function CameraWasDisplaced(vcam);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase
The virtual camera in question. This might be different from the virtual camera that owns the confiner, in the event that the camera has children

Return Value

Type: Boolean
True if the virtual camera has been repositioned
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.InvalidatePathCache Method

CinemachineConfinerInvalidatePathCache Method

Call this if the bounding shape's points change at runtime

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void InvalidatePathCache()
function InvalidatePathCache();
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.PostPipelineStageCallback Method

CinemachineConfinerPostPipelineStageCallback Method

Callback to to the camera confining

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void PostPipelineStageCallback(
    CinemachineVirtualCameraBase vcam,
    CinemachineCoreStage stage,
    ref CameraState state,
    float deltaTime
)
function PostPipelineStageCallback(vcam, stage, state, deltaTime);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineConfiner.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

stage
Type: CinemachineCinemachineCoreStage

[Missing <param name="stage"/> documentation for "M:Cinemachine.CinemachineConfiner.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

state
Type: CinemachineCameraState

[Missing <param name="state"/> documentation for "M:Cinemachine.CinemachineConfiner.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineConfiner.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

See Also

Reference

CinemachineConfiner Class


CinemachineConfiner Fields

The CinemachineConfiner type exposes the following members.

Fields
 | Name | Description
Public field | m_BoundingShape2D | The 2D shape within which the camera is to be contained.
Public field | m_BoundingVolume | The volume within which the camera is to be contained.
Public field | m_ConfineMode | The confiner can operate using a 2D bounding shape or a 3D bounding volume
Public field | m_ConfineScreenEdges | If camera is orthographic, screen edges will be confined to the volume.
Public field | m_Damping | How gradually to return the camera to the bounding volume if it goes beyond the borders
Top
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.m_BoundingShape2D Field

CinemachineConfinerm_BoundingShape2D Field

The 2D shape within which the camera is to be contained.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The 2D shape within which the camera is to be contained")]
public Collider2D m_BoundingShape2D
var m_BoundingShape2D

Field Value

Type: Collider2D
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.m_BoundingVolume Field

CinemachineConfinerm_BoundingVolume Field

The volume within which the camera is to be contained.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The volume within which the camera is to be contained")]
public Collider m_BoundingVolume
var m_BoundingVolume

Field Value

Type: Collider
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.m_ConfineMode Field

CinemachineConfinerm_ConfineMode Field

The confiner can operate using a 2D bounding shape or a 3D bounding volume

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The confiner can operate using a 2D bounding shape or a 3D bounding volume")]
public CinemachineConfinerMode m_ConfineMode
var m_ConfineMode

Field Value

Type: CinemachineConfinerMode
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.m_ConfineScreenEdges Field

CinemachineConfinerm_ConfineScreenEdges Field

If camera is orthographic, screen edges will be confined to the volume.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If camera is orthographic, screen edges will be confined to the volume.  If not checked, then only the camera center will be confined")]
public bool m_ConfineScreenEdges
var m_ConfineScreenEdges

Field Value

Type: Boolean
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.m_Damping Field

CinemachineConfinerm_Damping Field

How gradually to return the camera to the bounding volume if it goes beyond the borders

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How gradually to return the camera to the bounding volume if it goes beyond the borders.  Higher numbers are more gradual.")]
[RangeAttribute(0f, 10f)]
public float m_Damping
var m_Damping

Field Value

Type: Single
See Also

Reference

CinemachineConfiner Class


CinemachineConfiner.Mode Enumeration

CinemachineConfinerMode Enumeration

The confiner can operate using a 2D bounding shape or a 3D bounding volume

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum Mode
Cinemachine.Mode = function();
Cinemachine.Mode.createEnum('Cinemachine.Mode', false);
Members
Member name | Value | Description
Confine2D | 0 |
Confine3D | 1 |
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineCore Class

A singleton that manages complete lists of CinemachineBrain and, Cinemachine Virtual Cameras, and the priority queue. Provides services to keeping track of whether Cinemachine Virtual Cameras have been updated each frame.
Inheritance Hierarchy
SystemObject
CinemachineCinemachineCore

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public sealed class CinemachineCore
Cinemachine.CinemachineCore = function();

Type.createClass(
    'Cinemachine.CinemachineCore');

The CinemachineCore type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineCore |
Top
Properties
 | Name | Description
Public property | BrainCount | Access the array of active CinemachineBrains in the scene
 | Instance | Get the singleton instance
Public property | VirtualCameraCount | List of all active Cinemachine Virtual Cameras for all brains. This list is kept sorted by priority.
Top
Methods
 | Name | Description
Public method | FindPotentialTargetBrain | Try to find a CinemachineBrain to associate with a Cinemachine Virtual Camera. The first CinemachineBrain in which this Cinemachine Virtual Camera is live will be used. If none, then the first active CinemachineBrain will be used. Brains with OutputCamera == null will not be returned. Final result may be null.
Public method | GenerateCameraActivationEvent | Signal that the virtual has been activated. If the camera is live, then all CinemachineBrains that are showing it will send an activation event.
Public method | GenerateCameraCutEvent | Signal that the virtual camera's content is discontinuous WRT the previous frame. If the camera is live, then all CinemachineBrains that are showing it will send a cut event.
Public method | GetActiveBrain | Access the array of active CinemachineBrains in the scene without gebnerating garbage
Public method | GetVcamUpdateStatus | Internal use only
Public method | GetVirtualCamera | Access the array of active ICinemachineCamera in the scene without gebnerating garbage
Public method | IsLive | Is this virtual camera currently actively controlling any Camera?
Top
Fields
Name | Description
GetInputAxis | Delegate for overriding Unity's default input system. If you set this, then your delegate will be called instead of System.Input.GetAxis(axisName) whenever in-game user input is needed.
kStreamingVersion | Data version string. Used to upgrade from legacy projects
kVersionString | Human-readable Cinemachine Version
sShowHiddenObjects | If true, show hidden Cinemachine objects, to make manual script mapping possible.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineCore Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineCore.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineCore()
Cinemachine.CinemachineCore = function();
See Also

Reference

CinemachineCore Class


CinemachineCore Properties

The CinemachineCore type exposes the following members.

Properties
 | Name | Description
Public property | BrainCount | Access the array of active CinemachineBrains in the scene
 | Instance | Get the singleton instance
Public property | VirtualCameraCount | List of all active Cinemachine Virtual Cameras for all brains. This list is kept sorted by priority.
Top
See Also

Reference

CinemachineCore Class


CinemachineCore.BrainCount Property

CinemachineCoreBrainCount Property

Access the array of active CinemachineBrains in the scene

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public int BrainCount { get; }
function get_BrainCount();

Property Value

Type: Int32
See Also

Reference

CinemachineCore Class


CinemachineCore.Instance Property

CinemachineCoreInstance Property

Get the singleton instance

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static CinemachineCore Instance { get; }
Cinemachine.CinemachineCore.get_Instance = function();

Property Value

Type: CinemachineCore
See Also

Reference

CinemachineCore Class


CinemachineCore.VirtualCameraCount Property

CinemachineCoreVirtualCameraCount Property

List of all active Cinemachine Virtual Cameras for all brains. This list is kept sorted by priority.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public int VirtualCameraCount { get; }
function get_VirtualCameraCount();

Property Value

Type: Int32
See Also

Reference

CinemachineCore Class


CinemachineCore Methods

The CinemachineCore type exposes the following members.

Methods
 | Name | Description
Public method | FindPotentialTargetBrain | Try to find a CinemachineBrain to associate with a Cinemachine Virtual Camera. The first CinemachineBrain in which this Cinemachine Virtual Camera is live will be used. If none, then the first active CinemachineBrain will be used. Brains with OutputCamera == null will not be returned. Final result may be null.
Public method | GenerateCameraActivationEvent | Signal that the virtual has been activated. If the camera is live, then all CinemachineBrains that are showing it will send an activation event.
Public method | GenerateCameraCutEvent | Signal that the virtual camera's content is discontinuous WRT the previous frame. If the camera is live, then all CinemachineBrains that are showing it will send a cut event.
Public method | GetActiveBrain | Access the array of active CinemachineBrains in the scene without gebnerating garbage
Public method | GetVcamUpdateStatus | Internal use only
Public method | GetVirtualCamera | Access the array of active ICinemachineCamera in the scene without gebnerating garbage
Public method | IsLive | Is this virtual camera currently actively controlling any Camera?
Top
See Also

Reference

CinemachineCore Class


CinemachineCore.FindPotentialTargetBrain Method

CinemachineCoreFindPotentialTargetBrain Method

Try to find a CinemachineBrain to associate with a Cinemachine Virtual Camera. The first CinemachineBrain in which this Cinemachine Virtual Camera is live will be used. If none, then the first active CinemachineBrain will be used. Brains with OutputCamera == null will not be returned. Final result may be null.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBrain FindPotentialTargetBrain(
    ICinemachineCamera vcam
)
function FindPotentialTargetBrain(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
Virtual camera whose potential brain we need.

Return Value

Type: CinemachineBrain
First CinemachineBrain found that might be appropriate for this vcam, or null
See Also

Reference

CinemachineCore Class


CinemachineCore.GenerateCameraActivationEvent Method

CinemachineCoreGenerateCameraActivationEvent Method

Signal that the virtual has been activated. If the camera is live, then all CinemachineBrains that are showing it will send an activation event.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void GenerateCameraActivationEvent(
    ICinemachineCamera vcam
)
function GenerateCameraActivationEvent(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineCore.GenerateCameraActivationEvent(Cinemachine.ICinemachineCamera)"]

See Also

Reference

CinemachineCore Class


CinemachineCore.GenerateCameraCutEvent Method

CinemachineCoreGenerateCameraCutEvent Method

Signal that the virtual camera's content is discontinuous WRT the previous frame. If the camera is live, then all CinemachineBrains that are showing it will send a cut event.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void GenerateCameraCutEvent(
    ICinemachineCamera vcam
)
function GenerateCameraCutEvent(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineCore.GenerateCameraCutEvent(Cinemachine.ICinemachineCamera)"]

See Also

Reference

CinemachineCore Class


CinemachineCore.GetActiveBrain Method

CinemachineCoreGetActiveBrain Method

Access the array of active CinemachineBrains in the scene without gebnerating garbage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineBrain GetActiveBrain(
    int index
)
function GetActiveBrain(index);

Parameters

index
Type: SystemInt32
Index of the brain to access, range 0-BrainCount

Return Value

Type: CinemachineBrain
The brain at the specified index
See Also

Reference

CinemachineCore Class


CinemachineCore.GetVcamUpdateStatus Method

CinemachineCoreGetVcamUpdateStatus Method

Internal use only

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineCoreUpdateFilter GetVcamUpdateStatus(
    ICinemachineCamera vcam
)
function GetVcamUpdateStatus(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineCore.GetVcamUpdateStatus(Cinemachine.ICinemachineCamera)"]

Return Value

Type: CinemachineCoreUpdateFilter

[Missing <returns> documentation for "M:Cinemachine.CinemachineCore.GetVcamUpdateStatus(Cinemachine.ICinemachineCamera)"]

See Also

Reference

CinemachineCore Class


CinemachineCore.GetVirtualCamera Method

CinemachineCoreGetVirtualCamera Method

Access the array of active ICinemachineCamera in the scene without gebnerating garbage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public ICinemachineCamera GetVirtualCamera(
    int index
)
function GetVirtualCamera(index);

Parameters

index
Type: SystemInt32
Index of the camera to access, range 0-VirtualCameraCount

Return Value

Type: ICinemachineCamera
The virtual camera at the specified index
See Also

Reference

CinemachineCore Class


CinemachineCore.IsLive Method

CinemachineCoreIsLive Method

Is this virtual camera currently actively controlling any Camera?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsLive(
    ICinemachineCamera vcam
)
function IsLive(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineCore.IsLive(Cinemachine.ICinemachineCamera)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cinemachine.CinemachineCore.IsLive(Cinemachine.ICinemachineCamera)"]

See Also

Reference

CinemachineCore Class


CinemachineCore Fields

The CinemachineCore type exposes the following members.

Fields
Name | Description
GetInputAxis | Delegate for overriding Unity's default input system. If you set this, then your delegate will be called instead of System.Input.GetAxis(axisName) whenever in-game user input is needed.
kStreamingVersion | Data version string. Used to upgrade from legacy projects
kVersionString | Human-readable Cinemachine Version
sShowHiddenObjects | If true, show hidden Cinemachine objects, to make manual script mapping possible.
Top
See Also

Reference

CinemachineCore Class


CinemachineCore.GetInputAxis Field

CinemachineCoreGetInputAxis Field

Delegate for overriding Unity's default input system. If you set this, then your delegate will be called instead of System.Input.GetAxis(axisName) whenever in-game user input is needed.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static CinemachineCoreAxisInputDelegate GetInputAxis
var Cinemachine.CinemachineCore.GetInputAxis

Field Value

Type: CinemachineCoreAxisInputDelegate
See Also

Reference

CinemachineCore Class


CinemachineCore.kStreamingVersion Field

CinemachineCorekStreamingVersion Field

Data version string. Used to upgrade from legacy projects

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static readonly int kStreamingVersion
var Cinemachine.CinemachineCore.kStreamingVersion

Field Value

Type: Int32
See Also

Reference

CinemachineCore Class


CinemachineCore.kVersionString Field

CinemachineCorekVersionString Field

Human-readable Cinemachine Version

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static readonly string kVersionString
var Cinemachine.CinemachineCore.kVersionString

Field Value

Type: String
See Also

Reference

CinemachineCore Class


CinemachineCore.sShowHiddenObjects Field

CinemachineCoresShowHiddenObjects Field

If true, show hidden Cinemachine objects, to make manual script mapping possible.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static bool sShowHiddenObjects
var Cinemachine.CinemachineCore.sShowHiddenObjects

Field Value

Type: Boolean
See Also

Reference

CinemachineCore Class


CinemachineCore.AxisInputDelegate Delegate

CinemachineCoreAxisInputDelegate Delegate

Delegate for overriding Unity's default input system. Returns the value of the named axis.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public delegate float AxisInputDelegate(
    string axisName
)
function(axisName);

Parameters

axisName
Type: SystemString

Return Value

Type: Single
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineCore.Stage Enumeration

CinemachineCoreStage Enumeration

Stages in the Cinemachine Component pipeline, used for UI organization>. This enum defines the pipeline order.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum Stage
Cinemachine.Stage = function();
Cinemachine.Stage.createEnum('Cinemachine.Stage', false);
Members
Member name | Value | Description
Body | 0 | Second stage: position the camera in space
Aim | 1 | Third stage: orient the camera to point at the target
Noise | 2 | Final stage: apply noise (this is done separately, in the Correction channel of the CameraState)
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineCore.UpdateFilter Enumeration

CinemachineCoreUpdateFilter Enumeration

Internal use only

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum UpdateFilter
Cinemachine.UpdateFilter = function();
Cinemachine.UpdateFilter.createEnum('Cinemachine.UpdateFilter', false);
Members
Member name | Value | Description
Fixed | 0 |
Late | 1 |
Any | 2 |
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineDollyCart Class

This is a very simple behaviour that constrains its transform to a CinemachinePath. It can be used to animate any objects along a path, or as a Follow target for Cinemachine Virtual Cameras.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineDollyCart

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(21f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
public class CinemachineDollyCart : MonoBehaviour
Cinemachine.CinemachineDollyCart = function();

Type.createClass(
    'Cinemachine.CinemachineDollyCart',
    UnityEngine.MonoBehaviour);

The CinemachineDollyCart type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineDollyCart |
Top
Fields
 | Name | Description
Public field | m_Path | The path to follow
Public field | m_Position | The cart's current position on the path, in distance units
Public field | m_PositionUnits | How to interpret the Path Position
Public field | m_Speed | Move the cart with this speed
Public field | m_UpdateMethod | When to move the cart, if Velocity is non-zero
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineDollyCart Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineDollyCart.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineDollyCart()
Cinemachine.CinemachineDollyCart = function();
See Also

Reference

CinemachineDollyCart Class


CinemachineDollyCart Fields

The CinemachineDollyCart type exposes the following members.

Fields
 | Name | Description
Public field | m_Path | The path to follow
Public field | m_Position | The cart's current position on the path, in distance units
Public field | m_PositionUnits | How to interpret the Path Position
Public field | m_Speed | Move the cart with this speed
Public field | m_UpdateMethod | When to move the cart, if Velocity is non-zero
Top
See Also

Reference

CinemachineDollyCart Class


CinemachineDollyCart.m_Path Field

CinemachineDollyCartm_Path Field

The path to follow

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The path to follow")]
public CinemachinePathBase m_Path
var m_Path

Field Value

Type: CinemachinePathBase
See Also

Reference

CinemachineDollyCart Class


CinemachineDollyCart.m_Position Field

CinemachineDollyCartm_Position Field

The cart's current position on the path, in distance units

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The position along the path at which the cart will be placed.  This can be animated directly or, if the velocity is non-zero, will be updated automatically.  The value is interpreted according to the Position Units setting.")]
[FormerlySerializedAsAttribute("m_CurrentDistance")]
public float m_Position
var m_Position

Field Value

Type: Single
See Also

Reference

CinemachineDollyCart Class


CinemachineDollyCart.m_PositionUnits Field

CinemachineDollyCartm_PositionUnits Field

How to interpret the Path Position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How to interpret the Path Position.  If set to Path Units, values are as follows: 0 represents the first waypoint on the path, 1 is the second, and so on.  Values in-between are points on the path in between the waypoints.  If set to Distance, then Path Position represents distance along the path.")]
public CinemachinePathBasePositionUnits m_PositionUnits
var m_PositionUnits

Field Value

Type: CinemachinePathBasePositionUnits
See Also

Reference

CinemachineDollyCart Class


CinemachineDollyCart.m_Speed Field

CinemachineDollyCartm_Speed Field

Move the cart with this speed

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Move the cart with this speed along the path.  The value is interpreted according to the Position Units setting.")]
[FormerlySerializedAsAttribute("m_Velocity")]
public float m_Speed
var m_Speed

Field Value

Type: Single
See Also

Reference

CinemachineDollyCart Class


CinemachineDollyCart.m_UpdateMethod Field

CinemachineDollyCartm_UpdateMethod Field

When to move the cart, if Velocity is non-zero

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When to move the cart, if Velocity is non-zero")]
public CinemachineDollyCartUpdateMethod m_UpdateMethod
var m_UpdateMethod

Field Value

Type: CinemachineDollyCartUpdateMethod
See Also

Reference

CinemachineDollyCart Class


CinemachineDollyCart.UpdateMethod Enumeration

CinemachineDollyCartUpdateMethod Enumeration

This enum defines the options available for the update method.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum UpdateMethod
Cinemachine.UpdateMethod = function();
Cinemachine.UpdateMethod.createEnum('Cinemachine.UpdateMethod', false);
Members
Member name | Value | Description
Update | 0 | Updated in normal MonoBehaviour Update.
FixedUpdate | 1 | Updated in sync with the Physics module, in FixedUpdate
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineExtension Class

Base class for a Cinemachine Virtual Camera extension module. Hooks into the Cinemachine Pipeline.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineExtension
CinemachineCinemachineCollider
CinemachineCinemachineConfiner
CinemachineCinemachineFollowZoom

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(23f, DocumentationSortingAttributeLevel.API)]
public abstract class CinemachineExtension : MonoBehaviour
Cinemachine.CinemachineExtension = function();

Type.createClass(
    'Cinemachine.CinemachineExtension',
    UnityEngine.MonoBehaviour);

The CinemachineExtension type exposes the following members.

Constructors
 | Name | Description
Protected method | CinemachineExtension |
Top
Properties
 | Name | Description
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase
Top
Methods
 | Name | Description
Protected method | Awake | Connect to virtual camera pipeline. Override implementations must call this base implementation
Protected method | GetAllExtraStatesT | Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime!
Protected method | GetExtraStateT | Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this.
Protected method | OnDestroy | Disconnect from virtual camera pipeline. Override implementations must call this base implementation
Protected method | PostPipelineStageCallback | This callback will be called after the virtual camera has implemented each stage in the pipeline. This method may modify the referenced state. If deltaTime less than 0, reset all state info and perform no damping.
Top
Fields
Name | Description
Epsilon | Useful constant for very small floats
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineExtension Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineExtension.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected CinemachineExtension()
Cinemachine.CinemachineExtension = function();
See Also

Reference

CinemachineExtension Class


CinemachineExtension Properties

The CinemachineExtension type exposes the following members.

Properties
 | Name | Description
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase
Top
See Also

Reference

CinemachineExtension Class


CinemachineExtension.VirtualCamera Property

CinemachineExtensionVirtualCamera Property

Get the associated CinemachineVirtualCameraBase

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineVirtualCameraBase VirtualCamera { get; }
function get_VirtualCamera();

Property Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineExtension Class


CinemachineExtension Methods

The CinemachineExtension type exposes the following members.

Methods
 | Name | Description
Protected method | Awake | Connect to virtual camera pipeline. Override implementations must call this base implementation
Protected method | GetAllExtraStatesT | Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime!
Protected method | GetExtraStateT | Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this.
Protected method | OnDestroy | Disconnect from virtual camera pipeline. Override implementations must call this base implementation
Protected method | PostPipelineStageCallback | This callback will be called after the virtual camera has implemented each stage in the pipeline. This method may modify the referenced state. If deltaTime less than 0, reset all state info and perform no damping.
Top
See Also

Reference

CinemachineExtension Class


CinemachineExtension.Awake Method

CinemachineExtensionAwake Method

Connect to virtual camera pipeline. Override implementations must call this base implementation

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void Awake()
function Awake();
See Also

Reference

CinemachineExtension Class


CinemachineExtension.GetAllExtraStates(T) Method

CinemachineExtensionGetAllExtraStatesT Method

Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime!

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected List<T> GetAllExtraStates<T>()
where T : class, new()

JavaScript does not support generic types or methods.

Type Parameters

T

Return Value

Type: List T

[Missing <returns> documentation for "M:Cinemachine.CinemachineExtension.GetAllExtraStates``1"]

See Also

Reference

CinemachineExtension Class


CinemachineExtension.GetExtraState(T) Method

CinemachineExtensionGetExtraStateT Method

Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected T GetExtraState<T>(
    ICinemachineCamera vcam
)
where T : class, new()

JavaScript does not support generic types or methods.

Parameters

vcam
Type: CinemachineICinemachineCamera

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineExtension.GetExtraState``1(Cinemachine.ICinemachineCamera)"]

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:Cinemachine.CinemachineExtension.GetExtraState``1(Cinemachine.ICinemachineCamera)"]

See Also

Reference

CinemachineExtension Class


CinemachineExtension.OnDestroy Method

CinemachineExtensionOnDestroy Method

Disconnect from virtual camera pipeline. Override implementations must call this base implementation

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void OnDestroy()
function OnDestroy();
See Also

Reference

CinemachineExtension Class


CinemachineExtension.PostPipelineStageCallback Method

CinemachineExtensionPostPipelineStageCallback Method

This callback will be called after the virtual camera has implemented each stage in the pipeline. This method may modify the referenced state. If deltaTime less than 0, reset all state info and perform no damping.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected abstract void PostPipelineStageCallback(
    CinemachineVirtualCameraBase vcam,
    CinemachineCoreStage stage,
    ref CameraState state,
    float deltaTime
)
function PostPipelineStageCallback(vcam, stage, state, deltaTime);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineExtension.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

stage
Type: CinemachineCinemachineCoreStage

[Missing <param name="stage"/> documentation for "M:Cinemachine.CinemachineExtension.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

state
Type: CinemachineCameraState

[Missing <param name="state"/> documentation for "M:Cinemachine.CinemachineExtension.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineExtension.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

See Also

Reference

CinemachineExtension Class


CinemachineExtension Fields

The CinemachineExtension type exposes the following members.

Fields
Name | Description
Epsilon | Useful constant for very small floats
Top
See Also

Reference

CinemachineExtension Class


CinemachineExtension.Epsilon Field

CinemachineExtensionEpsilon Field

Useful constant for very small floats

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected const float Epsilon = 0.0001f
var Cinemachine.CinemachineExtension.Epsilon

Field Value

Type: Single
See Also

Reference

CinemachineExtension Class


CinemachineExternalCamera Class

This component will expose a non-cinemachine camera to the cinemachine system, allowing it to participate in blends. Just add it as a component alongside an existing Unity Camera component.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
CinemachineCinemachineExternalCamera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(14f, DocumentationSortingAttributeLevel.UserRef)]
[RequireComponent(typeof(Camera))]
[DisallowMultipleComponent]
[ExecuteInEditMode]
[AddComponentMenu("Cinemachine/CinemachineExternalCamera")]
public class CinemachineExternalCamera : CinemachineVirtualCameraBase
Cinemachine.CinemachineExternalCamera = function();

Type.createClass(
    'Cinemachine.CinemachineExternalCamera',
    Cinemachine.CinemachineVirtualCameraBase);

The CinemachineExternalCamera type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineExternalCamera |
Top
Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Inherited from CinemachineVirtualCameraBase.)
Public property | Follow | This vcam defines no targets (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | LiveChildOrSelf | Just returns self. (Inherited from CinemachineVirtualCameraBase.)
Public property | LookAt | The object that the camera is looking at (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | Get the CameraState, as we are able to construct one from the Unity Camera (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. This base class implementation always returns false. (Inherited from CinemachineVirtualCameraBase.)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Base class implementation adds the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid. (Inherited from CinemachineVirtualCameraBase.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Construct a CameraState object from the Unity Camera (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Top
Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | The object that the camera is looking at.
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineExternalCamera Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineExternalCamera.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineExternalCamera()
Cinemachine.CinemachineExternalCamera = function();
See Also

Reference

CinemachineExternalCamera Class


CinemachineExternalCamera Properties

The CinemachineExternalCamera type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Inherited from CinemachineVirtualCameraBase.)
Public property | Follow | This vcam defines no targets (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | LiveChildOrSelf | Just returns self. (Inherited from CinemachineVirtualCameraBase.)
Public property | LookAt | The object that the camera is looking at (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | Get the CameraState, as we are able to construct one from the Unity Camera (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineExternalCamera Class


CinemachineExternalCamera.Follow Property

CinemachineExternalCameraFollow Property

This vcam defines no targets

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform

Implements

ICinemachineCameraFollow
See Also

Reference

CinemachineExternalCamera Class


CinemachineExternalCamera.LookAt Property

CinemachineExternalCameraLookAt Property

The object that the camera is looking at

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform

Implements

ICinemachineCameraLookAt
See Also

Reference

CinemachineExternalCamera Class


CinemachineExternalCamera.State Property

CinemachineExternalCameraState Property

Get the CameraState, as we are able to construct one from the Unity Camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CameraState State { get; }
function get_State();

Property Value

Type: CameraState

Implements

ICinemachineCameraState
See Also

Reference

CinemachineExternalCamera Class


CinemachineExternalCamera Methods

The CinemachineExternalCamera type exposes the following members.

Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. This base class implementation always returns false. (Inherited from CinemachineVirtualCameraBase.)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Base class implementation adds the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid. (Inherited from CinemachineVirtualCameraBase.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Construct a CameraState object from the Unity Camera (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Top
See Also

Reference

CinemachineExternalCamera Class


CinemachineExternalCamera.UpdateCameraState Method

CinemachineExternalCameraUpdateCameraState Method

Construct a CameraState object from the Unity Camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3

[Missing <param name="worldUp"/> documentation for "M:Cinemachine.CinemachineExternalCamera.UpdateCameraState(UnityEngine.Vector3,System.Single)"]

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineExternalCamera.UpdateCameraState(UnityEngine.Vector3,System.Single)"]

Implements

ICinemachineCameraUpdateCameraState(Vector3, Single)
See Also

Reference

CinemachineExternalCamera Class


CinemachineExternalCamera Fields

The CinemachineExternalCamera type exposes the following members.

Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | The object that the camera is looking at.
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineExternalCamera Class


CinemachineExternalCamera.m_LookAt Field

CinemachineExternalCameram_LookAt Field

The object that the camera is looking at.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The object that the camera is looking at.  Setting this will improve the quality of the blends to and from this camera")]
[NoSaveDuringPlayAttribute]
public Transform m_LookAt
var m_LookAt

Field Value

Type: Transform
See Also

Reference

CinemachineExternalCamera Class


CinemachineFollowZoom Class

An add-on module for Cinemachine Virtual Camera that adjusts the FOV of the lens to keep the target object at a constant size on the screen, regardless of camera and target position.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineExtension
CinemachineCinemachineFollowZoom

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(16f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[AddComponentMenu("")]
[SaveDuringPlayAttribute]
public class CinemachineFollowZoom : CinemachineExtension
Cinemachine.CinemachineFollowZoom = function();

Type.createClass(
    'Cinemachine.CinemachineFollowZoom',
    Cinemachine.CinemachineExtension);

The CinemachineFollowZoom type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineFollowZoom |
Top
Properties
 | Name | Description
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineExtension.)
Top
Methods
 | Name | Description
Protected method | Awake | Connect to virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Protected method | GetAllExtraStatesT | Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime! (Inherited from CinemachineExtension.)
Protected method | GetExtraStateT | Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this. (Inherited from CinemachineExtension.)
Protected method | OnDestroy | Disconnect from virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Protected method | PostPipelineStageCallback | Callback to preform the zoom adjustment (Overrides CinemachineExtensionPostPipelineStageCallback(CinemachineVirtualCameraBase, CinemachineCoreStage, CameraState, Single).)
Top
Fields
 | Name | Description
Public field | m_Damping | Increase this value to soften the aggressiveness of the follow-zoom. Small numbers are more responsive, larger numbers give a more heavy slowly responding camera.
Public field | m_MaxFOV | Will not generate an FOV larget than this.
Public field | m_MinFOV | Will not generate an FOV smaller than this.
Public field | m_Width | The shot width to maintain, in world units, at target distance. FOV will be adusted as far as possible to maintain this width at the target distance from the camera.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineFollowZoom Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineFollowZoom.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineFollowZoom()
Cinemachine.CinemachineFollowZoom = function();
See Also

Reference

CinemachineFollowZoom Class


CinemachineFollowZoom Properties

The CinemachineFollowZoom type exposes the following members.

Properties
 | Name | Description
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineExtension.)
Top
See Also

Reference

CinemachineFollowZoom Class


CinemachineFollowZoom Methods

The CinemachineFollowZoom type exposes the following members.

Methods
 | Name | Description
Protected method | Awake | Connect to virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Protected method | GetAllExtraStatesT | Ineffeicient method to get all extra state infor for all vcams. Intended for Editor use only, not runtime! (Inherited from CinemachineExtension.)
Protected method | GetExtraStateT | Because extensions can be placed on manager cams and will in that case be called for all the vcam children, vcam-specific state information should be stored here. Just define a class to hold your state info and use it exclusively when calling this. (Inherited from CinemachineExtension.)
Protected method | OnDestroy | Disconnect from virtual camera pipeline. Override implementations must call this base implementation (Inherited from CinemachineExtension.)
Protected method | PostPipelineStageCallback | Callback to preform the zoom adjustment (Overrides CinemachineExtensionPostPipelineStageCallback(CinemachineVirtualCameraBase, CinemachineCoreStage, CameraState, Single).)
Top
See Also

Reference

CinemachineFollowZoom Class


CinemachineFollowZoom.PostPipelineStageCallback Method

CinemachineFollowZoomPostPipelineStageCallback Method

Callback to preform the zoom adjustment

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void PostPipelineStageCallback(
    CinemachineVirtualCameraBase vcam,
    CinemachineCoreStage stage,
    ref CameraState state,
    float deltaTime
)
function PostPipelineStageCallback(vcam, stage, state, deltaTime);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineFollowZoom.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

stage
Type: CinemachineCinemachineCoreStage

[Missing <param name="stage"/> documentation for "M:Cinemachine.CinemachineFollowZoom.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

state
Type: CinemachineCameraState

[Missing <param name="state"/> documentation for "M:Cinemachine.CinemachineFollowZoom.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineFollowZoom.PostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

See Also

Reference

CinemachineFollowZoom Class


CinemachineFollowZoom Fields

The CinemachineFollowZoom type exposes the following members.

Fields
 | Name | Description
Public field | m_Damping | Increase this value to soften the aggressiveness of the follow-zoom. Small numbers are more responsive, larger numbers give a more heavy slowly responding camera.
Public field | m_MaxFOV | Will not generate an FOV larget than this.
Public field | m_MinFOV | Will not generate an FOV smaller than this.
Public field | m_Width | The shot width to maintain, in world units, at target distance. FOV will be adusted as far as possible to maintain this width at the target distance from the camera.
Top
See Also

Reference

CinemachineFollowZoom Class


CinemachineFollowZoom.m_Damping Field

CinemachineFollowZoomm_Damping Field

Increase this value to soften the aggressiveness of the follow-zoom. Small numbers are more responsive, larger numbers give a more heavy slowly responding camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("Increase this value to soften the aggressiveness of the follow-zoom.  Small numbers are more responsive, larger numbers give a more heavy slowly responding camera.")]
public float m_Damping
var m_Damping

Field Value

Type: Single
See Also

Reference

CinemachineFollowZoom Class


CinemachineFollowZoom.m_MaxFOV Field

CinemachineFollowZoomm_MaxFOV Field

Will not generate an FOV larget than this.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(1f, 179f)]
[TooltipAttribute("Upper limit for the FOV that this behaviour will generate.")]
public float m_MaxFOV
var m_MaxFOV

Field Value

Type: Single
See Also

Reference

CinemachineFollowZoom Class


CinemachineFollowZoom.m_MinFOV Field

CinemachineFollowZoomm_MinFOV Field

Will not generate an FOV smaller than this.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(1f, 179f)]
[TooltipAttribute("Lower limit for the FOV that this behaviour will generate.")]
public float m_MinFOV
var m_MinFOV

Field Value

Type: Single
See Also

Reference

CinemachineFollowZoom Class


CinemachineFollowZoom.m_Width Field

CinemachineFollowZoomm_Width Field

The shot width to maintain, in world units, at target distance. FOV will be adusted as far as possible to maintain this width at the target distance from the camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The shot width to maintain, in world units, at target distance.")]
public float m_Width
var m_Width

Field Value

Type: Single
See Also

Reference

CinemachineFollowZoom Class


CinemachineFramingTransposer Class

This is a Cinemachine Component in the Body section of the component pipeline. Its job is to position the camera in a fixed screen-space relationship to the vcam's Follow target object, with offsets and damping. The camera will be first moved along the camera Z axis until the Follow target is at the desired distance from the camera's X-Y plane. The camera will then be moved in its XY plane until the Follow target is at the desired point on the camera's screen. The FramingTansposer will only change the camera's position in space. It will not re-orient or otherwise aim the camera. For this component to work properly, the vcam's LookAt target must be null. The Follow target will define what the camera is looking at. If the Follow target is a CinemachineTargetGroup, then additional controls will be available to dynamically adjust the camera’s view in order to frame the entire group. Although this component was designed for orthographic cameras, it works equally well with persective cameras and can be used in 3D environments.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineFramingTransposer

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(5.5f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineFramingTransposer : CinemachineComponentBase
Cinemachine.CinemachineFramingTransposer = function();

Type.createClass(
    'Cinemachine.CinemachineFramingTransposer',
    Cinemachine.CinemachineComponentBase);

The CinemachineFramingTransposer type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineFramingTransposer |
Top
Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | HardGuideRect | Internal API for the inspector editor
Public property | IsValid | True if component is enabled and has a valid Follow target (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | m_LastBounds | For editor visulaization of the calculated bounding box of the group
Public property | m_lastBoundsMatrix | For editor visualization of the calculated bounding box of the group
Public property | SoftGuideRect | Internal API for the inspector editor
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage (Overrides CinemachineComponentBaseStage.)
Public property | TargetGroup | Get Follow target as CinemachineTargetGroup, or null if target is not a group
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Public method | MutateCameraState | Positions the virtual camera according to the transposer rules. (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
Fields
 | Name | Description
Public field | m_AdjustmentMode | How to adjust the camera to get the desired framing
Public field | m_BiasX | A non-zero bias will move the targt position away from the center of the soft zone
Public field | m_BiasY | A non-zero bias will move the targt position away from the center of the soft zone
Public field | m_CameraDistance | The distance along the camera axis that will be maintained from the Follow target
Public field | m_DeadZoneDepth | The camera will not move along its z-axis if the Follow target is within this distance of the specified camera distance
Public field | m_DeadZoneHeight | Camera will not move vertically if the target is within this range of the position
Public field | m_DeadZoneWidth | Camera will not move horizontally if the target is within this range of the position
Public field | m_GroupFramingMode | What screen dimensions to consider when framing
Public field | m_GroupFramingSize | How much of the screen to fill with the bounding box of the targets.
Public field | m_LookaheadSmoothing | Controls the smoothness of the lookahead algorithm. Larger values smooth out jittery predictions and also increase prediction lag
Public field | m_LookaheadTime | This setting will instruct the composer to adjust its target offset based on the motion of the target. The composer will look at a point where it estimates the target will be this many seconds into the future. Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter. If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly.
Public field | m_MaxDollyIn | How much closer to the target can the camera go?
Public field | m_MaxDollyOut | How much farther from the target can the camera go?
Public field | m_MaximumDistance | Set this to limit how far from the taregt the camera can get
Public field | m_MaximumFOV | If adjusting FOV, will not set the FOV higher than this
Public field | m_MaximumOrthoSize | If adjusting Orthographic Size, will not set it higher than this
Public field | m_MinimumDistance | Set this to limit how close to the target the camera can get
Public field | m_MinimumFOV | If adjusting FOV, will not set the FOV lower than this
Public field | m_MinimumOrthoSize | If adjusting Orthographic Size, will not set it lower than this
Public field | m_ScreenX | Horizontal screen position for target. The camera will move to position the tracked object here
Public field | m_ScreenY | Vertical screen position for target, The camera will move to to position the tracked object here
Public field | m_SoftZoneHeight | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed
Public field | m_SoftZoneWidth | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed
Public field | m_UnlimitedSoftZone |
Public field | m_XDamping | How aggressively the camera tries to maintain the offset in the X-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_YDamping | How aggressively the camera tries to maintain the offset in the Y-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_ZDamping | How aggressively the camera tries to maintain the offset in the Z-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | OnGUICallback | Used by the Inspector Editor to display on-screen guides.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineFramingTransposer Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineFramingTransposer.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineFramingTransposer()
Cinemachine.CinemachineFramingTransposer = function();
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer Properties

The CinemachineFramingTransposer type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | HardGuideRect | Internal API for the inspector editor
Public property | IsValid | True if component is enabled and has a valid Follow target (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | m_LastBounds | For editor visulaization of the calculated bounding box of the group
Public property | m_lastBoundsMatrix | For editor visualization of the calculated bounding box of the group
Public property | SoftGuideRect | Internal API for the inspector editor
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage (Overrides CinemachineComponentBaseStage.)
Public property | TargetGroup | Get Follow target as CinemachineTargetGroup, or null if target is not a group
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.HardGuideRect Property

CinemachineFramingTransposerHardGuideRect Property

Internal API for the inspector editor

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Rect HardGuideRect { get; set; }
function get_HardGuideRect();
function set_HardGuideRect(value);

Property Value

Type: Rect
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.IsValid Property

CinemachineFramingTransposerIsValid Property

True if component is enabled and has a valid Follow target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_LastBounds Property

CinemachineFramingTransposerm_LastBounds Property

For editor visulaization of the calculated bounding box of the group

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Bounds m_LastBounds { get; }
function get_m_LastBounds();

Property Value

Type: Bounds
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_lastBoundsMatrix Property

CinemachineFramingTransposerm_lastBoundsMatrix Property

For editor visualization of the calculated bounding box of the group

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Matrix4x4 m_lastBoundsMatrix { get; }
function get_m_lastBoundsMatrix();

Property Value

Type: Matrix4x4
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.SoftGuideRect Property

CinemachineFramingTransposerSoftGuideRect Property

Internal API for the inspector editor

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Rect SoftGuideRect { get; set; }
function get_SoftGuideRect();
function set_SoftGuideRect(value);

Property Value

Type: Rect
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.Stage Property

CinemachineFramingTransposerStage Property

Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.TargetGroup Property

CinemachineFramingTransposerTargetGroup Property

Get Follow target as CinemachineTargetGroup, or null if target is not a group

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineTargetGroup TargetGroup { get; }
function get_TargetGroup();

Property Value

Type: CinemachineTargetGroup
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer Methods

The CinemachineFramingTransposer type exposes the following members.

Methods
 | Name | Description
Public method | MutateCameraState | Positions the virtual camera according to the transposer rules. (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.MutateCameraState Method

CinemachineFramingTransposerMutateCameraState Method

Positions the virtual camera according to the transposer rules.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
Used for damping. If less than 0, no damping is done.
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer Fields

The CinemachineFramingTransposer type exposes the following members.

Fields
 | Name | Description
Public field | m_AdjustmentMode | How to adjust the camera to get the desired framing
Public field | m_BiasX | A non-zero bias will move the targt position away from the center of the soft zone
Public field | m_BiasY | A non-zero bias will move the targt position away from the center of the soft zone
Public field | m_CameraDistance | The distance along the camera axis that will be maintained from the Follow target
Public field | m_DeadZoneDepth | The camera will not move along its z-axis if the Follow target is within this distance of the specified camera distance
Public field | m_DeadZoneHeight | Camera will not move vertically if the target is within this range of the position
Public field | m_DeadZoneWidth | Camera will not move horizontally if the target is within this range of the position
Public field | m_GroupFramingMode | What screen dimensions to consider when framing
Public field | m_GroupFramingSize | How much of the screen to fill with the bounding box of the targets.
Public field | m_LookaheadSmoothing | Controls the smoothness of the lookahead algorithm. Larger values smooth out jittery predictions and also increase prediction lag
Public field | m_LookaheadTime | This setting will instruct the composer to adjust its target offset based on the motion of the target. The composer will look at a point where it estimates the target will be this many seconds into the future. Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter. If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly.
Public field | m_MaxDollyIn | How much closer to the target can the camera go?
Public field | m_MaxDollyOut | How much farther from the target can the camera go?
Public field | m_MaximumDistance | Set this to limit how far from the taregt the camera can get
Public field | m_MaximumFOV | If adjusting FOV, will not set the FOV higher than this
Public field | m_MaximumOrthoSize | If adjusting Orthographic Size, will not set it higher than this
Public field | m_MinimumDistance | Set this to limit how close to the target the camera can get
Public field | m_MinimumFOV | If adjusting FOV, will not set the FOV lower than this
Public field | m_MinimumOrthoSize | If adjusting Orthographic Size, will not set it lower than this
Public field | m_ScreenX | Horizontal screen position for target. The camera will move to position the tracked object here
Public field | m_ScreenY | Vertical screen position for target, The camera will move to to position the tracked object here
Public field | m_SoftZoneHeight | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed
Public field | m_SoftZoneWidth | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed
Public field | m_UnlimitedSoftZone |
Public field | m_XDamping | How aggressively the camera tries to maintain the offset in the X-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_YDamping | How aggressively the camera tries to maintain the offset in the Y-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_ZDamping | How aggressively the camera tries to maintain the offset in the Z-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | OnGUICallback | Used by the Inspector Editor to display on-screen guides.
Top
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_AdjustmentMode Field

CinemachineFramingTransposerm_AdjustmentMode Field

How to adjust the camera to get the desired framing

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How to adjust the camera to get the desired framing.  You can zoom, dolly in/out, or do both.")]
public CinemachineFramingTransposerAdjustmentMode m_AdjustmentMode
var m_AdjustmentMode

Field Value

Type: CinemachineFramingTransposerAdjustmentMode
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_BiasX Field

CinemachineFramingTransposerm_BiasX Field

A non-zero bias will move the targt position away from the center of the soft zone

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(-0.5f, 0.5f)]
[TooltipAttribute("A non-zero bias will move the target position horizontally away from the center of the soft zone.")]
public float m_BiasX
var m_BiasX

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_BiasY Field

CinemachineFramingTransposerm_BiasY Field

A non-zero bias will move the targt position away from the center of the soft zone

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(-0.5f, 0.5f)]
[TooltipAttribute("A non-zero bias will move the target position vertically away from the center of the soft zone.")]
public float m_BiasY
var m_BiasY

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_CameraDistance Field

CinemachineFramingTransposerm_CameraDistance Field

The distance along the camera axis that will be maintained from the Follow target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The distance along the camera axis that will be maintained from the Follow target")]
public float m_CameraDistance
var m_CameraDistance

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_DeadZoneDepth Field

CinemachineFramingTransposerm_DeadZoneDepth Field

The camera will not move along its z-axis if the Follow target is within this distance of the specified camera distance

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The camera will not move along its z-axis if the Follow target is within this distance of the specified camera distance")]
[FormerlySerializedAsAttribute("m_DistanceDeadZoneSize")]
public float m_DeadZoneDepth
var m_DeadZoneDepth

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_DeadZoneHeight Field

CinemachineFramingTransposerm_DeadZoneHeight Field

Camera will not move vertically if the target is within this range of the position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 1f)]
[TooltipAttribute("Camera will not move vertically if the target is within this range of the position.")]
public float m_DeadZoneHeight
var m_DeadZoneHeight

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_DeadZoneWidth Field

CinemachineFramingTransposerm_DeadZoneWidth Field

Camera will not move horizontally if the target is within this range of the position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[RangeAttribute(0f, 1f)]
[TooltipAttribute("Camera will not move horizontally if the target is within this range of the position.")]
public float m_DeadZoneWidth
var m_DeadZoneWidth

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_GroupFramingMode Field

CinemachineFramingTransposerm_GroupFramingMode Field

What screen dimensions to consider when framing

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[TooltipAttribute("What screen dimensions to consider when framing.  Can be Horizontal, Vertical, or both")]
[FormerlySerializedAsAttribute("m_FramingMode")]
public CinemachineFramingTransposerFramingMode m_GroupFramingMode
var m_GroupFramingMode

Field Value

Type: CinemachineFramingTransposerFramingMode
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_GroupFramingSize Field

CinemachineFramingTransposerm_GroupFramingSize Field

How much of the screen to fill with the bounding box of the targets.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The bounding box of the targets should occupy this amount of the screen space.  1 means fill the whole screen.  0.5 means fill half the screen, etc.")]
public float m_GroupFramingSize
var m_GroupFramingSize

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_LookaheadSmoothing Field

CinemachineFramingTransposerm_LookaheadSmoothing Field

Controls the smoothness of the lookahead algorithm. Larger values smooth out jittery predictions and also increase prediction lag

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Controls the smoothness of the lookahead algorithm.  Larger values smooth out jittery predictions and also increase prediction lag")]
[RangeAttribute(3f, 30f)]
public float m_LookaheadSmoothing
var m_LookaheadSmoothing

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_LookaheadTime Field

CinemachineFramingTransposerm_LookaheadTime Field

This setting will instruct the composer to adjust its target offset based on the motion of the target. The composer will look at a point where it estimates the target will be this many seconds into the future. Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter. If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("This setting will instruct the composer to adjust its target offset based on the motion of the target.  The composer will look at a point where it estimates the target will be this many seconds into the future.  Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter.  If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly.")]
[RangeAttribute(0f, 1f)]
public float m_LookaheadTime
var m_LookaheadTime

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_MaxDollyIn Field

CinemachineFramingTransposerm_MaxDollyIn Field

How much closer to the target can the camera go?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The maximum distance toward the target that this behaviour is allowed to move the camera.")]
public float m_MaxDollyIn
var m_MaxDollyIn

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_MaxDollyOut Field

CinemachineFramingTransposerm_MaxDollyOut Field

How much farther from the target can the camera go?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The maximum distance away the target that this behaviour is allowed to move the camera.")]
public float m_MaxDollyOut
var m_MaxDollyOut

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_MaximumDistance Field

CinemachineFramingTransposerm_MaximumDistance Field

Set this to limit how far from the taregt the camera can get

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Set this to limit how far from the target the camera can get.")]
public float m_MaximumDistance
var m_MaximumDistance

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_MaximumFOV Field

CinemachineFramingTransposerm_MaximumFOV Field

If adjusting FOV, will not set the FOV higher than this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(1f, 179f)]
[TooltipAttribute("If adjusting FOV, will not set the FOV higher than this.")]
public float m_MaximumFOV
var m_MaximumFOV

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_MaximumOrthoSize Field

CinemachineFramingTransposerm_MaximumOrthoSize Field

If adjusting Orthographic Size, will not set it higher than this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If adjusting Orthographic Size, will not set it higher than this.")]
public float m_MaximumOrthoSize
var m_MaximumOrthoSize

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_MinimumDistance Field

CinemachineFramingTransposerm_MinimumDistance Field

Set this to limit how close to the target the camera can get

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Set this to limit how close to the target the camera can get.")]
public float m_MinimumDistance
var m_MinimumDistance

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_MinimumFOV Field

CinemachineFramingTransposerm_MinimumFOV Field

If adjusting FOV, will not set the FOV lower than this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(1f, 179f)]
[TooltipAttribute("If adjusting FOV, will not set the FOV lower than this.")]
public float m_MinimumFOV
var m_MinimumFOV

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_MinimumOrthoSize Field

CinemachineFramingTransposerm_MinimumOrthoSize Field

If adjusting Orthographic Size, will not set it lower than this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If adjusting Orthographic Size, will not set it lower than this.")]
public float m_MinimumOrthoSize
var m_MinimumOrthoSize

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_ScreenX Field

CinemachineFramingTransposerm_ScreenX Field

Horizontal screen position for target. The camera will move to position the tracked object here

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[RangeAttribute(0f, 1f)]
[TooltipAttribute("Horizontal screen position for target. The camera will move to position the tracked object here.")]
public float m_ScreenX
var m_ScreenX

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_ScreenY Field

CinemachineFramingTransposerm_ScreenY Field

Vertical screen position for target, The camera will move to to position the tracked object here

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 1f)]
[TooltipAttribute("Vertical screen position for target, The camera will move to position the tracked object here.")]
public float m_ScreenY
var m_ScreenY

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_SoftZoneHeight Field

CinemachineFramingTransposerm_SoftZoneHeight Field

When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 2f)]
[TooltipAttribute("When target is within this region, camera will gradually move vertically to re-align towards the desired position, depending on the damping speed.")]
public float m_SoftZoneHeight
var m_SoftZoneHeight

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_SoftZoneWidth Field

CinemachineFramingTransposerm_SoftZoneWidth Field

When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 2f)]
[TooltipAttribute("When target is within this region, camera will gradually move horizontally to re-align towards the desired position, depending on the damping speed.")]
public float m_SoftZoneWidth
var m_SoftZoneWidth

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_UnlimitedSoftZone Field

CinemachineFramingTransposerm_UnlimitedSoftZone Field

[Missing <summary> documentation for "F:Cinemachine.CinemachineFramingTransposer.m_UnlimitedSoftZone"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[TooltipAttribute("If checked, then then soft zone will be unlimited in size.")]
public bool m_UnlimitedSoftZone
var m_UnlimitedSoftZone

Field Value

Type: Boolean
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_XDamping Field

CinemachineFramingTransposerm_XDamping Field

How aggressively the camera tries to maintain the offset in the X-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain the offset in the X-axis.  Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_XDamping
var m_XDamping

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_YDamping Field

CinemachineFramingTransposerm_YDamping Field

How aggressively the camera tries to maintain the offset in the Y-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain the offset in the Y-axis.  Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_YDamping
var m_YDamping

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.m_ZDamping Field

CinemachineFramingTransposerm_ZDamping Field

How aggressively the camera tries to maintain the offset in the Z-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain the offset in the Z-axis.  Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_ZDamping
var m_ZDamping

Field Value

Type: Single
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.OnGUICallback Field

CinemachineFramingTransposerOnGUICallback Field

Used by the Inspector Editor to display on-screen guides.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[NoSaveDuringPlayAttribute]
[HideInInspector]
public Action OnGUICallback
var OnGUICallback

Field Value

Type: Action
See Also

Reference

CinemachineFramingTransposer Class


CinemachineFramingTransposer.AdjustmentMode Enumeration

CinemachineFramingTransposerAdjustmentMode Enumeration

How to adjust the camera to get the desired framing

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum AdjustmentMode
Cinemachine.AdjustmentMode = function();
Cinemachine.AdjustmentMode.createEnum('Cinemachine.AdjustmentMode', false);
Members
Member name | Value | Description
ZoomOnly | 0 | Do not move the camera, only adjust the FOV.
DollyOnly | 1 | Just move the camera, don't change the FOV.
DollyThenZoom | 2 | Move the camera as much as permitted by the ranges, then adjust the FOV if necessary to make the shot.
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineFramingTransposer.FramingMode Enumeration

CinemachineFramingTransposerFramingMode Enumeration

What screen dimensions to consider when framing

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(4.01f, DocumentationSortingAttributeLevel.UserRef)]
public enum FramingMode
Cinemachine.FramingMode = function();
Cinemachine.FramingMode.createEnum('Cinemachine.FramingMode', false);
Members
Member name | Value | Description
Horizontal | 0 | Consider only the horizontal dimension. Vertical framing is ignored.
Vertical | 1 | Consider only the vertical dimension. Horizontal framing is ignored.
HorizontalAndVertical | 2 | The larger of the horizontal and vertical dimensions will dominate, to get the best fit.
None | 3 | Don't do any framing adjustment
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineFreeLook Class

A Cinemachine Camera geared towards a 3rd person camera experience. The camera orbits around its subject with three separate camera rigs defining rings around the target. Each rig has its own radius, height offset, composer, and lens settings. Depending on the camera's position along the spline connecting these three rigs, these settings are interpolated to give the final camera position and state.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
CinemachineCinemachineFreeLook

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(11f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[DisallowMultipleComponent]
[AddComponentMenu("Cinemachine/CinemachineFreeLook")]
public class CinemachineFreeLook : CinemachineVirtualCameraBase
Cinemachine.CinemachineFreeLook = function();

Type.createClass(
    'Cinemachine.CinemachineFreeLook',
    Cinemachine.CinemachineVirtualCameraBase);

The CinemachineFreeLook type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineFreeLook |
Top
Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Inherited from CinemachineVirtualCameraBase.)
Public property | Follow | Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | LiveChildOrSelf | Returns the rig with the greatest weight (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
 | RigNames | Names of the 3 child rigs
Public property | State | The cacmera state, which will be a blend of the child rig states (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Public method | GetLocalPositionForCameraFromInput | Returns the local position of the camera along the spline used to connect the three camera rigs. Does not take into account the current heading of the camera (or its target)
Public method | GetRig | Get a child rig
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. Returns true if the child is currently contributing actively to the camera state. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Makes sure that the child rigs get destroyed in an undo-firndly manner. Invalidates the rig cache. (Overrides CinemachineVirtualCameraBaseOnDestroy.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Updates the child rig cache (Overrides CinemachineVirtualCameraBaseOnEnable.)
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | If we are transitioning from another FreeLook, grab the axis values from it. (Overrides CinemachineVirtualCameraBaseOnTransitionFromCamera(ICinemachineCamera).)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. (Overrides CinemachineVirtualCameraBaseOnValidate.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but might be called on LateUpdate. This implementation pushes the axis values to the rigs. (Overrides CinemachineVirtualCameraBasePreUpdateChildCameras(Vector3, Single).)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. All 3 child rigs are updated, and a blend calculated, depending on the value of the Y axis. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Top
Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
 | CreateRigOverride | Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in this class.
 | DestroyRigOverride | Override component pipeline destruction. This needs to be done by the editor to support Undo.
Public field | m_BindingMode | The coordinate space to use when interpreting the offset from the target
Public field | m_CommonLens | If enabled, this lens setting will apply to all three child rigs, otherwise the child rig lens settings will be used
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | Object for the camera children wants to move with (the body target)
Public field | m_Heading | The definition of Forward. Camera will follow behind
Public field | m_Lens | Specifies the lens properties of this Virtual Camera. This generally mirrors the Unity Camera's lens settings, and will be used to drive the Unity camera when the vcam is active
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | Object for the camera children to look at (the aim target)
Public field | m_Orbits | The radius and height of the three orbiting rigs
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_RecenterToTargetHeading | Controls how automatic recentering of the X axis is accomplished
Public field | m_SplineCurvature |
Public field | m_XAxis | The Horizontal axis. Value is 0..359. This is passed on to the rigs' OrbitalTransposer component
Public field | m_YAxis | The Vertical axis. Value is 0..1. Chooses how to blend the child rigs
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineFreeLook Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineFreeLook.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineFreeLook()
Cinemachine.CinemachineFreeLook = function();
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook Properties

The CinemachineFreeLook type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Inherited from CinemachineVirtualCameraBase.)
Public property | Follow | Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | LiveChildOrSelf | Returns the rig with the greatest weight (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
 | RigNames | Names of the 3 child rigs
Public property | State | The cacmera state, which will be a blend of the child rig states (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.Follow Property

CinemachineFreeLookFollow Property

Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform

Implements

ICinemachineCameraFollow
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.LiveChildOrSelf Property

CinemachineFreeLookLiveChildOrSelf Property

Returns the rig with the greatest weight

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override ICinemachineCamera LiveChildOrSelf { get; }
function get_LiveChildOrSelf();

Property Value

Type: ICinemachineCamera

Implements

ICinemachineCameraLiveChildOrSelf
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.LookAt Property

CinemachineFreeLookLookAt Property

Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform

Implements

ICinemachineCameraLookAt
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.RigNames Property

CinemachineFreeLookRigNames Property

Names of the 3 child rigs

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static string[] RigNames { get; }
Cinemachine.CinemachineFreeLook.get_RigNames = function();

Property Value

Type: String
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.State Property

CinemachineFreeLookState Property

The cacmera state, which will be a blend of the child rig states

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CameraState State { get; }
function get_State();

Property Value

Type: CameraState

Implements

ICinemachineCameraState
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook Methods

The CinemachineFreeLook type exposes the following members.

Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Public method | GetLocalPositionForCameraFromInput | Returns the local position of the camera along the spline used to connect the three camera rigs. Does not take into account the current heading of the camera (or its target)
Public method | GetRig | Get a child rig
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. Returns true if the child is currently contributing actively to the camera state. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Makes sure that the child rigs get destroyed in an undo-firndly manner. Invalidates the rig cache. (Overrides CinemachineVirtualCameraBaseOnDestroy.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Updates the child rig cache (Overrides CinemachineVirtualCameraBaseOnEnable.)
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | If we are transitioning from another FreeLook, grab the axis values from it. (Overrides CinemachineVirtualCameraBaseOnTransitionFromCamera(ICinemachineCamera).)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. (Overrides CinemachineVirtualCameraBaseOnValidate.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but might be called on LateUpdate. This implementation pushes the axis values to the rigs. (Overrides CinemachineVirtualCameraBasePreUpdateChildCameras(Vector3, Single).)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. All 3 child rigs are updated, and a blend calculated, depending on the value of the Y axis. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Top
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.GetLocalPositionForCameraFromInput Method

CinemachineFreeLookGetLocalPositionForCameraFromInput Method

Returns the local position of the camera along the spline used to connect the three camera rigs. Does not take into account the current heading of the camera (or its target)

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 GetLocalPositionForCameraFromInput(
    float t
)
function GetLocalPositionForCameraFromInput(t);

Parameters

t
Type: SystemSingle
The t-value for the camera on its spline. Internally clamped to the value [0,1]

Return Value

Type: Vector3
The local offset (back + up) of the camera WRT its target based on the supplied t-value
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.GetRig Method

CinemachineFreeLookGetRig Method

Get a child rig

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineVirtualCamera GetRig(
    int i
)
function GetRig(i);

Parameters

i
Type: SystemInt32
Rig index. Can be 0, 1, or 2

Return Value

Type: CinemachineVirtualCamera
The rig, or null if index is bad.
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.IsLiveChild Method

CinemachineFreeLookIsLiveChild Method

Check whether the vcam a live child of this camera. Returns true if the child is currently contributing actively to the camera state.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsLiveChild(
    ICinemachineCamera vcam
)
function IsLiveChild(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The Virtual Camera to check

Return Value

Type: Boolean
True if the vcam is currently actively influencing the state of this vcam

Implements

ICinemachineCameraIsLiveChild(ICinemachineCamera)
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.OnDestroy Method

CinemachineFreeLookOnDestroy Method

Makes sure that the child rigs get destroyed in an undo-firndly manner. Invalidates the rig cache.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnDestroy()
function OnDestroy();
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.OnEnable Method

CinemachineFreeLookOnEnable Method

Updates the child rig cache

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnEnable()
function OnEnable();
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.OnTransitionFromCamera Method

CinemachineFreeLookOnTransitionFromCamera Method

If we are transitioning from another FreeLook, grab the axis values from it.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void OnTransitionFromCamera(
    ICinemachineCamera fromCam
)
function OnTransitionFromCamera(fromCam);

Parameters

fromCam
Type: CinemachineICinemachineCamera
The camera being deactivated. May be null.

Implements

ICinemachineCameraOnTransitionFromCamera(ICinemachineCamera)
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.OnValidate Method

CinemachineFreeLookOnValidate Method

Enforce bounds for fields, when changed in inspector.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnValidate()
function OnValidate();
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.PreUpdateChildCameras Method

CinemachineFreeLookPreUpdateChildCameras Method

This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but might be called on LateUpdate. This implementation pushes the axis values to the rigs.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void PreUpdateChildCameras(
    Vector3 worldUp,
    float deltaTime
)
function PreUpdateChildCameras(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)

Implements

ICinemachineCameraPreUpdateChildCameras(Vector3, Single)
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.RemovePostPipelineStageHook Method

CinemachineFreeLookRemovePostPipelineStageHook Method

Remove a Pipeline stage hook callback. Make sure it is removed from all the children.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void RemovePostPipelineStageHook(
    CinemachineVirtualCameraBaseOnPostPipelineStageDelegate d
)
function RemovePostPipelineStageHook(d);

Parameters

d
Type: CinemachineCinemachineVirtualCameraBaseOnPostPipelineStageDelegate
The delegate to remove.
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.UpdateCameraState Method

CinemachineFreeLookUpdateCameraState Method

Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. All 3 child rigs are updated, and a blend calculated, depending on the value of the Y axis.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)

Implements

ICinemachineCameraUpdateCameraState(Vector3, Single)
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook Fields

The CinemachineFreeLook type exposes the following members.

Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
 | CreateRigOverride | Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in this class.
 | DestroyRigOverride | Override component pipeline destruction. This needs to be done by the editor to support Undo.
Public field | m_BindingMode | The coordinate space to use when interpreting the offset from the target
Public field | m_CommonLens | If enabled, this lens setting will apply to all three child rigs, otherwise the child rig lens settings will be used
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | Object for the camera children wants to move with (the body target)
Public field | m_Heading | The definition of Forward. Camera will follow behind
Public field | m_Lens | Specifies the lens properties of this Virtual Camera. This generally mirrors the Unity Camera's lens settings, and will be used to drive the Unity camera when the vcam is active
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | Object for the camera children to look at (the aim target)
Public field | m_Orbits | The radius and height of the three orbiting rigs
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_RecenterToTargetHeading | Controls how automatic recentering of the X axis is accomplished
Public field | m_SplineCurvature |
Public field | m_XAxis | The Horizontal axis. Value is 0..359. This is passed on to the rigs' OrbitalTransposer component
Public field | m_YAxis | The Vertical axis. Value is 0..1. Chooses how to blend the child rigs
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.CreateRigOverride Field

CinemachineFreeLookCreateRigOverride Field

Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in this class.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static CinemachineFreeLookCreateRigDelegate CreateRigOverride
var Cinemachine.CinemachineFreeLook.CreateRigOverride

Field Value

Type: CinemachineFreeLookCreateRigDelegate
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.DestroyRigOverride Field

CinemachineFreeLookDestroyRigOverride Field

Override component pipeline destruction. This needs to be done by the editor to support Undo.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static CinemachineFreeLookDestroyRigDelegate DestroyRigOverride
var Cinemachine.CinemachineFreeLook.DestroyRigOverride

Field Value

Type: CinemachineFreeLookDestroyRigDelegate
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_BindingMode Field

CinemachineFreeLookm_BindingMode Field

The coordinate space to use when interpreting the offset from the target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HeaderAttribute("Orbits")]
[TooltipAttribute("The coordinate space to use when interpreting the offset from the target.  This is also used to set the camera's Up vector, which will be maintained when aiming the camera.")]
public CinemachineTransposerBindingMode m_BindingMode
var m_BindingMode

Field Value

Type: CinemachineTransposerBindingMode
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_CommonLens Field

CinemachineFreeLookm_CommonLens Field

If enabled, this lens setting will apply to all three child rigs, otherwise the child rig lens settings will be used

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If enabled, this lens setting will apply to all three child rigs, otherwise the child rig lens settings will be used")]
[FormerlySerializedAsAttribute("m_UseCommonLensSetting")]
public bool m_CommonLens
var m_CommonLens

Field Value

Type: Boolean
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_Follow Field

CinemachineFreeLookm_Follow Field

Object for the camera children wants to move with (the body target)

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Object for the camera children wants to move with (the body target).")]
[NoSaveDuringPlayAttribute]
public Transform m_Follow
var m_Follow

Field Value

Type: Transform
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_Heading Field

CinemachineFreeLookm_Heading Field

The definition of Forward. Camera will follow behind

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The definition of Forward.  Camera will follow behind.")]
public CinemachineOrbitalTransposerHeading m_Heading
var m_Heading

Field Value

Type: CinemachineOrbitalTransposerHeading
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_Lens Field

CinemachineFreeLookm_Lens Field

Specifies the lens properties of this Virtual Camera. This generally mirrors the Unity Camera's lens settings, and will be used to drive the Unity camera when the vcam is active

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[FormerlySerializedAsAttribute("m_LensAttributes")]
[TooltipAttribute("Specifies the lens properties of this Virtual Camera.  This generally mirrors the Unity Camera's lens settings, and will be used to drive the Unity camera when the vcam is active")]
[LensSettingsPropertyAttribute]
public LensSettings m_Lens
var m_Lens

Field Value

Type: LensSettings
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_LookAt Field

CinemachineFreeLookm_LookAt Field

Object for the camera children to look at (the aim target)

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Object for the camera children to look at (the aim target).")]
[NoSaveDuringPlayAttribute]
public Transform m_LookAt
var m_LookAt

Field Value

Type: Transform
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_Orbits Field

CinemachineFreeLookm_Orbits Field

The radius and height of the three orbiting rigs

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The radius and height of the three orbiting rigs.")]
public CinemachineFreeLookOrbit[] m_Orbits
var m_Orbits

Field Value

Type: CinemachineFreeLookOrbit
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_RecenterToTargetHeading Field

CinemachineFreeLookm_RecenterToTargetHeading Field

Controls how automatic recentering of the X axis is accomplished

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Controls how automatic recentering of the X axis is accomplished")]
public CinemachineOrbitalTransposerRecentering m_RecenterToTargetHeading
var m_RecenterToTargetHeading

Field Value

Type: CinemachineOrbitalTransposerRecentering
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_SplineCurvature Field

CinemachineFreeLookm_SplineCurvature Field

[Missing <summary> documentation for "F:Cinemachine.CinemachineFreeLook.m_SplineCurvature"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Controls how taut is the line that connects the rigs' orbits, which determines final placement on the Y axis")]
[RangeAttribute(0f, 1f)]
[FormerlySerializedAsAttribute("m_SplineTension")]
public float m_SplineCurvature
var m_SplineCurvature

Field Value

Type: Single
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_XAxis Field

CinemachineFreeLookm_XAxis Field

The Horizontal axis. Value is 0..359. This is passed on to the rigs' OrbitalTransposer component

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The Horizontal axis.  Value is 0..359.  This is passed on to the rigs' OrbitalTransposer component")]
public AxisState m_XAxis
var m_XAxis

Field Value

Type: AxisState
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.m_YAxis Field

CinemachineFreeLookm_YAxis Field

The Vertical axis. Value is 0..1. Chooses how to blend the child rigs

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HeaderAttribute("Axis Control")]
[TooltipAttribute("The Vertical axis.  Value is 0..1.  Chooses how to blend the child rigs")]
public AxisState m_YAxis
var m_YAxis

Field Value

Type: AxisState
See Also

Reference

CinemachineFreeLook Class


CinemachineFreeLook.CreateRigDelegate Delegate

CinemachineFreeLookCreateRigDelegate Delegate

Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in this class.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public delegate CinemachineVirtualCamera CreateRigDelegate(
    CinemachineFreeLook vcam,
    string name,
    CinemachineVirtualCamera copyFrom
)
function(vcam, name, copyFrom);

Parameters

vcam
Type: CinemachineCinemachineFreeLook
name
Type: SystemString
copyFrom
Type: CinemachineCinemachineVirtualCamera

Return Value

Type: CinemachineVirtualCamera
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineFreeLook.DestroyRigDelegate Delegate

CinemachineFreeLookDestroyRigDelegate Delegate

Override component pipeline destruction. This needs to be done by the editor to support Undo.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public delegate void DestroyRigDelegate(
    GameObject rig
)
function(rig);

Parameters

rig
Type: GameObject
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineFreeLook.Orbit Structure

CinemachineFreeLookOrbit Structure

Defines the height and radius of the Rig orbit

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
public struct Orbit
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineFreeLookOrbit type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineFreeLookOrbit | Constructor with specific values
Top
Fields
 | Name | Description
Public field | m_Height | Height relative to target
Public field | m_Radius | Radius of orbit
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineFreeLook.Orbit Constructor

CinemachineFreeLookOrbit Constructor

Constructor with specific values

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Orbit(
    float h,
    float r
)
Cinemachine.Orbit = function(h, r);

Parameters

h
Type: SystemSingle

[Missing <param name="h"/> documentation for "M:Cinemachine.CinemachineFreeLook.Orbit.#ctor(System.Single,System.Single)"]

r
Type: SystemSingle

[Missing <param name="r"/> documentation for "M:Cinemachine.CinemachineFreeLook.Orbit.#ctor(System.Single,System.Single)"]

See Also

Reference

CinemachineFreeLookOrbit Structure


Orbit Fields

The CinemachineFreeLookOrbit type exposes the following members.

Fields
 | Name | Description
Public field | m_Height | Height relative to target
Public field | m_Radius | Radius of orbit
Top
See Also

Reference

CinemachineFreeLookOrbit Structure


CinemachineFreeLook.Orbit.m_Height Field

CinemachineFreeLookOrbitm_Height Field

Height relative to target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float m_Height
var m_Height

Field Value

Type: Single
See Also

Reference

CinemachineFreeLookOrbit Structure


CinemachineFreeLook.Orbit.m_Radius Field

CinemachineFreeLookOrbitm_Radius Field

Radius of orbit

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float m_Radius
var m_Radius

Field Value

Type: Single
See Also

Reference

CinemachineFreeLookOrbit Structure


CinemachineGroupComposer Class

This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to aim the camera at a target object, with configurable offsets, damping, and composition rules. In addition, if the target is a CinemachineTargetGroup, the behaviour will adjust the FOV and the camera distance to ensure that the entire group of targets is framed properly.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineComposer
CinemachineCinemachineGroupComposer

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(4f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineGroupComposer : CinemachineComposer
Cinemachine.CinemachineGroupComposer = function();

Type.createClass(
    'Cinemachine.CinemachineGroupComposer',
    Cinemachine.CinemachineComposer);

The CinemachineGroupComposer type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineGroupComposer |
Top
Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | HardGuideRect | Internal API for the inspector editor (Inherited from CinemachineComposer.)
Public property | IsValid | True if component is enabled and has a LookAt defined (Inherited from CinemachineComposer.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | m_LastBounds | For editor visulaization of the calculated bounding box of the group
Public property | m_lastBoundsMatrix | For editor visualization of the calculated bounding box of the group
Public property | SoftGuideRect | Internal API for the inspector editor (Inherited from CinemachineComposer.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Inherited from CinemachineComposer.)
Public property | TargetGroup | Get LookAt target as CinemachineTargetGroup, or null if target is not a group
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Protected method | GetTrackedPoint | Apply the target offsets to the target location. (Inherited from CinemachineComposer.)
Public method | MutateCameraState | Applies the composer rules and orients the camera accordingly (Overrides CinemachineComposerMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
Fields
 | Name | Description
Public field | m_AdjustmentMode | How to adjust the camera to get the desired framing
Public field | m_BiasX | A non-zero bias will move the targt position away from the center of the soft zone (Inherited from CinemachineComposer.)
Public field | m_BiasY | A non-zero bias will move the targt position away from the center of the soft zone (Inherited from CinemachineComposer.)
Public field | m_DeadZoneHeight | Camera will not rotate vertically if the target is within this range of the position (Inherited from CinemachineComposer.)
Public field | m_DeadZoneWidth | Camera will not rotate horizontally if the target is within this range of the position (Inherited from CinemachineComposer.)
Public field | m_FrameDamping | How aggressively the camera tries to frame the group. Small numbers are more responsive
Public field | m_FramingMode | What screen dimensions to consider when framing
Public field | m_GroupFramingSize | How much of the screen to fill with the bounding box of the targets.
Public field | m_HorizontalDamping | How aggressively the camera tries to follow the target in the screen-horizontal direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors. (Inherited from CinemachineComposer.)
Public field | m_LookaheadSmoothing | Controls the smoothness of the lookahead algorithm. Larger values smooth out jittery predictions and also increase prediction lag (Inherited from CinemachineComposer.)
Public field | m_LookaheadTime | This setting will instruct the composer to adjust its target offset based on the motion of the target. The composer will look at a point where it estimates the target will be this many seconds into the future. Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter. If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly. (Inherited from CinemachineComposer.)
Public field | m_MaxDollyIn | How much closer to the target can the camera go?
Public field | m_MaxDollyOut | How much farther from the target can the camera go?
Public field | m_MaximumDistance | Set this to limit how far from the taregt the camera can get
Public field | m_MaximumFOV | If adjusting FOV, will not set the FOV higher than this
Public field | m_MaximumOrthoSize | If adjusting Orthographic Size, will not set it higher than this
Public field | m_MinimumDistance | Set this to limit how close to the target the camera can get
Public field | m_MinimumFOV | If adjusting FOV, will not set the FOV lower than this
Public field | m_MinimumOrthoSize | If adjusting Orthographic Size, will not set it lower than this
Public field | m_ScreenX | Horizontal screen position for target. The camera will rotate to the position the tracked object here (Inherited from CinemachineComposer.)
Public field | m_ScreenY | Vertical screen position for target, The camera will rotate to to position the tracked object here (Inherited from CinemachineComposer.)
Public field | m_SoftZoneHeight | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed (Inherited from CinemachineComposer.)
Public field | m_SoftZoneWidth | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed (Inherited from CinemachineComposer.)
Public field | m_TrackedObjectOffset | Target offset from the object's center in LOCAL space which the Composer tracks. Use this to fine-tune the tracking target position when the desired area is not in the tracked object's center (Inherited from CinemachineComposer.)
Public field | m_VerticalDamping | How aggressively the camera tries to follow the target in the screen-vertical direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors. (Inherited from CinemachineComposer.)
Public field | OnGUICallback | Used by the Inspector Editor to display on-screen guides. (Inherited from CinemachineComposer.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineGroupComposer Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineGroupComposer.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineGroupComposer()
Cinemachine.CinemachineGroupComposer = function();
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer Properties

The CinemachineGroupComposer type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | HardGuideRect | Internal API for the inspector editor (Inherited from CinemachineComposer.)
Public property | IsValid | True if component is enabled and has a LookAt defined (Inherited from CinemachineComposer.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | m_LastBounds | For editor visulaization of the calculated bounding box of the group
Public property | m_lastBoundsMatrix | For editor visualization of the calculated bounding box of the group
Public property | SoftGuideRect | Internal API for the inspector editor (Inherited from CinemachineComposer.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Inherited from CinemachineComposer.)
Public property | TargetGroup | Get LookAt target as CinemachineTargetGroup, or null if target is not a group
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_LastBounds Property

CinemachineGroupComposerm_LastBounds Property

For editor visulaization of the calculated bounding box of the group

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Bounds m_LastBounds { get; }
function get_m_LastBounds();

Property Value

Type: Bounds
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_lastBoundsMatrix Property

CinemachineGroupComposerm_lastBoundsMatrix Property

For editor visualization of the calculated bounding box of the group

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Matrix4x4 m_lastBoundsMatrix { get; }
function get_m_lastBoundsMatrix();

Property Value

Type: Matrix4x4
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.TargetGroup Property

CinemachineGroupComposerTargetGroup Property

Get LookAt target as CinemachineTargetGroup, or null if target is not a group

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineTargetGroup TargetGroup { get; }
function get_TargetGroup();

Property Value

Type: CinemachineTargetGroup
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer Methods

The CinemachineGroupComposer type exposes the following members.

Methods
 | Name | Description
Protected method | GetTrackedPoint | Apply the target offsets to the target location. (Inherited from CinemachineComposer.)
Public method | MutateCameraState | Applies the composer rules and orients the camera accordingly (Overrides CinemachineComposerMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.MutateCameraState Method

CinemachineGroupComposerMutateCameraState Method

Applies the composer rules and orients the camera accordingly

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState

[Missing <param name="curState"/> documentation for "M:Cinemachine.CinemachineGroupComposer.MutateCameraState(Cinemachine.CameraState@,System.Single)"]

deltaTime
Type: SystemSingle
Used for calculating damping. If less than zero, then target will snap to the center of the dead zone.
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer Fields

The CinemachineGroupComposer type exposes the following members.

Fields
 | Name | Description
Public field | m_AdjustmentMode | How to adjust the camera to get the desired framing
Public field | m_BiasX | A non-zero bias will move the targt position away from the center of the soft zone (Inherited from CinemachineComposer.)
Public field | m_BiasY | A non-zero bias will move the targt position away from the center of the soft zone (Inherited from CinemachineComposer.)
Public field | m_DeadZoneHeight | Camera will not rotate vertically if the target is within this range of the position (Inherited from CinemachineComposer.)
Public field | m_DeadZoneWidth | Camera will not rotate horizontally if the target is within this range of the position (Inherited from CinemachineComposer.)
Public field | m_FrameDamping | How aggressively the camera tries to frame the group. Small numbers are more responsive
Public field | m_FramingMode | What screen dimensions to consider when framing
Public field | m_GroupFramingSize | How much of the screen to fill with the bounding box of the targets.
Public field | m_HorizontalDamping | How aggressively the camera tries to follow the target in the screen-horizontal direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors. (Inherited from CinemachineComposer.)
Public field | m_LookaheadSmoothing | Controls the smoothness of the lookahead algorithm. Larger values smooth out jittery predictions and also increase prediction lag (Inherited from CinemachineComposer.)
Public field | m_LookaheadTime | This setting will instruct the composer to adjust its target offset based on the motion of the target. The composer will look at a point where it estimates the target will be this many seconds into the future. Note that this setting is sensitive to noisy animation, and can amplify the noise, resulting in undesirable camera jitter. If the camera jitters unacceptably when the target is in motion, turn down this setting, or animate the target more smoothly. (Inherited from CinemachineComposer.)
Public field | m_MaxDollyIn | How much closer to the target can the camera go?
Public field | m_MaxDollyOut | How much farther from the target can the camera go?
Public field | m_MaximumDistance | Set this to limit how far from the taregt the camera can get
Public field | m_MaximumFOV | If adjusting FOV, will not set the FOV higher than this
Public field | m_MaximumOrthoSize | If adjusting Orthographic Size, will not set it higher than this
Public field | m_MinimumDistance | Set this to limit how close to the target the camera can get
Public field | m_MinimumFOV | If adjusting FOV, will not set the FOV lower than this
Public field | m_MinimumOrthoSize | If adjusting Orthographic Size, will not set it lower than this
Public field | m_ScreenX | Horizontal screen position for target. The camera will rotate to the position the tracked object here (Inherited from CinemachineComposer.)
Public field | m_ScreenY | Vertical screen position for target, The camera will rotate to to position the tracked object here (Inherited from CinemachineComposer.)
Public field | m_SoftZoneHeight | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed (Inherited from CinemachineComposer.)
Public field | m_SoftZoneWidth | When target is within this region, camera will gradually move to re-align towards the desired position, depending onm the damping speed (Inherited from CinemachineComposer.)
Public field | m_TrackedObjectOffset | Target offset from the object's center in LOCAL space which the Composer tracks. Use this to fine-tune the tracking target position when the desired area is not in the tracked object's center (Inherited from CinemachineComposer.)
Public field | m_VerticalDamping | How aggressively the camera tries to follow the target in the screen-vertical direction. Small numbers are more responsive, rapidly orienting the camera to keep the target in the dead zone. Larger numbers give a more heavy slowly responding camera. Using different vertical and horizontal settings can yield a wide range of camera behaviors. (Inherited from CinemachineComposer.)
Public field | OnGUICallback | Used by the Inspector Editor to display on-screen guides. (Inherited from CinemachineComposer.)
Top
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_AdjustmentMode Field

CinemachineGroupComposerm_AdjustmentMode Field

How to adjust the camera to get the desired framing

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How to adjust the camera to get the desired framing.  You can zoom, dolly in/out, or do both.")]
public CinemachineGroupComposerAdjustmentMode m_AdjustmentMode
var m_AdjustmentMode

Field Value

Type: CinemachineGroupComposerAdjustmentMode
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_FrameDamping Field

CinemachineGroupComposerm_FrameDamping Field

How aggressively the camera tries to frame the group. Small numbers are more responsive

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to frame the group. Small numbers are more responsive, rapidly adjusting the camera to keep the group in the frame.  Larger numbers give a more heavy slowly responding camera.")]
public float m_FrameDamping
var m_FrameDamping

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_FramingMode Field

CinemachineGroupComposerm_FramingMode Field

What screen dimensions to consider when framing

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("What screen dimensions to consider when framing.  Can be Horizontal, Vertical, or both")]
public CinemachineGroupComposerFramingMode m_FramingMode
var m_FramingMode

Field Value

Type: CinemachineGroupComposerFramingMode
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_GroupFramingSize Field

CinemachineGroupComposerm_GroupFramingSize Field

How much of the screen to fill with the bounding box of the targets.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[TooltipAttribute("The bounding box of the targets should occupy this amount of the screen space.  1 means fill the whole screen.  0.5 means fill half the screen, etc.")]
public float m_GroupFramingSize
var m_GroupFramingSize

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_MaxDollyIn Field

CinemachineGroupComposerm_MaxDollyIn Field

How much closer to the target can the camera go?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The maximum distance toward the target that this behaviour is allowed to move the camera.")]
public float m_MaxDollyIn
var m_MaxDollyIn

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_MaxDollyOut Field

CinemachineGroupComposerm_MaxDollyOut Field

How much farther from the target can the camera go?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The maximum distance away the target that this behaviour is allowed to move the camera.")]
public float m_MaxDollyOut
var m_MaxDollyOut

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_MaximumDistance Field

CinemachineGroupComposerm_MaximumDistance Field

Set this to limit how far from the taregt the camera can get

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Set this to limit how far from the target the camera can get.")]
public float m_MaximumDistance
var m_MaximumDistance

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_MaximumFOV Field

CinemachineGroupComposerm_MaximumFOV Field

If adjusting FOV, will not set the FOV higher than this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(1f, 179f)]
[TooltipAttribute("If adjusting FOV, will not set the FOV higher than this.")]
public float m_MaximumFOV
var m_MaximumFOV

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_MaximumOrthoSize Field

CinemachineGroupComposerm_MaximumOrthoSize Field

If adjusting Orthographic Size, will not set it higher than this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If adjusting Orthographic Size, will not set it higher than this.")]
public float m_MaximumOrthoSize
var m_MaximumOrthoSize

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_MinimumDistance Field

CinemachineGroupComposerm_MinimumDistance Field

Set this to limit how close to the target the camera can get

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Set this to limit how close to the target the camera can get.")]
public float m_MinimumDistance
var m_MinimumDistance

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_MinimumFOV Field

CinemachineGroupComposerm_MinimumFOV Field

If adjusting FOV, will not set the FOV lower than this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(1f, 179f)]
[TooltipAttribute("If adjusting FOV, will not set the FOV lower than this.")]
public float m_MinimumFOV
var m_MinimumFOV

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.m_MinimumOrthoSize Field

CinemachineGroupComposerm_MinimumOrthoSize Field

If adjusting Orthographic Size, will not set it lower than this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If adjusting Orthographic Size, will not set it lower than this.")]
public float m_MinimumOrthoSize
var m_MinimumOrthoSize

Field Value

Type: Single
See Also

Reference

CinemachineGroupComposer Class


CinemachineGroupComposer.AdjustmentMode Enumeration

CinemachineGroupComposerAdjustmentMode Enumeration

How to adjust the camera to get the desired framing

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum AdjustmentMode
Cinemachine.AdjustmentMode = function();
Cinemachine.AdjustmentMode.createEnum('Cinemachine.AdjustmentMode', false);
Members
Member name | Value | Description
ZoomOnly | 0 | Do not move the camera, only adjust the FOV.
DollyOnly | 1 | Just move the camera, don't change the FOV.
DollyThenZoom | 2 | Move the camera as much as permitted by the ranges, then adjust the FOV if necessary to make the shot.
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineGroupComposer.FramingMode Enumeration

CinemachineGroupComposerFramingMode Enumeration

What screen dimensions to consider when framing

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(4.01f, DocumentationSortingAttributeLevel.UserRef)]
public enum FramingMode
Cinemachine.FramingMode = function();
Cinemachine.FramingMode.createEnum('Cinemachine.FramingMode', false);
Members
Member name | Value | Description
Horizontal | 0 | Consider only the horizontal dimension. Vertical framing is ignored.
Vertical | 1 | Consider only the vertical dimension. Horizontal framing is ignored.
HorizontalAndVertical | 2 | The larger of the horizontal and vertical dimensions will dominate, to get the best fit.
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineHardLockToTarget Class

This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to place the camera on the Follow Target.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineHardLockToTarget

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(23f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineHardLockToTarget : CinemachineComponentBase
Cinemachine.CinemachineHardLockToTarget = function();

Type.createClass(
    'Cinemachine.CinemachineHardLockToTarget',
    Cinemachine.CinemachineComponentBase);

The CinemachineHardLockToTarget type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineHardLockToTarget |
Top
Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a LookAt defined (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Public method | MutateCameraState | Applies the composer rules and orients the camera accordingly (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineHardLockToTarget Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineHardLockToTarget.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineHardLockToTarget()
Cinemachine.CinemachineHardLockToTarget = function();
See Also

Reference

CinemachineHardLockToTarget Class


CinemachineHardLockToTarget Properties

The CinemachineHardLockToTarget type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a LookAt defined (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineHardLockToTarget Class


CinemachineHardLockToTarget.IsValid Property

CinemachineHardLockToTargetIsValid Property

True if component is enabled and has a LookAt defined

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineHardLockToTarget Class


CinemachineHardLockToTarget.Stage Property

CinemachineHardLockToTargetStage Property

Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineHardLockToTarget Class


CinemachineHardLockToTarget Methods

The CinemachineHardLockToTarget type exposes the following members.

Methods
 | Name | Description
Public method | MutateCameraState | Applies the composer rules and orients the camera accordingly (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineHardLockToTarget Class


CinemachineHardLockToTarget.MutateCameraState Method

CinemachineHardLockToTargetMutateCameraState Method

Applies the composer rules and orients the camera accordingly

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
Used for calculating damping. If less than zero, then target will snap to the center of the dead zone.
See Also

Reference

CinemachineHardLockToTarget Class


CinemachineHardLookAt Class

This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to aim the camera hard at the LookAt target.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineHardLookAt

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(23f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineHardLookAt : CinemachineComponentBase
Cinemachine.CinemachineHardLookAt = function();

Type.createClass(
    'Cinemachine.CinemachineHardLookAt',
    Cinemachine.CinemachineComponentBase);

The CinemachineHardLookAt type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineHardLookAt |
Top
Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a LookAt defined (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Public method | MutateCameraState | Applies the composer rules and orients the camera accordingly (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineHardLookAt Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineHardLookAt.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineHardLookAt()
Cinemachine.CinemachineHardLookAt = function();
See Also

Reference

CinemachineHardLookAt Class


CinemachineHardLookAt Properties

The CinemachineHardLookAt type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a LookAt defined (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineHardLookAt Class


CinemachineHardLookAt.IsValid Property

CinemachineHardLookAtIsValid Property

True if component is enabled and has a LookAt defined

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineHardLookAt Class


CinemachineHardLookAt.Stage Property

CinemachineHardLookAtStage Property

Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineHardLookAt Class


CinemachineHardLookAt Methods

The CinemachineHardLookAt type exposes the following members.

Methods
 | Name | Description
Public method | MutateCameraState | Applies the composer rules and orients the camera accordingly (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineHardLookAt Class


CinemachineHardLookAt.MutateCameraState Method

CinemachineHardLookAtMutateCameraState Method

Applies the composer rules and orients the camera accordingly

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
Used for calculating damping. If less than zero, then target will snap to the center of the dead zone.
See Also

Reference

CinemachineHardLookAt Class


CinemachineMixingCamera Class

CinemachineMixingCamera is a "manager camera" that takes on the state of the weighted average of the states of its child virtual cameras. A fixed number of slots are made available for cameras, rather than a dynamic array. We do it this way in order to support weight animation from the Timeline. Timeline cannot animate array elements.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
CinemachineCinemachineMixingCamera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(20f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[DisallowMultipleComponent]
[AddComponentMenu("Cinemachine/CinemachineMixingCamera")]
public class CinemachineMixingCamera : CinemachineVirtualCameraBase
Cinemachine.CinemachineMixingCamera = function();

Type.createClass(
    'Cinemachine.CinemachineMixingCamera',
    Cinemachine.CinemachineVirtualCameraBase);

The CinemachineMixingCamera type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineMixingCamera |
Top
Properties
 | Name | Description
Public property | ChildCameras | Get the cached list of child cameras. These are just the immediate children in the hierarchy. Note: only the first entries of this list participate in the final blend, up to MaxCameras
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Inherited from CinemachineVirtualCameraBase.)
Public property | Follow | Not used (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | LiveChildOrSelf | Return the live child. (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Not used (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The blended CameraState (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Public method | GetWeight(Int32) | Get the weight of the child at an index.
Public method | GetWeight(CinemachineVirtualCameraBase) | Get the weight of the child CinemachineVirtualCameraBase.
Protected method | InvalidateListOfChildren | Invalidate the cached list of child cameras.
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Makes sure the internal child cache is up to date (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnTransformChildrenChanged | Makes sure the internal child cache is up to date
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnValidate | Makes sure the weights are non-negative (Overrides CinemachineVirtualCameraBaseOnValidate.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Public method | SetWeight(Int32, Single) | Set the weight of the child at an index.
Public method | SetWeight(CinemachineVirtualCameraBase, Single) | Set the weight of the child CinemachineVirtualCameraBase.
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation computes and caches the weighted blend of the tracked cameras. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Protected method | ValidateListOfChildren | Rebuild the cached list of child cameras.
Top
Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Weight0 | Weight of the first tracked camera
Public field | m_Weight1 | Weight of the second tracked camera
Public field | m_Weight2 | Weight of the third tracked camera
Public field | m_Weight3 | Weight of the fourth tracked camera
Public field | m_Weight4 | Weight of the fifth tracked camera
Public field | m_Weight5 | Weight of the sixth tracked camera
Public field | m_Weight6 | Weight of the seventh tracked camera
Public field | m_Weight7 | Weight of the eighth tracked camera
 | MaxCameras | The maximum number of tracked cameras. If you want to add more cameras, do it here in the source code, and be sure to add the extra member variables and to make the appropriate changes in GetWeight() and SetWeight(). The inspector will figure itself out based on this value.
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineMixingCamera Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineMixingCamera.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineMixingCamera()
Cinemachine.CinemachineMixingCamera = function();
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera Properties

The CinemachineMixingCamera type exposes the following members.

Properties
 | Name | Description
Public property | ChildCameras | Get the cached list of child cameras. These are just the immediate children in the hierarchy. Note: only the first entries of this list participate in the final blend, up to MaxCameras
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Inherited from CinemachineVirtualCameraBase.)
Public property | Follow | Not used (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | LiveChildOrSelf | Return the live child. (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Not used (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The blended CameraState (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.ChildCameras Property

CinemachineMixingCameraChildCameras Property

Get the cached list of child cameras. These are just the immediate children in the hierarchy. Note: only the first entries of this list participate in the final blend, up to MaxCameras

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineVirtualCameraBase[] ChildCameras { get; }
function get_ChildCameras();

Property Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.Follow Property

CinemachineMixingCameraFollow Property

Not used

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform

Implements

ICinemachineCameraFollow
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.LiveChildOrSelf Property

CinemachineMixingCameraLiveChildOrSelf Property

Return the live child.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override ICinemachineCamera LiveChildOrSelf { get; }
function get_LiveChildOrSelf();

Property Value

Type: ICinemachineCamera

Implements

ICinemachineCameraLiveChildOrSelf
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.LookAt Property

CinemachineMixingCameraLookAt Property

Not used

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform

Implements

ICinemachineCameraLookAt
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.State Property

CinemachineMixingCameraState Property

The blended CameraState

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CameraState State { get; }
function get_State();

Property Value

Type: CameraState

Implements

ICinemachineCameraState
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera Methods

The CinemachineMixingCamera type exposes the following members.

Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Public method | GetWeight(Int32) | Get the weight of the child at an index.
Public method | GetWeight(CinemachineVirtualCameraBase) | Get the weight of the child CinemachineVirtualCameraBase.
Protected method | InvalidateListOfChildren | Invalidate the cached list of child cameras.
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Makes sure the internal child cache is up to date (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnTransformChildrenChanged | Makes sure the internal child cache is up to date
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnValidate | Makes sure the weights are non-negative (Overrides CinemachineVirtualCameraBaseOnValidate.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Public method | SetWeight(Int32, Single) | Set the weight of the child at an index.
Public method | SetWeight(CinemachineVirtualCameraBase, Single) | Set the weight of the child CinemachineVirtualCameraBase.
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation computes and caches the weighted blend of the tracked cameras. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Protected method | ValidateListOfChildren | Rebuild the cached list of child cameras.
Top
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.GetWeight Method

CinemachineMixingCameraGetWeight Method

Overload List
 | Name | Description
Public method | GetWeight(Int32) | Get the weight of the child at an index.
Public method | GetWeight(CinemachineVirtualCameraBase) | Get the weight of the child CinemachineVirtualCameraBase.
Top
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.GetWeight Method (Int32)

CinemachineMixingCameraGetWeight Method (Int32)

Get the weight of the child at an index.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float GetWeight(
    int index
)
function GetWeight(index);

Parameters

index
Type: SystemInt32
The child index. Only immediate CinemachineVirtualCameraBase children are counted.

Return Value

Type: Single
The weight of the camera. Valid only if camera is active and enabled.
See Also

Reference

CinemachineMixingCamera Class
GetWeight Overload


CinemachineMixingCamera.GetWeight Method (CinemachineVirtualCameraBase)

CinemachineMixingCameraGetWeight Method (CinemachineVirtualCameraBase)

Get the weight of the child CinemachineVirtualCameraBase.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float GetWeight(
    CinemachineVirtualCameraBase vcam
)
function GetWeight(vcam);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase
The child camera.

Return Value

Type: Single
The weight of the camera. Valid only if camera is active and enabled.
See Also

Reference

CinemachineMixingCamera Class
GetWeight Overload


CinemachineMixingCamera.InvalidateListOfChildren Method

CinemachineMixingCameraInvalidateListOfChildren Method

Invalidate the cached list of child cameras.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected void InvalidateListOfChildren()
function InvalidateListOfChildren();
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.IsLiveChild Method

CinemachineMixingCameraIsLiveChild Method

Check whether the vcam a live child of this camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsLiveChild(
    ICinemachineCamera vcam
)
function IsLiveChild(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The Virtual Camera to check

Return Value

Type: Boolean
True if the vcam is currently actively influencing the state of this vcam

Implements

ICinemachineCameraIsLiveChild(ICinemachineCamera)
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.OnEnable Method

CinemachineMixingCameraOnEnable Method

Makes sure the internal child cache is up to date

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnEnable()
function OnEnable();
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.OnTransformChildrenChanged Method

CinemachineMixingCameraOnTransformChildrenChanged Method

Makes sure the internal child cache is up to date

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void OnTransformChildrenChanged()
function OnTransformChildrenChanged();
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.OnValidate Method

CinemachineMixingCameraOnValidate Method

Makes sure the weights are non-negative

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnValidate()
function OnValidate();
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.RemovePostPipelineStageHook Method

CinemachineMixingCameraRemovePostPipelineStageHook Method

Remove a Pipeline stage hook callback. Make sure it is removed from all the children.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void RemovePostPipelineStageHook(
    CinemachineVirtualCameraBaseOnPostPipelineStageDelegate d
)
function RemovePostPipelineStageHook(d);

Parameters

d
Type: CinemachineCinemachineVirtualCameraBaseOnPostPipelineStageDelegate
The delegate to remove.
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.SetWeight Method

CinemachineMixingCameraSetWeight Method

Overload List
 | Name | Description
Public method | SetWeight(Int32, Single) | Set the weight of the child at an index.
Public method | SetWeight(CinemachineVirtualCameraBase, Single) | Set the weight of the child CinemachineVirtualCameraBase.
Top
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.SetWeight Method (Int32, Single)

CinemachineMixingCameraSetWeight Method (Int32, Single)

Set the weight of the child at an index.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void SetWeight(
    int index,
    float w
)
function SetWeight(index, w);

Parameters

index
Type: SystemInt32
The child index. Only immediate CinemachineVirtualCameraBase children are counted.
w
Type: SystemSingle
The weight to set. Can be any non-negative number.
See Also

Reference

CinemachineMixingCamera Class
SetWeight Overload


CinemachineMixingCamera.SetWeight Method (CinemachineVirtualCameraBase, Single)

CinemachineMixingCameraSetWeight Method (CinemachineVirtualCameraBase, Single)

Set the weight of the child CinemachineVirtualCameraBase.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void SetWeight(
    CinemachineVirtualCameraBase vcam,
    float w
)
function SetWeight(vcam, w);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase
The child camera.
w
Type: SystemSingle
The weight to set. Can be any non-negative number.
See Also

Reference

CinemachineMixingCamera Class
SetWeight Overload


CinemachineMixingCamera.UpdateCameraState Method

CinemachineMixingCameraUpdateCameraState Method

Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation computes and caches the weighted blend of the tracked cameras.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)

Implements

ICinemachineCameraUpdateCameraState(Vector3, Single)
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.ValidateListOfChildren Method

CinemachineMixingCameraValidateListOfChildren Method

Rebuild the cached list of child cameras.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected void ValidateListOfChildren()
function ValidateListOfChildren();
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera Fields

The CinemachineMixingCamera type exposes the following members.

Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Weight0 | Weight of the first tracked camera
Public field | m_Weight1 | Weight of the second tracked camera
Public field | m_Weight2 | Weight of the third tracked camera
Public field | m_Weight3 | Weight of the fourth tracked camera
Public field | m_Weight4 | Weight of the fifth tracked camera
Public field | m_Weight5 | Weight of the sixth tracked camera
Public field | m_Weight6 | Weight of the seventh tracked camera
Public field | m_Weight7 | Weight of the eighth tracked camera
 | MaxCameras | The maximum number of tracked cameras. If you want to add more cameras, do it here in the source code, and be sure to add the extra member variables and to make the appropriate changes in GetWeight() and SetWeight(). The inspector will figure itself out based on this value.
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.m_Weight0 Field

CinemachineMixingCameram_Weight0 Field

Weight of the first tracked camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The weight of the first tracked camera")]
public float m_Weight0
var m_Weight0

Field Value

Type: Single
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.m_Weight1 Field

CinemachineMixingCameram_Weight1 Field

Weight of the second tracked camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The weight of the second tracked camera")]
public float m_Weight1
var m_Weight1

Field Value

Type: Single
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.m_Weight2 Field

CinemachineMixingCameram_Weight2 Field

Weight of the third tracked camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The weight of the third tracked camera")]
public float m_Weight2
var m_Weight2

Field Value

Type: Single
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.m_Weight3 Field

CinemachineMixingCameram_Weight3 Field

Weight of the fourth tracked camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The weight of the fourth tracked camera")]
public float m_Weight3
var m_Weight3

Field Value

Type: Single
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.m_Weight4 Field

CinemachineMixingCameram_Weight4 Field

Weight of the fifth tracked camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The weight of the fifth tracked camera")]
public float m_Weight4
var m_Weight4

Field Value

Type: Single
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.m_Weight5 Field

CinemachineMixingCameram_Weight5 Field

Weight of the sixth tracked camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The weight of the sixth tracked camera")]
public float m_Weight5
var m_Weight5

Field Value

Type: Single
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.m_Weight6 Field

CinemachineMixingCameram_Weight6 Field

Weight of the seventh tracked camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The weight of the seventh tracked camera")]
public float m_Weight6
var m_Weight6

Field Value

Type: Single
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.m_Weight7 Field

CinemachineMixingCameram_Weight7 Field

Weight of the eighth tracked camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The weight of the eighth tracked camera")]
public float m_Weight7
var m_Weight7

Field Value

Type: Single
See Also

Reference

CinemachineMixingCamera Class


CinemachineMixingCamera.MaxCameras Field

CinemachineMixingCameraMaxCameras Field

The maximum number of tracked cameras. If you want to add more cameras, do it here in the source code, and be sure to add the extra member variables and to make the appropriate changes in GetWeight() and SetWeight(). The inspector will figure itself out based on this value.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public const int MaxCameras = 8
var Cinemachine.CinemachineMixingCamera.MaxCameras

Field Value

Type: Int32
See Also

Reference

CinemachineMixingCamera Class


CinemachineOrbitalTransposer Class

This is a CinemachineComponent in the the Body section of the component pipeline. Its job is to position the camera in a variable relationship to a the vcam's Follow target object, with offsets and damping. This component is typically used to implement a camera that follows its target. It can accept player input from an input device, which allows the player to dynamically control the relationship between the camera and the target, for example with a joystick. The OrbitalTransposer introduces the concept of __Heading__, which is the direction in which the target is moving, and the OrbitalTransposer will attempt to position the camera in relationship to the heading, which is by default directly behind the target. You can control the default relationship by adjusting the Heading Bias setting. If you attach an input controller to the OrbitalTransposer, then the player can also control the way the camera positions itself in relation to the target heading. This allows the camera to move to any spot on an orbit around the target.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineTransposer
CinemachineCinemachineOrbitalTransposer

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(6f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineOrbitalTransposer : CinemachineTransposer
Cinemachine.CinemachineOrbitalTransposer = function();

Type.createClass(
    'Cinemachine.CinemachineOrbitalTransposer',
    Cinemachine.CinemachineTransposer);

The CinemachineOrbitalTransposer type exposes the following members.

Properties
 | Name | Description
Protected property | AngularDamping | Damping speeds for each of the 3 axes of the target's rotation (Inherited from CinemachineTransposer.)
Protected property | Damping | Damping speeds for each of the 3 axes of the offset from target (Inherited from CinemachineTransposer.)
Protected property | EffectiveOffset | Get the target offset, with sanitization (Inherited from CinemachineTransposer.)
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a valid Follow target (Inherited from CinemachineTransposer.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage (Inherited from CinemachineTransposer.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Public method | GeTargetCameraPosition | Internal API for the Inspector Editor, so it can draw a marker at the target (Inherited from CinemachineTransposer.)
Public method | GetReferenceOrientation | Internal API for the Inspector Editor, so it can draw a marker at the target (Inherited from CinemachineTransposer.)
Protected method | InitPrevFrameStateInfo | Initializes the state for previous frame if appropriate. (Inherited from CinemachineTransposer.)
Public method | MutateCameraState | Positions the virtual camera according to the transposer rules. (Overrides CinemachineTransposerMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset, after zeroing out local x. (Overrides CinemachineTransposerOnPositionDragged(Vector3).)
Protected method | OnValidate | (Overrides CinemachineTransposerOnValidate.)
Protected method | TrackTarget | Positions the virtual camera according to the transposer rules. (Inherited from CinemachineTransposer.)
Public method | UpdateHeading | When in slave mode, this should be called once and only once every hrame to update the heading. When not in slave mode, this is called automatically.
Top
Fields
 | Name | Description
Public field | m_BindingMode | The coordinate space to use when interpreting the offset from the target (Inherited from CinemachineTransposer.)
Public field | m_FollowOffset | The distance which the transposer will attempt to maintain from the transposer subject (Inherited from CinemachineTransposer.)
Public field | m_Heading | The definition of Forward. Camera will follow behind.
Public field | m_HeadingIsSlave | Drive the x-axis setting programmatically. Automatic heading updating will be disabled.
Public field | m_PitchDamping | How aggressively the camera tries to track the target rotation's X angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera. (Inherited from CinemachineTransposer.)
Public field | m_RecenterToTargetHeading | Parameters that control Automating Heading Recentering
Public field | m_RollDamping | How aggressively the camera tries to track the target rotation's Z angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera. (Inherited from CinemachineTransposer.)
Public field | m_XAxis | Axis representing the current heading. Value is in degrees and represents a rotation about the up vector
Public field | m_XDamping | How aggressively the camera tries to maintain the offset in the X-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors (Inherited from CinemachineTransposer.)
Public field | m_YawDamping | How aggressively the camera tries to track the target rotation's Y angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera. (Inherited from CinemachineTransposer.)
Public field | m_YDamping | How aggressively the camera tries to maintain the offset in the Y-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors (Inherited from CinemachineTransposer.)
Public field | m_ZDamping | How aggressively the camera tries to maintain the offset in the Z-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors (Inherited from CinemachineTransposer.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineOrbitalTransposer Properties

The CinemachineOrbitalTransposer type exposes the following members.

Properties
 | Name | Description
Protected property | AngularDamping | Damping speeds for each of the 3 axes of the target's rotation (Inherited from CinemachineTransposer.)
Protected property | Damping | Damping speeds for each of the 3 axes of the offset from target (Inherited from CinemachineTransposer.)
Protected property | EffectiveOffset | Get the target offset, with sanitization (Inherited from CinemachineTransposer.)
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a valid Follow target (Inherited from CinemachineTransposer.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage (Inherited from CinemachineTransposer.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer Methods

The CinemachineOrbitalTransposer type exposes the following members.

Methods
 | Name | Description
Public method | GeTargetCameraPosition | Internal API for the Inspector Editor, so it can draw a marker at the target (Inherited from CinemachineTransposer.)
Public method | GetReferenceOrientation | Internal API for the Inspector Editor, so it can draw a marker at the target (Inherited from CinemachineTransposer.)
Protected method | InitPrevFrameStateInfo | Initializes the state for previous frame if appropriate. (Inherited from CinemachineTransposer.)
Public method | MutateCameraState | Positions the virtual camera according to the transposer rules. (Overrides CinemachineTransposerMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset, after zeroing out local x. (Overrides CinemachineTransposerOnPositionDragged(Vector3).)
Protected method | OnValidate | (Overrides CinemachineTransposerOnValidate.)
Protected method | TrackTarget | Positions the virtual camera according to the transposer rules. (Inherited from CinemachineTransposer.)
Public method | UpdateHeading | When in slave mode, this should be called once and only once every hrame to update the heading. When not in slave mode, this is called automatically.
Top
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.MutateCameraState Method

CinemachineOrbitalTransposerMutateCameraState Method

Positions the virtual camera according to the transposer rules.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
Used for damping. If less than 0, no damping is done.
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.OnPositionDragged Method

CinemachineOrbitalTransposerOnPositionDragged Method

API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset, after zeroing out local x.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void OnPositionDragged(
    Vector3 delta
)
function OnPositionDragged(delta);

Parameters

delta
Type: Vector3
The amount dragged this frame
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.OnValidate Method

CinemachineOrbitalTransposerOnValidate Method

[Missing <summary> documentation for "M:Cinemachine.CinemachineOrbitalTransposer.OnValidate"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnValidate()
function OnValidate();
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.UpdateHeading Method

CinemachineOrbitalTransposerUpdateHeading Method

When in slave mode, this should be called once and only once every hrame to update the heading. When not in slave mode, this is called automatically.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void UpdateHeading(
    float deltaTime,
    Vector3 up
)
function UpdateHeading(deltaTime, up);

Parameters

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineOrbitalTransposer.UpdateHeading(System.Single,UnityEngine.Vector3)"]

up
Type: Vector3

[Missing <param name="up"/> documentation for "M:Cinemachine.CinemachineOrbitalTransposer.UpdateHeading(System.Single,UnityEngine.Vector3)"]

See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer Fields

The CinemachineOrbitalTransposer type exposes the following members.

Fields
 | Name | Description
Public field | m_BindingMode | The coordinate space to use when interpreting the offset from the target (Inherited from CinemachineTransposer.)
Public field | m_FollowOffset | The distance which the transposer will attempt to maintain from the transposer subject (Inherited from CinemachineTransposer.)
Public field | m_Heading | The definition of Forward. Camera will follow behind.
Public field | m_HeadingIsSlave | Drive the x-axis setting programmatically. Automatic heading updating will be disabled.
Public field | m_PitchDamping | How aggressively the camera tries to track the target rotation's X angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera. (Inherited from CinemachineTransposer.)
Public field | m_RecenterToTargetHeading | Parameters that control Automating Heading Recentering
Public field | m_RollDamping | How aggressively the camera tries to track the target rotation's Z angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera. (Inherited from CinemachineTransposer.)
Public field | m_XAxis | Axis representing the current heading. Value is in degrees and represents a rotation about the up vector
Public field | m_XDamping | How aggressively the camera tries to maintain the offset in the X-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors (Inherited from CinemachineTransposer.)
Public field | m_YawDamping | How aggressively the camera tries to track the target rotation's Y angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera. (Inherited from CinemachineTransposer.)
Public field | m_YDamping | How aggressively the camera tries to maintain the offset in the Y-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors (Inherited from CinemachineTransposer.)
Public field | m_ZDamping | How aggressively the camera tries to maintain the offset in the Z-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors (Inherited from CinemachineTransposer.)
Top
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.m_Heading Field

CinemachineOrbitalTransposerm_Heading Field

The definition of Forward. Camera will follow behind.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[TooltipAttribute("The definition of Forward.  Camera will follow behind.")]
public CinemachineOrbitalTransposerHeading m_Heading
var m_Heading

Field Value

Type: CinemachineOrbitalTransposerHeading
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.m_HeadingIsSlave Field

CinemachineOrbitalTransposerm_HeadingIsSlave Field

Drive the x-axis setting programmatically. Automatic heading updating will be disabled.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HideInInspector]
[NoSaveDuringPlayAttribute]
public bool m_HeadingIsSlave
var m_HeadingIsSlave

Field Value

Type: Boolean
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.m_RecenterToTargetHeading Field

CinemachineOrbitalTransposerm_RecenterToTargetHeading Field

Parameters that control Automating Heading Recentering

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Automatic heading recentering.  The settings here defines how the camera will reposition itself in the absence of player input.")]
public CinemachineOrbitalTransposerRecentering m_RecenterToTargetHeading
var m_RecenterToTargetHeading

Field Value

Type: CinemachineOrbitalTransposerRecentering
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.m_XAxis Field

CinemachineOrbitalTransposerm_XAxis Field

Axis representing the current heading. Value is in degrees and represents a rotation about the up vector

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Heading Control.  The settings here control the behaviour of the camera in response to the player's input.")]
public AxisState m_XAxis
var m_XAxis

Field Value

Type: AxisState
See Also

Reference

CinemachineOrbitalTransposer Class


CinemachineOrbitalTransposer.Heading Structure

CinemachineOrbitalTransposerHeading Structure

How the "forward" direction is defined. Orbital offset is in relation to the forward direction.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(6.2f, DocumentationSortingAttributeLevel.UserRef)]
public struct Heading
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineOrbitalTransposerHeading type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineOrbitalTransposerHeading | Constructor
Top
Fields
 | Name | Description
Public field | m_HeadingBias | Additional Y rotation applied to the target heading. When this value is 0, the camera will be placed behind the target
Public field | m_HeadingDefinition | The method by which the 'default heading' is calculated if recentering to target heading is enabled
Public field | m_VelocityFilterStrength | Size of the velocity sampling window for target heading filter. Used only if deriving heading from target's movement
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineOrbitalTransposer.Heading Constructor

CinemachineOrbitalTransposerHeading Constructor

Constructor

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Heading(
    CinemachineOrbitalTransposerHeadingHeadingDefinition def,
    int filterStrength,
    float bias
)
Cinemachine.Heading = function(def, filterStrength, bias);

Parameters

def
Type: CinemachineCinemachineOrbitalTransposerHeadingHeadingDefinition

[Missing <param name="def"/> documentation for "M:Cinemachine.CinemachineOrbitalTransposer.Heading.#ctor(Cinemachine.CinemachineOrbitalTransposer.Heading.HeadingDefinition,System.Int32,System.Single)"]

filterStrength
Type: SystemInt32

[Missing <param name="filterStrength"/> documentation for "M:Cinemachine.CinemachineOrbitalTransposer.Heading.#ctor(Cinemachine.CinemachineOrbitalTransposer.Heading.HeadingDefinition,System.Int32,System.Single)"]

bias
Type: SystemSingle

[Missing <param name="bias"/> documentation for "M:Cinemachine.CinemachineOrbitalTransposer.Heading.#ctor(Cinemachine.CinemachineOrbitalTransposer.Heading.HeadingDefinition,System.Int32,System.Single)"]

See Also

Reference

CinemachineOrbitalTransposerHeading Structure


Heading Fields

The CinemachineOrbitalTransposerHeading type exposes the following members.

Fields
 | Name | Description
Public field | m_HeadingBias | Additional Y rotation applied to the target heading. When this value is 0, the camera will be placed behind the target
Public field | m_HeadingDefinition | The method by which the 'default heading' is calculated if recentering to target heading is enabled
Public field | m_VelocityFilterStrength | Size of the velocity sampling window for target heading filter. Used only if deriving heading from target's movement
Top
See Also

Reference

CinemachineOrbitalTransposerHeading Structure


CinemachineOrbitalTransposer.Heading.m_HeadingBias Field

CinemachineOrbitalTransposerHeadingm_HeadingBias Field

Additional Y rotation applied to the target heading. When this value is 0, the camera will be placed behind the target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(-180f, 180f)]
[TooltipAttribute("Where the camera is placed when the X-axis value is zero.  This is a rotation in degrees around the Y axis.  When this value is 0, the camera will be placed behind the target.  Nonzero offsets will rotate the zero position around the target.")]
public float m_HeadingBias
var m_HeadingBias

Field Value

Type: Single
See Also

Reference

CinemachineOrbitalTransposerHeading Structure


CinemachineOrbitalTransposer.Heading.m_HeadingDefinition Field

CinemachineOrbitalTransposerHeadingm_HeadingDefinition Field

The method by which the 'default heading' is calculated if recentering to target heading is enabled

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How 'forward' is defined.  The camera will be placed by default behind the target.  PositionDelta will consider 'forward' to be the direction in which the target is moving.")]
public CinemachineOrbitalTransposerHeadingHeadingDefinition m_HeadingDefinition
var m_HeadingDefinition

Field Value

Type: CinemachineOrbitalTransposerHeadingHeadingDefinition
See Also

Reference

CinemachineOrbitalTransposerHeading Structure


CinemachineOrbitalTransposer.Heading.m_VelocityFilterStrength Field

CinemachineOrbitalTransposerHeadingm_VelocityFilterStrength Field

Size of the velocity sampling window for target heading filter. Used only if deriving heading from target's movement

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 10f)]
[TooltipAttribute("Size of the velocity sampling window for target heading filter.  This filters out irregularities in the target's movement.  Used only if deriving heading from target's movement (PositionDelta or Velocity)")]
public int m_VelocityFilterStrength
var m_VelocityFilterStrength

Field Value

Type: Int32
See Also

Reference

CinemachineOrbitalTransposerHeading Structure


CinemachineOrbitalTransposer.Heading.HeadingDefinition Enumeration

CinemachineOrbitalTransposerHeadingHeadingDefinition Enumeration

Sets the algorithm for determining the target's heading for purposes of re-centering the camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(6.21f, DocumentationSortingAttributeLevel.UserRef)]
public enum HeadingDefinition
Cinemachine.HeadingDefinition = function();
Cinemachine.HeadingDefinition.createEnum('Cinemachine.HeadingDefinition', false);
Members
Member name | Value | Description
PositionDelta | 0 | Target heading calculated from the difference between its position on the last update and current frame.
Velocity | 1 | Target heading calculated from its Rigidbody's velocity. If no Rigidbody exists, it will fall back to HeadingDerivationMode.PositionDelta
TargetForward | 2 | Target heading calculated from the Target Transform's euler Y angle
WorldForward | 3 | Default heading is a constant world space heading.
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineOrbitalTransposer.Recentering Structure

CinemachineOrbitalTransposerRecentering Structure

Controls how automatic orbit recentering occurs

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(6.5f, DocumentationSortingAttributeLevel.UserRef)]
public struct Recentering
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineOrbitalTransposerRecentering type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Call this from OnValidate()
Top
Fields
 | Name | Description
Public field | m_enabled | If checked, will enable automatic recentering of the camera based on the heading calculation mode. If FALSE, recenting is disabled.
Public field | m_RecenteringTime | Maximum angular speed of recentering. Will accelerate into and decelerate out of this
Public field | m_RecenterWaitTime | If no input has been detected, the camera will wait this long in seconds before moving its heading to the default heading.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


Recentering Methods

The CinemachineOrbitalTransposerRecentering type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Call this from OnValidate()
Top
See Also

Reference

CinemachineOrbitalTransposerRecentering Structure


CinemachineOrbitalTransposer.Recentering.Validate Method

CinemachineOrbitalTransposerRecenteringValidate Method

Call this from OnValidate()

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void Validate()
function Validate();
See Also

Reference

CinemachineOrbitalTransposerRecentering Structure


Recentering Fields

The CinemachineOrbitalTransposerRecentering type exposes the following members.

Fields
 | Name | Description
Public field | m_enabled | If checked, will enable automatic recentering of the camera based on the heading calculation mode. If FALSE, recenting is disabled.
Public field | m_RecenteringTime | Maximum angular speed of recentering. Will accelerate into and decelerate out of this
Public field | m_RecenterWaitTime | If no input has been detected, the camera will wait this long in seconds before moving its heading to the default heading.
Top
See Also

Reference

CinemachineOrbitalTransposerRecentering Structure


CinemachineOrbitalTransposer.Recentering.m_enabled Field

CinemachineOrbitalTransposerRecenteringm_enabled Field

If checked, will enable automatic recentering of the camera based on the heading calculation mode. If FALSE, recenting is disabled.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If checked, will enable automatic recentering of the camera based on the heading definition. If unchecked, recenting is disabled.")]
public bool m_enabled
var m_enabled

Field Value

Type: Boolean
See Also

Reference

CinemachineOrbitalTransposerRecentering Structure


CinemachineOrbitalTransposer.Recentering.m_RecenteringTime Field

CinemachineOrbitalTransposerRecenteringm_RecenteringTime Field

Maximum angular speed of recentering. Will accelerate into and decelerate out of this

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Maximum angular speed of recentering.  Will accelerate into and decelerate out of this.")]
public float m_RecenteringTime
var m_RecenteringTime

Field Value

Type: Single
See Also

Reference

CinemachineOrbitalTransposerRecentering Structure


CinemachineOrbitalTransposer.Recentering.m_RecenterWaitTime Field

CinemachineOrbitalTransposerRecenteringm_RecenterWaitTime Field

If no input has been detected, the camera will wait this long in seconds before moving its heading to the default heading.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If no input has been detected, the camera will wait this long in seconds before moving its heading to the zero position.")]
public float m_RecenterWaitTime
var m_RecenterWaitTime

Field Value

Type: Single
See Also

Reference

CinemachineOrbitalTransposerRecentering Structure


CinemachinePath Class

Defines a world-space path, consisting of an array of waypoints, each of which has position, tangent, and roll settings. Bezier interpolation is performed between the waypoints, to get a smooth and continuous path.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachinePathBase
CinemachineCinemachinePath

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(18f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("Cinemachine/CinemachinePath")]
[SaveDuringPlayAttribute]
public class CinemachinePath : CinemachinePathBase
Cinemachine.CinemachinePath = function();

Type.createClass(
    'Cinemachine.CinemachinePath',
    Cinemachine.CinemachinePathBase);

The CinemachinePath type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachinePath |
Top
Properties
 | Name | Description
Public property | DistanceCacheSampleStepsPerSegment | When calculating the distance cache, sample the path this many times between points (Overrides CinemachinePathBaseDistanceCacheSampleStepsPerSegment.)
Public property | Looped | True if the path ends are joined to form a continuous loop (Overrides CinemachinePathBaseLooped.)
Public property | MaxPos | The maximum value for the path position (Overrides CinemachinePathBaseMaxPos.)
Public property | MinPos | The minimum value for the path position (Overrides CinemachinePathBaseMinPos.)
Public property | PathLength | Get the length of the path in distance units. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Top
Methods
 | Name | Description
Public method | DistanceCacheIsValid | See whether the distance cache is valid. If it's not valid, then any call to GetPathLength() or GetPathPositionFromDistance() will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | EvaluateOrientation | Get the orientation the curve at a point along the path. (Overrides CinemachinePathBaseEvaluateOrientation(Single).)
Public method | EvaluateOrientationAtUnit | Get the orientation the curve at a point along the path. (Inherited from CinemachinePathBase.)
Public method | EvaluatePosition | Get a worldspace position of a point along the path (Overrides CinemachinePathBaseEvaluatePosition(Single).)
Public method | EvaluatePositionAtUnit | Get a worldspace position of a point along the path (Inherited from CinemachinePathBase.)
Public method | EvaluateTangent | Get the tangent of the curve at a point along the path. (Overrides CinemachinePathBaseEvaluateTangent(Single).)
Public method | EvaluateTangentAtUnit | Get the tangent of the curve at a point along the path. (Inherited from CinemachinePathBase.)
Public method | FindClosestPoint | Find the closest point on the path to a given worldspace target point. (Inherited from CinemachinePathBase.)
Public method | GetPathDistanceFromPosition | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | GetPathPositionFromDistance | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | InvalidateDistanceCache | Call this if the path changes in such a way as to affect distances or other cached path elements (Inherited from CinemachinePathBase.)
Public method | MaxUnit | Get the maximum value, for the given unity type (Inherited from CinemachinePathBase.)
Public method | MinUnit | Get the minimum value, for the given unity type (Inherited from CinemachinePathBase.)
Public method | NormalizePathDistance | Normalize a distance along the path based on the path length. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | NormalizePos | Get a normalized path position, taking spins into account if looped (Inherited from CinemachinePathBase.)
Public method | NormalizeUnit | Normalize the unit, so that it lies between MinUmit and MaxUnit (Inherited from CinemachinePathBase.)
Top
Fields
 | Name | Description
Public field | m_Appearance | The settings that control how the path will appear in the editor scene view. (Inherited from CinemachinePathBase.)
Public field | m_Looped | If checked, then the path ends are joined to form a continuous loop
Public field | m_Resolution | Path samples per waypoint (Inherited from CinemachinePathBase.)
Public field | m_Waypoints | The waypoints that define the path. They will be interpolated using a bezier curve
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachinePath Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachinePath.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachinePath()
Cinemachine.CinemachinePath = function();
See Also

Reference

CinemachinePath Class


CinemachinePath Properties

The CinemachinePath type exposes the following members.

Properties
 | Name | Description
Public property | DistanceCacheSampleStepsPerSegment | When calculating the distance cache, sample the path this many times between points (Overrides CinemachinePathBaseDistanceCacheSampleStepsPerSegment.)
Public property | Looped | True if the path ends are joined to form a continuous loop (Overrides CinemachinePathBaseLooped.)
Public property | MaxPos | The maximum value for the path position (Overrides CinemachinePathBaseMaxPos.)
Public property | MinPos | The minimum value for the path position (Overrides CinemachinePathBaseMinPos.)
Public property | PathLength | Get the length of the path in distance units. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Top
See Also

Reference

CinemachinePath Class


CinemachinePath.DistanceCacheSampleStepsPerSegment Property

CinemachinePathDistanceCacheSampleStepsPerSegment Property

When calculating the distance cache, sample the path this many times between points

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override int DistanceCacheSampleStepsPerSegment { get; }
function get_DistanceCacheSampleStepsPerSegment();

Property Value

Type: Int32
See Also

Reference

CinemachinePath Class


CinemachinePath.Looped Property

CinemachinePathLooped Property

True if the path ends are joined to form a continuous loop

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool Looped { get; }
function get_Looped();

Property Value

Type: Boolean
See Also

Reference

CinemachinePath Class


CinemachinePath.MaxPos Property

CinemachinePathMaxPos Property

The maximum value for the path position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override float MaxPos { get; }
function get_MaxPos();

Property Value

Type: Single
See Also

Reference

CinemachinePath Class


CinemachinePath.MinPos Property

CinemachinePathMinPos Property

The minimum value for the path position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override float MinPos { get; }
function get_MinPos();

Property Value

Type: Single
See Also

Reference

CinemachinePath Class


CinemachinePath Methods

The CinemachinePath type exposes the following members.

Methods
 | Name | Description
Public method | DistanceCacheIsValid | See whether the distance cache is valid. If it's not valid, then any call to GetPathLength() or GetPathPositionFromDistance() will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | EvaluateOrientation | Get the orientation the curve at a point along the path. (Overrides CinemachinePathBaseEvaluateOrientation(Single).)
Public method | EvaluateOrientationAtUnit | Get the orientation the curve at a point along the path. (Inherited from CinemachinePathBase.)
Public method | EvaluatePosition | Get a worldspace position of a point along the path (Overrides CinemachinePathBaseEvaluatePosition(Single).)
Public method | EvaluatePositionAtUnit | Get a worldspace position of a point along the path (Inherited from CinemachinePathBase.)
Public method | EvaluateTangent | Get the tangent of the curve at a point along the path. (Overrides CinemachinePathBaseEvaluateTangent(Single).)
Public method | EvaluateTangentAtUnit | Get the tangent of the curve at a point along the path. (Inherited from CinemachinePathBase.)
Public method | FindClosestPoint | Find the closest point on the path to a given worldspace target point. (Inherited from CinemachinePathBase.)
Public method | GetPathDistanceFromPosition | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | GetPathPositionFromDistance | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | InvalidateDistanceCache | Call this if the path changes in such a way as to affect distances or other cached path elements (Inherited from CinemachinePathBase.)
Public method | MaxUnit | Get the maximum value, for the given unity type (Inherited from CinemachinePathBase.)
Public method | MinUnit | Get the minimum value, for the given unity type (Inherited from CinemachinePathBase.)
Public method | NormalizePathDistance | Normalize a distance along the path based on the path length. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | NormalizePos | Get a normalized path position, taking spins into account if looped (Inherited from CinemachinePathBase.)
Public method | NormalizeUnit | Normalize the unit, so that it lies between MinUmit and MaxUnit (Inherited from CinemachinePathBase.)
Top
See Also

Reference

CinemachinePath Class


CinemachinePath.EvaluateOrientation Method

CinemachinePathEvaluateOrientation Method

Get the orientation the curve at a point along the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Quaternion EvaluateOrientation(
    float pos
)
function EvaluateOrientation(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Quaternion
World-space orientation of the path, as defined by tangent, up, and roll.
See Also

Reference

CinemachinePath Class


CinemachinePath.EvaluatePosition Method

CinemachinePathEvaluatePosition Method

Get a worldspace position of a point along the path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Vector3 EvaluatePosition(
    float pos
)
function EvaluatePosition(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Vector3
World-space position of the point along at path at pos
See Also

Reference

CinemachinePath Class


CinemachinePath.EvaluateTangent Method

CinemachinePathEvaluateTangent Method

Get the tangent of the curve at a point along the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Vector3 EvaluateTangent(
    float pos
)
function EvaluateTangent(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Vector3
World-space direction of the path tangent. Length of the vector represents the tangent strength
See Also

Reference

CinemachinePath Class


CinemachinePath Fields

The CinemachinePath type exposes the following members.

Fields
 | Name | Description
Public field | m_Appearance | The settings that control how the path will appear in the editor scene view. (Inherited from CinemachinePathBase.)
Public field | m_Looped | If checked, then the path ends are joined to form a continuous loop
Public field | m_Resolution | Path samples per waypoint (Inherited from CinemachinePathBase.)
Public field | m_Waypoints | The waypoints that define the path. They will be interpolated using a bezier curve
Top
See Also

Reference

CinemachinePath Class


CinemachinePath.m_Looped Field

CinemachinePathm_Looped Field

If checked, then the path ends are joined to form a continuous loop

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If checked, then the path ends are joined to form a continuous loop.")]
public bool m_Looped
var m_Looped

Field Value

Type: Boolean
See Also

Reference

CinemachinePath Class


CinemachinePath.m_Waypoints Field

CinemachinePathm_Waypoints Field

The waypoints that define the path. They will be interpolated using a bezier curve

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The waypoints that define the path.  They will be interpolated using a bezier curve.")]
public CinemachinePathWaypoint[] m_Waypoints
var m_Waypoints

Field Value

Type: CinemachinePathWaypoint
See Also

Reference

CinemachinePath Class


CinemachinePath.Waypoint Structure

CinemachinePathWaypoint Structure

A waypoint along the path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(18.2f, DocumentationSortingAttributeLevel.UserRef)]
public struct Waypoint
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachinePathWaypoint type exposes the following members.

Fields
 | Name | Description
Public field | position | Position in path-local space
Public field | roll | Defines the roll of the path at this waypoint. The other orientation axes are inferred from the tangent and world up.
Public field | tangent | Offset from the position, which defines the tangent of the curve at the waypoint. The length of the tangent encodes the strength of the bezier handle. The same handle is used symmetrically on both sides of the waypoint, to ensure smoothness.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


Waypoint Fields

The CinemachinePathWaypoint type exposes the following members.

Fields
 | Name | Description
Public field | position | Position in path-local space
Public field | roll | Defines the roll of the path at this waypoint. The other orientation axes are inferred from the tangent and world up.
Public field | tangent | Offset from the position, which defines the tangent of the curve at the waypoint. The length of the tangent encodes the strength of the bezier handle. The same handle is used symmetrically on both sides of the waypoint, to ensure smoothness.
Top
See Also

Reference

CinemachinePathWaypoint Structure


CinemachinePath.Waypoint.position Field

CinemachinePathWaypointposition Field

Position in path-local space

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Position in path-local space")]
public Vector3 position
var position

Field Value

Type: Vector3
See Also

Reference

CinemachinePathWaypoint Structure


CinemachinePath.Waypoint.roll Field

CinemachinePathWaypointroll Field

Defines the roll of the path at this waypoint. The other orientation axes are inferred from the tangent and world up.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Defines the roll of the path at this waypoint.  The other orientation axes are inferred from the tangent and world up.")]
public float roll
var roll

Field Value

Type: Single
See Also

Reference

CinemachinePathWaypoint Structure


CinemachinePath.Waypoint.tangent Field

CinemachinePathWaypointtangent Field

Offset from the position, which defines the tangent of the curve at the waypoint. The length of the tangent encodes the strength of the bezier handle. The same handle is used symmetrically on both sides of the waypoint, to ensure smoothness.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Offset from the position, which defines the tangent of the curve at the waypoint.  The length of the tangent encodes the strength of the bezier handle.  The same handle is used symmetrically on both sides of the waypoint, to ensure smoothness.")]
public Vector3 tangent
var tangent

Field Value

Type: Vector3
See Also

Reference

CinemachinePathWaypoint Structure


CinemachinePathBase Class

Abstract base class for a world-space path, suitable for a camera dolly track.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachinePathBase
CinemachineCinemachinePath
CinemachineCinemachineSmoothPath

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract class CinemachinePathBase : MonoBehaviour
Cinemachine.CinemachinePathBase = function();

Type.createClass(
    'Cinemachine.CinemachinePathBase',
    UnityEngine.MonoBehaviour);

The CinemachinePathBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CinemachinePathBase |
Top
Properties
 | Name | Description
Public property | DistanceCacheSampleStepsPerSegment | When calculating the distance cache, sample the path this many times between points
Public property | Looped | True if the path ends are joined to form a continuous loop
Public property | MaxPos | The maximum value for the path position
Public property | MinPos | The minimum value for the path position
Public property | PathLength | Get the length of the path in distance units. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache
Top
Methods
 | Name | Description
Public method | DistanceCacheIsValid | See whether the distance cache is valid. If it's not valid, then any call to GetPathLength() or GetPathPositionFromDistance() will trigger a potentially costly regeneration of the path distance cache
Public method | EvaluateOrientation | Get the orientation the curve at a point along the path.
Public method | EvaluateOrientationAtUnit | Get the orientation the curve at a point along the path.
Public method | EvaluatePosition | Get a worldspace position of a point along the path
Public method | EvaluatePositionAtUnit | Get a worldspace position of a point along the path
Public method | EvaluateTangent | Get the tangent of the curve at a point along the path.
Public method | EvaluateTangentAtUnit | Get the tangent of the curve at a point along the path.
Public method | FindClosestPoint | Find the closest point on the path to a given worldspace target point.
Public method | GetPathDistanceFromPosition | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache
Public method | GetPathPositionFromDistance | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache
Public method | InvalidateDistanceCache | Call this if the path changes in such a way as to affect distances or other cached path elements
Public method | MaxUnit | Get the maximum value, for the given unity type
Public method | MinUnit | Get the minimum value, for the given unity type
Public method | NormalizePathDistance | Normalize a distance along the path based on the path length. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache
Public method | NormalizePos | Get a normalized path position, taking spins into account if looped
Public method | NormalizeUnit | Normalize the unit, so that it lies between MinUmit and MaxUnit
Top
Fields
 | Name | Description
Public field | m_Appearance | The settings that control how the path will appear in the editor scene view.
Public field | m_Resolution | Path samples per waypoint
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachinePathBase Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachinePathBase.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected CinemachinePathBase()
Cinemachine.CinemachinePathBase = function();
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase Properties

The CinemachinePathBase type exposes the following members.

Properties
 | Name | Description
Public property | DistanceCacheSampleStepsPerSegment | When calculating the distance cache, sample the path this many times between points
Public property | Looped | True if the path ends are joined to form a continuous loop
Public property | MaxPos | The maximum value for the path position
Public property | MinPos | The minimum value for the path position
Public property | PathLength | Get the length of the path in distance units. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache
Top
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.DistanceCacheSampleStepsPerSegment Property

CinemachinePathBaseDistanceCacheSampleStepsPerSegment Property

When calculating the distance cache, sample the path this many times between points

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract int DistanceCacheSampleStepsPerSegment { get; }
function get_DistanceCacheSampleStepsPerSegment();

Property Value

Type: Int32
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.Looped Property

CinemachinePathBaseLooped Property

True if the path ends are joined to form a continuous loop

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract bool Looped { get; }
function get_Looped();

Property Value

Type: Boolean
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.MaxPos Property

CinemachinePathBaseMaxPos Property

The maximum value for the path position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract float MaxPos { get; }
function get_MaxPos();

Property Value

Type: Single
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.MinPos Property

CinemachinePathBaseMinPos Property

The minimum value for the path position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract float MinPos { get; }
function get_MinPos();

Property Value

Type: Single
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.PathLength Property

CinemachinePathBasePathLength Property

Get the length of the path in distance units. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float PathLength { get; }
function get_PathLength();

Return Value

Type: Single
The length of the path in distance units, when sampled at this rate
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase Methods

The CinemachinePathBase type exposes the following members.

Methods
 | Name | Description
Public method | DistanceCacheIsValid | See whether the distance cache is valid. If it's not valid, then any call to GetPathLength() or GetPathPositionFromDistance() will trigger a potentially costly regeneration of the path distance cache
Public method | EvaluateOrientation | Get the orientation the curve at a point along the path.
Public method | EvaluateOrientationAtUnit | Get the orientation the curve at a point along the path.
Public method | EvaluatePosition | Get a worldspace position of a point along the path
Public method | EvaluatePositionAtUnit | Get a worldspace position of a point along the path
Public method | EvaluateTangent | Get the tangent of the curve at a point along the path.
Public method | EvaluateTangentAtUnit | Get the tangent of the curve at a point along the path.
Public method | FindClosestPoint | Find the closest point on the path to a given worldspace target point.
Public method | GetPathDistanceFromPosition | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache
Public method | GetPathPositionFromDistance | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache
Public method | InvalidateDistanceCache | Call this if the path changes in such a way as to affect distances or other cached path elements
Public method | MaxUnit | Get the maximum value, for the given unity type
Public method | MinUnit | Get the minimum value, for the given unity type
Public method | NormalizePathDistance | Normalize a distance along the path based on the path length. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache
Public method | NormalizePos | Get a normalized path position, taking spins into account if looped
Public method | NormalizeUnit | Normalize the unit, so that it lies between MinUmit and MaxUnit
Top
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.DistanceCacheIsValid Method

CinemachinePathBaseDistanceCacheIsValid Method

See whether the distance cache is valid. If it's not valid, then any call to GetPathLength() or GetPathPositionFromDistance() will trigger a potentially costly regeneration of the path distance cache

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool DistanceCacheIsValid()
function DistanceCacheIsValid();

Return Value

Type: Boolean
Whether the cache is valid for this sampling rate
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.EvaluateOrientation Method

CinemachinePathBaseEvaluateOrientation Method

Get the orientation the curve at a point along the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract Quaternion EvaluateOrientation(
    float pos
)
function EvaluateOrientation(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Quaternion
World-space orientation of the path
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.EvaluateOrientationAtUnit Method

CinemachinePathBaseEvaluateOrientationAtUnit Method

Get the orientation the curve at a point along the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Quaternion EvaluateOrientationAtUnit(
    float pos,
    CinemachinePathBasePositionUnits units
)
function EvaluateOrientationAtUnit(pos, units);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.
units
Type: CinemachineCinemachinePathBasePositionUnits
The unit to use when interpreting the value of pos.

Return Value

Type: Quaternion
World-space orientation of the path
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.EvaluatePosition Method

CinemachinePathBaseEvaluatePosition Method

Get a worldspace position of a point along the path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract Vector3 EvaluatePosition(
    float pos
)
function EvaluatePosition(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Vector3
World-space position of the point along at path at pos
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.EvaluatePositionAtUnit Method

CinemachinePathBaseEvaluatePositionAtUnit Method

Get a worldspace position of a point along the path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 EvaluatePositionAtUnit(
    float pos,
    CinemachinePathBasePositionUnits units
)
function EvaluatePositionAtUnit(pos, units);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.
units
Type: CinemachineCinemachinePathBasePositionUnits
The unit to use when interpreting the value of pos.

Return Value

Type: Vector3
World-space position of the point along at path at pos
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.EvaluateTangent Method

CinemachinePathBaseEvaluateTangent Method

Get the tangent of the curve at a point along the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract Vector3 EvaluateTangent(
    float pos
)
function EvaluateTangent(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Vector3
World-space direction of the path tangent. Length of the vector represents the tangent strength
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.EvaluateTangentAtUnit Method

CinemachinePathBaseEvaluateTangentAtUnit Method

Get the tangent of the curve at a point along the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 EvaluateTangentAtUnit(
    float pos,
    CinemachinePathBasePositionUnits units
)
function EvaluateTangentAtUnit(pos, units);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.
units
Type: CinemachineCinemachinePathBasePositionUnits
The unit to use when interpreting the value of pos.

Return Value

Type: Vector3
World-space direction of the path tangent. Length of the vector represents the tangent strength
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.FindClosestPoint Method

CinemachinePathBaseFindClosestPoint Method

Find the closest point on the path to a given worldspace target point.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual float FindClosestPoint(
    Vector3 p,
    int startSegment,
    int searchRadius,
    int stepsPerSegment
)
function FindClosestPoint(p, startSegment, searchRadius, stepsPerSegment);

Parameters

p
Type: Vector3
Worldspace target that we want to approach
startSegment
Type: SystemInt32
In what segment of the path to start the search. A Segment is a section of path between 2 waypoints.
searchRadius
Type: SystemInt32
How many segments on either side of the startSegment to search. -1 means no limit, i.e. search the entire path
stepsPerSegment
Type: SystemInt32
We search a segment by dividing it into this many straight pieces. The higher the number, the more accurate the result, but performance is proportionally slower for higher numbers

Return Value

Type: Single
The position along the path that is closest to the target point. The value is in Path Units, not Distance units.
Remarks
Performance could be improved by checking the bounding polygon of each segment, and only entering the best segment(s)
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.GetPathDistanceFromPosition Method

CinemachinePathBaseGetPathDistanceFromPosition Method

Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float GetPathDistanceFromPosition(
    float pos
)
function GetPathDistanceFromPosition(pos);

Parameters

pos
Type: SystemSingle

[Missing <param name="pos"/> documentation for "M:Cinemachine.CinemachinePathBase.GetPathDistanceFromPosition(System.Single)"]

Return Value

Type: Single
The length of the path in distance units, when sampled at this rate
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.GetPathPositionFromDistance Method

CinemachinePathBaseGetPathPositionFromDistance Method

Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float GetPathPositionFromDistance(
    float distance
)
function GetPathPositionFromDistance(distance);

Parameters

distance
Type: SystemSingle

[Missing <param name="distance"/> documentation for "M:Cinemachine.CinemachinePathBase.GetPathPositionFromDistance(System.Single)"]

Return Value

Type: Single
The length of the path in distance units, when sampled at this rate
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.InvalidateDistanceCache Method

CinemachinePathBaseInvalidateDistanceCache Method

Call this if the path changes in such a way as to affect distances or other cached path elements

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual void InvalidateDistanceCache()
function InvalidateDistanceCache();
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.MaxUnit Method

CinemachinePathBaseMaxUnit Method

Get the maximum value, for the given unity type

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float MaxUnit(
    CinemachinePathBasePositionUnits units
)
function MaxUnit(units);

Parameters

units
Type: CinemachineCinemachinePathBasePositionUnits
The uniot type

Return Value

Type: Single
The maximum allowable value for this path
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.MinUnit Method

CinemachinePathBaseMinUnit Method

Get the minimum value, for the given unity type

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float MinUnit(
    CinemachinePathBasePositionUnits units
)
function MinUnit(units);

Parameters

units
Type: CinemachineCinemachinePathBasePositionUnits
The uniot type

Return Value

Type: Single
The minimum allowable value for this path
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.NormalizePathDistance Method

CinemachinePathBaseNormalizePathDistance Method

Normalize a distance along the path based on the path length. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float NormalizePathDistance(
    float distance
)
function NormalizePathDistance(distance);

Parameters

distance
Type: SystemSingle
The distance to normalize

Return Value

Type: Single
The normalized distance, ranging from 0 to path length
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.NormalizePos Method

CinemachinePathBaseNormalizePos Method

Get a normalized path position, taking spins into account if looped

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual float NormalizePos(
    float pos
)
function NormalizePos(pos);

Parameters

pos
Type: SystemSingle
Position along the path

Return Value

Type: Single
Normalized position, between MinPos and MaxPos
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.NormalizeUnit Method

CinemachinePathBaseNormalizeUnit Method

Normalize the unit, so that it lies between MinUmit and MaxUnit

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual float NormalizeUnit(
    float pos,
    CinemachinePathBasePositionUnits units
)
function NormalizeUnit(pos, units);

Parameters

pos
Type: SystemSingle
The value to be normalized
units
Type: CinemachineCinemachinePathBasePositionUnits
The unit type

Return Value

Type: Single
The normalized value of pos, between MinUnit and MaxUnit
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase Fields

The CinemachinePathBase type exposes the following members.

Fields
 | Name | Description
Public field | m_Appearance | The settings that control how the path will appear in the editor scene view.
Public field | m_Resolution | Path samples per waypoint
Top
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.m_Appearance Field

CinemachinePathBasem_Appearance Field

The settings that control how the path will appear in the editor scene view.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The settings that control how the path will appear in the editor scene view.")]
public CinemachinePathBaseAppearance m_Appearance
var m_Appearance

Field Value

Type: CinemachinePathBaseAppearance
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.m_Resolution Field

CinemachinePathBasem_Resolution Field

Path samples per waypoint

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Path samples per waypoint.  This is used for calculating path distances.")]
[RangeAttribute(1f, 100f)]
public int m_Resolution
var m_Resolution

Field Value

Type: Int32
See Also

Reference

CinemachinePathBase Class


CinemachinePathBase.Appearance Class

CinemachinePathBaseAppearance Class

This class holds the settings that control how the path will appear in the editor scene view. The path is not visible in the game view
Inheritance Hierarchy
SystemObject
CinemachineCinemachinePathBaseAppearance

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(18.1f, DocumentationSortingAttributeLevel.UserRef)]
public class Appearance
Cinemachine.Appearance = function();

Type.createClass(
    'Cinemachine.Appearance');

The CinemachinePathBaseAppearance type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachinePathBaseAppearance |
Top
Fields
 | Name | Description
Public field | inactivePathColor |
Public field | pathColor |
Public field | width |
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachinePathBase.Appearance Constructor

CinemachinePathBaseAppearance Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachinePathBase.Appearance.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Appearance()
Cinemachine.Appearance = function();
See Also

Reference

CinemachinePathBaseAppearance Class


Appearance Fields

The CinemachinePathBaseAppearance type exposes the following members.

Fields
 | Name | Description
Public field | inactivePathColor |
Public field | pathColor |
Public field | width |
Top
See Also

Reference

CinemachinePathBaseAppearance Class


CinemachinePathBase.Appearance.inactivePathColor Field

CinemachinePathBaseAppearanceinactivePathColor Field

[Missing <summary> documentation for "F:Cinemachine.CinemachinePathBase.Appearance.inactivePathColor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The color of the path itself when it is inactive in the editor")]
public Color inactivePathColor
var inactivePathColor

Field Value

Type: Color
See Also

Reference

CinemachinePathBaseAppearance Class


CinemachinePathBase.Appearance.pathColor Field

CinemachinePathBaseAppearancepathColor Field

[Missing <summary> documentation for "F:Cinemachine.CinemachinePathBase.Appearance.pathColor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The color of the path itself when it is active in the editor")]
public Color pathColor
var pathColor

Field Value

Type: Color
See Also

Reference

CinemachinePathBaseAppearance Class


CinemachinePathBase.Appearance.width Field

CinemachinePathBaseAppearancewidth Field

[Missing <summary> documentation for "F:Cinemachine.CinemachinePathBase.Appearance.width"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The width of the railroad-tracks that are drawn to represent the path")]
[RangeAttribute(0f, 10f)]
public float width
var width

Field Value

Type: Single
See Also

Reference

CinemachinePathBaseAppearance Class


CinemachinePathBase.PositionUnits Enumeration

CinemachinePathBasePositionUnits Enumeration

How to interpret the Path Position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum PositionUnits
Cinemachine.PositionUnits = function();
Cinemachine.PositionUnits.createEnum('Cinemachine.PositionUnits', false);
Members
Member name | Value | Description
PathUnits | 0 | Use PathPosition units, where 0 is first waypoint, 1 is second waypoint, etc
Distance | 1 | Use Distance Along Path. Path will be sampled according to its Resolution setting, and a distance lookup table will be cached internally
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachinePipeline Class

Internal container for CinemachineComponentBase. Does nothing but contain.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachinePipeline

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[AddComponentMenu("")]
public sealed class CinemachinePipeline : MonoBehaviour
Cinemachine.CinemachinePipeline = function();

Type.createClass(
    'Cinemachine.CinemachinePipeline',
    UnityEngine.MonoBehaviour);

The CinemachinePipeline type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachinePipeline |
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachinePipeline Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachinePipeline.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachinePipeline()
Cinemachine.CinemachinePipeline = function();
See Also

Reference

CinemachinePipeline Class


CinemachinePOV Class

This is a CinemachineComponent in the Aim section of the component pipeline. Its job is to aim the camera in response to the user's mouse or joystick input. The composer does not change the camera's position. It will only pan and tilt the camera where it is, in order to get the desired framing. To move the camera, you have to use the virtual camera's Body section.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachinePOV

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(23f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachinePOV : CinemachineComponentBase
Cinemachine.CinemachinePOV = function();

Type.createClass(
    'Cinemachine.CinemachinePOV',
    Cinemachine.CinemachineComponentBase);

The CinemachinePOV type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachinePOV |
Top
Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a LookAt defined (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Public method | MutateCameraState | Applies the axis values and orients the camera accordingly (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
Fields
 | Name | Description
Public field | m_HorizontalAxis | The Horizontal axis. Value is -180..180. Controls the horizontal orientation
Public field | m_VerticalAxis | The Vertical axis. Value is -90..90. Controls the vertical orientation
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachinePOV Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachinePOV.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachinePOV()
Cinemachine.CinemachinePOV = function();
See Also

Reference

CinemachinePOV Class


CinemachinePOV Properties

The CinemachinePOV type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a LookAt defined (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachinePOV Class


CinemachinePOV.IsValid Property

CinemachinePOVIsValid Property

True if component is enabled and has a LookAt defined

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachinePOV Class


CinemachinePOV.Stage Property

CinemachinePOVStage Property

Get the Cinemachine Pipeline stage that this component implements. Always returns the Aim stage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachinePOV Class


CinemachinePOV Methods

The CinemachinePOV type exposes the following members.

Methods
 | Name | Description
Public method | MutateCameraState | Applies the axis values and orients the camera accordingly (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. Base class implementation does nothing. (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachinePOV Class


CinemachinePOV.MutateCameraState Method

CinemachinePOVMutateCameraState Method

Applies the axis values and orients the camera accordingly

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
Used for calculating damping. Not used.
See Also

Reference

CinemachinePOV Class


CinemachinePOV Fields

The CinemachinePOV type exposes the following members.

Fields
 | Name | Description
Public field | m_HorizontalAxis | The Horizontal axis. Value is -180..180. Controls the horizontal orientation
Public field | m_VerticalAxis | The Vertical axis. Value is -90..90. Controls the vertical orientation
Top
See Also

Reference

CinemachinePOV Class


CinemachinePOV.m_HorizontalAxis Field

CinemachinePOVm_HorizontalAxis Field

The Horizontal axis. Value is -180..180. Controls the horizontal orientation

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The Horizontal axis.  Value is -180..180.  Controls the horizontal orientation")]
public AxisState m_HorizontalAxis
var m_HorizontalAxis

Field Value

Type: AxisState
See Also

Reference

CinemachinePOV Class


CinemachinePOV.m_VerticalAxis Field

CinemachinePOVm_VerticalAxis Field

The Vertical axis. Value is -90..90. Controls the vertical orientation

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The Vertical axis.  Value is -90..90. Controls the vertical orientation")]
public AxisState m_VerticalAxis
var m_VerticalAxis

Field Value

Type: AxisState
See Also

Reference

CinemachinePOV Class


CinemachineSmoothPath Class

Defines a world-space path, consisting of an array of waypoints, each of which has position and roll settings. Bezier interpolation is performed between the waypoints, to get a smooth and continuous path. The path will pass through all waypoints, and (unlike CinemachinePath) first and second order continuity is guaranteed
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachinePathBase
CinemachineCinemachineSmoothPath

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(18.5f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("Cinemachine/CinemachineSmoothPath")]
[SaveDuringPlayAttribute]
public class CinemachineSmoothPath : CinemachinePathBase
Cinemachine.CinemachineSmoothPath = function();

Type.createClass(
    'Cinemachine.CinemachineSmoothPath',
    Cinemachine.CinemachinePathBase);

The CinemachineSmoothPath type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineSmoothPath |
Top
Properties
 | Name | Description
Public property | DistanceCacheSampleStepsPerSegment | When calculating the distance cache, sample the path this many times between points (Overrides CinemachinePathBaseDistanceCacheSampleStepsPerSegment.)
Public property | Looped | True if the path ends are joined to form a continuous loop (Overrides CinemachinePathBaseLooped.)
Public property | MaxPos | The maximum value for the path position (Overrides CinemachinePathBaseMaxPos.)
Public property | MinPos | The minimum value for the path position (Overrides CinemachinePathBaseMinPos.)
Public property | PathLength | Get the length of the path in distance units. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Top
Methods
 | Name | Description
Public method | DistanceCacheIsValid | See whether the distance cache is valid. If it's not valid, then any call to GetPathLength() or GetPathPositionFromDistance() will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | EvaluateOrientation | Get the orientation the curve at a point along the path. (Overrides CinemachinePathBaseEvaluateOrientation(Single).)
Public method | EvaluateOrientationAtUnit | Get the orientation the curve at a point along the path. (Inherited from CinemachinePathBase.)
Public method | EvaluatePosition | Get a worldspace position of a point along the path (Overrides CinemachinePathBaseEvaluatePosition(Single).)
Public method | EvaluatePositionAtUnit | Get a worldspace position of a point along the path (Inherited from CinemachinePathBase.)
Public method | EvaluateTangent | Get the tangent of the curve at a point along the path. (Overrides CinemachinePathBaseEvaluateTangent(Single).)
Public method | EvaluateTangentAtUnit | Get the tangent of the curve at a point along the path. (Inherited from CinemachinePathBase.)
Public method | FindClosestPoint | Find the closest point on the path to a given worldspace target point. (Inherited from CinemachinePathBase.)
Public method | GetPathDistanceFromPosition | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | GetPathPositionFromDistance | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | InvalidateDistanceCache | Call this if the path changes in such a way as to affect distances or other cached path elements (Overrides CinemachinePathBaseInvalidateDistanceCache.)
Public method | MaxUnit | Get the maximum value, for the given unity type (Inherited from CinemachinePathBase.)
Public method | MinUnit | Get the minimum value, for the given unity type (Inherited from CinemachinePathBase.)
Public method | NormalizePathDistance | Normalize a distance along the path based on the path length. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | NormalizePos | Get a normalized path position, taking spins into account if looped (Inherited from CinemachinePathBase.)
Public method | NormalizeUnit | Normalize the unit, so that it lies between MinUmit and MaxUnit (Inherited from CinemachinePathBase.)
Top
Fields
 | Name | Description
Public field | m_Appearance | The settings that control how the path will appear in the editor scene view. (Inherited from CinemachinePathBase.)
Public field | m_Looped | If checked, then the path ends are joined to form a continuous loop
Public field | m_Resolution | Path samples per waypoint (Inherited from CinemachinePathBase.)
Public field | m_Waypoints | The waypoints that define the path. They will be interpolated using a bezier curve
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineSmoothPath Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineSmoothPath.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineSmoothPath()
Cinemachine.CinemachineSmoothPath = function();
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath Properties

The CinemachineSmoothPath type exposes the following members.

Properties
 | Name | Description
Public property | DistanceCacheSampleStepsPerSegment | When calculating the distance cache, sample the path this many times between points (Overrides CinemachinePathBaseDistanceCacheSampleStepsPerSegment.)
Public property | Looped | True if the path ends are joined to form a continuous loop (Overrides CinemachinePathBaseLooped.)
Public property | MaxPos | The maximum value for the path position (Overrides CinemachinePathBaseMaxPos.)
Public property | MinPos | The minimum value for the path position (Overrides CinemachinePathBaseMinPos.)
Public property | PathLength | Get the length of the path in distance units. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Top
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.DistanceCacheSampleStepsPerSegment Property

CinemachineSmoothPathDistanceCacheSampleStepsPerSegment Property

When calculating the distance cache, sample the path this many times between points

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override int DistanceCacheSampleStepsPerSegment { get; }
function get_DistanceCacheSampleStepsPerSegment();

Property Value

Type: Int32
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.Looped Property

CinemachineSmoothPathLooped Property

True if the path ends are joined to form a continuous loop

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool Looped { get; }
function get_Looped();

Property Value

Type: Boolean
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.MaxPos Property

CinemachineSmoothPathMaxPos Property

The maximum value for the path position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override float MaxPos { get; }
function get_MaxPos();

Property Value

Type: Single
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.MinPos Property

CinemachineSmoothPathMinPos Property

The minimum value for the path position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override float MinPos { get; }
function get_MinPos();

Property Value

Type: Single
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath Methods

The CinemachineSmoothPath type exposes the following members.

Methods
 | Name | Description
Public method | DistanceCacheIsValid | See whether the distance cache is valid. If it's not valid, then any call to GetPathLength() or GetPathPositionFromDistance() will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | EvaluateOrientation | Get the orientation the curve at a point along the path. (Overrides CinemachinePathBaseEvaluateOrientation(Single).)
Public method | EvaluateOrientationAtUnit | Get the orientation the curve at a point along the path. (Inherited from CinemachinePathBase.)
Public method | EvaluatePosition | Get a worldspace position of a point along the path (Overrides CinemachinePathBaseEvaluatePosition(Single).)
Public method | EvaluatePositionAtUnit | Get a worldspace position of a point along the path (Inherited from CinemachinePathBase.)
Public method | EvaluateTangent | Get the tangent of the curve at a point along the path. (Overrides CinemachinePathBaseEvaluateTangent(Single).)
Public method | EvaluateTangentAtUnit | Get the tangent of the curve at a point along the path. (Inherited from CinemachinePathBase.)
Public method | FindClosestPoint | Find the closest point on the path to a given worldspace target point. (Inherited from CinemachinePathBase.)
Public method | GetPathDistanceFromPosition | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | GetPathPositionFromDistance | Get the path position (in path units) corresponding to this distance along the path. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | InvalidateDistanceCache | Call this if the path changes in such a way as to affect distances or other cached path elements (Overrides CinemachinePathBaseInvalidateDistanceCache.)
Public method | MaxUnit | Get the maximum value, for the given unity type (Inherited from CinemachinePathBase.)
Public method | MinUnit | Get the minimum value, for the given unity type (Inherited from CinemachinePathBase.)
Public method | NormalizePathDistance | Normalize a distance along the path based on the path length. If the distance cache is not valid, then calling this will trigger a potentially costly regeneration of the path distance cache (Inherited from CinemachinePathBase.)
Public method | NormalizePos | Get a normalized path position, taking spins into account if looped (Inherited from CinemachinePathBase.)
Public method | NormalizeUnit | Normalize the unit, so that it lies between MinUmit and MaxUnit (Inherited from CinemachinePathBase.)
Top
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.EvaluateOrientation Method

CinemachineSmoothPathEvaluateOrientation Method

Get the orientation the curve at a point along the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Quaternion EvaluateOrientation(
    float pos
)
function EvaluateOrientation(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Quaternion
World-space orientation of the path, as defined by tangent, up, and roll.
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.EvaluatePosition Method

CinemachineSmoothPathEvaluatePosition Method

Get a worldspace position of a point along the path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Vector3 EvaluatePosition(
    float pos
)
function EvaluatePosition(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Vector3
World-space position of the point along at path at pos
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.EvaluateTangent Method

CinemachineSmoothPathEvaluateTangent Method

Get the tangent of the curve at a point along the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Vector3 EvaluateTangent(
    float pos
)
function EvaluateTangent(pos);

Parameters

pos
Type: SystemSingle
Postion along the path. Need not be normalized.

Return Value

Type: Vector3
World-space direction of the path tangent. Length of the vector represents the tangent strength
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.InvalidateDistanceCache Method

CinemachineSmoothPathInvalidateDistanceCache Method

Call this if the path changes in such a way as to affect distances or other cached path elements

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void InvalidateDistanceCache()
function InvalidateDistanceCache();
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath Fields

The CinemachineSmoothPath type exposes the following members.

Fields
 | Name | Description
Public field | m_Appearance | The settings that control how the path will appear in the editor scene view. (Inherited from CinemachinePathBase.)
Public field | m_Looped | If checked, then the path ends are joined to form a continuous loop
Public field | m_Resolution | Path samples per waypoint (Inherited from CinemachinePathBase.)
Public field | m_Waypoints | The waypoints that define the path. They will be interpolated using a bezier curve
Top
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.m_Looped Field

CinemachineSmoothPathm_Looped Field

If checked, then the path ends are joined to form a continuous loop

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If checked, then the path ends are joined to form a continuous loop.")]
public bool m_Looped
var m_Looped

Field Value

Type: Boolean
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.m_Waypoints Field

CinemachineSmoothPathm_Waypoints Field

The waypoints that define the path. They will be interpolated using a bezier curve

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The waypoints that define the path.  They will be interpolated using a bezier curve.")]
public CinemachineSmoothPathWaypoint[] m_Waypoints
var m_Waypoints

Field Value

Type: CinemachineSmoothPathWaypoint
See Also

Reference

CinemachineSmoothPath Class


CinemachineSmoothPath.Waypoint Structure

CinemachineSmoothPathWaypoint Structure

A waypoint along the path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(18.7f, DocumentationSortingAttributeLevel.UserRef)]
public struct Waypoint
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineSmoothPathWaypoint type exposes the following members.

Fields
 | Name | Description
Public field | position | Position in path-local space
Public field | roll | Defines the roll of the path at this waypoint. The other orientation axes are inferred from the tangent and world up.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


Waypoint Fields

The CinemachineSmoothPathWaypoint type exposes the following members.

Fields
 | Name | Description
Public field | position | Position in path-local space
Public field | roll | Defines the roll of the path at this waypoint. The other orientation axes are inferred from the tangent and world up.
Top
See Also

Reference

CinemachineSmoothPathWaypoint Structure


CinemachineSmoothPath.Waypoint.position Field

CinemachineSmoothPathWaypointposition Field

Position in path-local space

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Position in path-local space")]
public Vector3 position
var position

Field Value

Type: Vector3
See Also

Reference

CinemachineSmoothPathWaypoint Structure


CinemachineSmoothPath.Waypoint.roll Field

CinemachineSmoothPathWaypointroll Field

Defines the roll of the path at this waypoint. The other orientation axes are inferred from the tangent and world up.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Defines the roll of the path at this waypoint.  The other orientation axes are inferred from the tangent and world up.")]
public float roll
var roll

Field Value

Type: Single
See Also

Reference

CinemachineSmoothPathWaypoint Structure


CinemachineStateDrivenCamera Class

This is a virtual camera "manager" that owns and manages a collection of child Virtual Cameras. These child vcams are mapped to individual states in an animation state machine, allowing you to associate specific vcams to specific animation states. When that state is active in the state machine, then the associated camera will be activated. You can define custom blends and transitions between child cameras. In order to use this behaviour, you must have an animated target (i.e. an object animated with a state machine) to drive the behaviour.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
CinemachineCinemachineStateDrivenCamera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(13f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[DisallowMultipleComponent]
[AddComponentMenu("Cinemachine/CinemachineStateDrivenCamera")]
public class CinemachineStateDrivenCamera : CinemachineVirtualCameraBase
Cinemachine.CinemachineStateDrivenCamera = function();

Type.createClass(
    'Cinemachine.CinemachineStateDrivenCamera',
    Cinemachine.CinemachineVirtualCameraBase);

The CinemachineStateDrivenCamera type exposes the following members.

Properties
 | Name | Description
Public property | ChildCameras | The list of child cameras. These are just the immediate children in the hierarchy.
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Overrides CinemachineVirtualCameraBaseDescription.)
Public property | Follow | Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | IsBlending | Is there a blend in progress?
Public property | LiveChild | Get the current "best" child virtual camera, that would be chosen if the State Driven Camera were active.
Public property | LiveChildOrSelf | Return the live child. (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The State of the current live child (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
 | CreateFakeHashName | API for the inspector editor. Animation module does not have hashes for state parents, so we have to invent them in order to implement nested state handling
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Makes sure the internal child cache is up to date (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnTransformChildrenChanged | Makes sure the internal child cache is up to date
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid. (Inherited from CinemachineVirtualCameraBase.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Public method | ValidateInstructions | Internal API for the inspector editor.
Top
Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_AnimatedTarget | The state machine whose state changes will drive this camera's choice of active child
Public field | m_CustomBlends | This is the asset which contains custom settings for specific child blends.
Public field | m_DefaultBlend | The blend which is used if you don't explicitly define a blend between two Virtual Camera children.
Public field | m_EnableAllChildCameras | Force all child cameras to be enabled. This is useful if animating them in Timeline, but consumes extra resources.
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | Default object for the camera children wants to move with (the body target), if not specified in a child rig. May be empty
Public field | m_Instructions | The set of instructions associating virtual cameras with states. These instructions are used to choose the live child at any given moment
Public field | m_LayerIndex | Which layer in the target FSM to observe
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | Default object for the camera children to look at (the aim target), if not specified in a child rig. May be empty
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ShowDebugText | When enabled, the current camera and blend will be indicated in the game window, for debugging
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineStateDrivenCamera Properties

The CinemachineStateDrivenCamera type exposes the following members.

Properties
 | Name | Description
Public property | ChildCameras | The list of child cameras. These are just the immediate children in the hierarchy.
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Overrides CinemachineVirtualCameraBaseDescription.)
Public property | Follow | Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | IsBlending | Is there a blend in progress?
Public property | LiveChild | Get the current "best" child virtual camera, that would be chosen if the State Driven Camera were active.
Public property | LiveChildOrSelf | Return the live child. (Overrides CinemachineVirtualCameraBaseLiveChildOrSelf.)
Public property | LookAt | Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The State of the current live child (Overrides CinemachineVirtualCameraBaseState.)
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.ChildCameras Property

CinemachineStateDrivenCameraChildCameras Property

The list of child cameras. These are just the immediate children in the hierarchy.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineVirtualCameraBase[] ChildCameras { get; }
function get_ChildCameras();

Property Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.Description Property

CinemachineStateDrivenCameraDescription Property

Gets a brief debug description of this virtual camera, for use when displayiong debug info

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override string Description { get; }
function get_Description();

Property Value

Type: String

Implements

ICinemachineCameraDescription
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.Follow Property

CinemachineStateDrivenCameraFollow Property

Get the current Follow target. Returns parent's Follow if parent is non-null and no specific Follow defined for this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform

Implements

ICinemachineCameraFollow
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.IsBlending Property

CinemachineStateDrivenCameraIsBlending Property

Is there a blend in progress?

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsBlending { get; }
function get_IsBlending();

Property Value

Type: Boolean
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.LiveChild Property

CinemachineStateDrivenCameraLiveChild Property

Get the current "best" child virtual camera, that would be chosen if the State Driven Camera were active.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public ICinemachineCamera LiveChild { get; set; }
function get_LiveChild();
function set_LiveChild(value);

Property Value

Type: ICinemachineCamera
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.LiveChildOrSelf Property

CinemachineStateDrivenCameraLiveChildOrSelf Property

Return the live child.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override ICinemachineCamera LiveChildOrSelf { get; }
function get_LiveChildOrSelf();

Property Value

Type: ICinemachineCamera

Implements

ICinemachineCameraLiveChildOrSelf
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.LookAt Property

CinemachineStateDrivenCameraLookAt Property

Get the current LookAt target. Returns parent's LookAt if parent is non-null and no specific LookAt defined for this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform

Implements

ICinemachineCameraLookAt
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.State Property

CinemachineStateDrivenCameraState Property

The State of the current live child

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CameraState State { get; }
function get_State();

Property Value

Type: CameraState

Implements

ICinemachineCameraState
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera Methods

The CinemachineStateDrivenCamera type exposes the following members.

Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
 | CreateFakeHashName | API for the inspector editor. Animation module does not have hashes for state parents, so we have to invent them in order to implement nested state handling
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. (Overrides CinemachineVirtualCameraBaseIsLiveChild(ICinemachineCamera).)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Makes sure the internal child cache is up to date (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnTransformChildrenChanged | Makes sure the internal child cache is up to date
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid. (Inherited from CinemachineVirtualCameraBase.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. Make sure it is removed from all the children. (Overrides CinemachineVirtualCameraBaseRemovePostPipelineStageHook(CinemachineVirtualCameraBaseOnPostPipelineStageDelegate).)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Public method | ValidateInstructions | Internal API for the inspector editor.
Top
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.CreateFakeHashName Method

CinemachineStateDrivenCameraCreateFakeHashName Method

API for the inspector editor. Animation module does not have hashes for state parents, so we have to invent them in order to implement nested state handling

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static string CreateFakeHashName(
    int parentHash,
    string stateName
)
Cinemachine.CinemachineStateDrivenCamera.CreateFakeHashName = function(parentHash, stateName);

Parameters

parentHash
Type: SystemInt32

[Missing <param name="parentHash"/> documentation for "M:Cinemachine.CinemachineStateDrivenCamera.CreateFakeHashName(System.Int32,System.String)"]

stateName
Type: SystemString

[Missing <param name="stateName"/> documentation for "M:Cinemachine.CinemachineStateDrivenCamera.CreateFakeHashName(System.Int32,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Cinemachine.CinemachineStateDrivenCamera.CreateFakeHashName(System.Int32,System.String)"]

See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.IsLiveChild Method

CinemachineStateDrivenCameraIsLiveChild Method

Check whether the vcam a live child of this camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsLiveChild(
    ICinemachineCamera vcam
)
function IsLiveChild(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The Virtual Camera to check

Return Value

Type: Boolean
True if the vcam is currently actively influencing the state of this vcam

Implements

ICinemachineCameraIsLiveChild(ICinemachineCamera)
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.OnEnable Method

CinemachineStateDrivenCameraOnEnable Method

Makes sure the internal child cache is up to date

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnEnable()
function OnEnable();
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.OnTransformChildrenChanged Method

CinemachineStateDrivenCameraOnTransformChildrenChanged Method

Makes sure the internal child cache is up to date

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void OnTransformChildrenChanged()
function OnTransformChildrenChanged();
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.RemovePostPipelineStageHook Method

CinemachineStateDrivenCameraRemovePostPipelineStageHook Method

Remove a Pipeline stage hook callback. Make sure it is removed from all the children.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void RemovePostPipelineStageHook(
    CinemachineVirtualCameraBaseOnPostPipelineStageDelegate d
)
function RemovePostPipelineStageHook(d);

Parameters

d
Type: CinemachineCinemachineVirtualCameraBaseOnPostPipelineStageDelegate
The delegate to remove.
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.UpdateCameraState Method

CinemachineStateDrivenCameraUpdateCameraState Method

Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. This implementation updates all the children, chooses the best one, and implements any required blending.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than or equal to 0)

Implements

ICinemachineCameraUpdateCameraState(Vector3, Single)
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.ValidateInstructions Method

CinemachineStateDrivenCameraValidateInstructions Method

Internal API for the inspector editor.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void ValidateInstructions()
function ValidateInstructions();
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera Fields

The CinemachineStateDrivenCamera type exposes the following members.

Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_AnimatedTarget | The state machine whose state changes will drive this camera's choice of active child
Public field | m_CustomBlends | This is the asset which contains custom settings for specific child blends.
Public field | m_DefaultBlend | The blend which is used if you don't explicitly define a blend between two Virtual Camera children.
Public field | m_EnableAllChildCameras | Force all child cameras to be enabled. This is useful if animating them in Timeline, but consumes extra resources.
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | Default object for the camera children wants to move with (the body target), if not specified in a child rig. May be empty
Public field | m_Instructions | The set of instructions associating virtual cameras with states. These instructions are used to choose the live child at any given moment
Public field | m_LayerIndex | Which layer in the target FSM to observe
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | Default object for the camera children to look at (the aim target), if not specified in a child rig. May be empty
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_ShowDebugText | When enabled, the current camera and blend will be indicated in the game window, for debugging
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_AnimatedTarget Field

CinemachineStateDrivenCameram_AnimatedTarget Field

The state machine whose state changes will drive this camera's choice of active child

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SpaceAttribute]
[TooltipAttribute("The state machine whose state changes will drive this camera's choice of active child")]
public Animator m_AnimatedTarget
var m_AnimatedTarget

Field Value

Type: Animator
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_CustomBlends Field

CinemachineStateDrivenCameram_CustomBlends Field

This is the asset which contains custom settings for specific child blends.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("This is the asset which contains custom settings for specific child blends")]
public CinemachineBlenderSettings m_CustomBlends
var m_CustomBlends

Field Value

Type: CinemachineBlenderSettings
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_DefaultBlend Field

CinemachineStateDrivenCameram_DefaultBlend Field

The blend which is used if you don't explicitly define a blend between two Virtual Camera children.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[CinemachineBlendDefinitionPropertyAttribute]
[TooltipAttribute("The blend which is used if you don't explicitly define a blend between two Virtual Camera children")]
public CinemachineBlendDefinition m_DefaultBlend
var m_DefaultBlend

Field Value

Type: CinemachineBlendDefinition
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_EnableAllChildCameras Field

CinemachineStateDrivenCameram_EnableAllChildCameras Field

Force all child cameras to be enabled. This is useful if animating them in Timeline, but consumes extra resources.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Force all child cameras to be enabled.  This is useful if animating them in Timeline, but consumes extra resources")]
public bool m_EnableAllChildCameras
var m_EnableAllChildCameras

Field Value

Type: Boolean
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_Follow Field

CinemachineStateDrivenCameram_Follow Field

Default object for the camera children wants to move with (the body target), if not specified in a child rig. May be empty

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Default object for the camera children wants to move with (the body target), if not specified in a child camera.  May be empty if all of the children define targets of their own.")]
[NoSaveDuringPlayAttribute]
public Transform m_Follow
var m_Follow

Field Value

Type: Transform
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_Instructions Field

CinemachineStateDrivenCameram_Instructions Field

The set of instructions associating virtual cameras with states. These instructions are used to choose the live child at any given moment

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The set of instructions associating virtual cameras with states.  These instructions are used to choose the live child at any given moment")]
public CinemachineStateDrivenCameraInstruction[] m_Instructions
var m_Instructions

Field Value

Type: CinemachineStateDrivenCameraInstruction
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_LayerIndex Field

CinemachineStateDrivenCameram_LayerIndex Field

Which layer in the target FSM to observe

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Which layer in the target state machine to observe")]
public int m_LayerIndex
var m_LayerIndex

Field Value

Type: Int32
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_LookAt Field

CinemachineStateDrivenCameram_LookAt Field

Default object for the camera children to look at (the aim target), if not specified in a child rig. May be empty

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Default object for the camera children to look at (the aim target), if not specified in a child camera.  May be empty if all of the children define targets of their own.")]
[NoSaveDuringPlayAttribute]
public Transform m_LookAt
var m_LookAt

Field Value

Type: Transform
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.m_ShowDebugText Field

CinemachineStateDrivenCameram_ShowDebugText Field

When enabled, the current camera and blend will be indicated in the game window, for debugging

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When enabled, the current child camera and blend will be indicated in the game window, for debugging")]
public bool m_ShowDebugText
var m_ShowDebugText

Field Value

Type: Boolean
See Also

Reference

CinemachineStateDrivenCamera Class


CinemachineStateDrivenCamera.Instruction Structure

CinemachineStateDrivenCameraInstruction Structure

This represents a single instrunction to the StateDrivenCamera. It associates an state from the state machine with a child Virtual Camera, and also holds activation tuning parameters.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
public struct Instruction
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineStateDrivenCameraInstruction type exposes the following members.

Fields
 | Name | Description
Public field | m_ActivateAfter | How long to wait (in seconds) before activating the virtual camera. This filters out very short state durations
Public field | m_FullHash | The full hash of the animation state
Public field | m_MinDuration | The minimum length of time (in seconds) to keep a virtual camera active
Public field | m_VirtualCamera | The virtual camera to activate whrn the animation state becomes active
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


Instruction Fields

The CinemachineStateDrivenCameraInstruction type exposes the following members.

Fields
 | Name | Description
Public field | m_ActivateAfter | How long to wait (in seconds) before activating the virtual camera. This filters out very short state durations
Public field | m_FullHash | The full hash of the animation state
Public field | m_MinDuration | The minimum length of time (in seconds) to keep a virtual camera active
Public field | m_VirtualCamera | The virtual camera to activate whrn the animation state becomes active
Top
See Also

Reference

CinemachineStateDrivenCameraInstruction Structure


CinemachineStateDrivenCamera.Instruction.m_ActivateAfter Field

CinemachineStateDrivenCameraInstructionm_ActivateAfter Field

How long to wait (in seconds) before activating the virtual camera. This filters out very short state durations

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How long to wait (in seconds) before activating the virtual camera. This filters out very short state durations")]
public float m_ActivateAfter
var m_ActivateAfter

Field Value

Type: Single
See Also

Reference

CinemachineStateDrivenCameraInstruction Structure


CinemachineStateDrivenCamera.Instruction.m_FullHash Field

CinemachineStateDrivenCameraInstructionm_FullHash Field

The full hash of the animation state

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The full hash of the animation state")]
public int m_FullHash
var m_FullHash

Field Value

Type: Int32
See Also

Reference

CinemachineStateDrivenCameraInstruction Structure


CinemachineStateDrivenCamera.Instruction.m_MinDuration Field

CinemachineStateDrivenCameraInstructionm_MinDuration Field

The minimum length of time (in seconds) to keep a virtual camera active

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The minimum length of time (in seconds) to keep a virtual camera active")]
public float m_MinDuration
var m_MinDuration

Field Value

Type: Single
See Also

Reference

CinemachineStateDrivenCameraInstruction Structure


CinemachineStateDrivenCamera.Instruction.m_VirtualCamera Field

CinemachineStateDrivenCameraInstructionm_VirtualCamera Field

The virtual camera to activate whrn the animation state becomes active

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The virtual camera to activate whrn the animation state becomes active")]
public CinemachineVirtualCameraBase m_VirtualCamera
var m_VirtualCamera

Field Value

Type: CinemachineVirtualCameraBase
See Also

Reference

CinemachineStateDrivenCameraInstruction Structure


CinemachineTargetGroup Class

Defines a group of target objects, each with a radius and a weight. The weight is used when calculating the average position of the target group. Higher-weighted members of the group will count more. The bounding box is calculated by taking the member positions, weight, and radii into account.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineTargetGroup

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(19f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("Cinemachine/CinemachineTargetGroup")]
[SaveDuringPlayAttribute]
[ExecuteInEditMode]
public class CinemachineTargetGroup : MonoBehaviour
Cinemachine.CinemachineTargetGroup = function();

Type.createClass(
    'Cinemachine.CinemachineTargetGroup',
    UnityEngine.MonoBehaviour);

The CinemachineTargetGroup type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineTargetGroup |
Top
Properties
 | Name | Description
Public property | BoundingBox | The axis-aligned bounding box of the group, computed using the targets positions and radii
Public property | IsEmpty | Return true if there are no members with weight > 0
Top
Methods
 | Name | Description
Public method | GetViewSpaceBoundingBox | The axis-aligned bounding box of the group, in a specific reference frame
Top
Fields
 | Name | Description
Public field | m_PositionMode | How the group's position is calculated
Public field | m_RotationMode | How the group's orientation is calculated
Public field | m_Targets | The target objects, together with their weights and radii, that will contribute to the group's average position, orientation, and size
Public field | m_UpdateMethod | When to update the group's transform based on the position of the group members
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineTargetGroup Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineTargetGroup.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineTargetGroup()
Cinemachine.CinemachineTargetGroup = function();
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup Properties

The CinemachineTargetGroup type exposes the following members.

Properties
 | Name | Description
Public property | BoundingBox | The axis-aligned bounding box of the group, computed using the targets positions and radii
Public property | IsEmpty | Return true if there are no members with weight > 0
Top
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup.BoundingBox Property

CinemachineTargetGroupBoundingBox Property

The axis-aligned bounding box of the group, computed using the targets positions and radii

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Bounds BoundingBox { get; }
function get_BoundingBox();

Property Value

Type: Bounds
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup.IsEmpty Property

CinemachineTargetGroupIsEmpty Property

Return true if there are no members with weight > 0

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool IsEmpty { get; }
function get_IsEmpty();

Property Value

Type: Boolean
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup Methods

The CinemachineTargetGroup type exposes the following members.

Methods
 | Name | Description
Public method | GetViewSpaceBoundingBox | The axis-aligned bounding box of the group, in a specific reference frame
Top
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup.GetViewSpaceBoundingBox Method

CinemachineTargetGroupGetViewSpaceBoundingBox Method

The axis-aligned bounding box of the group, in a specific reference frame

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Bounds GetViewSpaceBoundingBox(
    Matrix4x4 mView
)
function GetViewSpaceBoundingBox(mView);

Parameters

mView
Type: Matrix4x4
The frame of reference in which to compute the bounding box

Return Value

Type: Bounds
The axis-aligned bounding box of the group, in the desired frame of reference
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup Fields

The CinemachineTargetGroup type exposes the following members.

Fields
 | Name | Description
Public field | m_PositionMode | How the group's position is calculated
Public field | m_RotationMode | How the group's orientation is calculated
Public field | m_Targets | The target objects, together with their weights and radii, that will contribute to the group's average position, orientation, and size
Public field | m_UpdateMethod | When to update the group's transform based on the position of the group members
Top
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup.m_PositionMode Field

CinemachineTargetGroupm_PositionMode Field

How the group's position is calculated

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How the group's position is calculated.  Select GroupCenter for the center of the bounding box, and GroupAverage for a weighted average of the positions of the members.")]
public CinemachineTargetGroupPositionMode m_PositionMode
var m_PositionMode

Field Value

Type: CinemachineTargetGroupPositionMode
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup.m_RotationMode Field

CinemachineTargetGroupm_RotationMode Field

How the group's orientation is calculated

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How the group's rotation is calculated.  Select Manual to use the value in the group's transform, and GroupAverage for a weighted average of the orientations of the members.")]
public CinemachineTargetGroupRotationMode m_RotationMode
var m_RotationMode

Field Value

Type: CinemachineTargetGroupRotationMode
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup.m_Targets Field

CinemachineTargetGroupm_Targets Field

The target objects, together with their weights and radii, that will contribute to the group's average position, orientation, and size

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[NoSaveDuringPlayAttribute]
[TooltipAttribute("The target objects, together with their weights and radii, that will contribute to the group's average position, orientation, and size.")]
public CinemachineTargetGroupTarget[] m_Targets
var m_Targets

Field Value

Type: CinemachineTargetGroupTarget
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup.m_UpdateMethod Field

CinemachineTargetGroupm_UpdateMethod Field

When to update the group's transform based on the position of the group members

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When to update the group's transform based on the position of the group members")]
public CinemachineTargetGroupUpdateMethod m_UpdateMethod
var m_UpdateMethod

Field Value

Type: CinemachineTargetGroupUpdateMethod
See Also

Reference

CinemachineTargetGroup Class


CinemachineTargetGroup.PositionMode Enumeration

CinemachineTargetGroupPositionMode Enumeration

How the group's position is calculated

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(19.2f, DocumentationSortingAttributeLevel.UserRef)]
public enum PositionMode
Cinemachine.PositionMode = function();
Cinemachine.PositionMode.createEnum('Cinemachine.PositionMode', false);
Members
Member name | Value | Description
GroupCenter | 0 | Group position will be the center of the group's axis-aligned bounding box
GroupAverage | 1 | Group position will be the weighted average of the positions of the members
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineTargetGroup.RotationMode Enumeration

CinemachineTargetGroupRotationMode Enumeration

How the group's orientation is calculated

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(19.3f, DocumentationSortingAttributeLevel.UserRef)]
public enum RotationMode
Cinemachine.RotationMode = function();
Cinemachine.RotationMode.createEnum('Cinemachine.RotationMode', false);
Members
Member name | Value | Description
Manual | 0 | Manually set in the group's transform
GroupAverage | 1 | Weighted average of the orientation of its members.
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineTargetGroup.Target Structure

CinemachineTargetGroupTarget Structure

Holds the information that represents a member of the group

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(19.1f, DocumentationSortingAttributeLevel.UserRef)]
public struct Target
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineTargetGroupTarget type exposes the following members.

Fields
 | Name | Description
Public field | radius | The radius of the target, used for calculating the bounding box. Cannot be negative
Public field | target | The target objects. This object's position and orientation will contribute to the group's average position and orientation, in accordance with its weight
Public field | weight | How much weight to give the target when averaging. Cannot be negative
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


Target Fields

The CinemachineTargetGroupTarget type exposes the following members.

Fields
 | Name | Description
Public field | radius | The radius of the target, used for calculating the bounding box. Cannot be negative
Public field | target | The target objects. This object's position and orientation will contribute to the group's average position and orientation, in accordance with its weight
Public field | weight | How much weight to give the target when averaging. Cannot be negative
Top
See Also

Reference

CinemachineTargetGroupTarget Structure


CinemachineTargetGroup.Target.radius Field

CinemachineTargetGroupTargetradius Field

The radius of the target, used for calculating the bounding box. Cannot be negative

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The radius of the target, used for calculating the bounding box.  Cannot be negative")]
public float radius
var radius

Field Value

Type: Single
See Also

Reference

CinemachineTargetGroupTarget Structure


CinemachineTargetGroup.Target.target Field

CinemachineTargetGroupTargettarget Field

The target objects. This object's position and orientation will contribute to the group's average position and orientation, in accordance with its weight

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The target objects.  This object's position and orientation will contribute to the group's average position and orientation, in accordance with its weight")]
public Transform target
var target

Field Value

Type: Transform
See Also

Reference

CinemachineTargetGroupTarget Structure


CinemachineTargetGroup.Target.weight Field

CinemachineTargetGroupTargetweight Field

How much weight to give the target when averaging. Cannot be negative

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How much weight to give the target when averaging.  Cannot be negative")]
public float weight
var weight

Field Value

Type: Single
See Also

Reference

CinemachineTargetGroupTarget Structure


CinemachineTargetGroup.UpdateMethod Enumeration

CinemachineTargetGroupUpdateMethod Enumeration

This enum defines the options available for the update method.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum UpdateMethod
Cinemachine.UpdateMethod = function();
Cinemachine.UpdateMethod.createEnum('Cinemachine.UpdateMethod', false);
Members
Member name | Value | Description
Update | 0 | Updated in normal MonoBehaviour Update.
FixedUpdate | 1 | Updated in sync with the Physics module, in FixedUpdate
LateUpdate | 2 | Updated in MonoBehaviour LateUpdate.
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineTrackedDolly Class

A Cinemachine Virtual Camera Body component that constrains camera motion to a CinemachinePath. The camera can move along the path. This behaviour can operate in two modes: manual positioning, and Auto-Dolly positioning. In Manual mode, the camera's position is specified by animating the Path Position field. In Auto-Dolly mode, the Path Position field is animated automatically every frame by finding the position on the path that's closest to the virtual camera's Follow target.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineTrackedDolly

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(7f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineTrackedDolly : CinemachineComponentBase
Cinemachine.CinemachineTrackedDolly = function();

Type.createClass(
    'Cinemachine.CinemachineTrackedDolly',
    Cinemachine.CinemachineComponentBase);

The CinemachineTrackedDolly type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineTrackedDolly |
Top
Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a path (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Public method | MutateCameraState | Positions the virtual camera according to the transposer rules. (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset. (Overrides CinemachineComponentBaseOnPositionDragged(Vector3).)
Top
Fields
 | Name | Description
Public field | m_AutoDolly | Controls how automatic dollying occurs
Public field | m_CameraUp | How to set the virtual camera's Up vector. This will affect the screen composition.
Public field | m_Path | The path to which the camera will be constrained. This must be non-null.
Public field | m_PathOffset | Where to put the camera realtive to the path postion. X is perpendicular to the path, Y is up, and Z is parallel to the path.
Public field | m_PathPosition | The position along the path at which the camera will be placed. This can be animated directly, or set automatically by the Auto-Dolly feature to get as close as possible to the Follow target.
Public field | m_PitchDamping | "How aggressively the camera tries to track the target rotation's X angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_PositionUnits | How to interpret the Path Position
Public field | m_RollDamping | How aggressively the camera tries to track the target rotation's Z angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_XDamping | How aggressively the camera tries to maintain the offset perpendicular to the path. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_YawDamping | How aggressively the camera tries to track the target rotation's Y angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_YDamping | How aggressively the camera tries to maintain the offset in the path-local up direction. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_ZDamping | How aggressively the camera tries to maintain the offset parallel to the path. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineTrackedDolly Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineTrackedDolly.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineTrackedDolly()
Cinemachine.CinemachineTrackedDolly = function();
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly Properties

The CinemachineTrackedDolly type exposes the following members.

Properties
 | Name | Description
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a path (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.IsValid Property

CinemachineTrackedDollyIsValid Property

True if component is enabled and has a path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.Stage Property

CinemachineTrackedDollyStage Property

Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly Methods

The CinemachineTrackedDolly type exposes the following members.

Methods
 | Name | Description
Public method | MutateCameraState | Positions the virtual camera according to the transposer rules. (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset. (Overrides CinemachineComponentBaseOnPositionDragged(Vector3).)
Top
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.MutateCameraState Method

CinemachineTrackedDollyMutateCameraState Method

Positions the virtual camera according to the transposer rules.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
Used for damping. If less that 0, no damping is done.
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.OnPositionDragged Method

CinemachineTrackedDollyOnPositionDragged Method

API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void OnPositionDragged(
    Vector3 delta
)
function OnPositionDragged(delta);

Parameters

delta
Type: Vector3
The amount dragged this frame
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly Fields

The CinemachineTrackedDolly type exposes the following members.

Fields
 | Name | Description
Public field | m_AutoDolly | Controls how automatic dollying occurs
Public field | m_CameraUp | How to set the virtual camera's Up vector. This will affect the screen composition.
Public field | m_Path | The path to which the camera will be constrained. This must be non-null.
Public field | m_PathOffset | Where to put the camera realtive to the path postion. X is perpendicular to the path, Y is up, and Z is parallel to the path.
Public field | m_PathPosition | The position along the path at which the camera will be placed. This can be animated directly, or set automatically by the Auto-Dolly feature to get as close as possible to the Follow target.
Public field | m_PitchDamping | "How aggressively the camera tries to track the target rotation's X angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_PositionUnits | How to interpret the Path Position
Public field | m_RollDamping | How aggressively the camera tries to track the target rotation's Z angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_XDamping | How aggressively the camera tries to maintain the offset perpendicular to the path. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_YawDamping | How aggressively the camera tries to track the target rotation's Y angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_YDamping | How aggressively the camera tries to maintain the offset in the path-local up direction. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_ZDamping | How aggressively the camera tries to maintain the offset parallel to the path. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Top
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_AutoDolly Field

CinemachineTrackedDollym_AutoDolly Field

Controls how automatic dollying occurs

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Controls how automatic dollying occurs.  A Follow target is necessary to use this feature.")]
public CinemachineTrackedDollyAutoDolly m_AutoDolly
var m_AutoDolly

Field Value

Type: CinemachineTrackedDollyAutoDolly
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_CameraUp Field

CinemachineTrackedDollym_CameraUp Field

How to set the virtual camera's Up vector. This will affect the screen composition.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How to set the virtual camera's Up vector.  This will affect the screen composition, because the camera Aim behaviours will always try to respect the Up direction.")]
public CinemachineTrackedDollyCameraUpMode m_CameraUp
var m_CameraUp

Field Value

Type: CinemachineTrackedDollyCameraUpMode
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_Path Field

CinemachineTrackedDollym_Path Field

The path to which the camera will be constrained. This must be non-null.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The path to which the camera will be constrained.  This must be non-null.")]
public CinemachinePathBase m_Path
var m_Path

Field Value

Type: CinemachinePathBase
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_PathOffset Field

CinemachineTrackedDollym_PathOffset Field

Where to put the camera realtive to the path postion. X is perpendicular to the path, Y is up, and Z is parallel to the path.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Where to put the camera relative to the path position.  X is perpendicular to the path, Y is up, and Z is parallel to the path.  This allows the camera to be offset from the path itself (as if on a tripod, for example).")]
public Vector3 m_PathOffset
var m_PathOffset

Field Value

Type: Vector3
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_PathPosition Field

CinemachineTrackedDollym_PathPosition Field

The position along the path at which the camera will be placed. This can be animated directly, or set automatically by the Auto-Dolly feature to get as close as possible to the Follow target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The position along the path at which the camera will be placed.  This can be animated directly, or set automatically by the Auto-Dolly feature to get as close as possible to the Follow target.  The value is interpreted according to the Position Units setting.")]
public float m_PathPosition
var m_PathPosition

Field Value

Type: Single
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_PitchDamping Field

CinemachineTrackedDollym_PitchDamping Field

"How aggressively the camera tries to track the target rotation's X angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to track the target rotation's X angle.  Small numbers are more responsive.  Larger numbers give a more heavy slowly responding camera.")]
public float m_PitchDamping
var m_PitchDamping

Field Value

Type: Single
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_PositionUnits Field

CinemachineTrackedDollym_PositionUnits Field

How to interpret the Path Position

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("How to interpret Path Position.  If set to Path Units, values are as follows: 0 represents the first waypoint on the path, 1 is the second, and so on.  Values in-between are points on the path in between the waypoints.  If set to Distance, then Path Position represents distance along the path.")]
public CinemachinePathBasePositionUnits m_PositionUnits
var m_PositionUnits

Field Value

Type: CinemachinePathBasePositionUnits
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_RollDamping Field

CinemachineTrackedDollym_RollDamping Field

How aggressively the camera tries to track the target rotation's Z angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to track the target rotation's Z angle.  Small numbers are more responsive.  Larger numbers give a more heavy slowly responding camera.")]
public float m_RollDamping
var m_RollDamping

Field Value

Type: Single
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_XDamping Field

CinemachineTrackedDollym_XDamping Field

How aggressively the camera tries to maintain the offset perpendicular to the path. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain its position in a direction perpendicular to the path.  Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_XDamping
var m_XDamping

Field Value

Type: Single
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_YawDamping Field

CinemachineTrackedDollym_YawDamping Field

How aggressively the camera tries to track the target rotation's Y angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to track the target rotation's Y angle.  Small numbers are more responsive.  Larger numbers give a more heavy slowly responding camera.")]
public float m_YawDamping
var m_YawDamping

Field Value

Type: Single
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_YDamping Field

CinemachineTrackedDollym_YDamping Field

How aggressively the camera tries to maintain the offset in the path-local up direction. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain its position in the path-local up direction.  Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_YDamping
var m_YDamping

Field Value

Type: Single
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.m_ZDamping Field

CinemachineTrackedDollym_ZDamping Field

How aggressively the camera tries to maintain the offset parallel to the path. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain its position in a direction parallel to the path.  Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_ZDamping
var m_ZDamping

Field Value

Type: Single
See Also

Reference

CinemachineTrackedDolly Class


CinemachineTrackedDolly.AutoDolly Structure

CinemachineTrackedDollyAutoDolly Structure

Controls how automatic dollying occurs

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(7.2f, DocumentationSortingAttributeLevel.UserRef)]
public struct AutoDolly
JavaScript supports the use of structures, but not the declaration of new ones.

The CinemachineTrackedDollyAutoDolly type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineTrackedDollyAutoDolly | Constructor with specific field values
Top
Fields
 | Name | Description
Public field | m_Enabled | If checked, will enable automatic dolly, which chooses a path position that is as close as possible to the Follow target.
Public field | m_PositionOffset | Offset, in current position units, from the closest point on the path to the follow target.
Public field | m_SearchRadius | Search up to how many waypoints on either side of the current position. Use 0 for Entire path
Public field | m_SearchResolution | We search between waypoints by dividing the segment into this many straight pieces. The higher the number, the more accurate the result, but performance is proportionally slower for higher numbers
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineTrackedDolly.AutoDolly Constructor

CinemachineTrackedDollyAutoDolly Constructor

Constructor with specific field values

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public AutoDolly(
    bool enabled,
    float positionOffset,
    int searchRadius,
    int stepsPerSegment
)
Cinemachine.AutoDolly = function(enabled, positionOffset, searchRadius, stepsPerSegment);

Parameters

enabled
Type: SystemBoolean

[Missing <param name="enabled"/> documentation for "M:Cinemachine.CinemachineTrackedDolly.AutoDolly.#ctor(System.Boolean,System.Single,System.Int32,System.Int32)"]

positionOffset
Type: SystemSingle

[Missing <param name="positionOffset"/> documentation for "M:Cinemachine.CinemachineTrackedDolly.AutoDolly.#ctor(System.Boolean,System.Single,System.Int32,System.Int32)"]

searchRadius
Type: SystemInt32

[Missing <param name="searchRadius"/> documentation for "M:Cinemachine.CinemachineTrackedDolly.AutoDolly.#ctor(System.Boolean,System.Single,System.Int32,System.Int32)"]

stepsPerSegment
Type: SystemInt32

[Missing <param name="stepsPerSegment"/> documentation for "M:Cinemachine.CinemachineTrackedDolly.AutoDolly.#ctor(System.Boolean,System.Single,System.Int32,System.Int32)"]

See Also

Reference

CinemachineTrackedDollyAutoDolly Structure


AutoDolly Fields

The CinemachineTrackedDollyAutoDolly type exposes the following members.

Fields
 | Name | Description
Public field | m_Enabled | If checked, will enable automatic dolly, which chooses a path position that is as close as possible to the Follow target.
Public field | m_PositionOffset | Offset, in current position units, from the closest point on the path to the follow target.
Public field | m_SearchRadius | Search up to how many waypoints on either side of the current position. Use 0 for Entire path
Public field | m_SearchResolution | We search between waypoints by dividing the segment into this many straight pieces. The higher the number, the more accurate the result, but performance is proportionally slower for higher numbers
Top
See Also

Reference

CinemachineTrackedDollyAutoDolly Structure


CinemachineTrackedDolly.AutoDolly.m_Enabled Field

CinemachineTrackedDollyAutoDollym_Enabled Field

If checked, will enable automatic dolly, which chooses a path position that is as close as possible to the Follow target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("If checked, will enable automatic dolly, which chooses a path position that is as close as possible to the Follow target.  Note: this can have significant performance impact")]
public bool m_Enabled
var m_Enabled

Field Value

Type: Boolean
See Also

Reference

CinemachineTrackedDollyAutoDolly Structure


CinemachineTrackedDolly.AutoDolly.m_PositionOffset Field

CinemachineTrackedDollyAutoDollym_PositionOffset Field

Offset, in current position units, from the closest point on the path to the follow target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Offset, in current position units, from the closest point on the path to the follow target")]
public float m_PositionOffset
var m_PositionOffset

Field Value

Type: Single
See Also

Reference

CinemachineTrackedDollyAutoDolly Structure


CinemachineTrackedDolly.AutoDolly.m_SearchRadius Field

CinemachineTrackedDollyAutoDollym_SearchRadius Field

Search up to how many waypoints on either side of the current position. Use 0 for Entire path

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Search up to how many waypoints on either side of the current position.  Use 0 for Entire path.")]
public int m_SearchRadius
var m_SearchRadius

Field Value

Type: Int32
See Also

Reference

CinemachineTrackedDollyAutoDolly Structure


CinemachineTrackedDolly.AutoDolly.m_SearchResolution Field

CinemachineTrackedDollyAutoDollym_SearchResolution Field

We search between waypoints by dividing the segment into this many straight pieces. The higher the number, the more accurate the result, but performance is proportionally slower for higher numbers

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[FormerlySerializedAsAttribute("m_StepsPerSegment")]
[TooltipAttribute("We search between waypoints by dividing the segment into this many straight pieces.  The higher the number, the more accurate the result, but performance is proportionally slower for higher numbers")]
public int m_SearchResolution
var m_SearchResolution

Field Value

Type: Int32
See Also

Reference

CinemachineTrackedDollyAutoDolly Structure


CinemachineTrackedDolly.CameraUpMode Enumeration

CinemachineTrackedDollyCameraUpMode Enumeration

Different ways to set the camera's up vector

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(7.1f, DocumentationSortingAttributeLevel.UserRef)]
public enum CameraUpMode
Cinemachine.CameraUpMode = function();
Cinemachine.CameraUpMode.createEnum('Cinemachine.CameraUpMode', false);
Members
Member name | Value | Description
Default | 0 | Leave the camera's up vector alone. It will be set according to the Brain's WorldUp.
Path | 1 | Take the up vector from the path's up vector at the current point
PathNoRoll | 2 | Take the up vector from the path's up vector at the current point, but with the roll zeroed out
FollowTarget | 3 | Take the up vector from the Follow target's up vector
FollowTargetNoRoll | 4 | Take the up vector from the Follow target's up vector, but with the roll zeroed out
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineTransposer Class

This is a CinemachineComponent in the Body section of the component pipeline. Its job is to position the camera in a fixed relationship to the vcam's Follow target object, with offsets and damping. The Tansposer will only change the camera's position in space. It will not re-orient or otherwise aim the camera. To to that, you need to instruct the vcam in the Aim section of its pipeline.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineComponentBase
CinemachineCinemachineTransposer
CinemachineCinemachineOrbitalTransposer

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(5f, DocumentationSortingAttributeLevel.UserRef)]
[AddComponentMenu("")]
[RequireComponent(typeof(CinemachinePipeline))]
[SaveDuringPlayAttribute]
public class CinemachineTransposer : CinemachineComponentBase
Cinemachine.CinemachineTransposer = function();

Type.createClass(
    'Cinemachine.CinemachineTransposer',
    Cinemachine.CinemachineComponentBase);

The CinemachineTransposer type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineTransposer |
Top
Properties
 | Name | Description
Protected property | AngularDamping | Damping speeds for each of the 3 axes of the target's rotation
Protected property | Damping | Damping speeds for each of the 3 axes of the offset from target
Protected property | EffectiveOffset | Get the target offset, with sanitization
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a valid Follow target (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
Methods
 | Name | Description
Public method | GeTargetCameraPosition | Internal API for the Inspector Editor, so it can draw a marker at the target
Public method | GetReferenceOrientation | Internal API for the Inspector Editor, so it can draw a marker at the target
Protected method | InitPrevFrameStateInfo | Initializes the state for previous frame if appropriate.
Public method | MutateCameraState | Positions the virtual camera according to the transposer rules. (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset. (Overrides CinemachineComponentBaseOnPositionDragged(Vector3).)
Protected method | OnValidate |
Protected method | TrackTarget | Positions the virtual camera according to the transposer rules.
Top
Fields
 | Name | Description
Public field | m_BindingMode | The coordinate space to use when interpreting the offset from the target
Public field | m_FollowOffset | The distance which the transposer will attempt to maintain from the transposer subject
Public field | m_PitchDamping | How aggressively the camera tries to track the target rotation's X angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_RollDamping | How aggressively the camera tries to track the target rotation's Z angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_XDamping | How aggressively the camera tries to maintain the offset in the X-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_YawDamping | How aggressively the camera tries to track the target rotation's Y angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_YDamping | How aggressively the camera tries to maintain the offset in the Y-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_ZDamping | How aggressively the camera tries to maintain the offset in the Z-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineTransposer Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineTransposer.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineTransposer()
Cinemachine.CinemachineTransposer = function();
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer Properties

The CinemachineTransposer type exposes the following members.

Properties
 | Name | Description
Protected property | AngularDamping | Damping speeds for each of the 3 axes of the target's rotation
Protected property | Damping | Damping speeds for each of the 3 axes of the offset from target
Protected property | EffectiveOffset | Get the target offset, with sanitization
Public property | FollowTarget | Returns the owner vcam's Follow target. (Inherited from CinemachineComponentBase.)
Public property | IsValid | True if component is enabled and has a valid Follow target (Overrides CinemachineComponentBaseIsValid.)
Public property | LookAtTarget | Returns the owner vcam's LookAt target. (Inherited from CinemachineComponentBase.)
Public property | Stage | Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage (Overrides CinemachineComponentBaseStage.)
Public property | VcamState | Returns the owner vcam's CameraState. (Inherited from CinemachineComponentBase.)
Public property | VirtualCamera | Get the associated CinemachineVirtualCameraBase (Inherited from CinemachineComponentBase.)
Top
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.AngularDamping Property

CinemachineTransposerAngularDamping Property

Damping speeds for each of the 3 axes of the target's rotation

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected Vector3 AngularDamping { get; }
function get_AngularDamping();

Property Value

Type: Vector3
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.Damping Property

CinemachineTransposerDamping Property

Damping speeds for each of the 3 axes of the offset from target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected Vector3 Damping { get; }
function get_Damping();

Property Value

Type: Vector3
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.EffectiveOffset Property

CinemachineTransposerEffectiveOffset Property

Get the target offset, with sanitization

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected Vector3 EffectiveOffset { get; }
function get_EffectiveOffset();

Property Value

Type: Vector3
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.IsValid Property

CinemachineTransposerIsValid Property

True if component is enabled and has a valid Follow target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override bool IsValid { get; }
function get_IsValid();

Property Value

Type: Boolean
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.Stage Property

CinemachineTransposerStage Property

Get the Cinemachine Pipeline stage that this component implements. Always returns the Body stage

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CinemachineCoreStage Stage { get; }
function get_Stage();

Property Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer Methods

The CinemachineTransposer type exposes the following members.

Methods
 | Name | Description
Public method | GeTargetCameraPosition | Internal API for the Inspector Editor, so it can draw a marker at the target
Public method | GetReferenceOrientation | Internal API for the Inspector Editor, so it can draw a marker at the target
Protected method | InitPrevFrameStateInfo | Initializes the state for previous frame if appropriate.
Public method | MutateCameraState | Positions the virtual camera according to the transposer rules. (Overrides CinemachineComponentBaseMutateCameraState(CameraState, Single).)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset. (Overrides CinemachineComponentBaseOnPositionDragged(Vector3).)
Protected method | OnValidate |
Protected method | TrackTarget | Positions the virtual camera according to the transposer rules.
Top
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.GeTargetCameraPosition Method

CinemachineTransposerGeTargetCameraPosition Method

Internal API for the Inspector Editor, so it can draw a marker at the target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Vector3 GeTargetCameraPosition(
    Vector3 worldUp
)
function GeTargetCameraPosition(worldUp);

Parameters

worldUp
Type: Vector3

[Missing <param name="worldUp"/> documentation for "M:Cinemachine.CinemachineTransposer.GeTargetCameraPosition(UnityEngine.Vector3)"]

Return Value

Type: Vector3

[Missing <returns> documentation for "M:Cinemachine.CinemachineTransposer.GeTargetCameraPosition(UnityEngine.Vector3)"]

See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.GetReferenceOrientation Method

CinemachineTransposerGetReferenceOrientation Method

Internal API for the Inspector Editor, so it can draw a marker at the target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Quaternion GetReferenceOrientation(
    Vector3 worldUp
)
function GetReferenceOrientation(worldUp);

Parameters

worldUp
Type: Vector3

[Missing <param name="worldUp"/> documentation for "M:Cinemachine.CinemachineTransposer.GetReferenceOrientation(UnityEngine.Vector3)"]

Return Value

Type: Quaternion

[Missing <returns> documentation for "M:Cinemachine.CinemachineTransposer.GetReferenceOrientation(UnityEngine.Vector3)"]

See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.InitPrevFrameStateInfo Method

CinemachineTransposerInitPrevFrameStateInfo Method

Initializes the state for previous frame if appropriate.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected void InitPrevFrameStateInfo(
    ref CameraState curState,
    float deltaTime
)
function InitPrevFrameStateInfo(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState

[Missing <param name="curState"/> documentation for "M:Cinemachine.CinemachineTransposer.InitPrevFrameStateInfo(Cinemachine.CameraState@,System.Single)"]

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineTransposer.InitPrevFrameStateInfo(Cinemachine.CameraState@,System.Single)"]

See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.MutateCameraState Method

CinemachineTransposerMutateCameraState Method

Positions the virtual camera according to the transposer rules.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void MutateCameraState(
    ref CameraState curState,
    float deltaTime
)
function MutateCameraState(curState, deltaTime);

Parameters

curState
Type: CinemachineCameraState
The current camera state
deltaTime
Type: SystemSingle
Used for damping. If less than 0, no damping is done.
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.OnPositionDragged Method

CinemachineTransposerOnPositionDragged Method

API for the editor, to process a position drag from the user. This implementation adds the delta to the follow offset.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void OnPositionDragged(
    Vector3 delta
)
function OnPositionDragged(delta);

Parameters

delta
Type: Vector3
The amount dragged this frame
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.OnValidate Method

CinemachineTransposerOnValidate Method

[Missing <summary> documentation for "M:Cinemachine.CinemachineTransposer.OnValidate"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void OnValidate()
function OnValidate();
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.TrackTarget Method

CinemachineTransposerTrackTarget Method

Positions the virtual camera according to the transposer rules.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected void TrackTarget(
    float deltaTime,
    Vector3 up,
    Vector3 desiredCameraOffset,
    out Vector3 outTargetPosition,
    out Quaternion outTargetOrient
)
function TrackTarget(deltaTime, up, desiredCameraOffset, outTargetPosition, outTargetOrient);

Parameters

deltaTime
Type: SystemSingle
Used for damping. If less than 0, no damping is done.
up
Type: Vector3
Current camera up
desiredCameraOffset
Type: Vector3
Where we want to put the camera relative to the follow target
outTargetPosition
Type: Vector3
Resulting camera position
outTargetOrient
Type: Quaternion
Damped target orientation
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer Fields

The CinemachineTransposer type exposes the following members.

Fields
 | Name | Description
Public field | m_BindingMode | The coordinate space to use when interpreting the offset from the target
Public field | m_FollowOffset | The distance which the transposer will attempt to maintain from the transposer subject
Public field | m_PitchDamping | How aggressively the camera tries to track the target rotation's X angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_RollDamping | How aggressively the camera tries to track the target rotation's Z angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_XDamping | How aggressively the camera tries to maintain the offset in the X-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_YawDamping | How aggressively the camera tries to track the target rotation's Y angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.
Public field | m_YDamping | How aggressively the camera tries to maintain the offset in the Y-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Public field | m_ZDamping | How aggressively the camera tries to maintain the offset in the Z-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors
Top
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.m_BindingMode Field

CinemachineTransposerm_BindingMode Field

The coordinate space to use when interpreting the offset from the target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The coordinate space to use when interpreting the offset from the target.  This is also used to set the camera's Up vector, which will be maintained when aiming the camera.")]
public CinemachineTransposerBindingMode m_BindingMode
var m_BindingMode

Field Value

Type: CinemachineTransposerBindingMode
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.m_FollowOffset Field

CinemachineTransposerm_FollowOffset Field

The distance which the transposer will attempt to maintain from the transposer subject

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The distance vector that the transposer will attempt to maintain from the Follow target")]
public Vector3 m_FollowOffset
var m_FollowOffset

Field Value

Type: Vector3
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.m_PitchDamping Field

CinemachineTransposerm_PitchDamping Field

How aggressively the camera tries to track the target rotation's X angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to track the target rotation's X angle.  Small numbers are more responsive.  Larger numbers give a more heavy slowly responding camera.")]
public float m_PitchDamping
var m_PitchDamping

Field Value

Type: Single
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.m_RollDamping Field

CinemachineTransposerm_RollDamping Field

How aggressively the camera tries to track the target rotation's Z angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to track the target rotation's Z angle.  Small numbers are more responsive.  Larger numbers give a more heavy slowly responding camera.")]
public float m_RollDamping
var m_RollDamping

Field Value

Type: Single
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.m_XDamping Field

CinemachineTransposerm_XDamping Field

How aggressively the camera tries to maintain the offset in the X-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain the offset in the X-axis.  Small numbers are more responsive, rapidly translating the camera to keep the target's x-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_XDamping
var m_XDamping

Field Value

Type: Single
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.m_YawDamping Field

CinemachineTransposerm_YawDamping Field

How aggressively the camera tries to track the target rotation's Y angle. Small numbers are more responsive. Larger numbers give a more heavy slowly responding camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to track the target rotation's Y angle.  Small numbers are more responsive.  Larger numbers give a more heavy slowly responding camera.")]
public float m_YawDamping
var m_YawDamping

Field Value

Type: Single
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.m_YDamping Field

CinemachineTransposerm_YDamping Field

How aggressively the camera tries to maintain the offset in the Y-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain the offset in the Y-axis.  Small numbers are more responsive, rapidly translating the camera to keep the target's y-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_YDamping
var m_YDamping

Field Value

Type: Single
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.m_ZDamping Field

CinemachineTransposerm_ZDamping Field

How aggressively the camera tries to maintain the offset in the Z-axis. Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset. Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(0f, 20f)]
[TooltipAttribute("How aggressively the camera tries to maintain the offset in the Z-axis.  Small numbers are more responsive, rapidly translating the camera to keep the target's z-axis offset.  Larger numbers give a more heavy slowly responding camera. Using different settings per axis can yield a wide range of camera behaviors.")]
public float m_ZDamping
var m_ZDamping

Field Value

Type: Single
See Also

Reference

CinemachineTransposer Class


CinemachineTransposer.BindingMode Enumeration

CinemachineTransposerBindingMode Enumeration

The coordinate space to use when interpreting the offset from the target

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(5.01f, DocumentationSortingAttributeLevel.UserRef)]
public enum BindingMode
Cinemachine.BindingMode = function();
Cinemachine.BindingMode.createEnum('Cinemachine.BindingMode', false);
Members
Member name | Value | Description
LockToTargetOnAssign | 0 | Camera will be bound to the Follow target using a frame of reference consisting of the target's local frame at the moment when the virtual camera was enabled, or when the target was assigned.
LockToTargetWithWorldUp | 1 | Camera will be bound to the Follow target using a frame of reference consisting of the target's local frame, with the tilt and roll zeroed out.
LockToTargetNoRoll | 2 | Camera will be bound to the Follow target using a frame of reference consisting of the target's local frame, with the roll zeroed out.
LockToTarget | 3 | Camera will be bound to the Follow target using the target's local frame.
WorldSpace | 4 | Camera will be bound to the Follow target using a world space offset.
SimpleFollowWithWorldUp | 5 | Offsets will be calculated relative to the target, using Camera-local axes
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineVirtualCamera Class

This behaviour is intended to be attached to an empty Transform GameObject, and it represents a Virtual Camera within the Unity scene. The Virtual Camera will animate its Transform according to the rules contained in its CinemachineComponent pipeline (Aim, Body, and Noise). When the virtual camera is Live, the Unity camera will assume the position and orientation of the virtual camera. A virtual camera is not a camera. Instead, it can be thought of as a camera controller, not unlike a cameraman. It can drive the Unity Camera and control its position, orientation, lens settings, and PostProcessing effects. Each Virtual Camera owns its own Cinemachine Component Pipeline, through which you provide the instructions for dynamically tracking specific game objects. A virtual camera is very lightweight, and does no rendering of its own. It merely tracks interesting GameObjects, and positions itself accordingly. A typical game can have dozens of virtual cameras, each set up to follow a particular character or capture a particular event. A Virtual Camera can be in any of three states: * **Live**: The virtual camera is actively controlling the Unity Camera. The virtual camera is tracking its targets and being updated every frame. * **Standby**: The virtual camera is tracking its targets and being updated every frame, but no Unity Camera is actively being controlled by it. This is the state of a virtual camera that is enabled in the scene but perhaps at a lower priority than the Live virtual camera. * **Disabled**: The virtual camera is present but disabled in the scene. It is not actively tracking its targets and so consumes no processing power. However, the virtual camera can be made live from the Timeline. The Unity Camera can be driven by any virtual camera in the scene. The game logic can choose the virtual camera to make live by manipulating the virtual cameras' enabled flags and their priorities, based on game logic. In order to be driven by a virtual camera, the Unity Camera must have a CinemachineBrain behaviour, which will select the most eligible virtual camera based on its priority or on other criteria, and will manage blending.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
CinemachineCinemachineVirtualCamera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(1f, DocumentationSortingAttributeLevel.UserRef)]
[ExecuteInEditMode]
[DisallowMultipleComponent]
[AddComponentMenu("Cinemachine/CinemachineVirtualCamera")]
public class CinemachineVirtualCamera : CinemachineVirtualCameraBase
Cinemachine.CinemachineVirtualCamera = function();

Type.createClass(
    'Cinemachine.CinemachineVirtualCamera',
    Cinemachine.CinemachineVirtualCameraBase);

The CinemachineVirtualCamera type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineVirtualCamera |
Top
Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Inherited from CinemachineVirtualCameraBase.)
Public property | Follow | Get the Follow target for the Body component in the CinemachinePipeline. If this vcam is a part of a meta-camera collection, then the owner's target will be used if the local target is null. (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | LiveChildOrSelf | Just returns self. (Inherited from CinemachineVirtualCameraBase.)
Public property | LookAt | Get the LookAt target for the Aim component in the CinemachinePipeline. If this vcam is a part of a meta-camera collection, then the owner's target will be used if the local target is null. (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The CameraState object holds all of the information necessary to position the Unity camera. It is the output of this class. (Overrides CinemachineVirtualCameraBaseState.)
Public property | UserIsDragging | API for the editor, to make the dragging of position handles behave better.
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
Methods
 | Name | Description
Public method | AddCinemachineComponentT | Add a component to the cinemachine pipeline.
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Public method | DestroyCinemachineComponentT | Remove a component from the cinemachine pipeline.
Public method | GetCinemachineComponent(CinemachineCoreStage) | Get the component set for a specific stage.
Public method | GetCinemachineComponentT | Get an existing component of a specific type from the cinemachine pipeline.
Public method | GetComponentOwner | Get the hidden CinemachinePipeline child object.
Public method | GetComponentPipeline | Get the component pipeline owned by the hidden child pipline container. For most purposes, it is preferable to use the GetCinemachineComponent method.
Public method | InvalidateComponentPipeline | Editor API: Call this when changing the pipeline from the editor. Will force a rebuild of the pipeline cache.
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. This base class implementation always returns false. (Inherited from CinemachineVirtualCameraBase.)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Calls the DestroyPipelineDelegate for destroying the hidden child object, to support undo. (Overrides CinemachineVirtualCameraBaseOnDestroy.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Make sure that the pipeline cache is up-to-date. (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user.
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. (Overrides CinemachineVirtualCameraBaseOnValidate.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at LateUpdate time so the vcam can position itself and track its targets. This class will invoke its pipeline and generate a CameraState for this frame. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Top
Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
 | CreatePipelineOverride | Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in this class.
 | DestroyPipelineOverride | Override component pipeline destruction. This needs to be done by the editor to support Undo.
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | The object that the camera wants to move with (the Body target). The Body component of the CinemachineComponent pipeline will refer to this target and position the vcam in accordance with rules and settings that are provided to it. If this is null, then the vcam's Transform position will be used.
Public field | m_Lens | Specifies the LensSettings of this Virtual Camera. These settings will be transferred to the Unity camera when the vcam is live.
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | The object that the camera wants to look at (the Aim target). The Aim component of the CinemachineComponent pipeline will refer to this target and orient the vcam in accordance with rules and settings that are provided to it. If this is null, then the vcam's Transform orientation will be used.
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
 | PipelineName | This is the name of the hidden GameObject that will be created as a child object of the virtual camera. This hidden game object acts as a container for the polymorphic CinemachineComponent pipeline. The Inspector UI for the Virtual Camera provides access to this pipleline, as do the CinemachineComponent-family of public methods in this class. The lifecycle of the pipeline GameObject is managed automatically.
Top
See Also

Reference

Cinemachine Namespace
CinemachineCinemachineVirtualCameraBase
CinemachineLensSettings
CinemachineCinemachineComposer
CinemachineCinemachineTransposer
CinemachineCinemachineBasicMultiChannelPerlin


CinemachineVirtualCamera Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineVirtualCamera.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineVirtualCamera()
Cinemachine.CinemachineVirtualCamera = function();
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera Properties

The CinemachineVirtualCamera type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info (Inherited from CinemachineVirtualCameraBase.)
Public property | Follow | Get the Follow target for the Body component in the CinemachinePipeline. If this vcam is a part of a meta-camera collection, then the owner's target will be used if the local target is null. (Overrides CinemachineVirtualCameraBaseFollow.)
Public property | LiveChildOrSelf | Just returns self. (Inherited from CinemachineVirtualCameraBase.)
Public property | LookAt | Get the LookAt target for the Aim component in the CinemachinePipeline. If this vcam is a part of a meta-camera collection, then the owner's target will be used if the local target is null. (Overrides CinemachineVirtualCameraBaseLookAt.)
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name. (Inherited from CinemachineVirtualCameraBase.)
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam. (Inherited from CinemachineVirtualCameraBase.)
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself (Inherited from CinemachineVirtualCameraBase.)
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots. (Inherited from CinemachineVirtualCameraBase.)
Public property | State | The CameraState object holds all of the information necessary to position the Unity camera. It is the output of this class. (Overrides CinemachineVirtualCameraBaseState.)
Public property | UserIsDragging | API for the editor, to make the dragging of position handles behave better.
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy (Inherited from CinemachineVirtualCameraBase.)
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour. (Inherited from CinemachineVirtualCameraBase.)
Top
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.Follow Property

CinemachineVirtualCameraFollow Property

Get the Follow target for the Body component in the CinemachinePipeline. If this vcam is a part of a meta-camera collection, then the owner's target will be used if the local target is null.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform

Implements

ICinemachineCameraFollow
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.LookAt Property

CinemachineVirtualCameraLookAt Property

Get the LookAt target for the Aim component in the CinemachinePipeline. If this vcam is a part of a meta-camera collection, then the owner's target will be used if the local target is null.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform

Implements

ICinemachineCameraLookAt
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.State Property

CinemachineVirtualCameraState Property

The CameraState object holds all of the information necessary to position the Unity camera. It is the output of this class.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override CameraState State { get; }
function get_State();

Property Value

Type: CameraState

Implements

ICinemachineCameraState
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.UserIsDragging Property

CinemachineVirtualCameraUserIsDragging Property

API for the editor, to make the dragging of position handles behave better.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool UserIsDragging { get; set; }
function get_UserIsDragging();
function set_UserIsDragging(value);

Property Value

Type: Boolean
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera Methods

The CinemachineVirtualCamera type exposes the following members.

Methods
 | Name | Description
Public method | AddCinemachineComponentT | Add a component to the cinemachine pipeline.
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
Public method | DestroyCinemachineComponentT | Remove a component from the cinemachine pipeline.
Public method | GetCinemachineComponent(CinemachineCoreStage) | Get the component set for a specific stage.
Public method | GetCinemachineComponentT | Get an existing component of a specific type from the cinemachine pipeline.
Public method | GetComponentOwner | Get the hidden CinemachinePipeline child object.
Public method | GetComponentPipeline | Get the component pipeline owned by the hidden child pipline container. For most purposes, it is preferable to use the GetCinemachineComponent method.
Public method | InvalidateComponentPipeline | Editor API: Call this when changing the pipeline from the editor. Will force a rebuild of the pipeline cache.
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any). (Inherited from CinemachineVirtualCameraBase.)
Public method | IsLiveChild | Check whether the vcam a live child of this camera. This base class implementation always returns false. (Inherited from CinemachineVirtualCameraBase.)
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnDestroy | Calls the DestroyPipelineDelegate for destroying the hidden child object, to support undo. (Overrides CinemachineVirtualCameraBaseOnDestroy.)
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnEnable | Make sure that the pipeline cache is up-to-date. (Overrides CinemachineVirtualCameraBaseOnEnable.)
Public method | OnPositionDragged | API for the editor, to process a position drag from the user.
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method. (Inherited from CinemachineVirtualCameraBase.)
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. (Overrides CinemachineVirtualCameraBaseOnValidate.)
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Start | Base class implementation does nothing. (Inherited from CinemachineVirtualCameraBase.)
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date. (Inherited from CinemachineVirtualCameraBase.)
Public method | UpdateCameraState | Called by CinemachineCore at LateUpdate time so the vcam can position itself and track its targets. This class will invoke its pipeline and generate a CameraState for this frame. (Overrides CinemachineVirtualCameraBaseUpdateCameraState(Vector3, Single).)
Top
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.AddCinemachineComponent(T) Method

CinemachineVirtualCameraAddCinemachineComponentT Method

Add a component to the cinemachine pipeline.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public T AddCinemachineComponent<T>()
where T : CinemachineComponentBase

JavaScript does not support generic types or methods.

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:Cinemachine.CinemachineVirtualCamera.AddCinemachineComponent``1"]

See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.DestroyCinemachineComponent(T) Method

CinemachineVirtualCameraDestroyCinemachineComponentT Method

Remove a component from the cinemachine pipeline.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void DestroyCinemachineComponent<T>()
where T : CinemachineComponentBase

JavaScript does not support generic types or methods.

Type Parameters

T
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.GetCinemachineComponent Method

CinemachineVirtualCameraGetCinemachineComponent Method

Overload List
 | Name | Description
Public method | GetCinemachineComponentT | Get an existing component of a specific type from the cinemachine pipeline.
Public method | GetCinemachineComponent(CinemachineCoreStage) | Get the component set for a specific stage.
Top
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.GetCinemachineComponent(T) Method

CinemachineVirtualCameraGetCinemachineComponentT Method

Get an existing component of a specific type from the cinemachine pipeline.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public T GetCinemachineComponent<T>()
where T : CinemachineComponentBase

JavaScript does not support generic types or methods.

Type Parameters

T

Return Value

Type: T

[Missing <returns> documentation for "M:Cinemachine.CinemachineVirtualCamera.GetCinemachineComponent``1"]

See Also

Reference

CinemachineVirtualCamera Class
GetCinemachineComponent Overload


CinemachineVirtualCamera.GetCinemachineComponent Method (CinemachineCore.Stage)

CinemachineVirtualCameraGetCinemachineComponent Method (CinemachineCoreStage)

Get the component set for a specific stage.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineComponentBase GetCinemachineComponent(
    CinemachineCoreStage stage
)
function GetCinemachineComponent(stage);

Parameters

stage
Type: CinemachineCinemachineCoreStage
The stage for which we want the component

Return Value

Type: CinemachineComponentBase
The Cinemachine component for that stage, or null if not defined
See Also

Reference

CinemachineVirtualCamera Class
GetCinemachineComponent Overload


CinemachineVirtualCamera.GetComponentOwner Method

CinemachineVirtualCameraGetComponentOwner Method

Get the hidden CinemachinePipeline child object.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public Transform GetComponentOwner()
function GetComponentOwner();

Return Value

Type: Transform

[Missing <returns> documentation for "M:Cinemachine.CinemachineVirtualCamera.GetComponentOwner"]

See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.GetComponentPipeline Method

CinemachineVirtualCameraGetComponentPipeline Method

Get the component pipeline owned by the hidden child pipline container. For most purposes, it is preferable to use the GetCinemachineComponent method.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineComponentBase[] GetComponentPipeline()
function GetComponentPipeline();

Return Value

Type: CinemachineComponentBase

[Missing <returns> documentation for "M:Cinemachine.CinemachineVirtualCamera.GetComponentPipeline"]

See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.InvalidateComponentPipeline Method

CinemachineVirtualCameraInvalidateComponentPipeline Method

Editor API: Call this when changing the pipeline from the editor. Will force a rebuild of the pipeline cache.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void InvalidateComponentPipeline()
function InvalidateComponentPipeline();
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.OnDestroy Method

CinemachineVirtualCameraOnDestroy Method

Calls the DestroyPipelineDelegate for destroying the hidden child object, to support undo.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnDestroy()
function OnDestroy();
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.OnEnable Method

CinemachineVirtualCameraOnEnable Method

Make sure that the pipeline cache is up-to-date.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnEnable()
function OnEnable();
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.OnPositionDragged Method

CinemachineVirtualCameraOnPositionDragged Method

API for the editor, to process a position drag from the user.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void OnPositionDragged(
    Vector3 delta
)
function OnPositionDragged(delta);

Parameters

delta
Type: Vector3

[Missing <param name="delta"/> documentation for "M:Cinemachine.CinemachineVirtualCamera.OnPositionDragged(UnityEngine.Vector3)"]

See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.OnValidate Method

CinemachineVirtualCameraOnValidate Method

Enforce bounds for fields, when changed in inspector.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected override void OnValidate()
function OnValidate();
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.UpdateCameraState Method

CinemachineVirtualCameraUpdateCameraState Method

Called by CinemachineCore at LateUpdate time so the vcam can position itself and track its targets. This class will invoke its pipeline and generate a CameraState for this frame.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public override void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3

[Missing <param name="worldUp"/> documentation for "M:Cinemachine.CinemachineVirtualCamera.UpdateCameraState(UnityEngine.Vector3,System.Single)"]

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineVirtualCamera.UpdateCameraState(UnityEngine.Vector3,System.Single)"]

Implements

ICinemachineCameraUpdateCameraState(Vector3, Single)
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera Fields

The CinemachineVirtualCamera type exposes the following members.

Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor. (Inherited from CinemachineVirtualCameraBase.)
 | CreatePipelineOverride | Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in this class.
 | DestroyPipelineOverride | Override component pipeline destruction. This needs to be done by the editor to support Undo.
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_Follow | The object that the camera wants to move with (the Body target). The Body component of the CinemachineComponent pipeline will refer to this target and position the vcam in accordance with rules and settings that are provided to it. If this is null, then the vcam's Transform position will be used.
Public field | m_Lens | Specifies the LensSettings of this Virtual Camera. These settings will be transferred to the Unity camera when the vcam is live.
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI. (Inherited from CinemachineVirtualCameraBase.)
Public field | m_LookAt | The object that the camera wants to look at (the Aim target). The Aim component of the CinemachineComponent pipeline will refer to this target and orient the vcam in accordance with rules and settings that are provided to it. If this is null, then the vcam's Transform orientation will be used.
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority. (Inherited from CinemachineVirtualCameraBase.)
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. (Inherited from CinemachineVirtualCameraBase.)
 | PipelineName | This is the name of the hidden GameObject that will be created as a child object of the virtual camera. This hidden game object acts as a container for the polymorphic CinemachineComponent pipeline. The Inspector UI for the Virtual Camera provides access to this pipleline, as do the CinemachineComponent-family of public methods in this class. The lifecycle of the pipeline GameObject is managed automatically.
Top
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.CreatePipelineOverride Field

CinemachineVirtualCameraCreatePipelineOverride Field

Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in this class.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static CinemachineVirtualCameraCreatePipelineDelegate CreatePipelineOverride
var Cinemachine.CinemachineVirtualCamera.CreatePipelineOverride

Field Value

Type: CinemachineVirtualCameraCreatePipelineDelegate
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.DestroyPipelineOverride Field

CinemachineVirtualCameraDestroyPipelineOverride Field

Override component pipeline destruction. This needs to be done by the editor to support Undo.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static CinemachineVirtualCameraDestroyPipelineDelegate DestroyPipelineOverride
var Cinemachine.CinemachineVirtualCamera.DestroyPipelineOverride

Field Value

Type: CinemachineVirtualCameraDestroyPipelineDelegate
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.m_Follow Field

CinemachineVirtualCameram_Follow Field

The object that the camera wants to move with (the Body target). The Body component of the CinemachineComponent pipeline will refer to this target and position the vcam in accordance with rules and settings that are provided to it. If this is null, then the vcam's Transform position will be used.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The object that the camera wants to move with (the Body target).  If this is null, then the vcam's Transform position will define the camera's position.")]
[NoSaveDuringPlayAttribute]
public Transform m_Follow
var m_Follow

Field Value

Type: Transform
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.m_Lens Field

CinemachineVirtualCameram_Lens Field

Specifies the LensSettings of this Virtual Camera. These settings will be transferred to the Unity camera when the vcam is live.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[FormerlySerializedAsAttribute("m_LensAttributes")]
[TooltipAttribute("Specifies the lens properties of this Virtual Camera.  This generally mirrors the Unity Camera's lens settings, and will be used to drive the Unity camera when the vcam is active.")]
[LensSettingsPropertyAttribute]
public LensSettings m_Lens
var m_Lens

Field Value

Type: LensSettings
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.m_LookAt Field

CinemachineVirtualCameram_LookAt Field

The object that the camera wants to look at (the Aim target). The Aim component of the CinemachineComponent pipeline will refer to this target and orient the vcam in accordance with rules and settings that are provided to it. If this is null, then the vcam's Transform orientation will be used.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The object that the camera wants to look at (the Aim target).  If this is null, then the vcam's Transform orientation will define the camera's orientation.")]
[NoSaveDuringPlayAttribute]
public Transform m_LookAt
var m_LookAt

Field Value

Type: Transform
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.PipelineName Field

CinemachineVirtualCameraPipelineName Field

This is the name of the hidden GameObject that will be created as a child object of the virtual camera. This hidden game object acts as a container for the polymorphic CinemachineComponent pipeline. The Inspector UI for the Virtual Camera provides access to this pipleline, as do the CinemachineComponent-family of public methods in this class. The lifecycle of the pipeline GameObject is managed automatically.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public const string PipelineName = "cm"
var Cinemachine.CinemachineVirtualCamera.PipelineName

Field Value

Type: String
See Also

Reference

CinemachineVirtualCamera Class


CinemachineVirtualCamera.CreatePipelineDelegate Delegate

CinemachineVirtualCameraCreatePipelineDelegate Delegate

Override component pipeline creation. This needs to be done by the editor to support Undo. The override must do exactly the same thing as the CreatePipeline method in the CinemachineVirtualCamera class.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public delegate Transform CreatePipelineDelegate(
    CinemachineVirtualCamera vcam,
    string name,
    CinemachineComponentBase[] copyFrom
)
function(vcam, name, copyFrom);

Parameters

vcam
Type: CinemachineCinemachineVirtualCamera
name
Type: SystemString
copyFrom
Type: CinemachineCinemachineComponentBase

Return Value

Type: Transform
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineVirtualCamera.DestroyPipelineDelegate Delegate

CinemachineVirtualCameraDestroyPipelineDelegate Delegate

Override component pipeline destruction. This needs to be done by the editor to support Undo.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public delegate void DestroyPipelineDelegate(
    GameObject pipeline
)
function(pipeline);

Parameters

pipeline
Type: GameObject
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


CinemachineVirtualCameraBase Class

Base class for a Monobehaviour that represents a Virtual Camera within the Unity scene. This is intended to be attached to an empty Transform GameObject. Inherited classes can be either standalone virtual cameras such as CinemachineVirtualCamera, or meta-cameras such as CinemachineClearShot or CinemachineFreeLook. A CinemachineVirtualCameraBase exposes a Priority property. When the behaviour is enabled in the game, the Virtual Camera is automatically placed in a queue maintained by the static CinemachineCore singleton. The queue is sorted by priority. When a Unity camera is equipped with a CinemachineBrain behaviour, the brain will choose the camera at the head of the queue. If you have multiple Unity cameras with CinemachineBrain behaviours (say in a split-screen context), then you can filter the queue by setting the culling flags on the virtual cameras. The culling mask of the Unity Camera will then act as a filter for the brain. Apart from this, there is nothing that prevents a virtual camera from controlling multiple Unity cameras simultaneously.
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
More...

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SaveDuringPlayAttribute]
public abstract class CinemachineVirtualCameraBase : MonoBehaviour,
    ICinemachineCamera
Cinemachine.CinemachineVirtualCameraBase = function();

Type.createClass(
    'Cinemachine.CinemachineVirtualCameraBase',
    UnityEngine.MonoBehaviour,
    Cinemachine.ICinemachineCamera);

The CinemachineVirtualCameraBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CinemachineVirtualCameraBase |
Top
Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info
Public property | Follow | Get the Follow target for the Body component in the CinemachinePipeline.
Public property | LiveChildOrSelf | Just returns self.
Public property | LookAt | Get the LookAt target for the Aim component in the CinemachinePipeline.
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name.
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam.
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots.
Public property | State | The CameraState object holds all of the information necessary to position the Unity camera. It is the output of this class.
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour.
Top
Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage.
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any).
Public method | IsLiveChild | Check whether the vcam a live child of this camera. This base class implementation always returns false.
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live.
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue.
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date.
Protected method | OnEnable | Base class implementation adds the virtual camera from the priority queue.
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date.
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method.
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid.
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing.
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback.
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target.
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target.
Protected method | Start | Base class implementation does nothing.
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date.
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. Do not call this method. Let the framework do it at the appropriate time
Top
Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor.
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI.
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI.
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority.
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage.
Top
See Also

Reference

Cinemachine Namespace
Inheritance Hierarchy
SystemObject
Object
Component
Behaviour
MonoBehaviour
CinemachineCinemachineVirtualCameraBase
CinemachineCinemachineBlendListCamera
CinemachineCinemachineClearShot
CinemachineCinemachineExternalCamera
CinemachineCinemachineFreeLook
CinemachineCinemachineMixingCamera
CinemachineCinemachineStateDrivenCamera
CinemachineCinemachineVirtualCamera


CinemachineVirtualCameraBase Constructor

[Missing <summary> documentation for "M:Cinemachine.CinemachineVirtualCameraBase.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected CinemachineVirtualCameraBase()
Cinemachine.CinemachineVirtualCameraBase = function();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase Properties

The CinemachineVirtualCameraBase type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info
Public property | Follow | Get the Follow target for the Body component in the CinemachinePipeline.
Public property | LiveChildOrSelf | Just returns self.
Public property | LookAt | Get the LookAt target for the Aim component in the CinemachinePipeline.
Public property | Name | Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name.
Public property | ParentCamera | Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam.
Public property | PreviousStateIsValid | Set this to force the next update to ignore deltaTime and reset itself
Public property | Priority | Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots.
Public property | State | The CameraState object holds all of the information necessary to position the Unity camera. It is the output of this class.
Public property | ValidatingStreamVersion | Version that was last streamed, for upgrading legacy
Public property | VirtualCameraGameObject | The GameObject owner of the Virtual Camera behaviour.
Top
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.Description Property

CinemachineVirtualCameraBaseDescription Property

Gets a brief debug description of this virtual camera, for use when displayiong debug info

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual string Description { get; }
function get_Description();

Property Value

Type: String

Implements

ICinemachineCameraDescription
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.Follow Property

CinemachineVirtualCameraBaseFollow Property

Get the Follow target for the Body component in the CinemachinePipeline.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform

Implements

ICinemachineCameraFollow
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.LiveChildOrSelf Property

CinemachineVirtualCameraBaseLiveChildOrSelf Property

Just returns self.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual ICinemachineCamera LiveChildOrSelf { get; }
function get_LiveChildOrSelf();

Property Value

Type: ICinemachineCamera

Implements

ICinemachineCameraLiveChildOrSelf
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.LookAt Property

CinemachineVirtualCameraBaseLookAt Property

Get the LookAt target for the Aim component in the CinemachinePipeline.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform

Implements

ICinemachineCameraLookAt
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.Name Property

CinemachineVirtualCameraBaseName Property

Get the name of the Virtual Camera. Base implementation returns the owner GameObject's name.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public string Name { get; }
function get_Name();

Property Value

Type: String

Implements

ICinemachineCameraName
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.ParentCamera Property

CinemachineVirtualCameraBaseParentCamera Property

Support for meta-virtual-cameras. This is the situation where a virtual camera is in fact the public face of a private army of virtual cameras, which it manages on its own. This method gets the VirtualCamera owner, if any. Private armies are implemented as Transform children of the parent vcam.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public ICinemachineCamera ParentCamera { get; }
function get_ParentCamera();

Property Value

Type: ICinemachineCamera

Implements

ICinemachineCameraParentCamera
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.PreviousStateIsValid Property

CinemachineVirtualCameraBasePreviousStateIsValid Property

Set this to force the next update to ignore deltaTime and reset itself

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public bool PreviousStateIsValid { get; set; }
function get_PreviousStateIsValid();
function set_PreviousStateIsValid(value);

Property Value

Type: Boolean
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.Priority Property

CinemachineVirtualCameraBasePriority Property

Get the Priority of the virtual camera. This determines its placement in the CinemachineCore's queue of eligible shots.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public int Priority { get; set; }
function get_Priority();
function set_Priority(value);

Property Value

Type: Int32

Implements

ICinemachineCameraPriority
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.State Property

CinemachineVirtualCameraBaseState Property

The CameraState object holds all of the information necessary to position the Unity camera. It is the output of this class.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract CameraState State { get; }
function get_State();

Property Value

Type: CameraState

Implements

ICinemachineCameraState
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.ValidatingStreamVersion Property

CinemachineVirtualCameraBaseValidatingStreamVersion Property

Version that was last streamed, for upgrading legacy

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public int ValidatingStreamVersion { get; }
function get_ValidatingStreamVersion();

Property Value

Type: Int32
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.VirtualCameraGameObject Property

CinemachineVirtualCameraBaseVirtualCameraGameObject Property

The GameObject owner of the Virtual Camera behaviour.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public GameObject VirtualCameraGameObject { get; }
function get_VirtualCameraGameObject();

Property Value

Type: GameObject

Implements

ICinemachineCameraVirtualCameraGameObject
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase Methods

The CinemachineVirtualCameraBase type exposes the following members.

Methods
 | Name | Description
Public method | AddPostPipelineStageHook | A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage.
Protected method | InvokePostPipelineStageCallback | Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any).
Public method | IsLiveChild | Check whether the vcam a live child of this camera. This base class implementation always returns false.
Public method | MoveToTopOfPrioritySubqueue | When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live.
Protected method | OnDestroy | Base class implementation removes the virtual camera from the priority queue.
Protected method | OnDisable | Base class implementation makes sure the priority queue remains up-to-date.
Protected method | OnEnable | Base class implementation adds the virtual camera from the priority queue.
Protected method | OnTransformParentChanged | Base class implementation makes sure the priority queue remains up-to-date.
Public method | OnTransitionFromCamera | Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method.
Protected method | OnValidate | Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid.
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing.
Public method | RemovePostPipelineStageHook | Remove a Pipeline stage hook callback.
Protected method | ResolveFollow | Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target.
Protected method | ResolveLookAt | Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target.
Protected method | Start | Base class implementation does nothing.
Protected method | Update | Base class implementation makes sure the priority queue remains up-to-date.
Public method | UpdateCameraState | Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. Do not call this method. Let the framework do it at the appropriate time
Top
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.AddPostPipelineStageHook Method

CinemachineVirtualCameraBaseAddPostPipelineStageHook Method

A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow others to hook into the pipeline. See CinemachineCore.Stage.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual void AddPostPipelineStageHook(
    CinemachineVirtualCameraBaseOnPostPipelineStageDelegate d
)
function AddPostPipelineStageHook(d);

Parameters

d
Type: CinemachineCinemachineVirtualCameraBaseOnPostPipelineStageDelegate
The delegate to call.
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.InvokePostPipelineStageCallback Method

CinemachineVirtualCameraBaseInvokePostPipelineStageCallback Method

Invokes the PostPipelineStageDelegate for this camera, and up the hierarchy for all parent cameras (if any).

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected void InvokePostPipelineStageCallback(
    CinemachineVirtualCameraBase vcam,
    CinemachineCoreStage stage,
    ref CameraState newState,
    float deltaTime
)
function InvokePostPipelineStageCallback(vcam, stage, newState, deltaTime);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase

[Missing <param name="vcam"/> documentation for "M:Cinemachine.CinemachineVirtualCameraBase.InvokePostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

stage
Type: CinemachineCinemachineCoreStage

[Missing <param name="stage"/> documentation for "M:Cinemachine.CinemachineVirtualCameraBase.InvokePostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

newState
Type: CinemachineCameraState

[Missing <param name="newState"/> documentation for "M:Cinemachine.CinemachineVirtualCameraBase.InvokePostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

deltaTime
Type: SystemSingle

[Missing <param name="deltaTime"/> documentation for "M:Cinemachine.CinemachineVirtualCameraBase.InvokePostPipelineStageCallback(Cinemachine.CinemachineVirtualCameraBase,Cinemachine.CinemachineCore.Stage,Cinemachine.CameraState@,System.Single)"]

See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.IsLiveChild Method

CinemachineVirtualCameraBaseIsLiveChild Method

Check whether the vcam a live child of this camera. This base class implementation always returns false.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual bool IsLiveChild(
    ICinemachineCamera vcam
)
function IsLiveChild(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The Virtual Camera to check

Return Value

Type: Boolean
True if the vcam is currently actively influencing the state of this vcam

Implements

ICinemachineCameraIsLiveChild(ICinemachineCamera)
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.MoveToTopOfPrioritySubqueue Method

CinemachineVirtualCameraBaseMoveToTopOfPrioritySubqueue Method

When multiple virtual cameras have the highest priority, there is sometimes the need to push one to the top, making it the current Live camera if it shares the highest priority in the queue with its peers. This happens automatically when a new vcam is enabled: the most recent one goes to the top of the priority subqueue. Use this method to push a vcam to the top of its priority peers. If it and its peers share the highest priority, then this vcam will become Live.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void MoveToTopOfPrioritySubqueue()
function MoveToTopOfPrioritySubqueue();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.OnDestroy Method

CinemachineVirtualCameraBaseOnDestroy Method

Base class implementation removes the virtual camera from the priority queue.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void OnDestroy()
function OnDestroy();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.OnDisable Method

CinemachineVirtualCameraBaseOnDisable Method

Base class implementation makes sure the priority queue remains up-to-date.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void OnDisable()
function OnDisable();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.OnEnable Method

CinemachineVirtualCameraBaseOnEnable Method

Base class implementation adds the virtual camera from the priority queue.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void OnEnable()
function OnEnable();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.OnTransformParentChanged Method

CinemachineVirtualCameraBaseOnTransformParentChanged Method

Base class implementation makes sure the priority queue remains up-to-date.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void OnTransformParentChanged()
function OnTransformParentChanged();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.OnTransitionFromCamera Method

CinemachineVirtualCameraBaseOnTransitionFromCamera Method

Notification that this virtual camera is going live. Base class implementationmust be called by any overridden method.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual void OnTransitionFromCamera(
    ICinemachineCamera fromCam
)
function OnTransitionFromCamera(fromCam);

Parameters

fromCam
Type: CinemachineICinemachineCamera
The camera being deactivated. May be null.

Implements

ICinemachineCameraOnTransitionFromCamera(ICinemachineCamera)
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.OnValidate Method

CinemachineVirtualCameraBaseOnValidate Method

Enforce bounds for fields, when changed in inspector. Call base class implementation at the beginning of overridden method. After base method is called, ValidatingStreamVersion will be valid.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void OnValidate()
function OnValidate();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.PreUpdateChildCameras Method

CinemachineVirtualCameraBasePreUpdateChildCameras Method

This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead. Base class implementation does nothing.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual void PreUpdateChildCameras(
    Vector3 worldUp,
    float deltaTime
)
function PreUpdateChildCameras(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)

Implements

ICinemachineCameraPreUpdateChildCameras(Vector3, Single)
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.RemovePostPipelineStageHook Method

CinemachineVirtualCameraBaseRemovePostPipelineStageHook Method

Remove a Pipeline stage hook callback.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public virtual void RemovePostPipelineStageHook(
    CinemachineVirtualCameraBaseOnPostPipelineStageDelegate d
)
function RemovePostPipelineStageHook(d);

Parameters

d
Type: CinemachineCinemachineVirtualCameraBaseOnPostPipelineStageDelegate
The delegate to remove.
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.ResolveFollow Method

CinemachineVirtualCameraBaseResolveFollow Method

Returns this vcam's Follow target, or if that is null, will retrun the parent vcam's Follow target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected Transform ResolveFollow(
    Transform localFollow
)
function ResolveFollow(localFollow);

Parameters

localFollow
Type: Transform
This vcam's Follow value.

Return Value

Type: Transform
The same value, or the parent's if null and a parent exists.
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.ResolveLookAt Method

CinemachineVirtualCameraBaseResolveLookAt Method

Returns this vcam's LookAt target, or if that is null, will retrun the parent vcam's LookAt target.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected Transform ResolveLookAt(
    Transform localLookAt
)
function ResolveLookAt(localLookAt);

Parameters

localLookAt
Type: Transform
This vcam's LookAt value.

Return Value

Type: Transform
The same value, or the parent's if null and a parent exists.
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.Start Method

CinemachineVirtualCameraBaseStart Method

Base class implementation does nothing.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void Start()
function Start();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.Update Method

CinemachineVirtualCameraBaseUpdate Method

Base class implementation makes sure the priority queue remains up-to-date.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected virtual void Update()
function Update();
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.UpdateCameraState Method

CinemachineVirtualCameraBaseUpdateCameraState Method

Called by CinemachineCore at designated update time so the vcam can position itself and track its targets. Do not call this method. Let the framework do it at the appropriate time

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public abstract void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)

Implements

ICinemachineCameraUpdateCameraState(Vector3, Single)
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase Fields

The CinemachineVirtualCameraBase type exposes the following members.

Fields
 | Name | Description
Public field | CinemachineGUIDebuggerCallback | This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor.
Public field | m_ExcludedPropertiesInInspector | Inspector control - Use for hiding sections of the Inspector UI.
Public field | m_LockStageInInspector | Inspector control - Use for enabling sections of the Inspector UI.
Public field | m_Priority | The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority.
Protected field | OnPostPipelineStage | A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage.
Top
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.CinemachineGUIDebuggerCallback Field

CinemachineVirtualCameraBaseCinemachineGUIDebuggerCallback Field

This is deprecated. It is here to support the soon-to-be-removed Cinemachine Debugger in the Editor.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HideInInspector]
[NoSaveDuringPlayAttribute]
public Action CinemachineGUIDebuggerCallback
var CinemachineGUIDebuggerCallback

Field Value

Type: Action
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.m_ExcludedPropertiesInInspector Field

CinemachineVirtualCameraBasem_ExcludedPropertiesInInspector Field

Inspector control - Use for hiding sections of the Inspector UI.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HideInInspector]
[SerializeField]
[NoSaveDuringPlayAttribute]
public string[] m_ExcludedPropertiesInInspector
var m_ExcludedPropertiesInInspector

Field Value

Type: String
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.m_LockStageInInspector Field

CinemachineVirtualCameraBasem_LockStageInInspector Field

Inspector control - Use for enabling sections of the Inspector UI.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[HideInInspector]
[SerializeField]
[NoSaveDuringPlayAttribute]
public CinemachineCoreStage[] m_LockStageInInspector
var m_LockStageInInspector

Field Value

Type: CinemachineCoreStage
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.m_Priority Field

CinemachineVirtualCameraBasem_Priority Field

The priority will determine which camera becomes active based on the state of other cameras and this camera. Higher numbers have greater priority.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[NoSaveDuringPlayAttribute]
[TooltipAttribute("The priority will determine which camera becomes active based on the state of other cameras and this camera.  Higher numbers have greater priority.")]
public int m_Priority
var m_Priority

Field Value

Type: Int32
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.OnPostPipelineStage Field

CinemachineVirtualCameraBaseOnPostPipelineStage Field

A delegate to hook into the state calculation pipeline. Implementaion must be sure to call this after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
protected CinemachineVirtualCameraBaseOnPostPipelineStageDelegate OnPostPipelineStage
var OnPostPipelineStage

Field Value

Type: CinemachineVirtualCameraBaseOnPostPipelineStageDelegate
See Also

Reference

CinemachineVirtualCameraBase Class


CinemachineVirtualCameraBase.OnPostPipelineStageDelegate Delegate

CinemachineVirtualCameraBaseOnPostPipelineStageDelegate Delegate

A delegate to hook into the state calculation pipeline. This will be called after each pipeline stage, to allow other services to hook into the pipeline. See CinemachineCore.Stage. Parameters: * CinemachineVirtualCameraBase vcam: the virtual camera being updated * CinemachineCore.Stage stage: what stage in the pipeline has just been updated * ref CameraState newState: the current state of the vcam * float deltaTime: the frame timestep. Less than 0 means "don't consider the previous frame"

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public delegate void OnPostPipelineStageDelegate(
    CinemachineVirtualCameraBase vcam,
    CinemachineCoreStage stage,
    ref CameraState newState,
    float deltaTime
)
function(vcam, stage, newState, deltaTime);

Parameters

vcam
Type: CinemachineCinemachineVirtualCameraBase
stage
Type: CinemachineCinemachineCoreStage
newState
Type: CinemachineCameraState
deltaTime
Type: SystemSingle
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


DocumentationSortingAttribute Class

Atrtribute to control the automatic generation of documentation.
Inheritance Hierarchy
SystemObject
SystemAttribute
CinemachineDocumentationSortingAttribute

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(0f, DocumentationSortingAttributeLevel.Undoc)]
public sealed class DocumentationSortingAttribute : Attribute
Cinemachine.DocumentationSortingAttribute = function();

Type.createClass(
    'Cinemachine.DocumentationSortingAttribute',
    Attribute);

The DocumentationSortingAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | DocumentationSortingAttribute | Contructor with specific values
Top
Properties
 | Name | Description
Public property | Category | Refinement level of the documentation. The more refined, the more is excluded.
Public property | SortOrder | Where this type appears in the manual. Smaller number sort earlier.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


DocumentationSortingAttribute Constructor

Contructor with specific values

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public DocumentationSortingAttribute(
    float sortOrder,
    DocumentationSortingAttributeLevel category
)
Cinemachine.DocumentationSortingAttribute = function(sortOrder, category);

Parameters

sortOrder
Type: SystemSingle

[Missing <param name="sortOrder"/> documentation for "M:Cinemachine.DocumentationSortingAttribute.#ctor(System.Single,Cinemachine.DocumentationSortingAttribute.Level)"]

category
Type: CinemachineDocumentationSortingAttributeLevel

[Missing <param name="category"/> documentation for "M:Cinemachine.DocumentationSortingAttribute.#ctor(System.Single,Cinemachine.DocumentationSortingAttribute.Level)"]

See Also

Reference

DocumentationSortingAttribute Class


DocumentationSortingAttribute Properties

The DocumentationSortingAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Category | Refinement level of the documentation. The more refined, the more is excluded.
Public property | SortOrder | Where this type appears in the manual. Smaller number sort earlier.
Top
See Also

Reference

DocumentationSortingAttribute Class


DocumentationSortingAttribute.Category Property

DocumentationSortingAttributeCategory Property

Refinement level of the documentation. The more refined, the more is excluded.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public DocumentationSortingAttributeLevel Category { get; }
function get_Category();

Property Value

Type: DocumentationSortingAttributeLevel
See Also

Reference

DocumentationSortingAttribute Class


DocumentationSortingAttribute.SortOrder Property

DocumentationSortingAttributeSortOrder Property

Where this type appears in the manual. Smaller number sort earlier.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public float SortOrder { get; }
function get_SortOrder();

Property Value

Type: Single
See Also

Reference

DocumentationSortingAttribute Class


DocumentationSortingAttribute.Level Enumeration

DocumentationSortingAttributeLevel Enumeration

Refinement level of the documentation

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public enum Level
Cinemachine.Level = function();
Cinemachine.Level.createEnum('Cinemachine.Level', false);
Members
Member name | Value | Description
Undoc | 0 | Type is excluded from documentation
API | 1 | Type is documented in the API reference
UserRef | 2 | Type is documented in the highly-refined User Manual
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


ICinemachineCamera Interface

An abstract representation of a virtual camera which lives within the Unity scene

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public interface ICinemachineCamera
Cinemachine.ICinemachineCamera = function();
Cinemachine.ICinemachineCamera.createInterface('Cinemachine.ICinemachineCamera');

The ICinemachineCamera type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info
Public property | Follow | The thing the camera wants to follow (moving camera). May be null.
Public property | LiveChildOrSelf | For cameras that implement child cameras, return the live child, otherwise, just returns self.
Public property | LookAt | The thing the camera wants to look at (aim). May be null.
Public property | Name | Gets the name of this virtual camera. For use when deciding how to blend to or from this camera
Public property | ParentCamera | For cameras that implement child cameras, returns the parent vcam, otherwise null.
Public property | Priority | Gets the priority of this ICinemachineCamera. The virtual camera will be inserted into the global priority stack based on this value.
Public property | State | Camera state at the current time.
Public property | VirtualCameraGameObject | Gets the virtual camera game attached to this class.
Top
Methods
 | Name | Description
Public method | IsLiveChild | Check whether the vcam is a live child of this camera.
Public method | OnTransitionFromCamera | Notification that a new camera is being activated. This is sent to the currently active camera. Both may be active simultaneously for a while, if blending.
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead.
Public method | UpdateCameraState | Updates this Cinemachine Camera. For an active camera this should be called once and only once each frame. To guarantee this, you should never call this method directly. Always use CinemachineCore.UpdateVirtualCamera(ICinemachineCamera, float), which has protection against multiple calls per frame.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


ICinemachineCamera Properties

The ICinemachineCamera type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets a brief debug description of this virtual camera, for use when displayiong debug info
Public property | Follow | The thing the camera wants to follow (moving camera). May be null.
Public property | LiveChildOrSelf | For cameras that implement child cameras, return the live child, otherwise, just returns self.
Public property | LookAt | The thing the camera wants to look at (aim). May be null.
Public property | Name | Gets the name of this virtual camera. For use when deciding how to blend to or from this camera
Public property | ParentCamera | For cameras that implement child cameras, returns the parent vcam, otherwise null.
Public property | Priority | Gets the priority of this ICinemachineCamera. The virtual camera will be inserted into the global priority stack based on this value.
Public property | State | Camera state at the current time.
Public property | VirtualCameraGameObject | Gets the virtual camera game attached to this class.
Top
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.Description Property

ICinemachineCameraDescription Property

Gets a brief debug description of this virtual camera, for use when displayiong debug info

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
string Description { get; }
function get_Description();

Property Value

Type: String
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.Follow Property

ICinemachineCameraFollow Property

The thing the camera wants to follow (moving camera). May be null.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
Transform Follow { get; set; }
function get_Follow();
function set_Follow(value);

Property Value

Type: Transform
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.LiveChildOrSelf Property

ICinemachineCameraLiveChildOrSelf Property

For cameras that implement child cameras, return the live child, otherwise, just returns self.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
ICinemachineCamera LiveChildOrSelf { get; }
function get_LiveChildOrSelf();

Property Value

Type: ICinemachineCamera
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.LookAt Property

ICinemachineCameraLookAt Property

The thing the camera wants to look at (aim). May be null.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
Transform LookAt { get; set; }
function get_LookAt();
function set_LookAt(value);

Property Value

Type: Transform
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.Name Property

ICinemachineCameraName Property

Gets the name of this virtual camera. For use when deciding how to blend to or from this camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
string Name { get; }
function get_Name();

Property Value

Type: String
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.ParentCamera Property

ICinemachineCameraParentCamera Property

For cameras that implement child cameras, returns the parent vcam, otherwise null.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
ICinemachineCamera ParentCamera { get; }
function get_ParentCamera();

Property Value

Type: ICinemachineCamera
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.Priority Property

ICinemachineCameraPriority Property

Gets the priority of this ICinemachineCamera. The virtual camera will be inserted into the global priority stack based on this value.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
int Priority { get; set; }
function get_Priority();
function set_Priority(value);

Property Value

Type: Int32
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.State Property

ICinemachineCameraState Property

Camera state at the current time.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
CameraState State { get; }
function get_State();

Property Value

Type: CameraState
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.VirtualCameraGameObject Property

ICinemachineCameraVirtualCameraGameObject Property

Gets the virtual camera game attached to this class.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
GameObject VirtualCameraGameObject { get; }
function get_VirtualCameraGameObject();

Property Value

Type: GameObject
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera Methods

The ICinemachineCamera type exposes the following members.

Methods
 | Name | Description
Public method | IsLiveChild | Check whether the vcam is a live child of this camera.
Public method | OnTransitionFromCamera | Notification that a new camera is being activated. This is sent to the currently active camera. Both may be active simultaneously for a while, if blending.
Public method | PreUpdateChildCameras | This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead.
Public method | UpdateCameraState | Updates this Cinemachine Camera. For an active camera this should be called once and only once each frame. To guarantee this, you should never call this method directly. Always use CinemachineCore.UpdateVirtualCamera(ICinemachineCamera, float), which has protection against multiple calls per frame.
Top
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.IsLiveChild Method

ICinemachineCameraIsLiveChild Method

Check whether the vcam is a live child of this camera.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
bool IsLiveChild(
    ICinemachineCamera vcam
)
function IsLiveChild(vcam);

Parameters

vcam
Type: CinemachineICinemachineCamera
The Virtual Camera to check

Return Value

Type: Boolean
True if the vcam is currently actively influencing the state of this vcam
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.OnTransitionFromCamera Method

ICinemachineCameraOnTransitionFromCamera Method

Notification that a new camera is being activated. This is sent to the currently active camera. Both may be active simultaneously for a while, if blending.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
void OnTransitionFromCamera(
    ICinemachineCamera fromCam
)
function OnTransitionFromCamera(fromCam);

Parameters

fromCam
Type: CinemachineICinemachineCamera
The camera being deactivated. May be null.
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.PreUpdateChildCameras Method

ICinemachineCameraPreUpdateChildCameras Method

This is called prior to the updating of the vcam's child cameras, in order to allow the parent to prepare its children. If the children are updating on FixedUpdate, then this will not necessarily be called prior to every FixedUpdate, but it might be called on LateUpdate instead.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
void PreUpdateChildCameras(
    Vector3 worldUp,
    float deltaTime
)
function PreUpdateChildCameras(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)
See Also

Reference

ICinemachineCamera Interface


ICinemachineCamera.UpdateCameraState Method

ICinemachineCameraUpdateCameraState Method

Updates this Cinemachine Camera. For an active camera this should be called once and only once each frame. To guarantee this, you should never call this method directly. Always use CinemachineCore.UpdateVirtualCamera(ICinemachineCamera, float), which has protection against multiple calls per frame.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
void UpdateCameraState(
    Vector3 worldUp,
    float deltaTime
)
function UpdateCameraState(worldUp, deltaTime);

Parameters

worldUp
Type: Vector3
Default world Up, set by the CinemachineBrain
deltaTime
Type: SystemSingle
Delta time for time-based effects (ignore if less than 0)
See Also

Reference

ICinemachineCamera Interface


LensSettings Structure

Describes the FOV and clip planes for a camera. This generally mirrors the Unity Camera's lens settings, and will be used to drive the Unity camera when the vcam is active.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(2f, DocumentationSortingAttributeLevel.UserRef)]
public struct LensSettings
JavaScript supports the use of structures, but not the declaration of new ones.

The LensSettings type exposes the following members.

Constructors
 | Name | Description
Public method | LensSettings | Explicit constructor for this LensSettings
Top
Methods
 | Name | Description
 | FromCamera | Creates a new LensSettings, copying the values from the supplied Camera
 | Lerp | Linearly blends the fields of two LensSettings and returns the result
Public method | Validate | Make sure lens settings are sane. Call this from OnValidate().
Top
Fields
 | Name | Description
 | Default | Default Lens Settings
Public field | Dutch | The dutch (tilt) to be applied to the camera. In degrees
Public field | FarClipPlane | The far clip plane for this LensSettings
Public field | FieldOfView | This is the camera view in vertical degrees. For cinematic people, a 50mm lens on a super-35mm sensor would equal a 19.6 degree FOV
Public field | NearClipPlane | The near clip plane for this LensSettings
Public field | OrthographicSize | When using an orthographic camera, this defines the height, in world co-ordinates, of the camera view.
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


LensSettings Constructor

Explicit constructor for this LensSettings

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public LensSettings(
    float fov,
    float orthographicSize,
    float nearClip,
    float farClip,
    float dutch,
    bool ortho,
    float aspect
)
Cinemachine.LensSettings = function(fov, orthographicSize, nearClip, farClip, dutch, ortho, aspect);

Parameters

fov
Type: SystemSingle
The Vertical field of view
orthographicSize
Type: SystemSingle
If orthographic, this is the half-height of the screen
nearClip
Type: SystemSingle
The near clip plane
farClip
Type: SystemSingle
The far clip plane
dutch
Type: SystemSingle
Camera roll, in degrees. This is applied at the end Whether the lens is orthographicThe aspect ratio of the lens Width/height after shot composition.
ortho
Type: SystemBoolean

[Missing <param name="ortho"/> documentation for "M:Cinemachine.LensSettings.#ctor(System.Single,System.Single,System.Single,System.Single,System.Single,System.Boolean,System.Single)"]

aspect
Type: SystemSingle

[Missing <param name="aspect"/> documentation for "M:Cinemachine.LensSettings.#ctor(System.Single,System.Single,System.Single,System.Single,System.Single,System.Boolean,System.Single)"]

See Also

Reference

LensSettings Structure


LensSettings Methods

The LensSettings type exposes the following members.

Methods
 | Name | Description
 | FromCamera | Creates a new LensSettings, copying the values from the supplied Camera
 | Lerp | Linearly blends the fields of two LensSettings and returns the result
Public method | Validate | Make sure lens settings are sane. Call this from OnValidate().
Top
See Also

Reference

LensSettings Structure


LensSettings.FromCamera Method

LensSettingsFromCamera Method

Creates a new LensSettings, copying the values from the supplied Camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static LensSettings FromCamera(
    Camera fromCamera
)
Cinemachine.LensSettings.FromCamera = function(fromCamera);

Parameters

fromCamera
Type: Camera
The Camera from which the FoV, near and far clip planes will be copied.

Return Value

Type: LensSettings

[Missing <returns> documentation for "M:Cinemachine.LensSettings.FromCamera(UnityEngine.Camera)"]

See Also

Reference

LensSettings Structure


LensSettings.Lerp Method

LensSettingsLerp Method

Linearly blends the fields of two LensSettings and returns the result

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static LensSettings Lerp(
    LensSettings lensA,
    LensSettings lensB,
    float t
)
Cinemachine.LensSettings.Lerp = function(lensA, lensB, t);

Parameters

lensA
Type: CinemachineLensSettings
The LensSettings to blend from
lensB
Type: CinemachineLensSettings
The LensSettings to blend to
t
Type: SystemSingle
The interpolation value. Internally clamped to the range [0,1]

Return Value

Type: LensSettings
Interpolated settings
See Also

Reference

LensSettings Structure


LensSettings.Validate Method

LensSettingsValidate Method

Make sure lens settings are sane. Call this from OnValidate().

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public void Validate()
function Validate();
See Also

Reference

LensSettings Structure


LensSettings Fields

The LensSettings type exposes the following members.

Fields
 | Name | Description
 | Default | Default Lens Settings
Public field | Dutch | The dutch (tilt) to be applied to the camera. In degrees
Public field | FarClipPlane | The far clip plane for this LensSettings
Public field | FieldOfView | This is the camera view in vertical degrees. For cinematic people, a 50mm lens on a super-35mm sensor would equal a 19.6 degree FOV
Public field | NearClipPlane | The near clip plane for this LensSettings
Public field | OrthographicSize | When using an orthographic camera, this defines the height, in world co-ordinates, of the camera view.
Top
See Also

Reference

LensSettings Structure


LensSettings.Default Field

LensSettingsDefault Field

Default Lens Settings

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static LensSettings Default
var Cinemachine.LensSettings.Default

Field Value

Type: LensSettings
See Also

Reference

LensSettings Structure


LensSettings.Dutch Field

LensSettingsDutch Field

The dutch (tilt) to be applied to the camera. In degrees

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(-180f, 180f)]
[TooltipAttribute("Camera Z roll, or tilt, in degrees.")]
public float Dutch
var Dutch

Field Value

Type: Single
See Also

Reference

LensSettings Structure


LensSettings.FarClipPlane Field

LensSettingsFarClipPlane Field

The far clip plane for this LensSettings

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("This defines the far region of the renderable range of the camera frustum. Typically you want to set this value as low as possible without cutting off desired distant objects")]
public float FarClipPlane
var FarClipPlane

Field Value

Type: Single
See Also

Reference

LensSettings Structure


LensSettings.FieldOfView Field

LensSettingsFieldOfView Field

This is the camera view in vertical degrees. For cinematic people, a 50mm lens on a super-35mm sensor would equal a 19.6 degree FOV

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[RangeAttribute(1f, 179f)]
[TooltipAttribute("This is the camera view in vertical degrees. For cinematic people, a 50mm lens on a super-35mm sensor would equal a 19.6 degree FOV")]
public float FieldOfView
var FieldOfView

Field Value

Type: Single
See Also

Reference

LensSettings Structure


LensSettings.NearClipPlane Field

LensSettingsNearClipPlane Field

The near clip plane for this LensSettings

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("This defines the near region in the renderable range of the camera frustum. Raising this value will stop the game from drawing things near the camera, which can sometimes come in handy.  Larger values will also increase your shadow resolution.")]
public float NearClipPlane
var NearClipPlane

Field Value

Type: Single
See Also

Reference

LensSettings Structure


LensSettings.OrthographicSize Field

LensSettingsOrthographicSize Field

When using an orthographic camera, this defines the height, in world co-ordinates, of the camera view.

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("When using an orthographic camera, this defines the half-height, in world coordinates, of the camera view.")]
public float OrthographicSize
var OrthographicSize

Field Value

Type: Single
See Also

Reference

LensSettings Structure


LensSettingsPropertyAttribute Class

Property applied to LensSettings. Used for custom drawing in the inspector.
Inheritance Hierarchy
SystemObject
SystemAttribute
PropertyAttribute
CinemachineLensSettingsPropertyAttribute

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public sealed class LensSettingsPropertyAttribute : PropertyAttribute
Cinemachine.LensSettingsPropertyAttribute = function();

Type.createClass(
    'Cinemachine.LensSettingsPropertyAttribute',
    UnityEngine.PropertyAttribute);

The LensSettingsPropertyAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | LensSettingsPropertyAttribute |
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


LensSettingsPropertyAttribute Constructor

[Missing <summary> documentation for "M:Cinemachine.LensSettingsPropertyAttribute.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public LensSettingsPropertyAttribute()
Cinemachine.LensSettingsPropertyAttribute = function();
See Also

Reference

LensSettingsPropertyAttribute Class


NoiseSettings Class

This is an asset that defines a noise profile. A noise profile is the shape of the noise as a function of time. You can build arbitrarily complex shapes by combining different base perlin noise frequencies at different amplitudes. The frequencies and amplitudes should be chosen with care, to ensure an interesting noise quality that is not obviously repetitive. As a mathematical side-note, any arbitrary periodic curve can be broken down into a series of fixed-amplitude sine-waves added together. This is called fourier decomposition, and is the basis of much signal processing. It doesn't really have much to do with this asset, but it's super interesting!
Inheritance Hierarchy
SystemObject
Object
ScriptableObject
CinemachineNoiseSettings

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(9f, DocumentationSortingAttributeLevel.UserRef)]
public sealed class NoiseSettings : ScriptableObject
Cinemachine.NoiseSettings = function();

Type.createClass(
    'Cinemachine.NoiseSettings',
    UnityEngine.ScriptableObject);

The NoiseSettings type exposes the following members.

Constructors
 | Name | Description
Public method | NoiseSettings |
Top
Properties
 | Name | Description
Public property | OrientationNoise | Gets the array of orientation noise channels for this NoiseSettings
Public property | PositionNoise | Gets the array of positional noise channels for this NoiseSettings
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


NoiseSettings Constructor

[Missing <summary> documentation for "M:Cinemachine.NoiseSettings.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public NoiseSettings()
Cinemachine.NoiseSettings = function();
See Also

Reference

NoiseSettings Class


NoiseSettings Properties

The NoiseSettings type exposes the following members.

Properties
 | Name | Description
Public property | OrientationNoise | Gets the array of orientation noise channels for this NoiseSettings
Public property | PositionNoise | Gets the array of positional noise channels for this NoiseSettings
Top
See Also

Reference

NoiseSettings Class


NoiseSettings.OrientationNoise Property

NoiseSettingsOrientationNoise Property

Gets the array of orientation noise channels for this NoiseSettings

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public NoiseSettingsTransformNoiseParams[] OrientationNoise { get; }
function get_OrientationNoise();

Property Value

Type: NoiseSettingsTransformNoiseParams
See Also

Reference

NoiseSettings Class


NoiseSettings.PositionNoise Property

NoiseSettingsPositionNoise Property

Gets the array of positional noise channels for this NoiseSettings

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public NoiseSettingsTransformNoiseParams[] PositionNoise { get; }
function get_PositionNoise();

Property Value

Type: NoiseSettingsTransformNoiseParams
See Also

Reference

NoiseSettings Class


NoiseSettings.NoiseParams Structure

NoiseSettingsNoiseParams Structure

Describes the behaviour for a channel of noise

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(9.1f, DocumentationSortingAttributeLevel.UserRef)]
public struct NoiseParams
JavaScript supports the use of structures, but not the declaration of new ones.

The NoiseSettingsNoiseParams type exposes the following members.

Fields
 | Name | Description
Public field | Amplitude | The amplitude of the noise for this channel. Larger numbers vibrate higher
Public field | Frequency | The frequency of noise for this channel. Higher magnitudes vibrate faster
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


NoiseParams Fields

The NoiseSettingsNoiseParams type exposes the following members.

Fields
 | Name | Description
Public field | Amplitude | The amplitude of the noise for this channel. Larger numbers vibrate higher
Public field | Frequency | The frequency of noise for this channel. Higher magnitudes vibrate faster
Top
See Also

Reference

NoiseSettingsNoiseParams Structure


NoiseSettings.NoiseParams.Amplitude Field

NoiseSettingsNoiseParamsAmplitude Field

The amplitude of the noise for this channel. Larger numbers vibrate higher

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The amplitude of the noise for this channel.  Larger numbers vibrate higher.")]
public float Amplitude
var Amplitude

Field Value

Type: Single
See Also

Reference

NoiseSettingsNoiseParams Structure


NoiseSettings.NoiseParams.Frequency Field

NoiseSettingsNoiseParamsFrequency Field

The frequency of noise for this channel. Higher magnitudes vibrate faster

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("The frequency of noise for this channel.  Higher magnitudes vibrate faster.")]
public float Frequency
var Frequency

Field Value

Type: Single
See Also

Reference

NoiseSettingsNoiseParams Structure


NoiseSettings.TransformNoiseParams Structure

NoiseSettingsTransformNoiseParams Structure

Contains the behaviour of noise for the noise module for all 3 cardinal axes of the camera

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[SerializableAttribute]
[DocumentationSortingAttribute(9.2f, DocumentationSortingAttributeLevel.UserRef)]
public struct TransformNoiseParams
JavaScript supports the use of structures, but not the declaration of new ones.

The NoiseSettingsTransformNoiseParams type exposes the following members.

Fields
 | Name | Description
Public field | X | Noise definition for X-axis
Public field | Y | Noise definition for Y-axis
Public field | Z | Noise definition for Z-axis
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


TransformNoiseParams Fields

The NoiseSettingsTransformNoiseParams type exposes the following members.

Fields
 | Name | Description
Public field | X | Noise definition for X-axis
Public field | Y | Noise definition for Y-axis
Public field | Z | Noise definition for Z-axis
Top
See Also

Reference

NoiseSettingsTransformNoiseParams Structure


NoiseSettings.TransformNoiseParams.X Field

NoiseSettingsTransformNoiseParamsX Field

Noise definition for X-axis

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Noise definition for X-axis")]
public NoiseSettingsNoiseParams X
var X

Field Value

Type: NoiseSettingsNoiseParams
See Also

Reference

NoiseSettingsTransformNoiseParams Structure


NoiseSettings.TransformNoiseParams.Y Field

NoiseSettingsTransformNoiseParamsY Field

Noise definition for Y-axis

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Noise definition for Y-axis")]
public NoiseSettingsNoiseParams Y
var Y

Field Value

Type: NoiseSettingsNoiseParams
See Also

Reference

NoiseSettingsTransformNoiseParams Structure


NoiseSettings.TransformNoiseParams.Z Field

NoiseSettingsTransformNoiseParamsZ Field

Noise definition for Z-axis

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[TooltipAttribute("Noise definition for Z-axis")]
public NoiseSettingsNoiseParams Z
var Z

Field Value

Type: NoiseSettingsNoiseParams
See Also

Reference

NoiseSettingsTransformNoiseParams Structure


NoSaveDuringPlayAttribute Class

Suppresses play-mode-save for a field. Use it if the calsee has [SaveDuringPlay] attribute but there are fields in the class that shouldn't be saved.
Inheritance Hierarchy
SystemObject
SystemAttribute
PropertyAttribute
CinemachineNoSaveDuringPlayAttribute

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public sealed class NoSaveDuringPlayAttribute : PropertyAttribute
Cinemachine.NoSaveDuringPlayAttribute = function();

Type.createClass(
    'Cinemachine.NoSaveDuringPlayAttribute',
    UnityEngine.PropertyAttribute);

The NoSaveDuringPlayAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | NoSaveDuringPlayAttribute |
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


NoSaveDuringPlayAttribute Constructor

[Missing <summary> documentation for "M:Cinemachine.NoSaveDuringPlayAttribute.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public NoSaveDuringPlayAttribute()
Cinemachine.NoSaveDuringPlayAttribute = function();
See Also

Reference

NoSaveDuringPlayAttribute Class


SaveDuringPlayAttribute Class

Invoke play-mode-save for a class. This class's fields will be scanned upon exiting play mode, and its property values will be applied to the scene object. This is a stopgap measure that will become obsolete once Unity implements play-mode-save in a more general way.
Inheritance Hierarchy
SystemObject
SystemAttribute
CinemachineSaveDuringPlayAttribute

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public sealed class SaveDuringPlayAttribute : Attribute
Cinemachine.SaveDuringPlayAttribute = function();

Type.createClass(
    'Cinemachine.SaveDuringPlayAttribute',
    Attribute);

The SaveDuringPlayAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SaveDuringPlayAttribute |
Top
See Also

Reference

Cinemachine Namespace
Visit the Cinemachine Forum

https://unity3d.com/legal/terms-of-service


SaveDuringPlayAttribute Constructor

[Missing <summary> documentation for "M:Cinemachine.SaveDuringPlayAttribute.#ctor"]

Namespace: Cinemachine
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public SaveDuringPlayAttribute()
Cinemachine.SaveDuringPlayAttribute = function();
See Also

Reference

SaveDuringPlayAttribute Class


Cinemachine.Utility Namespace

Cinemachine non-domain utilities and Unity extensions and helpers
Classes
 | Class | Description
Public class | CinemachineGameWindowDebug | Manages onscreen positions for Cinemachine debugging output
Public class | Damper | Utility to perform realistic damping of float or Vector3 values. The algorithm is based on exponentially decaying the delta until only a negligible amount remains.
Public class | ReflectionHelpers | An ad-hoc collection of helpers for reflection, used by Cinemachine or its editor tools in various places
Public class | UnityQuaternionExtensions | Extentions to the Quaternion class, usen in various places by Cinemachine
Public class | UnityRectExtensions | Ad-hoc xxtentions to the Rect structure, used by Cinemachine
Public class | UnityVectorExtensions | Extensions to the Vector3 class, used by Cinemachine


CinemachineGameWindowDebug Class

Manages onscreen positions for Cinemachine debugging output
Inheritance Hierarchy
SystemObject
Cinemachine.UtilityCinemachineGameWindowDebug

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public class CinemachineGameWindowDebug
Cinemachine.Utility.CinemachineGameWindowDebug = function();

Type.createClass(
    'Cinemachine.Utility.CinemachineGameWindowDebug');

The CinemachineGameWindowDebug type exposes the following members.

Constructors
 | Name | Description
Public method | CinemachineGameWindowDebug |
Top
Methods
Name | Description
GetScreenPos | Reserve an on-screen rectangle for debugging output.
ReleaseScreenPos | Release a screen rectangle previously obtained through GetScreenPos()
Top
See Also

Reference

Cinemachine.Utility Namespace


CinemachineGameWindowDebug Constructor

[Missing <summary> documentation for "M:Cinemachine.Utility.CinemachineGameWindowDebug.#ctor"]

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public CinemachineGameWindowDebug()
Cinemachine.Utility.CinemachineGameWindowDebug = function();
See Also

Reference

CinemachineGameWindowDebug Class
Cinemachine.Utility Namespace


CinemachineGameWindowDebug Methods

The CinemachineGameWindowDebug type exposes the following members.

Methods
Name | Description
GetScreenPos | Reserve an on-screen rectangle for debugging output.
ReleaseScreenPos | Release a screen rectangle previously obtained through GetScreenPos()
Top
See Also

Reference

CinemachineGameWindowDebug Class
Cinemachine.Utility Namespace


CinemachineGameWindowDebug.GetScreenPos Method

CinemachineGameWindowDebugGetScreenPos Method

Reserve an on-screen rectangle for debugging output.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Rect GetScreenPos(
    Object client,
    string text,
    GUIStyle style
)
Cinemachine.Utility.CinemachineGameWindowDebug.GetScreenPos = function(client, text, style);

Parameters

client
Type: Object
The client caller. This is used as a handle.
text
Type: SystemString
Sample text, for determining rectangle size
style
Type: GUIStyle
What style will be used to draw, used here for determining rect size

Return Value

Type: Rect
An area on the game screen large enough to print the text in the style indicated
See Also

Reference

CinemachineGameWindowDebug Class
Cinemachine.Utility Namespace


CinemachineGameWindowDebug.ReleaseScreenPos Method

CinemachineGameWindowDebugReleaseScreenPos Method

Release a screen rectangle previously obtained through GetScreenPos()

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static void ReleaseScreenPos(
    Object client
)
Cinemachine.Utility.CinemachineGameWindowDebug.ReleaseScreenPos = function(client);

Parameters

client
Type: Object
The client caller. Used as a handle.
See Also

Reference

CinemachineGameWindowDebug Class
Cinemachine.Utility Namespace


Damper Class

Utility to perform realistic damping of float or Vector3 values. The algorithm is based on exponentially decaying the delta until only a negligible amount remains.
Inheritance Hierarchy
SystemObject
Cinemachine.UtilityDamper

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static class Damper
Cinemachine.Utility.Damper = function();

Type.createClass(
    'Cinemachine.Utility.Damper');

The Damper type exposes the following members.

Methods
Name | Description
Damp(Single, Single, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Damp(Vector3, Single, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Damp(Vector3, Vector3, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Top
Fields
Name | Description
kNegligibleResidual | Standard residual
Top
See Also

Reference

Cinemachine.Utility Namespace


Damper Methods

Methods
Name | Description
Damp(Single, Single, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Damp(Vector3, Single, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Damp(Vector3, Vector3, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Top
See Also

Reference

Damper Class
Cinemachine.Utility Namespace


Damper.Damp Method

DamperDamp Method

Overload List
Name | Description
Damp(Single, Single, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Damp(Vector3, Single, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Damp(Vector3, Vector3, Single) | Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.
Top
See Also

Reference

Damper Class
Cinemachine.Utility Namespace


Damper.Damp Method (Single, Single, Single)

DamperDamp Method (Single, Single, Single)

Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static float Damp(
    float initial,
    float dampTime,
    float deltaTime
)
Cinemachine.Utility.Damper.Damp = function(initial, dampTime, deltaTime);

Parameters

initial
Type: SystemSingle
The amount that will be damped
dampTime
Type: SystemSingle
The rate of damping. This is the time it would take to reduce the original amount to a negligible percentage
deltaTime
Type: SystemSingle
The time over which to damp

Return Value

Type: Single
The damped amount. This will be the original amount scaled by a value between 0 and 1.
See Also

Reference

Damper Class
Damp Overload
Cinemachine.Utility Namespace


Damper.Damp Method (Vector3, Single, Single)

DamperDamp Method (Vector3, Single, Single)

Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Vector3 Damp(
    Vector3 initial,
    float dampTime,
    float deltaTime
)
Cinemachine.Utility.Damper.Damp = function(initial, dampTime, deltaTime);

Parameters

initial
Type: Vector3
The amount that will be damped
dampTime
Type: SystemSingle
The rate of damping. This is the time it would take to reduce the original amount to a negligible percentage
deltaTime
Type: SystemSingle
The time over which to damp

Return Value

Type: Vector3
The damped amount. This will be the original amount scaled by a value between 0 and 1.
See Also

Reference

Damper Class
Damp Overload
Cinemachine.Utility Namespace


Damper.Damp Method (Vector3, Vector3, Single)

DamperDamp Method (Vector3, Vector3, Single)

Get a damped version of a quantity. This is the portion of the quantity that will take effect over the given time.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Vector3 Damp(
    Vector3 initial,
    Vector3 dampTime,
    float deltaTime
)
Cinemachine.Utility.Damper.Damp = function(initial, dampTime, deltaTime);

Parameters

initial
Type: Vector3
The amount that will be damped
dampTime
Type: Vector3
The rate of damping. This is the time it would take to reduce the original amount to a negligible percentage
deltaTime
Type: SystemSingle
The time over which to damp

Return Value

Type: Vector3
The damped amount. This will be the original amount scaled by a value between 0 and 1.
See Also

Reference

Damper Class
Damp Overload
Cinemachine.Utility Namespace


Damper Fields

The Damper type exposes the following members.

Fields
Name | Description
kNegligibleResidual | Standard residual
Top
See Also

Reference

Damper Class
Cinemachine.Utility Namespace


Damper.kNegligibleResidual Field

DamperkNegligibleResidual Field

Standard residual

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public const float kNegligibleResidual = 0.01f
var Cinemachine.Utility.Damper.kNegligibleResidual

Field Value

Type: Single
See Also

Reference

Damper Class
Cinemachine.Utility Namespace


ReflectionHelpers Class

An ad-hoc collection of helpers for reflection, used by Cinemachine or its editor tools in various places
Inheritance Hierarchy
SystemObject
Cinemachine.UtilityReflectionHelpers

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
[DocumentationSortingAttribute(0f, DocumentationSortingAttributeLevel.Undoc)]
public static class ReflectionHelpers
Cinemachine.Utility.ReflectionHelpers = function();

Type.createClass(
    'Cinemachine.Utility.ReflectionHelpers');

The ReflectionHelpers type exposes the following members.

Methods
Name | Description
AccessInternalFieldT | Cheater extension to access internal field of an object
CopyFields | Copy the fields from one object to another
GetFieldPathTType, TValue | Returns a string path from an expression - mostly used to retrieve serialized properties without hardcoding the field path. Safer, and allows for proper refactoring.
GetParentObject | Get the object owner of a field. This method processes the '.' separator to get from the object that owns the compound field to the object that owns the leaf field
Top
See Also

Reference

Cinemachine.Utility Namespace


ReflectionHelpers Methods

The ReflectionHelpers type exposes the following members.

Methods
Name | Description
AccessInternalFieldT | Cheater extension to access internal field of an object
CopyFields | Copy the fields from one object to another
GetFieldPathTType, TValue | Returns a string path from an expression - mostly used to retrieve serialized properties without hardcoding the field path. Safer, and allows for proper refactoring.
GetParentObject | Get the object owner of a field. This method processes the '.' separator to get from the object that owns the compound field to the object that owns the leaf field
Top
See Also

Reference

ReflectionHelpers Class
Cinemachine.Utility Namespace


ReflectionHelpers.AccessInternalField(T) Method

ReflectionHelpersAccessInternalFieldT Method

Cheater extension to access internal field of an object

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static T AccessInternalField<T>(
    this Type type,
    Object obj,
    string memberName
)

JavaScript does not support generic types or methods.

Parameters

type
Type: SystemType
The type of the field
obj
Type: SystemObject
The object to access
memberName
Type: SystemString
The string name of the field to access

Type Parameters

T

Return Value

Type: T
The value of the field in the objects

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ReflectionHelpers Class
Cinemachine.Utility Namespace


ReflectionHelpers.CopyFields Method

ReflectionHelpersCopyFields Method

Copy the fields from one object to another

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static void CopyFields(
    Object src,
    Object dst,
    BindingFlags bindingAttr = BindingFlags.Default|BindingFlags.Instance|BindingFlags.Public|BindingFlags.NonPublic
)
Cinemachine.Utility.ReflectionHelpers.CopyFields = function(src, dst, bindingAttr);

Parameters

src
Type: SystemObject
The source object to copy from
dst
Type: SystemObject
The destination object to copy to
bindingAttr (Optional)
Type: System.ReflectionBindingFlags
The mask to filter the attributes. Only those fields that get caught in the filter will be copied
See Also

Reference

ReflectionHelpers Class
Cinemachine.Utility Namespace


ReflectionHelpers.GetFieldPath(TType, TValue) Method

ReflectionHelpersGetFieldPathTType, TValue Method

Returns a string path from an expression - mostly used to retrieve serialized properties without hardcoding the field path. Safer, and allows for proper refactoring.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static string GetFieldPath<TType, TValue>(
    Expression<Func<TType, TValue>> expr
)

JavaScript does not support generic types or methods.

Parameters

expr
Type: System.Linq.ExpressionsExpression Func TType, TValue

[Missing <param name="expr"/> documentation for "M:Cinemachine.Utility.ReflectionHelpers.GetFieldPath``2(System.Linq.Expressions.Expression{System.Func{``0,``1}})"]

Type Parameters

TType
TValue

Return Value

Type: String

[Missing <returns> documentation for "M:Cinemachine.Utility.ReflectionHelpers.GetFieldPath``2(System.Linq.Expressions.Expression{System.Func{``0,``1}})"]

See Also

Reference

ReflectionHelpers Class
Cinemachine.Utility Namespace


ReflectionHelpers.GetParentObject Method

ReflectionHelpersGetParentObject Method

Get the object owner of a field. This method processes the '.' separator to get from the object that owns the compound field to the object that owns the leaf field

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Object GetParentObject(
    string path,
    Object obj
)
Cinemachine.Utility.ReflectionHelpers.GetParentObject = function(path, obj);

Parameters

path
Type: SystemString
The name of the field, which may contain '.' separators
obj
Type: SystemObject
the owner of the compound field

Return Value

Type: Object

[Missing <returns> documentation for "M:Cinemachine.Utility.ReflectionHelpers.GetParentObject(System.String,System.Object)"]

See Also

Reference

ReflectionHelpers Class
Cinemachine.Utility Namespace


UnityQuaternionExtensions Class

Extentions to the Quaternion class, usen in various places by Cinemachine
Inheritance Hierarchy
SystemObject
Cinemachine.UtilityUnityQuaternionExtensions

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static class UnityQuaternionExtensions
Cinemachine.Utility.UnityQuaternionExtensions = function();

Type.createClass(
    'Cinemachine.Utility.UnityQuaternionExtensions');

The UnityQuaternionExtensions type exposes the following members.

Methods
Name | Description
ApplyCameraRotation | Apply rotations, first about world up, then about (travelling) local right. rot.y is rotation about worldUp, and rot.x is second rotation, about local right.
GetCameraRotationToTarget | Get the rotations, first about world up, then about (travelling) local right, necessary to align the quaternion's forward with the target direction. This represents the tripod head movement needed to look at the target. This formulation makes it easy to interpolate without introducing spurious roll.
Normalized | Normalize a quaternion
SlerpWithReferenceUp | This is a slerp that mimics a camera operator's movement in that it chooses a path that avoids the lower hemisphere, as defined by the up param
Top
See Also

Reference

Cinemachine.Utility Namespace


UnityQuaternionExtensions Methods

The UnityQuaternionExtensions type exposes the following members.

Methods
Name | Description
ApplyCameraRotation | Apply rotations, first about world up, then about (travelling) local right. rot.y is rotation about worldUp, and rot.x is second rotation, about local right.
GetCameraRotationToTarget | Get the rotations, first about world up, then about (travelling) local right, necessary to align the quaternion's forward with the target direction. This represents the tripod head movement needed to look at the target. This formulation makes it easy to interpolate without introducing spurious roll.
Normalized | Normalize a quaternion
SlerpWithReferenceUp | This is a slerp that mimics a camera operator's movement in that it chooses a path that avoids the lower hemisphere, as defined by the up param
Top
See Also

Reference

UnityQuaternionExtensions Class
Cinemachine.Utility Namespace


UnityQuaternionExtensions.ApplyCameraRotation Method

UnityQuaternionExtensionsApplyCameraRotation Method

Apply rotations, first about world up, then about (travelling) local right. rot.y is rotation about worldUp, and rot.x is second rotation, about local right.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Quaternion ApplyCameraRotation(
    this Quaternion orient,
    Vector2 rot,
    Vector3 worldUp
)
Cinemachine.Utility.UnityQuaternionExtensions.ApplyCameraRotation = function(orient, rot, worldUp);

Parameters

orient
Type: Quaternion

[Missing <param name="orient"/> documentation for "M:Cinemachine.Utility.UnityQuaternionExtensions.ApplyCameraRotation(UnityEngine.Quaternion,UnityEngine.Vector2,UnityEngine.Vector3)"]

rot
Type: Vector2
Vector2.y is rotation about worldUp, and Vector2.x is second rotation, about local right.
worldUp
Type: Vector3
Which way is up

Return Value

Type: Quaternion

[Missing <returns> documentation for "M:Cinemachine.Utility.UnityQuaternionExtensions.ApplyCameraRotation(UnityEngine.Quaternion,UnityEngine.Vector2,UnityEngine.Vector3)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Quaternion. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UnityQuaternionExtensions Class
Cinemachine.Utility Namespace


UnityQuaternionExtensions.GetCameraRotationToTarget Method

UnityQuaternionExtensionsGetCameraRotationToTarget Method

Get the rotations, first about world up, then about (travelling) local right, necessary to align the quaternion's forward with the target direction. This represents the tripod head movement needed to look at the target. This formulation makes it easy to interpolate without introducing spurious roll.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Vector2 GetCameraRotationToTarget(
    this Quaternion orient,
    Vector3 lookAtDir,
    Vector3 worldUp
)
Cinemachine.Utility.UnityQuaternionExtensions.GetCameraRotationToTarget = function(orient, lookAtDir, worldUp);

Parameters

orient
Type: Quaternion

[Missing <param name="orient"/> documentation for "M:Cinemachine.Utility.UnityQuaternionExtensions.GetCameraRotationToTarget(UnityEngine.Quaternion,UnityEngine.Vector3,UnityEngine.Vector3)"]

lookAtDir
Type: Vector3
The worldspace target direction in which we want to look
worldUp
Type: Vector3
Which way is up

Return Value

Type: Vector2
Vector2.y is rotation about worldUp, and Vector2.x is second rotation, about local right.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Quaternion. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UnityQuaternionExtensions Class
Cinemachine.Utility Namespace


UnityQuaternionExtensions.Normalized Method

UnityQuaternionExtensionsNormalized Method

Normalize a quaternion

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Quaternion Normalized(
    this Quaternion q
)
Cinemachine.Utility.UnityQuaternionExtensions.Normalized = function(q);

Parameters

q
Type: Quaternion

[Missing <param name="q"/> documentation for "M:Cinemachine.Utility.UnityQuaternionExtensions.Normalized(UnityEngine.Quaternion)"]

Return Value

Type: Quaternion
The normalized quaternion. Unit length is 1.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Quaternion. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UnityQuaternionExtensions Class
Cinemachine.Utility Namespace


UnityQuaternionExtensions.SlerpWithReferenceUp Method

UnityQuaternionExtensionsSlerpWithReferenceUp Method

This is a slerp that mimics a camera operator's movement in that it chooses a path that avoids the lower hemisphere, as defined by the up param

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Quaternion SlerpWithReferenceUp(
    Quaternion qA,
    Quaternion qB,
    float t,
    Vector3 up
)
Cinemachine.Utility.UnityQuaternionExtensions.SlerpWithReferenceUp = function(qA, qB, t, up);

Parameters

qA
Type: Quaternion
First direction
qB
Type: Quaternion
Second direction
t
Type: SystemSingle
Interpolation amoun t
up
Type: Vector3
Defines the up direction

Return Value

Type: Quaternion

[Missing <returns> documentation for "M:Cinemachine.Utility.UnityQuaternionExtensions.SlerpWithReferenceUp(UnityEngine.Quaternion,UnityEngine.Quaternion,System.Single,UnityEngine.Vector3)"]

See Also

Reference

UnityQuaternionExtensions Class
Cinemachine.Utility Namespace


UnityRectExtensions Class

Ad-hoc xxtentions to the Rect structure, used by Cinemachine
Inheritance Hierarchy
SystemObject
Cinemachine.UtilityUnityRectExtensions

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static class UnityRectExtensions
Cinemachine.Utility.UnityRectExtensions = function();

Type.createClass(
    'Cinemachine.Utility.UnityRectExtensions');

The UnityRectExtensions type exposes the following members.

Methods
Name | Description
Inflated | Inflate a rect
Top
See Also

Reference

Cinemachine.Utility Namespace


UnityRectExtensions Methods

The UnityRectExtensions type exposes the following members.

Methods
Name | Description
Inflated | Inflate a rect
Top
See Also

Reference

UnityRectExtensions Class
Cinemachine.Utility Namespace


UnityRectExtensions.Inflated Method

UnityRectExtensionsInflated Method

Inflate a rect

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Rect Inflated(
    this Rect r,
    Vector2 delta
)
Cinemachine.Utility.UnityRectExtensions.Inflated = function(r, delta);

Parameters

r
Type: Rect

[Missing <param name="r"/> documentation for "M:Cinemachine.Utility.UnityRectExtensions.Inflated(UnityEngine.Rect,UnityEngine.Vector2)"]

delta
Type: Vector2
x and y are added/subtracted fto/from the edges of the rect, inflating it in all directions

Return Value

Type: Rect
The inflated rect

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Rect. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UnityRectExtensions Class
Cinemachine.Utility Namespace


UnityVectorExtensions Class

Extensions to the Vector3 class, used by Cinemachine
Inheritance Hierarchy
SystemObject
Cinemachine.UtilityUnityVectorExtensions

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static class UnityVectorExtensions
Cinemachine.Utility.UnityVectorExtensions = function();

Type.createClass(
    'Cinemachine.Utility.UnityVectorExtensions');

The UnityVectorExtensions type exposes the following members.

Methods
Name | Description
AlmostZero | Is the vector within Epsilon of zero length?
ClosestPointOnSegment(Vector2, Vector2, Vector2) | Get the closest point on a line segment.
ClosestPointOnSegment(Vector3, Vector3, Vector3) | Get the closest point on a line segment.
ProjectOntoPlane | Returns a non-normalized projection of the supplied vector onto a plane as described by its normal
SignedAngle | Get a signed angle between two vectors
SlerpWithReferenceUp | This is a slerp that mimics a camera operator's movement in that it chooses a path that avoids the lower hemisphere, as defined by the up param
Top
Fields
Name | Description
Epsilon | A useful Epsilon
Top
See Also

Reference

Cinemachine.Utility Namespace


UnityVectorExtensions Methods

The UnityVectorExtensions type exposes the following members.

Methods
Name | Description
AlmostZero | Is the vector within Epsilon of zero length?
ClosestPointOnSegment(Vector2, Vector2, Vector2) | Get the closest point on a line segment.
ClosestPointOnSegment(Vector3, Vector3, Vector3) | Get the closest point on a line segment.
ProjectOntoPlane | Returns a non-normalized projection of the supplied vector onto a plane as described by its normal
SignedAngle | Get a signed angle between two vectors
SlerpWithReferenceUp | This is a slerp that mimics a camera operator's movement in that it chooses a path that avoids the lower hemisphere, as defined by the up param
Top
See Also

Reference

UnityVectorExtensions Class
Cinemachine.Utility Namespace


UnityVectorExtensions.AlmostZero Method

UnityVectorExtensionsAlmostZero Method

Is the vector within Epsilon of zero length?

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static bool AlmostZero(
    this Vector3 v
)
Cinemachine.Utility.UnityVectorExtensions.AlmostZero = function(v);

Parameters

v
Type: Vector3

[Missing <param name="v"/> documentation for "M:Cinemachine.Utility.UnityVectorExtensions.AlmostZero(UnityEngine.Vector3)"]

Return Value

Type: Boolean
True if the square magnitude of the vector is within Epsilon of zero

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Vector3. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UnityVectorExtensions Class
Cinemachine.Utility Namespace


UnityVectorExtensions.ClosestPointOnSegment Method

UnityVectorExtensionsClosestPointOnSegment Method

Overload List
Name | Description
ClosestPointOnSegment(Vector2, Vector2, Vector2) | Get the closest point on a line segment.
ClosestPointOnSegment(Vector3, Vector3, Vector3) | Get the closest point on a line segment.
Top
See Also

Reference

UnityVectorExtensions Class
Cinemachine.Utility Namespace


UnityVectorExtensions.ClosestPointOnSegment Method (Vector2, Vector2, Vector2)

UnityVectorExtensionsClosestPointOnSegment Method (Vector2, Vector2, Vector2)

Get the closest point on a line segment.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static float ClosestPointOnSegment(
    this Vector2 p,
    Vector2 s0,
    Vector2 s1
)
Cinemachine.Utility.UnityVectorExtensions.ClosestPointOnSegment = function(p, s0, s1);

Parameters

p
Type: Vector2
A point in space
s0
Type: Vector2
Start of line segment
s1
Type: Vector2
End of line segment

Return Value

Type: Single
The interpolation parameter representing the point on the segment, with 0==s0, and 1==s1

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Vector2. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UnityVectorExtensions Class
ClosestPointOnSegment Overload
Cinemachine.Utility Namespace


UnityVectorExtensions.ClosestPointOnSegment Method (Vector3, Vector3, Vector3)

UnityVectorExtensionsClosestPointOnSegment Method (Vector3, Vector3, Vector3)

Get the closest point on a line segment.

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static float ClosestPointOnSegment(
    this Vector3 p,
    Vector3 s0,
    Vector3 s1
)
Cinemachine.Utility.UnityVectorExtensions.ClosestPointOnSegment = function(p, s0, s1);

Parameters

p
Type: Vector3
A point in space
s0
Type: Vector3
Start of line segment
s1
Type: Vector3
End of line segment

Return Value

Type: Single
The interpolation parameter representing the point on the segment, with 0==s0, and 1==s1

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Vector3. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UnityVectorExtensions Class
ClosestPointOnSegment Overload
Cinemachine.Utility Namespace


UnityVectorExtensions.ProjectOntoPlane Method

UnityVectorExtensionsProjectOntoPlane Method

Returns a non-normalized projection of the supplied vector onto a plane as described by its normal

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Vector3 ProjectOntoPlane(
    this Vector3 vector,
    Vector3 planeNormal
)
Cinemachine.Utility.UnityVectorExtensions.ProjectOntoPlane = function(vector, planeNormal);

Parameters

vector
Type: Vector3

[Missing <param name="vector"/> documentation for "M:Cinemachine.Utility.UnityVectorExtensions.ProjectOntoPlane(UnityEngine.Vector3,UnityEngine.Vector3)"]

planeNormal
Type: Vector3
The normal that defines the plane. Cannot be zero-length.

Return Value

Type: Vector3
The component of the vector that lies in the plane

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Vector3. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

UnityVectorExtensions Class
Cinemachine.Utility Namespace


UnityVectorExtensions.SignedAngle Method

UnityVectorExtensionsSignedAngle Method

Get a signed angle between two vectors

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static float SignedAngle(
    Vector3 from,
    Vector3 to,
    Vector3 refNormal
)
Cinemachine.Utility.UnityVectorExtensions.SignedAngle = function(from, to, refNormal);

Parameters

from
Type: Vector3
Start direction
to
Type: Vector3
End direction
refNormal
Type: Vector3
This is needed in order to determine the sign. For example, if from an to lie on the XZ plane, then this would be the Y unit vector, or indeed any vector which, when dotted with Y unit vector, would give a positive result.

Return Value

Type: Single
The signed angle between the vectors
See Also

Reference

UnityVectorExtensions Class
Cinemachine.Utility Namespace


UnityVectorExtensions.SlerpWithReferenceUp Method

UnityVectorExtensionsSlerpWithReferenceUp Method

This is a slerp that mimics a camera operator's movement in that it chooses a path that avoids the lower hemisphere, as defined by the up param

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public static Vector3 SlerpWithReferenceUp(
    Vector3 vA,
    Vector3 vB,
    float t,
    Vector3 up
)
Cinemachine.Utility.UnityVectorExtensions.SlerpWithReferenceUp = function(vA, vB, t, up);

Parameters

vA
Type: Vector3
First direction
vB
Type: Vector3
Second direction
t
Type: SystemSingle
Interpolation amoun t
up
Type: Vector3
Defines the up direction

Return Value

Type: Vector3

[Missing <returns> documentation for "M:Cinemachine.Utility.UnityVectorExtensions.SlerpWithReferenceUp(UnityEngine.Vector3,UnityEngine.Vector3,System.Single,UnityEngine.Vector3)"]

See Also

Reference

UnityVectorExtensions Class
Cinemachine.Utility Namespace


UnityVectorExtensions Fields

The UnityVectorExtensions type exposes the following members.

Fields
Name | Description
Epsilon | A useful Epsilon
Top
See Also

Reference

UnityVectorExtensions Class
Cinemachine.Utility Namespace


UnityVectorExtensions.Epsilon Field

UnityVectorExtensionsEpsilon Field

A useful Epsilon

Namespace: Cinemachine.Utility
Assembly: Cinemachine (in Cinemachine.dll) Version: 2.0.0.0 (2.0.0.0)
Syntax
C#
JavaScript
Copy
public const float Epsilon = 0.0001f
var Cinemachine.Utility.UnityVectorExtensions.Epsilon

Field Value

Type: Single
See Also

Reference

UnityVectorExtensions Class
Cinemachine.Utility Namespace